Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
How to permanently mask KDE 5 [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
jonfr
Veteran
Veteran


Joined: 20 Jul 2003
Posts: 1006
Location: Iceland

PostPosted: Thu Jun 23, 2016 11:05 pm    Post subject: How to permanently mask KDE 5 [solved] Reply with quote

At the moment KDE 5 is not something I'm ready to use. I did test it by using it for a month, it didn't work out for me. So I'm going to wait longer until KDE 5 gets better in the new format (even if that means waiting for KDE 6). Currently portage is pulling in KDE 5 even if I have it masked. I want this to stop.

emerge output. Thanks for the help.

Code:
emerge world -uDNpv

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] sys-libs/timezone-data-2016d::gentoo [2016c::gentoo] USE="nls -leaps_timezone" 494 KiB
[ebuild  NS   #] dev-qt/qtcore-5.5.1-r1:5::gentoo [4.8.6-r2:4::gentoo] USE="icu -debug -systemd {-test}" 0 KiB
[ebuild   R    ] sys-devel/binutils-2.25.1-r1:2.25.1::gentoo  USE="cxx nls zlib -multitarget -static-libs {-test} -vanilla (-multislot%)" 0 KiB
[ebuild  NS   #] dev-qt/qtdbus-5.5.1:5::gentoo [4.8.6-r1:4::gentoo] USE="-debug {-test}" 0 KiB
[ebuild  N    #] dev-qt/qtxml-5.5.1:5::gentoo  USE="-debug {-test}" 0 KiB
[ebuild  N    #] dev-qt/qtnetwork-5.5.1:5::gentoo  USE="ssl -bindist -connman -debug -libproxy -networkmanager {-test}" 0 KiB
[ebuild  NS   #] dev-qt/qtscript-5.5.1-r1:5::gentoo [4.8.6-r2:4::gentoo] USE="jit -debug -scripttools {-test}" 0 KiB
[ebuild  NS   #] dev-qt/qttest-5.5.1:5::gentoo [4.8.6-r1:4::gentoo] USE="-debug {-test}" 0 KiB
[ebuild   R    ] sys-devel/gcc-4.9.3:4.9.3::gentoo  USE="cxx fortran (multilib) nls nptl objc openmp sanitize vtv (-altivec) (-awt) -cilk -debug -doc (-fixed-point) -gcj -go -graphite (-hardened) (-libssp) -nopie -nossp -objc++ -objc-gc -regression-test -vanilla (-multislot%)" 0 KiB
[ebuild  N    #] dev-qt/qtconcurrent-5.5.1:5::gentoo  USE="-debug {-test}" 0 KiB
[ebuild  NS   #] dev-qt/qtxmlpatterns-5.5.1-r1:5::gentoo [4.8.6-r1:4::gentoo] USE="-debug {-test}" 0 KiB
[ebuild  N    #] dev-qt/linguist-tools-5.5.1-r1:5::gentoo  USE="-debug -qml {-test}" 0 KiB
[ebuild   R    ] sys-apps/man-pages-4.05::gentoo  USE="nls" L10N="-da% -de% -fr% -it% -ja% -nl% -pl% -ro% -ru% -zh-CN%" LINGUAS="(-da%*) (-de%*) (-fr%) (-it%) (-ja%) (-nl%) (-pl%) (-ro%) (-ru%) (-zh_CN%)" 0 KiB
[ebuild  NS   #] dev-qt/qtsql-5.5.1:5::gentoo [4.8.6-r1:4::gentoo] USE="mysql sqlite -debug -freetds -oci8 -odbc -postgres {-test}" 0 KiB
[ebuild  NS   #] dev-qt/qtgui-5.5.1-r1:5::gentoo [4.8.6-r4:4::gentoo] USE="dbus gif jpeg png udev xcb -accessibility -debug -egl -eglfs -evdev -gles2 -gtkstyle -ibus -libinput {-test} -tslib -tuio" 0 KiB
[ebuild  N    #] dev-qt/qtwidgets-5.5.1-r1:5::gentoo  USE="png xcb -debug -gles2 -gtkstyle {-test}" 0 KiB
[ebuild  N    #] dev-qt/qtx11extras-5.5.1:5::gentoo  USE="-debug {-test}" 0 KiB
[ebuild  N    #] dev-qt/qtprintsupport-5.5.1:5::gentoo  USE="cups -debug -gles2 {-test}" 0 KiB
[ebuild  NS   #] dev-qt/qtdeclarative-5.5.1-r1:5::gentoo [4.8.6-r1:4::gentoo] USE="jit widgets xml -debug -gles2 -localstorage {-test}" 0 KiB
[ebuild  NS   #] dev-qt/qtsvg-5.5.1-r1:5::gentoo [4.8.6-r1:4::gentoo] USE="-debug {-test}" 0 KiB
[ebuild  NS   #] dev-qt/qtopengl-5.5.1:5::gentoo [4.8.6-r1:4::gentoo] USE="-debug -gles2 {-test}" 0 KiB
[ebuild  NS   #] dev-qt/designer-5.5.1-r1:5::gentoo [4.8.6-r1:4::gentoo] USE="declarative -debug {-test} -webkit" 0 KiB
[ebuild  N    #] kde-frameworks/kcoreaddons-5.21.0-r1:5/5.21::gentoo  USE="nls -debug (-fam) {-test}" 0 KiB
[ebuild  N    #] kde-frameworks/kconfig-5.21.0:5/5.21::gentoo  USE="nls -debug {-test}" 0 KiB
[ebuild  N    #] kde-frameworks/kwidgetsaddons-5.21.0:5/5.21::gentoo  USE="nls -debug {-test}" 0 KiB
[ebuild  N    #] kde-frameworks/ki18n-5.21.0:5/5.21::gentoo  USE="-debug {-test}" 0 KiB
[ebuild  N    #] kde-frameworks/kwindowsystem-5.21.0:5/5.21::gentoo  USE="X nls -debug {-test}" 0 KiB
[ebuild  N    #] kde-frameworks/kdbusaddons-5.21.0:5/5.21::gentoo  USE="X nls -debug {-test}" 0 KiB
[ebuild  N    #] kde-frameworks/kcodecs-5.21.0:5/5.21::gentoo  USE="nls -debug {-test}" 0 KiB
[ebuild  N    #] kde-frameworks/kitemviews-5.21.0:5/5.21::gentoo  USE="nls -debug {-test}" 0 KiB
[ebuild   R    ] dev-libs/libdbusmenu-qt-0.9.3_pre20140619-r1::gentoo  USE="qt4 qt5* -debug -doc {-test}" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild  N    #] kde-frameworks/kguiaddons-5.21.0:5/5.21::gentoo  USE="-debug {-test}" 0 KiB
[ebuild  N    #] kde-frameworks/karchive-5.21.0:5/5.21::gentoo  USE="bzip2 lzma -debug {-test}" 0 KiB
[ebuild  N    #] kde-frameworks/sonnet-5.21.0:5/5.21::gentoo  USE="hunspell nls -aspell -debug {-test}" 0 KiB
[ebuild  N    #] kde-frameworks/kcrash-5.21.0:5/5.21::gentoo  USE="X nls -debug {-test}" 0 KiB
[ebuild  N    #] kde-frameworks/kdoctools-5.21.0:5/5.21::gentoo  USE="-debug {-test}" 0 KiB
[ebuild  N    #] kde-frameworks/kcompletion-5.21.0:5/5.21::gentoo  USE="nls -debug {-test}" 0 KiB
[ebuild  N    #] kde-frameworks/kjobwidgets-5.21.0:5/5.21::gentoo  USE="X nls -debug {-test}" 0 KiB
[ebuild  N    #] kde-frameworks/kservice-5.21.0:5/5.21::gentoo  USE="man -debug {-test}" 0 KiB
[ebuild  N    #] kde-frameworks/kglobalaccel-5.21.0:5/5.21::gentoo  USE="nls -debug {-test}" 0 KiB
[ebuild  N    #] kde-apps/gpgmepp-15.12.3:5::gentoo  USE="-debug" 67 KiB
[ebuild   R    ] media-libs/phonon-4.7.2::gentoo  USE="designer gstreamer pulseaudio qt4 qt5* vlc (-aqua) -debug (-zeitgeist)" 0 KiB
[ebuild   R    ] media-libs/phonon-vlc-0.7.2::gentoo  USE="qt4 qt5* -debug" 0 KiB
[ebuild   R    ] media-libs/phonon-gstreamer-4.7.2::gentoo  USE="alsa network qt4 qt5* -debug" 0 KiB
[ebuild  N    #] kde-frameworks/knotifications-5.21.0:5/5.21::gentoo  USE="X dbus nls -debug (-speech)" 0 KiB
[ebuild   R    ] sys-auth/polkit-qt-0.112.0-r1::gentoo  USE="qt4 qt5* -debug -examples" 0 KiB
[ebuild  N    #] kde-frameworks/solid-5.21.0:5/5.21::gentoo  USE="nls -debug {-test}" 0 KiB
[ebuild  N    #] kde-frameworks/kauth-5.21.0:5/5.21::gentoo  USE="nls (policykit) -debug {-test}" 0 KiB
[ebuild  N    #] kde-frameworks/kconfigwidgets-5.21.0:5/5.21::gentoo  USE="man -debug {-test}" 0 KiB
[ebuild  N    #] kde-frameworks/kiconthemes-5.21.0:5/5.21::gentoo  USE="-debug {-test}" 0 KiB
[ebuild  N    #] kde-frameworks/ktextwidgets-5.21.0:5/5.21::gentoo  USE="-debug (-speech) {-test}" 0 KiB
[ebuild  N    #] kde-frameworks/kxmlgui-5.21.0:5/5.21::gentoo  USE="-attica -debug {-test}" 0 KiB
[ebuild  N    #] kde-frameworks/kwallet-5.21.0:5/5.21::gentoo  USE="gpg man -debug {-test}" 0 KiB
[ebuild  N    #] kde-frameworks/kbookmarks-5.21.0:5/5.21::gentoo  USE="nls -debug {-test}" 0 KiB
[ebuild  N    #] kde-frameworks/kio-5.21.0:5/5.21::gentoo  USE="X acl handbook kwallet -debug -kerberos {-test}" 0 KiB
[ebuild  N    #] kde-frameworks/kinit-5.21.0:5/5.21::gentoo  USE="caps man -debug" 0 KiB
[ebuild  N    #] kde-frameworks/kded-5.21.0:5/5.21::gentoo  USE="man -debug" 0 KiB
[ebuild  NS    ] media-video/kaffeine-2.0.3:5::gentoo [1.2.2-r1:4::gentoo] USE="-debug" 1.730 KiB
[uninstall     ] media-video/kaffeine-1.2.2-r1:4::gentoo  USE="(-aqua) -debug" LINGUAS="da de en_GB -ar -ast -be -bg -ca -ca@valencia -cs -el -eo -es -et -fi -fr -ga -gl -hr -hu -it -ja -km -ko -ku -lt -mai -nb -nds -nl -nn -pa -pl -pt -pt_BR -ro -ru -se -sk -sr@ijekavian -sr@ijekavianlatin -sr@latin -sv -th -tr -uk -zh_CN -zh_TW"
[blocks b      ] media-video/kaffeine:4 ("media-video/kaffeine:4" is blocking media-video/kaffeine-2.0.3)
[ebuild  N    #] kde-plasma/polkit-kde-agent-5.5.5:5::gentoo  USE="-debug" 0 KiB
[uninstall     ] sys-auth/polkit-kde-agent-0.99.1-r1:4::gentoo  USE="(-aqua) -debug -minimal" LINGUAS="da de en_GB is -ar -bs -ca -ca@valencia -cs -el -eo -es -et -fi -fr -ga -gl -hr -hu -it -ja -kk -km -lt -mai -mr -ms -nb -nds -nl -pa -pl -pt -pt_BR -ro -ru -sk -sl -sr -sr@ijekavian -sr@ijekavianlatin -sr@latin -sv -th -tr -ug -uk -vi -zh_CN -zh_TW"
[blocks b      ] sys-auth/polkit-kde-agent:4[-minimal(-)] ("sys-auth/polkit-kde-agent:4[-minimal(-)]" is blocking kde-plasma/polkit-kde-agent-5.5.5)
[blocks B      ] kde-apps/kde4-l10n[-minimal(-)] ("kde-apps/kde4-l10n[-minimal(-)]" is blocking kde-frameworks/kwindowsystem-5.21.0, kde-frameworks/kjobwidgets-5.21.0, kde-frameworks/knotifications-5.21.0, kde-frameworks/kconfigwidgets-5.21.0, kde-frameworks/kxmlgui-5.21.0, kde-frameworks/kauth-5.21.0, kde-frameworks/kguiaddons-5.21.0, kde-frameworks/kcoreaddons-5.21.0-r1, kde-frameworks/kio-5.21.0, kde-frameworks/kwallet-5.21.0, kde-frameworks/kconfig-5.21.0, kde-frameworks/ktextwidgets-5.21.0, kde-frameworks/kdbusaddons-5.21.0, kde-frameworks/kitemviews-5.21.0, kde-frameworks/kdoctools-5.21.0, kde-frameworks/karchive-5.21.0, kde-frameworks/kiconthemes-5.21.0, kde-frameworks/solid-5.21.0, kde-frameworks/kinit-5.21.0, kde-frameworks/kwidgetsaddons-5.21.0, kde-frameworks/kglobalaccel-5.21.0, kde-frameworks/kbookmarks-5.21.0, kde-frameworks/kded-5.21.0, kde-frameworks/kservice-5.21.0, kde-frameworks/ki18n-5.21.0, kde-frameworks/kcodecs-5.21.0, kde-frameworks/sonnet-5.21.0, kde-frameworks/kcompletion-5.21.0, kde-frameworks/kcrash-5.21.0)

Total: 59 packages (1 upgrade, 38 new, 12 in new slots, 8 reinstalls, 2 uninstalls), Size of downloads: 2.289 KiB
Conflict: 3 blocks (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-frameworks/knotifications-5.21.0:5/5.21::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-frameworks/knotifications-5.21.0:5 required by (kde-plasma/polkit-kde-agent-5.5.5:5/5::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/knotifications-5.21:5 required by (kde-frameworks/kwallet-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/knotifications-5.21:5 required by (kde-frameworks/kio-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)

  (kde-frameworks/kwidgetsaddons-5.21.0:5/5.21::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-frameworks/kwidgetsaddons-5.21:5 required by (kde-frameworks/kjobwidgets-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kwidgetsaddons-5.21:5 required by (kde-frameworks/kwallet-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kwidgetsaddons-5.21.0:5 required by (media-video/kaffeine-2.0.3:5/5::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kwidgetsaddons-5.21:5 required by (kde-frameworks/ktextwidgets-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kwidgetsaddons-5.21:5 required by (kde-frameworks/kbookmarks-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kwidgetsaddons-5.21.0:5 required by (kde-plasma/polkit-kde-agent-5.5.5:5/5::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kwidgetsaddons-5.21:5 required by (kde-frameworks/kcompletion-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kwidgetsaddons-5.21:5 required by (kde-frameworks/kiconthemes-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kwidgetsaddons-5.21:5 required by (kde-frameworks/kio-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kwidgetsaddons-5.21:5 required by (kde-frameworks/kconfigwidgets-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kwidgetsaddons-5.21:5 required by (kde-frameworks/kxmlgui-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)

  (kde-frameworks/ki18n-5.21.0:5/5.21::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-frameworks/ki18n-5.21:5 required by (kde-frameworks/kinit-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/ki18n-5.21.0:5 required by (kde-plasma/polkit-kde-agent-5.5.5:5/5::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/ki18n-5.21.0:5 required by (media-video/kaffeine-2.0.3:5/5::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/ki18n-5.21:5 required by (kde-frameworks/ktextwidgets-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/ki18n-5.21:5 required by (kde-frameworks/kservice-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/ki18n-5.21:5 required by (kde-frameworks/kwallet-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/ki18n-5.21:5 required by (kde-frameworks/kxmlgui-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/ki18n-5.21:5 required by (kde-frameworks/kconfigwidgets-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/ki18n-5.21:5 required by (kde-frameworks/kio-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/ki18n-5.21:5 required by (kde-frameworks/kiconthemes-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)

  (kde-frameworks/kxmlgui-5.21.0:5/5.21::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-frameworks/kxmlgui-5.21:5 required by (kde-frameworks/kbookmarks-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kxmlgui-5.21.0:5 required by (media-video/kaffeine-2.0.3:5/5::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kxmlgui-5.21:5 required by (kde-frameworks/kio-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)

  (kde-frameworks/kconfig-5.21.0:5/5.21::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-frameworks/kconfig-5.21:5 required by (kde-frameworks/kcompletion-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kconfig-5.21:5 required by (kde-frameworks/kwallet-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kconfig-5.21.0:5 required by (media-video/kaffeine-2.0.3:5/5::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kconfig-5.21:5 required by (kde-frameworks/kinit-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kconfig-5.21:5 required by (kde-frameworks/kded-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kconfig-5.21:5 required by (kde-frameworks/kservice-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kconfig-5.21:5 required by (kde-frameworks/kglobalaccel-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kconfig-5.21:5 required by (kde-frameworks/kbookmarks-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kconfig-5.21:5 required by (kde-frameworks/ktextwidgets-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kconfig-5.21:5 required by (kde-frameworks/knotifications-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kconfig-5.21:5 required by (kde-frameworks/kconfigwidgets-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kconfig-5.21:5 required by (kde-frameworks/kio-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kconfig-5.21:5 required by (kde-frameworks/kiconthemes-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kconfig-5.21:5 required by (kde-frameworks/kxmlgui-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)

  (kde-frameworks/kcoreaddons-5.21.0-r1:5/5.21::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-frameworks/kcoreaddons-5.21:5 required by (kde-frameworks/kglobalaccel-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kcoreaddons-5.21:5 required by (kde-frameworks/kservice-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kcoreaddons-5.21:5 required by (kde-frameworks/kded-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kcoreaddons-5.21:5 required by (kde-frameworks/kauth-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kcoreaddons-5.21:5 required by (kde-frameworks/kjobwidgets-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kcoreaddons-5.21:5 required by (kde-frameworks/kinit-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kcoreaddons-5.21:5 required by (kde-frameworks/kwallet-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kcoreaddons-5.21.0:5 required by (media-video/kaffeine-2.0.3:5/5::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kcoreaddons-5.21.0:5 required by (kde-plasma/polkit-kde-agent-5.5.5:5/5::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kcoreaddons-5.21:5 required by (kde-frameworks/kbookmarks-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kcoreaddons-5.21:5 required by (kde-frameworks/ktextwidgets-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kcoreaddons-5.21:5 required by (kde-frameworks/kio-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kcoreaddons-5.21:5 required by (kde-frameworks/kiconthemes-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kcoreaddons-5.21:5 required by (kde-frameworks/kcrash-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kcoreaddons-5.21:5 required by (kde-frameworks/kconfigwidgets-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kcoreaddons-5.21:5 required by (kde-frameworks/kxmlgui-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kcoreaddons-5.21:5 required by (kde-frameworks/knotifications-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)

  (kde-frameworks/solid-5.21.0:5/5.21::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-frameworks/solid-5.21.0:5 required by (media-video/kaffeine-2.0.3:5/5::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/solid-5.21:5 required by (kde-frameworks/kio-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)

  (kde-frameworks/kwindowsystem-5.21.0:5/5.21::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-frameworks/kwindowsystem-5.21:5[X] required by (kde-frameworks/kglobalaccel-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kwindowsystem-5.21:5 required by (kde-frameworks/ktextwidgets-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kwindowsystem-5.21.0:5 required by (kde-plasma/polkit-kde-agent-5.5.5:5/5::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kwindowsystem-5.21:5 required by (kde-frameworks/kwallet-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kwindowsystem-5.21:5 required by (kde-frameworks/kinit-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kwindowsystem-5.21:5 required by (kde-frameworks/kcrash-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kwindowsystem-5.21:5 required by (kde-frameworks/kio-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kwindowsystem-5.21:5 required by (kde-frameworks/knotifications-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kwindowsystem-5.21:5 required by (kde-frameworks/kxmlgui-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)

  (kde-frameworks/kio-5.21.0:5/5.21::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-frameworks/kio-5.21.0:5 required by (media-video/kaffeine-2.0.3:5/5::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kio-5.21:5 required by (kde-frameworks/kinit-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)

  (kde-frameworks/kconfigwidgets-5.21.0:5/5.21::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-frameworks/kconfigwidgets-5.21.0:5 required by (media-video/kaffeine-2.0.3:5/5::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kconfigwidgets-5.21:5 required by (kde-frameworks/kbookmarks-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kconfigwidgets-5.21:5 required by (kde-frameworks/kwallet-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kconfigwidgets-5.21:5 required by (kde-frameworks/ktextwidgets-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kconfigwidgets-5.21:5 required by (kde-frameworks/kiconthemes-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kconfigwidgets-5.21:5 required by (kde-frameworks/kxmlgui-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kconfigwidgets-5.21:5 required by (kde-frameworks/kio-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)

  (kde-frameworks/kdbusaddons-5.21.0:5/5.21::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-frameworks/kdbusaddons-5.21:5 required by (kde-frameworks/kservice-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kdbusaddons-5.21.0:5 required by (media-video/kaffeine-2.0.3:5/5::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kdbusaddons-5.21.0:5 required by (kde-plasma/polkit-kde-agent-5.5.5:5/5::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kdbusaddons-5.21:5 required by (kde-frameworks/kded-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kdbusaddons-5.21:5 required by (kde-frameworks/kglobalaccel-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kdbusaddons-5.21:5 required by (kde-frameworks/kwallet-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kdbusaddons-5.21:5 required by (kde-frameworks/kio-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)

  (kde-apps/kde4-l10n-15.12.3-r1:4/15.12::gentoo, installed) pulled in by
    >=kde-apps/kde4-l10n-4.10:4[aqua=,linguas_en_GB(+)] (>=kde-apps/kde4-l10n-4.10:4[-aqua,linguas_en_GB(+)]) required by (media-gfx/digikam-4.4.0-r1:4/4::gentoo, installed)
    >=kde-apps/kde4-l10n-4.4:4[aqua=,linguas_da(+)] (>=kde-apps/kde4-l10n-4.4:4[-aqua,linguas_da(+)]) required by (net-wireless/bluedevil-2.1.1:4/4::gentoo, installed)
    >=kde-apps/kde4-l10n-4.14.3-r1:4[aqua=] (>=kde-apps/kde4-l10n-4.14.3-r1:4[-aqua]) required by (kde-apps/kdepim-meta-4.14.11_pre20160211:4/4::gentoo, installed)
    >=kde-apps/kde4-l10n-4.8:4[aqua=,linguas_da(+)] (>=kde-apps/kde4-l10n-4.8:4[-aqua,linguas_da(+)]) required by (x11-misc/lightdm-kde-0.3.2.1-r1:4/4::gentoo, installed)
    >=kde-apps/kde4-l10n-4.4:4[aqua=,linguas_da(+)] (>=kde-apps/kde4-l10n-4.4:4[-aqua,linguas_da(+)]) required by (app-cdr/k3b-2.0.3-r2:4/4::gentoo, installed)
    >=kde-apps/kde4-l10n-4.14.3-r1:4[aqua=] (>=kde-apps/kde4-l10n-4.14.3-r1:4[-aqua]) required by (kde-apps/kde-meta-4.14.3-r1:4/4::gentoo, installed)
    >=kde-apps/kde4-l10n-4.10:4[aqua=,linguas_is(+)] (>=kde-apps/kde4-l10n-4.10:4[-aqua,linguas_is(+)]) required by (media-plugins/kipi-plugins-4.4.0:4/4::gentoo, installed)
    >=kde-apps/kde4-l10n-4.4:4[aqua=,linguas_en_GB(+)] (>=kde-apps/kde4-l10n-4.4:4[-aqua,linguas_en_GB(+)]) required by (app-cdr/k3b-2.0.3-r2:4/4::gentoo, installed)
    >=kde-apps/kde4-l10n-4.10:4[aqua=,linguas_is(+)] (>=kde-apps/kde4-l10n-4.10:4[-aqua,linguas_is(+)]) required by (media-gfx/digikam-4.4.0-r1:4/4::gentoo, installed)
    >=kde-apps/kde4-l10n-4.4:4[aqua=,linguas_en_GB(+)] (>=kde-apps/kde4-l10n-4.4:4[-aqua,linguas_en_GB(+)]) required by (net-wireless/bluedevil-2.1.1:4/4::gentoo, installed)
    >=kde-apps/kde4-l10n-4.10:4[aqua=,linguas_da(+)] (>=kde-apps/kde4-l10n-4.10:4[-aqua,linguas_da(+)]) required by (media-gfx/digikam-4.4.0-r1:4/4::gentoo, installed)
    >=kde-apps/kde4-l10n-4.4:4[aqua=,linguas_en_GB(+)] (>=kde-apps/kde4-l10n-4.4:4[-aqua,linguas_en_GB(+)]) required by (kde-misc/kscreen-1.0.71_p20150824:4/4::gentoo, installed)
    >=kde-apps/kde4-l10n-4.4:4[aqua=,linguas_de(+)] (>=kde-apps/kde4-l10n-4.4:4[-aqua,linguas_de(+)]) required by (kde-misc/kde-gtk-config-2.2.1:4/4::gentoo, installed)
    >=kde-apps/kde4-l10n-4.10:4[aqua=,linguas_de(+)] (>=kde-apps/kde4-l10n-4.10:4[-aqua,linguas_de(+)]) required by (media-plugins/kipi-plugins-4.4.0:4/4::gentoo, installed)
    >=kde-apps/kde4-l10n-4.4:4[aqua=,linguas_da(+)] (>=kde-apps/kde4-l10n-4.4:4[-aqua,linguas_da(+)]) required by (kde-misc/kscreen-1.0.71_p20150824:4/4::gentoo, installed)
    >=kde-apps/kde4-l10n-4.10:4[aqua=,linguas_da(+)] (>=kde-apps/kde4-l10n-4.10:4[-aqua,linguas_da(+)]) required by (media-plugins/kipi-plugins-4.4.0:4/4::gentoo, installed)
    >=kde-apps/kde4-l10n-4.10:4[aqua=,linguas_en_GB(+)] (>=kde-apps/kde4-l10n-4.10:4[-aqua,linguas_en_GB(+)]) required by (media-plugins/kipi-plugins-4.4.0:4/4::gentoo, installed)
    >=kde-apps/kde4-l10n-4.4:4[aqua=,linguas_is(+)] (>=kde-apps/kde4-l10n-4.4:4[-aqua,linguas_is(+)]) required by (app-cdr/k3b-2.0.3-r2:4/4::gentoo, installed)
    >=kde-apps/kde4-l10n-4.4:4[aqua=,linguas_da(+)] (>=kde-apps/kde4-l10n-4.4:4[-aqua,linguas_da(+)]) required by (kde-misc/kde-gtk-config-2.2.1:4/4::gentoo, installed)
    >=kde-apps/kde4-l10n-4.4:4[aqua=,linguas_de(+)] (>=kde-apps/kde4-l10n-4.4:4[-aqua,linguas_de(+)]) required by (net-wireless/bluedevil-2.1.1:4/4::gentoo, installed)
    >=kde-apps/kde4-l10n-4.10:4[aqua=,linguas_de(+)] (>=kde-apps/kde4-l10n-4.10:4[-aqua,linguas_de(+)]) required by (media-gfx/digikam-4.4.0-r1:4/4::gentoo, installed)
    >=kde-apps/kde4-l10n-4.4:4[aqua=,linguas_de(+)] (>=kde-apps/kde4-l10n-4.4:4[-aqua,linguas_de(+)]) required by (kde-misc/kscreen-1.0.71_p20150824:4/4::gentoo, installed)
    >=kde-apps/kde4-l10n-4.4:4[aqua=,linguas_de(+)] (>=kde-apps/kde4-l10n-4.4:4[-aqua,linguas_de(+)]) required by (app-cdr/k3b-2.0.3-r2:4/4::gentoo, installed)
    >=kde-apps/kde4-l10n-4.8:4[aqua=,linguas_de(+)] (>=kde-apps/kde4-l10n-4.8:4[-aqua,linguas_de(+)]) required by (x11-misc/lightdm-kde-0.3.2.1-r1:4/4::gentoo, installed)

  (kde-frameworks/kiconthemes-5.21.0:5/5.21::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-frameworks/kiconthemes-5.21.0:5 required by (kde-plasma/polkit-kde-agent-5.5.5:5/5::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kiconthemes-5.21:5 required by (kde-frameworks/ktextwidgets-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kiconthemes-5.21:5 required by (kde-frameworks/kwallet-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kiconthemes-5.21:5 required by (kde-frameworks/kbookmarks-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kiconthemes-5.21:5 required by (kde-frameworks/kxmlgui-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kiconthemes-5.21:5 required by (kde-frameworks/kio-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)

  (kde-frameworks/kcrash-5.21.0:5/5.21::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-frameworks/kcrash-5.21:5 required by (kde-frameworks/kglobalaccel-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kcrash-5.21.0:5 required by (kde-plasma/polkit-kde-agent-5.5.5:5/5::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kcrash-5.21:5 required by (kde-frameworks/kservice-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kcrash-5.21:5 required by (kde-frameworks/kinit-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/kcrash-5.21:5 required by (kde-frameworks/kded-5.21.0:5/5.21::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by kde-plasma/polkit-kde-agent-5.5.5::gentoo
# required by kde-frameworks/kauth-5.21.0::gentoo
# required by kde-frameworks/kconfigwidgets-5.21.0::gentoo
# required by media-video/kaffeine-2.0.3::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=kde-frameworks/knotifications-5.21.0
# required by kde-frameworks/kcompletion-5.21.0::gentoo
# required by kde-frameworks/ktextwidgets-5.21.0::gentoo
# required by kde-frameworks/kxmlgui-5.21.0::gentoo
# required by media-video/kaffeine-2.0.3::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=kde-frameworks/kwidgetsaddons-5.21.0
# required by kde-frameworks/ktextwidgets-5.21.0::gentoo
# required by kde-frameworks/kxmlgui-5.21.0::gentoo
# required by media-video/kaffeine-2.0.3::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=kde-frameworks/kcompletion-5.21.0
# required by kde-frameworks/ki18n-5.21.0::gentoo
# required by media-video/kaffeine-2.0.3::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=dev-qt/qtscript-5.5.1-r1
# required by media-video/kaffeine-2.0.3::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=kde-frameworks/ki18n-5.21.0
# required by media-video/kaffeine-2.0.3::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=kde-frameworks/kxmlgui-5.21.0
# required by kde-frameworks/ktextwidgets-5.21.0::gentoo
# required by kde-frameworks/kxmlgui-5.21.0::gentoo
# required by media-video/kaffeine-2.0.3::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=kde-frameworks/kconfig-5.21.0
# required by kde-plasma/polkit-kde-agent-5.5.5::gentoo
# required by kde-frameworks/kauth-5.21.0::gentoo
# required by kde-frameworks/kconfigwidgets-5.21.0::gentoo
# required by media-video/kaffeine-2.0.3::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=kde-frameworks/kcoreaddons-5.21.0-r1
# required by kde-frameworks/kio-5.21.0::gentoo
# required by media-video/kaffeine-2.0.3::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=kde-frameworks/solid-5.21.0
# required by kde-frameworks/kio-5.21.0::gentoo
# required by media-video/kaffeine-2.0.3::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=kde-frameworks/kitemviews-5.21.0
# required by kde-frameworks/kconfigwidgets-5.21.0::gentoo
# required by media-video/kaffeine-2.0.3::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=kde-frameworks/kauth-5.21.0
# required by kde-frameworks/kxmlgui-5.21.0::gentoo
# required by media-video/kaffeine-2.0.3::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=kde-frameworks/kwindowsystem-5.21.0
# required by kde-frameworks/kwallet-5.21.0::gentoo[gpg]
# required by kde-frameworks/kio-5.21.0::gentoo[kwallet]
# required by media-video/kaffeine-2.0.3::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=kde-apps/gpgmepp-15.12.3
# required by media-video/kaffeine-2.0.3::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=dev-qt/qtsql-5.5.1
# required by dev-qt/designer-5.5.1-r1::gentoo[declarative]
# required by media-libs/phonon-4.7.2::gentoo[designer,qt5]
# required by media-libs/phonon-vlc-0.7.2::gentoo
# /etc/portage/package.mask:
=dev-qt/qtdeclarative-5.5.1-r1
# required by kde-frameworks/kxmlgui-5.21.0::gentoo
# required by media-video/kaffeine-2.0.3::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=kde-frameworks/kglobalaccel-5.21.0
# required by kde-frameworks/kinit-5.21.0::gentoo
# required by kde-frameworks/kded-5.21.0::gentoo
# /etc/portage/package.mask:
=kde-frameworks/kio-5.21.0
# required by kde-frameworks/kio-5.21.0::gentoo
# required by media-video/kaffeine-2.0.3::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=dev-qt/qtconcurrent-5.5.1
# required by kde-frameworks/knotifications-5.21.0::gentoo[nls]
# required by kde-plasma/polkit-kde-agent-5.5.5::gentoo
# required by kde-frameworks/kauth-5.21.0::gentoo
# required by kde-frameworks/kconfigwidgets-5.21.0::gentoo
# required by media-video/kaffeine-2.0.3::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=dev-qt/linguist-tools-5.5.1-r1
# required by dev-qt/qtdeclarative-5.5.1-r1::gentoo[xml]
# required by dev-qt/designer-5.5.1-r1::gentoo[declarative]
# required by media-libs/phonon-4.7.2::gentoo[designer,qt5]
# required by media-libs/phonon-vlc-0.7.2::gentoo
# /etc/portage/package.mask:
=dev-qt/qtxmlpatterns-5.5.1-r1
# required by dev-qt/qtxmlpatterns-5.5.1-r1::gentoo
# required by dev-qt/qtdeclarative-5.5.1-r1::gentoo[xml]
# required by dev-qt/designer-5.5.1-r1::gentoo[declarative]
# required by media-libs/phonon-4.7.2::gentoo[designer,qt5]
# required by media-libs/phonon-vlc-0.7.2::gentoo
# /etc/portage/package.mask:
=dev-qt/qtcore-5.5.1-r1
# required by kde-frameworks/kconfigwidgets-5.21.0::gentoo
# required by media-video/kaffeine-2.0.3::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=kde-frameworks/kguiaddons-5.21.0
# required by kde-frameworks/ktextwidgets-5.21.0::gentoo
# required by kde-frameworks/kxmlgui-5.21.0::gentoo
# required by media-video/kaffeine-2.0.3::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=kde-frameworks/kservice-5.21.0
# required by media-video/kaffeine-2.0.3::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=kde-frameworks/kconfigwidgets-5.21.0
# required by kde-frameworks/kio-5.21.0::gentoo
# required by media-video/kaffeine-2.0.3::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=kde-frameworks/kdbusaddons-5.21.0
# required by dev-qt/qtdeclarative-5.5.1-r1::gentoo[-test]
# required by dev-qt/designer-5.5.1-r1::gentoo[declarative]
# required by media-libs/phonon-4.7.2::gentoo[designer,qt5]
# required by media-libs/phonon-vlc-0.7.2::gentoo
# /etc/portage/package.mask:
=dev-qt/qttest-5.5.1
# required by kde-frameworks/kdoctools-5.21.0::gentoo
# required by kde-frameworks/kinit-5.21.0::gentoo[man]
# required by kde-frameworks/kded-5.21.0::gentoo
# required by kde-frameworks/kio-5.21.0::gentoo
# required by media-video/kaffeine-2.0.3::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=kde-frameworks/karchive-5.21.0
# required by dev-qt/designer-5.5.1-r1::gentoo
# required by media-libs/phonon-4.7.2::gentoo[designer,qt5]
# required by media-libs/phonon-vlc-0.7.2::gentoo
# /etc/portage/package.mask:
=dev-qt/qtxml-5.5.1
# required by media-libs/phonon-4.7.2::gentoo[designer,qt5]
# required by media-libs/phonon-vlc-0.7.2::gentoo
# /etc/portage/package.mask:
=dev-qt/designer-5.5.1-r1
# required by media-libs/phonon-gstreamer-4.7.2::gentoo[qt5]
# required by media-libs/phonon-4.7.2::gentoo[gstreamer]
# required by media-libs/phonon-vlc-0.7.2::gentoo
# /etc/portage/package.mask:
=dev-qt/qtopengl-5.5.1
# required by kde-frameworks/ktextwidgets-5.21.0::gentoo
# required by kde-frameworks/kxmlgui-5.21.0::gentoo
# required by media-video/kaffeine-2.0.3::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=kde-frameworks/sonnet-5.21.0
# required by dev-qt/designer-5.5.1-r1::gentoo
# required by media-libs/phonon-4.7.2::gentoo[designer,qt5]
# required by media-libs/phonon-vlc-0.7.2::gentoo
# /etc/portage/package.mask:
=dev-qt/qtwidgets-5.5.1-r1
# required by kde-frameworks/kio-5.21.0::gentoo
# required by media-video/kaffeine-2.0.3::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=kde-frameworks/kbookmarks-5.21.0
# required by kde-frameworks/kio-5.21.0::gentoo
# required by media-video/kaffeine-2.0.3::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=kde-frameworks/kjobwidgets-5.21.0
# required by kde-frameworks/kinit-5.21.0::gentoo[man]
# required by kde-frameworks/kded-5.21.0::gentoo
# required by kde-frameworks/kio-5.21.0::gentoo
# required by media-video/kaffeine-2.0.3::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=kde-frameworks/kdoctools-5.21.0
# required by kde-frameworks/kiconthemes-5.21.0::gentoo
# required by kde-plasma/polkit-kde-agent-5.5.5::gentoo
# required by kde-frameworks/kauth-5.21.0::gentoo
# required by kde-frameworks/kconfigwidgets-5.21.0::gentoo
# required by media-video/kaffeine-2.0.3::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=dev-qt/qtsvg-5.5.1-r1
# required by kde-frameworks/kio-5.21.0::gentoo
# required by media-video/kaffeine-2.0.3::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=kde-frameworks/kded-5.21.0
# required by kde-frameworks/kio-5.21.0::gentoo[kwallet]
# required by media-video/kaffeine-2.0.3::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=kde-frameworks/kwallet-5.21.0
# required by kde-frameworks/kded-5.21.0::gentoo
# required by kde-frameworks/kio-5.21.0::gentoo
# required by media-video/kaffeine-2.0.3::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=kde-frameworks/kinit-5.21.0
# required by kde-plasma/polkit-kde-agent-5.5.5::gentoo
# required by kde-frameworks/kauth-5.21.0::gentoo
# required by kde-frameworks/kconfigwidgets-5.21.0::gentoo
# required by media-video/kaffeine-2.0.3::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=kde-frameworks/kiconthemes-5.21.0
# required by kde-plasma/polkit-kde-agent-5.5.5::gentoo
# required by kde-frameworks/kauth-5.21.0::gentoo
# required by kde-frameworks/kconfigwidgets-5.21.0::gentoo
# required by media-video/kaffeine-2.0.3::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=kde-frameworks/kcrash-5.21.0
# required by kde-frameworks/kio-5.21.0::gentoo
# required by media-video/kaffeine-2.0.3::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=kde-frameworks/kcodecs-5.21.0
# required by dev-qt/qtgui-5.5.1-r1::gentoo[dbus]
# required by dev-qt/qtprintsupport-5.5.1::gentoo
# required by kde-frameworks/kxmlgui-5.21.0::gentoo
# required by media-video/kaffeine-2.0.3::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=dev-qt/qtdbus-5.5.1
# required by kde-frameworks/kio-5.21.0::gentoo
# required by media-video/kaffeine-2.0.3::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=kde-frameworks/ktextwidgets-5.21.0
# required by dev-qt/designer-5.5.1-r1::gentoo
# required by media-libs/phonon-4.7.2::gentoo[designer,qt5]
# required by media-libs/phonon-vlc-0.7.2::gentoo
# /etc/portage/package.mask:
=dev-qt/qtnetwork-5.5.1
# required by dev-qt/qtdeclarative-5.5.1-r1::gentoo
# required by dev-qt/designer-5.5.1-r1::gentoo[declarative]
# required by media-libs/phonon-4.7.2::gentoo[designer,qt5]
# required by media-libs/phonon-vlc-0.7.2::gentoo
# /etc/portage/package.mask:
=dev-qt/qtgui-5.5.1-r1
# required by kde-frameworks/kguiaddons-5.21.0::gentoo
# required by kde-frameworks/kconfigwidgets-5.21.0::gentoo
# required by media-video/kaffeine-2.0.3::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=dev-qt/qtx11extras-5.5.1
# required by sys-auth/polkit-0.113::gentoo[kde]
# required by sys-auth/polkit-qt-0.112.0-r1::gentoo
# required by kde-frameworks/kauth-5.21.0::gentoo
# required by kde-frameworks/kconfigwidgets-5.21.0::gentoo
# required by media-video/kaffeine-2.0.3::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=kde-plasma/polkit-kde-agent-5.5.5
# required by dev-qt/designer-5.5.1-r1::gentoo
# required by media-libs/phonon-4.7.2::gentoo[designer,qt5]
# required by media-libs/phonon-vlc-0.7.2::gentoo
# /etc/portage/package.mask:
=dev-qt/qtprintsupport-5.5.1

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by media-libs/phonon-4.7.2::gentoo[vlc]
# required by media-libs/phonon-gstreamer-4.7.2::gentoo
>=media-libs/phonon-vlc-0.7.2 qt5
# required by kde-plasma/polkit-kde-agent-5.5.5::gentoo
# required by kde-frameworks/kauth-5.21.0::gentoo
# required by kde-frameworks/kconfigwidgets-5.21.0::gentoo
# required by media-video/kaffeine-2.0.3::gentoo
# required by @selected
# required by @world (argument)
>=sys-auth/polkit-qt-0.112.0-r1 qt5
# required by media-libs/phonon-vlc-0.7.2::gentoo
>=media-libs/phonon-4.7.2 qt5
# required by kde-frameworks/knotifications-5.21.0::gentoo[dbus]
# required by kde-plasma/polkit-kde-agent-5.5.5::gentoo
# required by kde-frameworks/kauth-5.21.0::gentoo
# required by kde-frameworks/kconfigwidgets-5.21.0::gentoo
# required by media-video/kaffeine-2.0.3::gentoo
# required by @selected
# required by @world (argument)
>=dev-libs/libdbusmenu-qt-0.9.3_pre20140619-r1 qt5
# required by media-libs/phonon-4.7.2::gentoo[gstreamer]
# required by media-libs/phonon-vlc-0.7.2::gentoo
>=media-libs/phonon-gstreamer-4.7.2 qt5

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.

!!! The following installed packages are masked:
- kde-frameworks/extra-cmake-modules-5.21.0::gentoo (masked by: package.mask)
- kde-frameworks/kf-env-3::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


!!! All ebuilds that could satisfy ">=media-libs/phonon-4.7.0[qt4=,qt5=]" have been masked.
!!! One of the following masked packages is required to complete your request:
- media-libs/phonon-9999::gentoo (masked by: missing keyword)
- media-libs/phonon-4.9.0::gentoo (masked by: ~amd64 keyword)
- media-libs/phonon-4.8.3-r1::gentoo (masked by: ~amd64 keyword)
- media-libs/phonon-4.8.3::gentoo (masked by: ~amd64 keyword)
- media-libs/phonon-4.7.2::gentoo (masked by: )

(dependency required by "media-libs/phonon-vlc-0.7.2::gentoo" [ebuild])
(dependency required by "media-libs/phonon-4.7.2::gentoo[vlc]" [ebuild])
(dependency required by "media-libs/phonon-gstreamer-4.7.2::gentoo" [ebuild])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Last edited by jonfr on Fri Jun 24, 2016 12:06 am; edited 1 time in total
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Thu Jun 23, 2016 11:23 pm    Post subject: Reply with quote

There is no KDE5, but the following package is pulling in Frameworks and Qt5:
Code:
[ebuild  NS    ] media-video/kaffeine-2.0.3:5::gentoo [1.2.2-r1:4::gentoo] USE="-debug" 1.730 KiB

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
jonfr
Veteran
Veteran


Joined: 20 Jul 2003
Posts: 1006
Location: Iceland

PostPosted: Thu Jun 23, 2016 11:55 pm    Post subject: Reply with quote

I did notice this when I ran the package as a single to test it before I updated it. I have now blocked it. I hope nothing else is pulling kde plasma (version 5) in.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Sat Jun 25, 2016 10:33 am    Post subject: Reply with quote

KDE Plasma wasn't pulled in.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum