Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE Plasma + Wayland
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Draenin
n00b
n00b


Joined: 24 Mar 2016
Posts: 26

PostPosted: Wed Jun 22, 2016 6:14 pm    Post subject: KDE Plasma + Wayland Reply with quote

Hello,

I would like to use Plasma over Wayland (maybe even latter removing the X-server) but to begin with I'm having troubles to initiate Plasma on Wayland. In the sddm selection window if I choose the option Plasma (Wayland) the terminal hangs up, it does not show anything from Plasma, the sddm screen just stay. I've tried looking into the logs but I can't find anything to get a clue. If I choose the X-server version for Plasma, it runs without problems.

The system is a fresh install, for installing Plasma I did:
Code:
emerge --ask dev-libs/wayland
emerge --ask dev-qt/qtwayland
emerge --ask kde-plasma/plasma-meta
emerge --ask =qtgui-5.5.1-r1


The related USE flags are: plasma qt5 wayland
Also, VIDEO_CARDS="radeon r600"

I read somewhere that Plasma(Wayland) could hang up when initiating if I have installed qt4 (which is exactly what happens to me, btw, I don't know why it's pulling qt4 when I don't have that USE flag active globally), and that the system should be upgraded to qt5. That's the reason why I'm emerging the atom =qtgui-5.5.1-r1. But I guess I'm not upgrading the qt version properly, because although the 'KInfocenter - KDE Info Center / About System' shows Qt Version: 5.5.1 (KDE Plasma Version: 5.5.5, just in case), if I make a 'qmake -version' it still shows the qt4 version: 'Using Qt version 4.8.6 in /usr/lib64/qt4'

I tried to complete(?) the qt5 upgrade by:
Code:
emerge -av @qt5-essentials @qt5-addons

But it says that: "emerge: There are no sets to satisfy 'qt5-essentials'"

Well, I'm not sure what the problem may be. If somebody knows the steps to install Plasma/Wayland, or may have a clue of what the problem could be, chime in. Any help will be greatly appreciated.

Thanks.
_________________
Linux enthusiast
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Wed Jun 22, 2016 7:41 pm    Post subject: Reply with quote

You don't 'upgrade' to Qt5, you install it side-by-side with Qt4. Both will stay installed as long as there are applications that need either of them, such as the kde-apps-meta bundle.

The sets only exist in Qt overlay, but you certainly don't need them. Plasma-5 and Applications will pull in the Qt packages they need.

Qt4 has no influence on Plasma-5 on wayland as long as you do not start any Qt4-based application (and then it should just work).
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum