Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xlib: extension "GLX" missing on display [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
HeXiLeD
Veteran
Veteran


Joined: 20 Aug 2005
Posts: 1068
Location: Online

PostPosted: Tue Jun 21, 2016 8:53 pm    Post subject: Xlib: extension "GLX" missing on display [SOLVED Reply with quote

This issue may be related to this.

# glxgears
Code:
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't get an RGB, Double-buffered visual


Code:
[I] x11-apps/rgb
     Available versions:  1.0.5 1.0.6
     Installed versions:  1.0.6(08:15:41 PM 02/19/2015)
     Homepage:            http://xorg.freedesktop.org/
     Description:         uncompile an rgb color-name database


# glxinfo

Code:
name of display: :0.0
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual or fbconfig


# eix mesa
Code:
[I] app-eselect/eselect-mesa
     Available versions:  0.0.10{tbz2}
     Installed versions:  0.0.10{tbz2}(07:01:55 AM 06/12/2016)
     Homepage:            https://www.gentoo.org/
     Description:         Utility to change the Mesa OpenGL driver being used

[I] media-libs/mesa
     Available versions:  [M]7.10.3 10.3.7-r1^d 11.0.6^d{tbz2} ~11.0.9^d ~11.1.3^d ~11.1.4^d ~11.2.1^d ~11.2.2^d **9999^d {bindist +classic d3d9 debug +dri3 +egl +gallium +gbm gles gles1 gles2 hardened (+)llvm motif +nptl opencl openmax openvg osmesa pax_kernel pic selinux +udev vaapi valgrind vdpau wayland xa xvmc ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32" KERNEL="FreeBSD linux" VIDEO_CARDS="freedreno i915 i965 ilo intel mach64 mga nouveau r100 r128 r200 r300 r600 radeon radeonsi savage sis tdfx vc4 via vmware"}
     Installed versions:  11.0.6^d{tbz2}(07:45:02 PM 06/12/2016)(classic dri3 egl gallium gbm llvm nptl opencl udev vaapi vdpau -bindist -d3d9 -debug -gles1 -gles2 -openmax -osmesa -pax_kernel -pic -selinux -wayland -xa -xvmc ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="32 64 -x32" KERNEL="-FreeBSD" VIDEO_CARDS="-freedreno -i915 -i965 -ilo -intel -nouveau -r100 -r200 -r300 -r600 -radeon -radeonsi -vmware")
     Homepage:            http://mesa3d.sourceforge.net/
     Description:         OpenGL-like graphic library for Linux

[I] x11-apps/mesa-progs
     Available versions:  8.2.0{tbz2} ~8.3.0 **9999 {egl gles2}
     Installed versions:  8.2.0{tbz2}(02:43:32 PM 06/21/2016)(-egl -gles2)
     Homepage:            http://mesa3d.sourceforge.net/
     Description:         Mesa's OpenGL utility and demo programs (glxgears and glxinfo)


# eix dri
Code:
[I] x11-proto/dri2proto
     Available versions:  2.8-r1{tbz2} {ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Installed versions:  2.8-r1{tbz2}(11:09:44 AM 06/12/2016)(ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="32 64 -x32")
     Homepage:            http://xorg.freedesktop.org/
     Description:         X.Org DRI2 protocol headers

[I] x11-proto/dri3proto
     Available versions:  1.0 {ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Installed versions:  1.0(04:03:18 AM 04/04/2015)(ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="32 64 -x32")
     Homepage:            http://xorg.freedesktop.org/
     Description:         X.Org DRI3 protocol specification and Xlib/Xserver headers

[I] x11-proto/xf86driproto
     Available versions:  2.1.1-r1{tbz2} {ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Installed versions:  2.1.1-r1{tbz2}(11:12:48 AM 06/12/2016)(ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="32 64 -x32")
     Homepage:            http://xorg.freedesktop.org/
     Description:         X.Org XF86DRI protocol headers


Code:
[I] x11-drivers/nvidia-drivers
     Available versions:  [M]96.43.23-r1(0/96)^msd [M]173.14.39-r1(0/173)^msd 304.131(0/304)^msd ~304.131-r1(0/304)^msd ~304.131-r4(0/304)^md 340.93-r1(0/340)^msd 340.96(0/340)^msd ~340.96-r5(0/340)^md 346.96-r1(0/346)^msd ~346.96-r6(0/346)^md 352.63(0/352)^msd 352.79(0/352)^msd ~352.79-r4(0/352)^md ~355.00.27(0/355.00)^fmd 355.11-r2(0/355)^msd ~355.11-r4(0/355)^md 358.16-r1(0/358)^msd ~358.16-r5(0/358)^md 361.28(0/361)^msd{tbz2} ~361.28-r2(0/361)^md ~361.42(0/361)^md ~361.45.11(0/361.45)^md ~364.12-r1(0/364)^md ~364.15(0/364)^md ~364.19(0/364)^md ~367.18(0/367)^md ~367.27(0/367)^md {+X acpi compat custom-cflags +driver gtk gtk2 gtk3 +kms multilib pax_kernel static-libs (+)tools uvm wayland KERNEL="FreeBSD linux"}
     Installed versions:  361.28^msd{tbz2}(05:51:29 AM 06/20/2016)(X acpi driver gtk3 kms multilib tools uvm -pax_kernel -static-libs KERNEL="linux -FreeBSD")
     Homepage:            http://www.nvidia.com/ http://www.nvidia.com/Download/Find.aspx
     Description:         NVIDIA Accelerated Graphics Driver


# cat /var/log/Xorg.0.log

Code:
[    85.691]
X.Org X Server 1.17.4
Release Date: 2015-10-28
[    85.691] X Protocol Version 11, Revision 0
[    85.692] Build Operating System: Linux 3.15.6-aufs-r1 x86_64 Gentoo
[    85.692] Current Operating System: Linux gentrix 4.4.6-gentoo #15 SMP Tue Jun 21 10:40:54 EDT 2016 x86_64
[    85.692] Kernel command line: BOOT_IMAGE=/vmlinuz-4.4.6-stable3-gentoo root=/dev/sda3 ro ahci.marvell_enable=0 net.ifnames=0 pcie_aspm=default
[    85.693] Build Date: 14 February 2016  11:30:54AM
[    85.693] 
[    85.693] Current version of pixman: 0.32.8
[    85.694]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[    85.694] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    85.696] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Jun 21 14:25:48 2016
[    85.773] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    85.773] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    85.812] (==) ServerLayout "Layout0"
[    85.812] (**) |-->Screen "Screen0" (0)
[    85.812] (**) |   |-->Monitor "Monitor0"
[    85.812] (**) |   |-->Device "Device0"
[    85.812] (**) Option "DontZap" "False"
[    85.812] (**) Option "BlankTime" "10"
[    85.812] (**) Option "StandbyTime" "20"
[    85.812] (**) Option "OffTime" "25"
[    85.812] (**) Option "Xinerama" "0"
[    85.812] (==) Automatically adding devices
[    85.812] (==) Automatically enabling devices
[    85.812] (==) Automatically adding GPU devices
[    85.813] (WW) The directory "/usr/share/fonts/OTF" does not exist.
[    85.813]    Entry deleted from font path.
[    85.813] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    85.813]    Entry deleted from font path.
[    85.813]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[    85.813] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    85.813]    Entry deleted from font path.
[    85.813]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[    85.813] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    85.813]    Entry deleted from font path.
[    85.813]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[    85.813] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    85.813]    Entry deleted from font path.
[    85.813]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[    85.813] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[    85.813]    Entry deleted from font path.
[    85.845] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[    85.845]    Entry deleted from font path.
[    85.845] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[    85.845]    Entry deleted from font path.
[    85.845] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[    85.845]    Entry deleted from font path.
[    85.845] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    85.845]    Entry deleted from font path.
[    85.845]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[    85.845] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    85.845]    Entry deleted from font path.
[    85.845]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[    85.845] (**) FontPath set to:
        /usr/share/fonts/freefonts/,
        /usr/share/fonts/misc/,
        /usr/share/fonts/TTF/,
        /usr/lib64/X11/fonts/misc/:unscaled,
        /usr/lib64/X11/fonts/misc/,
        /usr/lib/X11/fonts/misc/,
        /usr/share/fonts/misc/,
        /usr/share/fonts/TTF/
[    85.845] (**) ModulePath set to "/usr/lib64/xorg/modules,/usr/lib32/xorg/modules,/usr/lib64/opengl/nvidia,/usr/lib64/xorg/modules"
[    85.845] (**) Extension "Composite" is enabled
[    85.845] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
[    85.845] (II) Loader magic: 0x80cc80
[    85.845] (II) Module ABI versions:
[    85.845]    X.Org ANSI C Emulation: 0.4
[    85.845]    X.Org Video Driver: 19.0
[    85.845]    X.Org XInput driver : 21.0
[    85.845]    X.Org Server Extension : 9.0
[    85.848] (--) PCI:*(0:1:0:0) 10de:1380:3842:3753 rev 162, Mem @ 0xfd000000/16777216, 0xd0000000/268435456, 0xce000000/33554432, I/O @ 0x00008c00/128, BIOS @ 0x????????/524288
[    85.848] (WW) "noveau" will not be loaded unless you've specified it to be loaded elsewhere.
[    85.848] (WW) "xinerama" will not be loaded unless you've specified it to be loaded elsewhere.
[    85.848] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[    85.848] (II) LoadModule: "glx"
[    85.910] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[    86.047] (II) Module glx: vendor="X.Org Foundation"
[    86.047]    compiled for 1.17.4, module version = 1.0.0
[    86.047]    ABI class: X.Org Server Extension, version 9.0
[    86.047] (==) AIGLX enabled
[    86.047] (II) LoadModule: "extmod"
[    86.047] (II) Module "extmod" already built-in
[    86.047] (II) LoadModule: "record"
[    86.047] (II) Module "record" already built-in
[    86.047] (II) LoadModule: "dbe"
[    86.047] (II) Module "dbe" already built-in
[    86.047] (II) LoadModule: "dri"
[    86.047] (II) Module "dri" already built-in
[    86.047] (II) LoadModule: "dri2"
[    86.047] (II) Module "dri2" already built-in
[    86.047] (II) LoadModule: "nvidia"
[    86.047] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[    86.122] (II) Module nvidia: vendor="NVIDIA Corporation"
[    86.122]    compiled for 4.0.2, module version = 1.0.0
[    86.122]    Module class: X.Org Video Driver
[    86.129] (II) NVIDIA dlloader X Driver  361.28  Wed Feb  3 14:48:10 PST 2016
[    86.129] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    86.130] (--) using VT number 7

[    86.145] (II) Loading sub module "fb"
[    86.145] (II) LoadModule: "fb"
[    86.145] (II) Loading /usr/lib64/xorg/modules/libfb.so
[    86.158] (II) Module fb: vendor="X.Org Foundation"
[    86.158]    compiled for 1.17.4, module version = 1.0.0
[    86.158]    ABI class: X.Org ANSI C Emulation, version 0.4
[    86.158] (II) Loading sub module "wfb"
[    86.158] (II) LoadModule: "wfb"
[    86.158] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[    86.199] (II) Module wfb: vendor="X.Org Foundation"
[    86.199]    compiled for 1.17.4, module version = 1.0.0
[    86.199]    ABI class: X.Org ANSI C Emulation, version 0.4
[    86.199] (II) Loading sub module "ramdac"
[    86.199] (II) LoadModule: "ramdac"
[    86.199] (II) Module "ramdac" already built-in
[    86.243] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[    86.243] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[    86.243] (==) NVIDIA(0): RGB weight 888
[    86.243] (==) NVIDIA(0): Default visual is TrueColor
[    86.243] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    86.244] (**) NVIDIA(0): Option "NoLogo" "true"
[    86.244] (**) NVIDIA(0): Option "Stereo" "0"
[    86.244] (**) NVIDIA(0): Option "SWcursor" "false"
[    86.244] (**) NVIDIA(0): Option "HWcursor" "true"
[    86.244] (**) NVIDIA(0): Option "RenderAccel" "true"
[    86.244] (**) NVIDIA(0): Option "UseEdidDpi" "true"
[    86.244] (**) NVIDIA(0): Option "SLI" "Off"
[    86.244] (**) NVIDIA(0): Option "MultiGPU" "Single"
[    86.244] (**) NVIDIA(0): Option "ProbeAllGpus" "true"
[    86.244] (**) NVIDIA(0): Option "ConnectToAcpid" "true"
[    86.244] (**) NVIDIA(0): Option "BaseMosaic" "Off"
[    86.244] (**) NVIDIA(0): Stereo disabled by request
[    86.244] (**) NVIDIA(0): Enabling RENDER acceleration
[    86.244] (**) NVIDIA(0): NVIDIA SLI disabled.
[    86.244] (**) NVIDIA(0): NVIDIA Multi-GPU disabled.
[    86.244] (**) NVIDIA(0): Option "UseEDID" "true"
[    86.244] (**) NVIDIA(0): Option "Coolbits" "1"
[    86.244] (**) NVIDIA(0): Option "MetaModes" "GPU-7c671092-9b7c-9bd4-ad6a-a927d978aa6c.DVI-I-1: 1920x1080_60 +0+0"
[    86.245] (**) NVIDIA(0): Enabling 2D acceleration
[    86.245] (EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
[    86.245] (EE) NVIDIA(0):     log file that the GLX module has been loaded in your X
[    86.245] (EE) NVIDIA(0):     server, and that the module is the NVIDIA GLX module.  If
[    86.245] (EE) NVIDIA(0):     you continue to encounter problems, Please try
[    86.245] (EE) NVIDIA(0):     reinstalling the NVIDIA driver.
[    86.426] (--) NVIDIA(0): Valid display device(s) on GPU-0 at PCI:1:0:0
[    86.426] (--) NVIDIA(0):     CRT-0
[    86.426] (--) NVIDIA(0):     DFP-0 (boot)
[    86.426] (--) NVIDIA(0):     DFP-1
[    86.426] (--) NVIDIA(0):     DFP-2
[    86.426] (--) NVIDIA(0):     DFP-3
[    86.433] (--) NVIDIA(0): CRT-0: disconnected
[    86.433] (--) NVIDIA(0): CRT-0: 400.0 MHz maximum pixel clock
[    86.433] (--) NVIDIA(0):
[    86.446] (--) NVIDIA(0): AOC 2236 (DFP-0): connected
[    86.446] (--) NVIDIA(0): AOC 2236 (DFP-0): Internal TMDS
[    86.446] (--) NVIDIA(0): AOC 2236 (DFP-0): 330.0 MHz maximum pixel clock
[    86.446] (--) NVIDIA(0):
[    86.446] (--) NVIDIA(0): DFP-1: disconnected
[    86.446] (--) NVIDIA(0): DFP-1: Internal TMDS
[    86.446] (--) NVIDIA(0): DFP-1: 165.0 MHz maximum pixel clock
[    86.446] (--) NVIDIA(0):
[    86.446] (--) NVIDIA(0): DFP-2: disconnected
[    86.446] (--) NVIDIA(0): DFP-2: Internal TMDS
[    86.446] (--) NVIDIA(0): DFP-2: 165.0 MHz maximum pixel clock
[    86.446] (--) NVIDIA(0):
[    86.446] (--) NVIDIA(0): DFP-3: disconnected
[    86.446] (--) NVIDIA(0): DFP-3: Internal DisplayPort
[    86.446] (--) NVIDIA(0): DFP-3: 960.0 MHz maximum pixel clock
[    86.446] (--) NVIDIA(0):
[    86.532] (II) NVIDIA(0): NVIDIA GPU GeForce GTX 750 Ti (GM107-A) at PCI:1:0:0 (GPU-0)
[    86.532] (--) NVIDIA(0): Memory: 2097152 kBytes
[    86.532] (--) NVIDIA(0): VideoBIOS: 82.07.32.00.50
[    86.532] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[    86.532] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[    86.532] (**) NVIDIA(0):     device AOC 2236 (DFP-0) (Using EDID frequencies has been
[    86.532] (**) NVIDIA(0):     enabled on all display devices.)
[    86.537] (II) NVIDIA(0): Validated MetaModes:
[    86.537] (II) NVIDIA(0):   
[    86.537] (II) NVIDIA(0):     "GPU-7c671092-9b7c-9bd4-ad6a-a927d978aa6c.DVI-I-1:1920x1080_60+0+0"
[    86.537] (II) NVIDIA(0): Virtual screen size determined to be 1920 x 1080
[    86.555] (--) NVIDIA(0): DPI set to (101, 101); computed from "UseEdidDpi" X config
[    86.555] (--) NVIDIA(0):     option
[    86.555] (--) Depth 24 pixmap format is 32 bpp
[    86.557] (II) NVIDIA: Using 3072.00 MB of virtual memory for indirect memory
[    86.557] (II) NVIDIA:     access.
[    86.638] (II) NVIDIA(0): Setting mode "GPU-7c671092-9b7c-9bd4-ad6a-a927d978aa6c.DVI-I-1:1920x1080_60+0+0"
[    86.740] (==) NVIDIA(0): Disabling shared memory pixmaps
[    86.740] (==) NVIDIA(0): Backing store enabled
[    86.740] (==) NVIDIA(0): Silken mouse enabled
[    86.741] (**) NVIDIA(0): DPMS enabled
[    86.741] (II) Loading sub module "x11glvnd"
[    86.741] (II) LoadModule: "x11glvnd"
[    86.765] (WW) Warning, couldn't open module x11glvnd
[    86.765] (II) UnloadModule: "x11glvnd"
[    86.765] (II) Unloading x11glvnd
[    86.765] (II) x11glvnd Loading
[    86.765] (WW) NVIDIA(0): Option "PerformanceMonitorMode" is not used
[    86.765] (WW) NVIDIA(0): Option "TwinView" is not used
[    86.765] (WW) NVIDIA(0): Option "AllowDDCCI" is not used
[    86.765] (WW) NVIDIA(0): Option "VideoRam" is not used
[    86.765] (II) Loading sub module "dri2"
[    86.765] (II) LoadModule: "dri2"
[    86.765] (II) Module "dri2" already built-in
[    86.765] (II) NVIDIA(0): [DRI2] Setup complete
[    86.765] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[    86.765] (--) RandR disabled
[    86.766] (II) AIGLX: Screen 0 is not DRI2 capable
[    86.766] (EE) AIGLX: reverting to software rendering
[    86.833] (EE) AIGLX error: dlopen of /usr/lib64/dri/swrast_dri.so failed (/usr/lib64/dri/swrast_dri.so: undefined symbol: _glapi_tls_Context)
[    86.833] (EE) GLX: could not load software renderer
[    86.833] (II) GLX: no usable GL providers found for screen 0
[    87.261] (II) config/udev: Adding input device HDA NVidia HDMI (/dev/input/event1)
[    87.261] (**) HDA NVidia HDMI: Applying InputClass "keyboard0"
[    87.261] (II) LoadModule: "evdev"
[    87.261] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[    87.360] (II) Module evdev: vendor="X.Org Foundation"
[    87.360]    compiled for 1.17.4, module version = 2.9.2
[    87.360]    Module class: X.Org XInput Driver
[    87.360]    ABI class: X.Org XInput driver, version 21.0
[    87.360] (II) Using input driver 'evdev' for 'HDA NVidia HDMI'
[    87.360] (**) HDA NVidia HDMI: always reports core events
[    87.360] (**) evdev: HDA NVidia HDMI: Device: "/dev/input/event1"
[    87.360] (--) evdev: HDA NVidia HDMI: Vendor 0 Product 0
[    87.360] (WW) evdev: HDA NVidia HDMI: Don't know how to use device
[    87.367] (EE) PreInit returned 8 for "HDA NVidia HDMI"
[    87.367] (II) UnloadModule: "evdev"
[    87.367] (II) config/udev: Adding input device HDA NVidia HDMI (/dev/input/event2)
[    87.367] (**) HDA NVidia HDMI: Applying InputClass "keyboard0"
[    87.367] (II) Using input driver 'evdev' for 'HDA NVidia HDMI'
[    87.367] (**) HDA NVidia HDMI: always reports core events
[    87.367] (**) evdev: HDA NVidia HDMI: Device: "/dev/input/event2"
[    87.367] (--) evdev: HDA NVidia HDMI: Vendor 0 Product 0
[    87.368] (WW) evdev: HDA NVidia HDMI: Don't know how to use device
[    87.376] (EE) PreInit returned 8 for "HDA NVidia HDMI"
[    87.376] (II) UnloadModule: "evdev"
[    87.377] (II) config/udev: Adding input device HID 1241:1166 (/dev/input/event4)
[    87.377] (**) HID 1241:1166: Applying InputClass "evdev pointer catchall"
[    87.377] (**) HID 1241:1166: Applying InputClass "keyboard0"
[    87.377] (II) Using input driver 'evdev' for 'HID 1241:1166'
[    87.377] (**) HID 1241:1166: always reports core events
[    87.377] (**) evdev: HID 1241:1166: Device: "/dev/input/event4"
[    87.428] (--) evdev: HID 1241:1166: Vendor 0x1241 Product 0x1166
[    87.428] (--) evdev: HID 1241:1166: Found 9 mouse buttons
[    87.428] (--) evdev: HID 1241:1166: Found scroll wheel(s)
[    87.428] (--) evdev: HID 1241:1166: Found relative axes
[    87.428] (--) evdev: HID 1241:1166: Found x and y relative axes
[    87.428] (II) evdev: HID 1241:1166: Configuring as mouse
[    87.428] (II) evdev: HID 1241:1166: Adding scrollwheel support
[    87.428] (**) evdev: HID 1241:1166: YAxisMapping: buttons 4 and 5
[    87.428] (**) evdev: HID 1241:1166: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[    87.428] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1a.7/usb1/1-5/1-5.2/1-5.2:1.0/0003:1241:1166.0001/input/input7/event4"
[    87.428] (II) XINPUT: Adding extended input device "HID 1241:1166" (type: MOUSE, id 6)
[    87.428] (II) evdev: HID 1241:1166: initialized for relative axes.
[    87.428] (**) HID 1241:1166: (accel) keeping acceleration scheme 1
[    87.428] (**) HID 1241:1166: (accel) acceleration profile 0
[    87.428] (**) HID 1241:1166: (accel) acceleration factor: 2.000
[    87.428] (**) HID 1241:1166: (accel) acceleration threshold: 4
[    87.429] (II) config/udev: Adding input device HID 1241:1166 (/dev/input/mouse0)
[    87.430] (**) HID 1241:1166: Applying InputClass "keyboard0"
[    87.430] (II) Using input driver 'evdev' for 'HID 1241:1166'
[    87.430] (**) HID 1241:1166: always reports core events
[    87.430] (**) evdev: HID 1241:1166: Device: "/dev/input/mouse0"
[    87.430] (EE) evdev: HID 1241:1166: Unable to query fd: Inappropriate ioctl for device
[    87.442] (EE) PreInit returned 2 for "HID 1241:1166"
[    87.442] (II) UnloadModule: "evdev"
[    87.443] (II) config/udev: Adding input device HID 04d9:1400 (/dev/input/event5)
[    87.443] (**) HID 04d9:1400: Applying InputClass "evdev keyboard catchall"
[    87.443] (**) HID 04d9:1400: Applying InputClass "keyboard0"
[    87.443] (II) Using input driver 'evdev' for 'HID 04d9:1400'
[    87.443] (**) HID 04d9:1400: always reports core events
[    87.443] (**) evdev: HID 04d9:1400: Device: "/dev/input/event5"
[    87.443] (--) evdev: HID 04d9:1400: Vendor 0x4d9 Product 0x1400
[    87.443] (--) evdev: HID 04d9:1400: Found keys
[    87.443] (II) evdev: HID 04d9:1400: Configuring as keyboard
[    87.443] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.2/usb8/8-2/8-2:1.0/0003:04D9:1400.0002/input/input8/event5"
[    87.443] (II) XINPUT: Adding extended input device "HID 04d9:1400" (type: KEYBOARD, id 7)
[    87.443] (**) Option "xkb_rules" "evdev"
[    87.443] (**) Option "xkb_model" "logitech_base"
[    87.443] (**) Option "xkb_layout" "us_intl"
[    87.443] (**) Option "xkb_variant" "qwerty,euro"
[    87.443] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    87.491] (II) config/udev: Adding input device HID 04d9:1400 (/dev/input/event6)
[    87.491] (**) HID 04d9:1400: Applying InputClass "evdev pointer catchall"
[    87.491] (**) HID 04d9:1400: Applying InputClass "evdev keyboard catchall"
[    87.491] (**) HID 04d9:1400: Applying InputClass "keyboard0"
[    87.491] (II) Using input driver 'evdev' for 'HID 04d9:1400'
[    87.491] (**) HID 04d9:1400: always reports core events
[    87.491] (**) evdev: HID 04d9:1400: Device: "/dev/input/event6"
[    87.491] (--) evdev: HID 04d9:1400: Vendor 0x4d9 Product 0x1400
[    87.491] (--) evdev: HID 04d9:1400: Found 9 mouse buttons
[    87.491] (--) evdev: HID 04d9:1400: Found scroll wheel(s)
[    87.491] (--) evdev: HID 04d9:1400: Found relative axes
[    87.491] (--) evdev: HID 04d9:1400: Found x and y relative axes
[    87.491] (--) evdev: HID 04d9:1400: Found keys
[    87.491] (II) evdev: HID 04d9:1400: Configuring as mouse
[    87.491] (II) evdev: HID 04d9:1400: Configuring as keyboard
[    87.491] (II) evdev: HID 04d9:1400: Adding scrollwheel support
[    87.491] (**) evdev: HID 04d9:1400: YAxisMapping: buttons 4 and 5
[    87.491] (**) evdev: HID 04d9:1400: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[    87.492] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.2/usb8/8-2/8-2:1.1/0003:04D9:1400.0003/input/input9/event6"
[    87.492] (II) XINPUT: Adding extended input device "HID 04d9:1400" (type: KEYBOARD, id 8)
[    87.492] (**) Option "xkb_rules" "evdev"
[    87.492] (**) Option "xkb_model" "logitech_base"
[    87.492] (**) Option "xkb_layout" "us_intl"
[    87.492] (**) Option "xkb_variant" "qwerty,euro"
[    87.492] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    87.492] (II) evdev: HID 04d9:1400: initialized for relative axes.
[    87.492] (**) HID 04d9:1400: (accel) keeping acceleration scheme 1
[    87.492] (**) HID 04d9:1400: (accel) acceleration profile 0
[    87.492] (**) HID 04d9:1400: (accel) acceleration factor: 2.000
[    87.492] (**) HID 04d9:1400: (accel) acceleration threshold: 4
[    87.493] (II) config/udev: Adding input device HID 04d9:1400 (/dev/input/mouse1)
[    87.493] (**) HID 04d9:1400: Applying InputClass "keyboard0"
[    87.493] (II) Using input driver 'evdev' for 'HID 04d9:1400'
[    87.493] (**) HID 04d9:1400: always reports core events
[    87.494] (**) evdev: HID 04d9:1400: Device: "/dev/input/mouse1"
[    87.494] (EE) evdev: HID 04d9:1400: Unable to query fd: Inappropriate ioctl for device
[    87.504] (EE) PreInit returned 2 for "HID 04d9:1400"
[    87.504] (II) UnloadModule: "evdev"
[    87.504] (II) config/udev: Adding input device UVC Camera (046d:0990) (/dev/input/event3)
[    87.505] (**) UVC Camera (046d:0990): Applying InputClass "evdev keyboard catchall"
[    87.505] (**) UVC Camera (046d:0990): Applying InputClass "keyboard0"
[    87.505] (II) Using input driver 'evdev' for 'UVC Camera (046d:0990)'
[    87.505] (**) UVC Camera (046d:0990): always reports core events
[    87.505] (**) evdev: UVC Camera (046d:0990): Device: "/dev/input/event3"
[    87.505] (--) evdev: UVC Camera (046d:0990): Vendor 0x46d Product 0x990
[    87.505] (--) evdev: UVC Camera (046d:0990): Found keys
[    87.505] (II) evdev: UVC Camera (046d:0990): Configuring as keyboard
[    87.505] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.7/usb2/2-2/2-2:1.0/input/input6/event3"
[    87.505] (II) XINPUT: Adding extended input device "UVC Camera (046d:0990)" (type: KEYBOARD, id 9)
[    87.505] (**) Option "xkb_rules" "evdev"
[    87.505] (**) Option "xkb_model" "logitech_base"
[    87.505] (**) Option "xkb_layout" "us_intl"
[    87.505] (**) Option "xkb_variant" "qwerty,euro"
[    87.505] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    87.506] (II) config/udev: Adding input device PC Speaker (/dev/input/event0)
[    87.506] (**) PC Speaker: Applying InputClass "keyboard0"
[    87.506] (II) Using input driver 'evdev' for 'PC Speaker'
[    87.506] (**) PC Speaker: always reports core events
[    87.506] (**) evdev: PC Speaker: Device: "/dev/input/event0"
[    87.506] (--) evdev: PC Speaker: Vendor 0x1f Product 0x1
[    87.506] (WW) evdev: PC Speaker: Don't know how to use device
[    87.520] (EE) PreInit returned 8 for "PC Speaker"
[    87.520] (II) UnloadModule: "evdev"
[  4359.500] (--) NVIDIA(GPU-0): CRT-0: disconnected
[  4359.500] (--) NVIDIA(GPU-0): CRT-0: 400.0 MHz maximum pixel clock
[  4359.500] (--) NVIDIA(GPU-0):
[  4359.521] (--) NVIDIA(GPU-0): AOC 2236 (DFP-0): connected
[  4359.521] (--) NVIDIA(GPU-0): AOC 2236 (DFP-0): Internal TMDS
[  4359.521] (--) NVIDIA(GPU-0): AOC 2236 (DFP-0): 330.0 MHz maximum pixel clock
[  4359.521] (--) NVIDIA(GPU-0):
[  4359.522] (--) NVIDIA(GPU-0): DFP-1: disconnected
[  4359.522] (--) NVIDIA(GPU-0): DFP-1: Internal TMDS
[  4359.522] (--) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
[  4359.522] (--) NVIDIA(GPU-0):
[  4359.522] (--) NVIDIA(GPU-0): DFP-2: disconnected
[  4359.522] (--) NVIDIA(GPU-0): DFP-2: Internal TMDS
[  4359.522] (--) NVIDIA(GPU-0): DFP-2: 165.0 MHz maximum pixel clock
[  4359.522] (--) NVIDIA(GPU-0):
[  4359.522] (--) NVIDIA(GPU-0): DFP-3: disconnected
[  4359.522] (--) NVIDIA(GPU-0): DFP-3: Internal DisplayPort
[  4359.522] (--) NVIDIA(GPU-0): DFP-3: 960.0 MHz maximum pixel clock
[  4359.522] (--) NVIDIA(GPU-0):
[    85.845]    Entry deleted from font path.
[    85.845]    (Run 'mkfontdir' on


# cat /usr/share/X11/xorg.conf.d/20opengl.conf
Code:
Section "Files"
        ModulePath "/usr/lib32/xorg/modules"
        ModulePath "/usr/lib64/opengl/nvidia"
        ModulePath "/usr/lib64/xorg/modules"
EndSection


# cat /usr/share/X11/xorg.conf.d/modules.conf
Code:
Section "Module"
    Load           "glx"
    Load           "extmod"
    Load           "record"
    Load           "dbe"
    Load           "dri"
    Load           "dri2"
    Disable        "noveau"
    Disable        "xinerama"
EndSection
`fonts.dir' not found


edit:
Solution was found. It had to do with xorg.conf related files overriding other configuration files

TOPIC IS SOLVED
_________________
Do you hear the sound of inevitability?
With age, comes great grumpiness and that, was 20 years ago...

CertFP: becbbd161d5a5c31de3c45171b77bf710911db29 / d985d21f89fe2977b593c4d381a1a86802e62990d9328d893db76d59f9935244
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum