Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] kdm / sddm text missing
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
trigggl
Apprentice
Apprentice


Joined: 26 Aug 2007
Posts: 234
Location: Arkansas

PostPosted: Wed Jun 08, 2016 8:00 pm    Post subject: [solved] kdm / sddm text missing Reply with quote

I don't know why I can't figure this out, but when I had KDE4 (kdm) and now that I have Plasma 5 (sddm), I don't get any text in the greeter. I've cross checked with two of my other computers that do show the text and I can't find any setting regarding text that is obviously different. Sad that my main PC is the one with the problem. This has been going on for a while, but I just didn't reboot enough to care much. It has finally gotten on my nerves enough that I want to fix it.

Does this sound like I need to recompile something, or change some USE flags for some text related package or what? Perhaps it's some file somewhere that I modified inadvertently and never changed back.

emerge --info:
Quote:
Portage 2.2.28 (python 2.7.10-final-0, default/linux/amd64/13.0/desktop/plasma, gcc-4.9.3, glibc-2.22-r4, 4.1.15-gentoo-r1 x86_64)
=================================================================
System uname: Linux-4.1.15-gentoo-r1-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9550_@_2.83GHz-with-gentoo-2.2
KiB Mem: 8179508 total, 3157612 free
KiB Swap: 3028216 total, 3028032 free
Timestamp of repository gentoo: Tue, 07 Jun 2016 15:00:01 +0000
sh bash 4.3_p42-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
distcc 3.2rc1 x86_64-pc-linux-gnu [enabled]
app-shells/bash: 4.3_p42-r1::gentoo
dev-java/java-config: 2.2.0-r3::gentoo
dev-lang/perl: 5.20.2::gentoo
dev-lang/python: 2.7.10-r1::gentoo, 3.4.3-r1::gentoo
dev-util/cmake: 3.3.1-r1::gentoo
dev-util/pkgconfig: 0.28-r2::gentoo
sys-apps/baselayout: 2.2::gentoo
sys-apps/openrc: 0.19.1::gentoo
sys-apps/sandbox: 2.10-r1::gentoo
sys-devel/autoconf: 2.13::gentoo, 2.69::gentoo
sys-devel/automake: 1.11.6-r1::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils: 2.25.1-r1::gentoo
sys-devel/gcc: 4.9.3::gentoo
sys-devel/gcc-config: 1.7.3::gentoo
sys-devel/libtool: 2.4.6::gentoo
sys-devel/make: 4.1-r1::gentoo
sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers)
sys-libs/glibc: 2.22-r4::gentoo
Repositories:

gentoo
location: /usr/portage
sync-type: rsync
sync-uri: rsync://rsync.gentoo.org/gentoo-portage
priority: -1000

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=core2 -mcx16 -msahf -mfxsr --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=6144 -mtune=core2"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=core2 -mcx16 -msahf -mfxsr --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=6144 -mtune=core2"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps=y --nospinner"
FCFLAGS="-O2 -pipe -march=core2 -mcx16 -msahf -mfxsr --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=6144 -mtune=core2"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distcc distlocks ebuild-locks fail-clean fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe -march=core2 -mcx16 -msahf -mfxsr --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=6144 -mtune=core2"
GENTOO_MIRRORS="http://gentoo.cites.uiuc.edu/pub/gentoo/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j17 -l4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 bash-completion berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam firefox flac fortran gif glamor gpm graphicsmagick gtk iconv ipv6 jpeg kde kipi lcms libnotify lm_sensors mad mmx mmxext mng modules mp3 mp4 mpeg multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds pulseaudio qml qt3support qt4 qt5 readline sdl seccomp semantic-desktop session spell sse sse2 ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vaapi vdpau vorbis widgets wxwidgets x264 xattr xcb xcomposite xinerama xml xscreensaver xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="canon ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2 sse3 sse4_1 ssse3" CURL_SSL="openssl" DVB_CARDS="cx23880" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_US" LIRC_DEVICES="pctv" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" SANE_BACKENDS="kodak avision" USERLAND="GNU" VIDEO_CARDS="nvidia v4l2" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset: CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

_________________
Greg


Last edited by trigggl on Wed Jun 08, 2016 11:35 pm; edited 1 time in total
Back to top
View user's profile Send private message
trigggl
Apprentice
Apprentice


Joined: 26 Aug 2007
Posts: 234
Location: Arkansas

PostPosted: Wed Jun 08, 2016 8:26 pm    Post subject: Reply with quote

I guess I should also post my fontconfig:
Quote:
Available fontconfig .conf files (* is enabled):
[1] 10-autohint.conf
[2] 10-no-sub-pixel.conf
[3] 10-scale-bitmap-fonts.conf *
[4] 10-sub-pixel-bgr.conf
[5] 10-sub-pixel-rgb.conf *
[6] 10-sub-pixel-vbgr.conf
[7] 10-sub-pixel-vrgb.conf
[8] 10-unhinted.conf
[9] 11-lcdfilter-default.conf *
[10] 11-lcdfilter-legacy.conf
[11] 11-lcdfilter-light.conf
[12] 20-unhint-small-dejavu-sans.conf *
[13] 20-unhint-small-dejavu-sans-mono.conf *
[14] 20-unhint-small-dejavu-serif.conf *
[15] 20-unhint-small-vera.conf *
[16] 25-ttf-arphic-ukai-render.conf
[17] 25-ttf-arphic-uming-bitmaps.conf
[18] 25-ttf-arphic-uming-render.conf
[19] 25-unhint-nonlatin.conf
[20] 30-metric-aliases.conf *
[21] 30-urw-aliases.conf *
[22] 35-ttf-arphic-ukai-aliases.conf
[23] 35-ttf-arphic-uming-aliases.conf
[24] 40-nonlatin.conf *
[25] 41-ttf-arphic-ukai.conf
[26] 41-ttf-arphic-uming.conf
[27] 42-luxi-mono.conf *
[28] 43-wqy-zenhei-sharp.conf
[29] 44-wqy-zenhei.conf
[30] 45-latin.conf *
[31] 49-sansserif.conf *
[32] 50-user.conf *
[33] 51-local.conf *
[34] 57-dejavu-sans.conf *
[35] 57-dejavu-sans-mono.conf *
[36] 57-dejavu-serif.conf *
[37] 60-latin.conf *
[38] 60-liberation.conf *
[39] 61-stix.conf *
[40] 62-croscore-arimo.conf *
[41] 62-croscore-cousine.conf *
[42] 62-croscore-symbolneu.conf *
[43] 62-croscore-tinos.conf *
[44] 64-ttf-arphic-uming.conf
[45] 65-fonts-persian.conf *
[46] 65-khmer.conf *
[47] 65-nonlatin.conf *
[48] 66-ja-ipafonts.conf
[49] 66-takao-fonts.conf
[50] 69-unifont.conf *
[51] 70-no-bitmaps.conf
[52] 70-yes-bitmaps.conf *
[53] 75-ttf-arphic-ukai-select.conf
[54] 75-yes-terminus.conf *
[55] 80-delicious.conf *
[56] 90-synthetic.conf *
[57] 90-ttf-arphic-ukai-embolden.conf
[58] 90-ttf-arphic-uming-embolden.conf
[59] 99pdftoopvp.conf *

_________________
Greg
Back to top
View user's profile Send private message
trigggl
Apprentice
Apprentice


Joined: 26 Aug 2007
Posts: 234
Location: Arkansas

PostPosted: Wed Jun 08, 2016 11:34 pm    Post subject: Reply with quote

Found the problem.

I had some folder permission/ownership problems in "/usr/share/fonts/".

The folders in question were owned by a user account (greg) with permission set to 700. I may have copied some fonts from a thumbdrive. The folders were all caps.
_________________
Greg
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum