Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Making X11 use the Microsoft numpad behavoir
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
demize
n00b
n00b


Joined: 05 Jun 2016
Posts: 3

PostPosted: Sun Jun 05, 2016 7:41 pm    Post subject: Making X11 use the Microsoft numpad behavoir Reply with quote

I just setup Gentoo on my laptop, and since it's a laptop keyboard I tend to use Shift+Numpad 7 to select from my cursor to the beginning of a line. Unfortunately, the default behavior of X11 is to make that key combination type "7" instead, which is pretty far from what I actually want it to do. There is an option that changed this behavior in OpenSUSE and in Ubuntu (when I used them), but this doesn't work here despite being picked up by X11:

My 00-keyboard.conf file:
Code:

# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "us"
        Option "XkbModel" "pc105+inet"
        Option "XkbOptions" "terminate:ctrl_alt_bksp,numpad:microsoft"
EndSection


The output of localectl showing that the numpad:microsoft option is picked up:

Code:

   System Locale: LANG=en_US.utf8
                  LC_COLLATE=C
       VC Keymap: us
      X11 Layout: us
       X11 Model: pc105+inet
     X11 Options: terminate:ctrl_alt_bksp,numpad:microsoft


Further, there are no errors in /var/log/Xorg.0.log about this option (but it does show that it was picked up from the file).
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Mon Jun 06, 2016 2:01 pm    Post subject: Reply with quote

Does it work if you run
Code:
$ setxkbmap -option numpad:microsoft
?

What if you remove terminate:ctrl_alt_bksp from xorg.conf?
Back to top
View user's profile Send private message
demize
n00b
n00b


Joined: 05 Jun 2016
Posts: 3

PostPosted: Tue Jun 07, 2016 1:38 am    Post subject: Reply with quote

Code:
setxkbmap
appears to work, but only if I run it manually. I've tried putting it in ~/.profile, ~/.xinitrc, /etc/gdm/PostLogin/Default, but after a login it still defaults to the behavior I don't want.

Removing terminate:ctrl_alt_bksp from xorg.conf doesn't change anything either.
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Tue Jun 07, 2016 7:46 am    Post subject: Reply with quote

My theory is then that you are using a desktop environment which interferes with your keyboard settings.
Back to top
View user's profile Send private message
demize
n00b
n00b


Joined: 05 Jun 2016
Posts: 3

PostPosted: Tue Jun 07, 2016 11:11 am    Post subject: Reply with quote

I found a setting in GNOME Tweak Tool that fixed it (Typing->Miscellaneous Compatibility Options->Numlock on:...).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum