Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] New Plasma 5 Install Dolphin Blocked Package?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
dmac0o1
n00b
n00b


Joined: 01 May 2016
Posts: 19

PostPosted: Mon May 30, 2016 12:23 am    Post subject: [SOLVED] New Plasma 5 Install Dolphin Blocked Package? Reply with quote

Hey everyone,


I'm in the process of configuring a new Plasma 5 install, and I'm getting an error regarding a blocked package when I try to emerge Dolphin.

Code:
~ # emerge kde-apps/dolphin
Calculating dependencies... done!
[ebuild  N     ] dev-libs/xapian-1.2.22  USE="brass chert inmemory -doc -static-libs" CPU_FLAGS_X86="sse sse2"
[ebuild  N     ] dev-libs/qjson-0.8.1-r1  USE="-debug -doc {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] app-office/akonadi-server-1.13.0-r2  USE="mysql qt4 -postgres (-qt5) -sqlite {-test}"
[ebuild  N     ] app-crypt/gpgme-1.5.5  USE="-common-lisp -static-libs"
[ebuild  N     ] kde-base/kfilemetadata-4.14.3  USE="exif pdf (-aqua) -debug -epub -ffmpeg -mobi -taglib"
[ebuild  N     ] kde-apps/kdialog-15.08.3  USE="(-aqua) -debug"
[ebuild  N     ] kde-apps/kdepimlibs-4.14.10  USE="handbook ldap (-aqua) -debug -prison {-test}"
[ebuild  N     ] kde-base/baloo-4.14.3  USE="(-aqua) -debug -minimal"
[ebuild  N     ] kde-apps/kfind-15.08.3  USE="handbook (-aqua) -debug"
[ebuild  N     ] kde-apps/kdebase-kioslaves-15.08.3  USE="bzip2 exif handbook sftp (-aqua) -debug -lzma -openexr -samba"
[ebuild  N     ] kde-apps/baloo-widgets-4.14.3  USE="(-aqua) -debug"
[ebuild  N     ] kde-base/kactivities-4.13.3-r2  USE="(-aqua)"
[ebuild  N     ] kde-apps/dolphin-4.14.3-r1  USE="handbook semantic-desktop (-aqua) -debug -thumbnail"
[blocks B      ] kde-base/baloo:4[-minimal(-)] ("kde-base/baloo:4[-minimal(-)]" is blocking kde-frameworks/baloo-5.21.0)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-base/baloo-4.14.3:4/4.14::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-base/baloo-4.14.3:4[aqua=] (>=kde-base/baloo-4.14.3:4[-aqua]) required by (kde-apps/baloo-widgets-4.14.3:4/4.14::gentoo, ebuild scheduled for merge)
    >=kde-base/baloo-4.14.3:4[aqua=] (>=kde-base/baloo-4.14.3:4[-aqua]) required by (kde-apps/dolphin-4.14.3-r1:4/4.14::gentoo, ebuild scheduled for merge)

  (kde-frameworks/baloo-5.21.0:5/5.21::gentoo, installed) pulled in by
    >=kde-frameworks/baloo-5.19.0:5 required by (kde-plasma/plasma-desktop-5.5.5-r1:5/5::gentoo, installed)
    >=kde-frameworks/baloo-5.21.0:5 required by (kde-plasma/plasma-workspace-5.5.5-r2:5/5::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages



1. If I manually install the older version of baloo (4.14.3:4) required for Dolphin, will that break my plasma desktop and workspace? Should I just manually emerge the older version of baloo and then try again?



2. Also, kind of unrelated, is there a way to add a USE flag in the terminal when I emerge a file? eg:

Code:
~ # emerge USE="thumbnail" kde-apps/dolphin


(I remember seeing something similar somewhere, but I forget what it was exactly...)


Last edited by dmac0o1 on Tue May 31, 2016 6:15 am; edited 1 time in total
Back to top
View user's profile Send private message
keet
Guru
Guru


Joined: 09 Sep 2008
Posts: 531

PostPosted: Mon May 30, 2016 12:53 am    Post subject: Reply with quote

Since you are installing Plasma 5, not K.D.E. 4, you might want to try installing something higher than version 4 of the applications.

Interestingly, though, I ran 'emerge -pv kde-apps/dolphin:4', on top of my Plasma 5 installation, and it just reported slotted installations of baloo and its dependencies, with no conflicts. It might be that I keyworded other packages that prevent the conflict that you are seeing.

If you want to install something with a certain USE flag only once, the syntax is:

Code:
USE="whatever" emerge packagename


If you want always to install the package with that flag, then this article should help.
Back to top
View user's profile Send private message
dmac0o1
n00b
n00b


Joined: 01 May 2016
Posts: 19

PostPosted: Mon May 30, 2016 1:29 am    Post subject: Reply with quote

Thank you for the response!

How can I ensure that I only emerge versions relevant to Plasma 5, and not K.D.E. 4?
Back to top
View user's profile Send private message
dmac0o1
n00b
n00b


Joined: 01 May 2016
Posts: 19

PostPosted: Mon May 30, 2016 1:53 am    Post subject: Reply with quote

Interestingly enough I've noticed that even though I have th recent builds of dolphin (and other kde apps), the 4.x version is still listed as the "latest version available".

Code:

~ # ls /usr/portage/kde-apps/dolphin
ChangeLog  ChangeLog-2015  Manifest  dolphin-15.12.3-r1.ebuild  dolphin-16.04.1.ebuild  dolphin-4.14.3-r1.ebuild  dolphin-4.14.3.ebuild  metadata.xml


Code:

~ # emerge --ask =dolphin-15.12.3-r1

These are the packages that would be merged, in order:

Calculating dependencies -

 
[ Results for search key : dolphin ]
*  games-emulation/dolphin [ Masked ]
      Latest version available: 9999
      Latest version installed: [ Not Installed ]
      Size of files: 0 KiB
      Homepage:      https://www.dolphin-emu.org/
      Description:   Gamecube and Wii game emulator
      License:       GPL-2

*  kde-apps/dolphin
      Latest version available: 4.14.3-r1
      Latest version installed: [ Not Installed ]
      Size of files: 2,489 KiB
      Homepage:      https://dolphin.kde.org https://www.kde.org/applications/system/dolphin
      Description:   A KDE filemanager focusing on usability
      License:       GPL-2

[ Applications found : 4 ]

!!! The short ebuild name "=dolphin-15.12.3-r1" is ambiguous. Please specify
!!! one of the above fully-qualified ebuild names instead.

... done!



Why does it default to the 4.x version?
Back to top
View user's profile Send private message
dmac0o1
n00b
n00b


Joined: 01 May 2016
Posts: 19

PostPosted: Mon May 30, 2016 2:07 am    Post subject: Reply with quote

Also, I just successfully emerged ksnapshot via:

Code:
~ # emerge --ask =ksnapshot-15.08.3-r1

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] kde-apps/ksnapshot-15.08.3-r1  USE="handbook kipi (-aqua) -debug"


But when I open it up and look at the "about KDE" dropdown, I see "KDE - Be Free! Platform Version 4.14.16".


I emerged Plasma 5 from a "clean" install (i.e. no KDE 4 -- I was previously using i3 and XFCE4) through setting my system profile to "plasma", then emerging:

Code:
emerge --update --changed-use @world && emerge kde-plasma/plasma-meta


Did I do something wrong? I'm on my Plasma desktop right now, so I'm certain that at least SOME of the install went well.

How can I make sure that my I emerge the relevant KDE Applications version (I believe it's 15.x for stable)?
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7112
Location: Austria

PostPosted: Mon May 30, 2016 5:06 am    Post subject: Reply with quote

If you don't get supplied with 15.12.3 packages then you are missing a recent enough `emerge --sync`, it was stabilised (amd64 only) a few days ago.

The blocker in your first post is only possible if you actually don't use plasma profile, or if you (wrongly) set USE=-minimal.

ksnapshot is discontinued, new screenshots application is spectacle.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
dmac0o1
n00b
n00b


Joined: 01 May 2016
Posts: 19

PostPosted: Mon May 30, 2016 2:43 pm    Post subject: Reply with quote

@genstorm
That's it. I put the -minimal flag on while emerging the metapackage.

I'd like to start over. It seems it is not cleaning up nicely without a complete unmerge... Doing an
Code:
emerge --deep --update --changed-use @world

is just running into all the same dependency errors.

How can I completely unmerge the entire Plasma 5 metapackage to start afresh?
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7112
Location: Austria

PostPosted: Mon May 30, 2016 2:58 pm    Post subject: Reply with quote

Why would you? What blocks do you get? Try -N in addition.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
dmac0o1
n00b
n00b


Joined: 01 May 2016
Posts: 19

PostPosted: Tue May 31, 2016 6:11 am    Post subject: Reply with quote

I re-emerged everything without the "-minimal" USE flag and it's all good now! Thank you for your help. :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum