Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Incomplete? migration to Plasma
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
iandoug
Guru
Guru


Joined: 11 Feb 2005
Posts: 537
Location: Cape Town, South Africa

PostPosted: Fri May 27, 2016 12:08 pm    Post subject: Incomplete? migration to Plasma Reply with quote

Hi

A few weeks back I moved to Plasma as "suggested", had some issues, but the latest updates the past few days are more stable.

However if I look at what is installed, I seem to still be on KDE4 for a lot of things, eg (a selection)

Code:


[U] kde-apps/kapptemplate
     Available versions: 
     (4)    4.14.3(4/4.14)
     (5)    15.12.3-r1 ~16.04.1
       {aqua debug +handbook test}
     Installed versions:  4.14.3(4)(00:29:12 13/12/2014)(handbook -aqua -debug)
     Homepage:            https://www.kde.org/applications/development/kapptemplate
     Description:         A shell script to create the necessary framework to develop KDE applications

[U] kde-apps/kate
     Available versions: 
     (4)    4.14.3(4/4.14)
     (5)    15.12.3 ~16.04.1
       {+addons aqua debug +handbook python test PYTHON_SINGLE_TARGET="python2_7 python3_3 python3_4" PYTHON_TARGETS="python2_7 python3_3 python3_4"}
     Installed versions:  4.14.3(4)(23:44:50 02/10/2015)(handbook python -aqua -debug PYTHON_SINGLE_TARGET="python2_7 -python3_3 -python3_4" PYTHON_TARGETS="python2_7 python3_4 -python3_3")
     Homepage:            https://www.kde.org/applications/utilities/kate http://kate-editor.org
     Description:         Kate is an advanced text editor

[U] kde-apps/katomic
     Available versions: 
     (4)    4.14.3(4/4.14)
     (5)    15.12.3 ~16.04.1
       {aqua debug +handbook selinux}
     Installed versions:  4.14.3(4)(23:14:08 03/10/2015)(handbook -aqua -debug -selinux)
     Homepage:            https://www.kde.org/applications/games/katomic/ https://games.kde.org/game.php?game=katomic
     Description:         KDE Atomic Entertainment Game

[U] kde-apps/kblackbox
     Available versions: 
     (4)    4.14.3(4/4.14)
     (5)    15.12.3 ~16.04.1
       {aqua debug +handbook selinux}
     Installed versions:  4.14.3(4)(23:20:59 03/10/2015)(handbook -aqua -debug -selinux)
     Homepage:            https://www.kde.org/
     Description:         KDE Blackbox Game

[U] kde-apps/kblocks
     Available versions: 
     (4)    4.14.3(4/4.14)
     (5)    15.12.3-r1 ~16.04.1
       {aqua debug +handbook}
     Installed versions:  4.14.3(4)(23:28:40 03/10/2015)(handbook -aqua -debug)
     Homepage:            https://www.kde.org/applications/games/kblocks/
     Description:         A single-player Tetris-like KDE game

[U] kde-apps/kbounce
     Available versions: 
     (4)    4.14.3(4/4.14)
     (5)    15.12.3 ~16.04.1
       {aqua debug +handbook selinux}
     Installed versions:  4.14.3(4)(23:13:48 03/10/2015)(handbook -aqua -debug -selinux)
     Homepage:            https://www.kde.org/applications/games/kbounce/ https://games.kde.org/game.php?game=kbounce
     Description:         KDE Bounce Ball Game


[U] kde-apps/kbruch
     Available versions: 
     (4)    4.14.3(4/4.14)
     (5)    15.12.3-r1 ~16.04.1
       {aqua debug +handbook}
     Installed versions:  4.14.3(4)(22:48:49 03/10/2015)(handbook -aqua -debug)
     Homepage:            https://www.kde.org/applications/education/kbruch https://edu.kde.org/kbruch
     Description:         Educational application to learn calculating with fractions


[U] kde-apps/kcalc
     Available versions: 
     (4)    4.14.3(4/4.14)
     (5)    15.12.3-r1 ~16.04.1
       {aqua debug doc +handbook test}
     Installed versions:  4.14.3(4)(22:56:03 03/10/2015)(handbook -aqua -debug)
     Homepage:            https://www.kde.org/applications/utilities/kcalc https://utils.kde.org/projects/kcalc
     Description:         KDE calculator



But emerge does not upgrade them.

I don't appear to have anything relevant in the portage config files which would block them, except perhaps this, suggested in these forums:

Code:

# some settings for during the KDE 4 to 5 migration
kde-apps/kde-wallpapers minimal
kde-apps/kde4-l10n minimal
kde-apps/kdeartwork-meta minimal
kde-apps/kdebase-kioslaves-4* minimal
kde-apps/kdebase-runtime-meta minimal
kde-apps/konsole-4* minimal


Should I remove that now, or is there some other magic trick to get portage to upgrade the packages still in slot 4?

Thanks, Ian
_________________
Asus Sabertooth P990, AMD FX-8150, GeForce GTX 560, 16GB Ram | Asus M3A78 64, X2 6000+, PX9800 GT, 4GB Ram | Asus M4A77TD PRO, X2 245, HD4350, 4GB RAM
Back to top
View user's profile Send private message
kite14
Apprentice
Apprentice


Joined: 07 Nov 2006
Posts: 199
Location: Pordenone/Italy

PostPosted: Fri May 27, 2016 3:11 pm    Post subject: Reply with quote

Hello Ian,
probably those packages cannot be update because they have "slot 4" dependencies.
Try, for example:
Code:
equery d kde-apps/kapptemplate

and you probably will find out it depends on some "slot 4" atom...
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7138
Location: Austria

PostPosted: Fri May 27, 2016 3:28 pm    Post subject: Reply with quote

Please read: https://wiki.gentoo.org/wiki/KDE/de#KDE_Frameworks.2C_Plasma.2C_and_Applications_5

If you have synced today, then the only reason for not getting those upgrades would be you are missing entries in your world file. After Plasma-5 migration, you would usually have plasma-meta in your world file. But that's only for the desktop; for Applications, you either pick kde-apps-meta or choose an individual selection of smaller meta packages or even single packages, as you wish.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
iandoug
Guru
Guru


Joined: 11 Feb 2005
Posts: 537
Location: Cape Town, South Africa

PostPosted: Fri May 27, 2016 9:58 pm    Post subject: Reply with quote

genstorm wrote:
Please read: https://wiki.gentoo.org/wiki/KDE/de#KDE_Frameworks.2C_Plasma.2C_and_Applications_5

If you have synced today, then the only reason for not getting those upgrades would be you are missing entries in your world file. After Plasma-5 migration, you would usually have plasma-meta in your world file. But that's only for the desktop; for Applications, you either pick kde-apps-meta or choose an individual selection of smaller meta packages or even single packages, as you wish.


Ah, such magic. Sorted. Thanks a mill :-)

Cheers, Ian
_________________
Asus Sabertooth P990, AMD FX-8150, GeForce GTX 560, 16GB Ram | Asus M3A78 64, X2 6000+, PX9800 GT, 4GB Ram | Asus M4A77TD PRO, X2 245, HD4350, 4GB RAM
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum