Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] XFCE - cant mount luks encrypted usb disk
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
vlynd
Tux's lil' helper
Tux's lil' helper


Joined: 23 Jan 2012
Posts: 113

PostPosted: Thu May 26, 2016 10:12 am    Post subject: [SOLVED] XFCE - cant mount luks encrypted usb disk Reply with quote

I have an external USB Drive which is completely encrypted with LUKS.
When I plug it in, it expect to be prompted with a password prompt, but nothing happens.
Unencrypted USB sticks just pop up in Thunar without problems.

Code:

# fdisk -l /dev/sdc
Disk /dev/sdc: 3,7 TiB, 4000752599040 bytes, 976746240 sectors
Units: sectors of 1 * 4096 = 4096 bytes
Sector size (logical/physical): 4096 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0xdb4bf07b

Device     Boot Start       End   Sectors  Size Id Type
/dev/sdc1         256 976746239 976745984  3,7T 83 Linux


Code:

$ groups
disk lp wheel audio video usb users plugdev lpadmin portage vlynd


I suppose it could be a deeper-lying problem since I cant even mount it via console:

Code:

# cryptsetup luksOpen /dev/sdc1 foobar
Device /dev/sdc1 doesn't exist or access denied.


EDIT

Solved it. Was missing MS DOS table support in my kernel config.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum