Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
upgrade KDE4 to KDE5 - multiple conflicts
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
dr_Fell
Apprentice
Apprentice


Joined: 10 Nov 2004
Posts: 170
Location: Sosnowiec, Poland

PostPosted: Wed May 25, 2016 7:41 pm    Post subject: upgrade KDE4 to KDE5 - multiple conflicts Reply with quote

Hello. I am just trying to upgrade my box to kde5, using https://wiki.gentoo.org/wiki/KDE/Plasma_5_upgrade .

When I try to do: emerge --ask --changed-use --newrepo --deep world I am getting multiple conflicts:

Code:


!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtcore:5

  (dev-qt/qtcore-5.6.0:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-5.6.0 required by (dev-qt/qtnetwork-5.6.0:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                     
    (and 12 more with the same problem)

  (dev-qt/qtcore-5.5.1-r1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-5.5.1 required by (dev-qt/qttest-5.5.1:5/5::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                 
    (and 15 more with the same problem)

dev-qt/qtgui:5

  (dev-qt/qtgui-5.6.0-r1:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtgui-5.6.0 required by (dev-qt/qtsvg-5.6.0:5/5.6::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                 
    (and 4 more with the same problem)

  (dev-qt/qtgui-5.5.1-r1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtgui-5.5.1 required by (dev-qt/qtwebkit-5.5.1-r1:5/5::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                     
    (and 10 more with the same problem)

dev-qt/qtdbus:5

  (dev-qt/qtdbus-5.6.0:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtdbus-5.6.0 required by (dev-qt/qtgui-5.6.0-r1:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                     

  (dev-qt/qtdbus-5.5.1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtdbus-5.5.1 required by (dev-qt/qtgui-5.5.1-r1:5/5::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                   

dev-qt/qtdeclarative:5

  (dev-qt/qtdeclarative-5.6.0:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtdeclarative-5.6.0 required by (dev-qt/qtquickcontrols-5.6.0:5/5.6::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                                                                           
    (and 1 more with the same problem)

  (dev-qt/qtdeclarative-5.5.1-r1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtdeclarative-5.5.1 required by (dev-qt/qtwebkit-5.5.1-r1:5/5::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                                                                     
    (and 3 more with the same problem)

dev-qt/qttest:5

  (dev-qt/qttest-5.6.0:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qttest-5.6.0 required by (dev-qt/qtdeclarative-5.6.0:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                         

  (dev-qt/qttest-5.5.1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qttest-5.5.1 required by (dev-qt/qtdeclarative-5.5.1-r1:5/5::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                           

dev-qt/qtxmlpatterns:5

  (dev-qt/qtxmlpatterns-5.6.0:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtxmlpatterns-5.6.0 required by (dev-qt/qtdeclarative-5.6.0:5/5.6::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                                                                         

  (dev-qt/qtxmlpatterns-5.5.1-r1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtxmlpatterns-5.5.1 required by (dev-qt/qtquick1-5.5.1-r1:5/5::gentoo, installed)
    ^                     ^^^^^                                                                                                                     
    (and 1 more with the same problem)

dev-qt/qtwidgets:5

  (dev-qt/qtwidgets-5.6.0:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtwidgets-5.6.0 required by (dev-qt/qtsvg-5.6.0:5/5.6::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                                                                 
    (and 2 more with the same problem)

  (dev-qt/qtwidgets-5.5.1-r1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtwidgets-5.5.1 required by (dev-qt/qtmultimedia-5.5.1-r2:5/5::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                                                                         
    (and 7 more with the same problem)

dev-qt/qtnetwork:5

  (dev-qt/qtnetwork-5.6.0:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtnetwork-5.6.0 required by (dev-qt/qtdeclarative-5.6.0:5/5.6::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                                                                         
    (and 1 more with the same problem)

  (dev-qt/qtnetwork-5.5.1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtnetwork-5.5.1 required by (dev-qt/qtmultimedia-5.5.1-r2:5/5::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                                                                         
    (and 5 more with the same problem)

dev-qt/qtxml:5

  (dev-qt/qtxml-5.6.0:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtxml-5.6.0 required by (dev-qt/linguist-tools-5.6.0:5/5.6::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                           

  (dev-qt/qtxml-5.5.1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtxml-5.5.1 required by (dev-qt/designer-5.5.1-r1:5/5::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                     

dev-lang/perl:0

  (dev-lang/perl-5.22.2:0/5.22::gentoo, installed) pulled in by
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/PlRPC-0.202.0-r2:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                             
    =dev-lang/perl-5.22* required by (virtual/perl-Test-Harness-3.350.0:0/0::gentoo, installed)
    ^              ^^^^^                                                                                                                             
    (and 26 more with the same problems)

  (dev-lang/perl-5.24.0:0/5.24::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.24* required by (virtual/perl-parent-0.234.0:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                         
    (and 2 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above



I tried to remove packages that pull the conflicting versions (as I usually do) but I ended up with emerge trying to install two conflicting packages at once. What should I do?
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Thu May 26, 2016 7:28 am    Post subject: Reply with quote

That is a bad idea very often, especially in case of Qt. I assume this is an ~amd64 system?

Try to upgrade _only_ your already installed Qt packages first:
Code:
# emerge -1ua $(qlist -CI dev-qt/*)

The reason for this command: It will consider all your installed Qt packages for upgrade at the same time and does not rely on (probably incomplete) depgraph to pull them in as dependencies.


Another bad idea is starting such an upgrade before other parts of your system are up to date, as you can see with that perl conflict. You can try to `emerge -uaD world --exclude "kde-plasma/* kde-apps/*` to set things straight, then continue with upgrade guide.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
dr_Fell
Apprentice
Apprentice


Joined: 10 Nov 2004
Posts: 170
Location: Sosnowiec, Poland

PostPosted: Fri May 27, 2016 11:36 am    Post subject: Reply with quote

I did
Code:
# emerge -1ua $(qlist -CI dev-qt/*)
but there wers problems with compiling some qt parts

so I removed whole QT in order to install it later toegether:
Code:
emerge -C $(qlist -CI dev-qt/*)


Then I tried to do
Code:
emerge -uaD world --exclude "kde-plasma/* kde-apps/*
(without success - emerge was still asking about kde4 packages.)

I was removing dependancies part after part, but seems that many KDE4 packages were still there and asked about the rest of the KDE4. So I removed whole KDE
Code:
emerge -Ca $(qlist -CI kde-plasma/* kde-apps/* kde-misc/* kde-base/*)



Then I dit this:
Code:
emerge -uaD world --exclude "kde-plasma/* kde-apps/*
removing some apps that were kde4 dependant and asked about KDE4 packages. No success at this point:



Now I am at the strange point:

Code:

!!! All ebuilds that could satisfy ">=kde-apps/kde4-l10n-4.4:4[aqua=,linguas_de(+)]" have been masked.
!!! One of the following masked packages is required to complete your request:
- kde-apps/kde4-l10n-16.04.1::gentoo (masked by: exclude option)
- kde-apps/kde4-l10n-15.12.3-r1::gentoo (masked by: exclude option)
- kde-apps/kde4-l10n-15.08.3-r2::gentoo (masked by: exclude option)
- kde-apps/kde4-l10n-4.14.3-r1::gentoo (masked by: exclude option)
- kde-apps/kde4-l10n-4.14.3::gentoo (masked by: exclude option)

(dependency required by "sys-auth/polkit-kde-agent-0.99.1-r1::gentoo" [ebuild])
(dependency required by "sys-auth/polkit-0.113-r1::gentoo[kde]" [ebuild])
(dependency required by "sys-auth/consolekit-1.1.0::gentoo" [ebuild])
(dependency required by "sys-auth/pambase-20150213::gentoo[consolekit]" [installed])
(dependency required by "sys-libs/pam-1.3.0::gentoo" [ebuild])
(dependency required by "sys-apps/util-linux-2.28::gentoo[pam]" [ebuild])
(dependency required by "sys-fs/e2fsprogs-1.43::gentoo" [ebuild])
(dependency required by "app-arch/libarchive-3.1.2-r5::gentoo[e2fsprogs]" [ebuild])
(dependency required by "dev-util/cmake-3.5.2-r1::gentoo" [ebuild])
(dependency required by "dev-cpp/eigen-3.2.8-r2::gentoo" [ebuild])
(dependency required by "media-libs/opencv-3.1.0-r1::gentoo[eigen]" [ebuild])
(dependency required by "media-plugins/frei0r-plugins-1.4::gentoo[facedetect]" [installed])
(dependency required by "media-video/ffmpeg-2.8.7::gentoo[frei0r]" [ebuild])
(dependency required by "media-plugins/alsa-plugins-1.1.1::gentoo[-libav,ffmpeg]" [ebuild])
(dependency required by "media-sound/pulseaudio-8.0::gentoo[alsa-plugin,alsa]" [installed])
(dependency required by "dev-qt/qtmultimedia-5.6.0::gentoo[pulseaudio]" [ebuild])
(dependency required by "dev-qt/qtwebkit-5.6.0::gentoo[multimedia]" [ebuild])
(dependency required by "net-misc/dropbox-3.19.34::gentoo[X]" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


It seems that even upgraded QT 5.6 needs KDE4? I am confused.


EDIT: At the end I tried (again)
Code:
emerge --ask --changed-use --newrepo --deep world
- no problems with kde4-l10n this time, and only one conflict (perl). Adding --backtrack=100 solved that problem and the compilation started.
Back to top
View user's profile Send private message
uraes
Tux's lil' helper
Tux's lil' helper


Joined: 28 Nov 2002
Posts: 120
Location: Estonia

PostPosted: Fri May 27, 2016 3:06 pm    Post subject: Reply with quote

Had same problem. Solution - at least for now - remove (comment out) all lines in keywords file pointing to qt, e.g dev-qt/* - move away from unstable

and don't forget "-qt4 -kde qt5" from USE flags (atleast I'm currently in state, where I wan't get rid of all qt4 things)

second thing I did, removed all qt and kde4 things, and then started emerge plasma (but this is already more or less meant to have cleaner feeling)
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Fri May 27, 2016 3:24 pm    Post subject: Reply with quote

uraes wrote:
and don't forget "-qt4 -kde qt5" from USE flags (atleast I'm currently in state, where I wan't get rid of all qt4 things)

Not everything USE=kde means kdelibs4, some things are already kf5-based. Only a minority will want to have -qt4 as a lot of packages within Applications 15.12.3 are still kdelibs4 based - for regular use this is the wrong choice, as Qt4-based applications might look awful as a result. Plasma profile sets things straight automatically.

dr_Fell wrote:
It seems that even upgraded QT 5.6 needs KDE4? I am confused.

No. KDE Applications contains both kf5- and kdelibs4-based applications.

Please read: https://wiki.gentoo.org/wiki/KDE/de#KDE_Frameworks.2C_Plasma.2C_and_Applications_5
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum