Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Icons missing in KDE apps if started from XFCE
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
mike155
l33t
l33t


Joined: 17 Sep 2010
Posts: 990
Location: Frankfurt, Germany

PostPosted: Wed May 25, 2016 3:07 pm    Post subject: [solved] Icons missing in KDE apps if started from XFCE Reply with quote

My main desktop is XFCE, but I installed some KDE 5 apps (konsole, kate, dolphin, etc.)

Two weeks ago, all icons in the KDE 5 apps disappeared. The KDE apps still ran fine, but no icons were shown.

After a while, I found out that I had to do 2 things to get the icons back:
    1) I had to install kde-frameworks/frameworkintegration
    2) I had to set the environment variable XDG_CURRENT_DESKTOP="kde" before starting a KDE app
Update (2016-07-27)
For KDE Frameworks 5.23 (and probably later), these rules must be changed to:
    1) kde-frameworks/frameworkintegration must be installed
    2) The environment variable XDG_CURRENT_DESKTOP must be set to "XFCE" before starting a KDE app


Last edited by mike155 on Wed Jul 27, 2016 11:26 pm; edited 2 times in total
Back to top
View user's profile Send private message
dr.nil
n00b
n00b


Joined: 18 Jul 2007
Posts: 47

PostPosted: Mon Jun 06, 2016 10:09 am    Post subject: Reply with quote

Thanks for documenting this tip. I just ran into this issue and found your workaround.

-dirk
Back to top
View user's profile Send private message
spindle
Apprentice
Apprentice


Joined: 01 Dec 2003
Posts: 243

PostPosted: Mon Jul 18, 2016 10:48 pm    Post subject: Reply with quote

Nice, works great. Fixed it for me as well.
Back to top
View user's profile Send private message
gentooP4
Apprentice
Apprentice


Joined: 20 Sep 2010
Posts: 182
Location: NZ

PostPosted: Fri Jul 22, 2016 2:00 am    Post subject: Reply with quote

Need to try this myself. I have the same issue since moving from KDE4 to XFCE, mainly missing icons for folders, etc in Dolphin.

Here's another suggestion that apparently works
https://forums.gentoo.org/viewtopic-t-1048308.html

EDIT: Damn, neither worked for me :cry:
Back to top
View user's profile Send private message
dasPaul
Apprentice
Apprentice


Joined: 14 Feb 2012
Posts: 183
Location: Dresden

PostPosted: Fri Jul 22, 2016 11:20 am    Post subject: Re: [solved] icons missing in KDE apps Reply with quote

bug_report wrote:

2) I had to set the environment variable XDG_CURRENT_DESKTOP="kde" before starting a KDE app


gorgeous, thanks! I was looking for that quite a while because kstars always started without icons and theme settings without runiing a plasma session.
Back to top
View user's profile Send private message
mike155
l33t
l33t


Joined: 17 Sep 2010
Posts: 990
Location: Frankfurt, Germany

PostPosted: Wed Jul 27, 2016 11:14 pm    Post subject: Reply with quote

Yesterday I upgraded to kde-frameworks 5.23. After that, all icons in my KDE apps were gone again!

After a while, I found out that icons come back if I set XDG_CURRENT_DESKTOP to "XFCE" before starting a KDE app.

For KDE Frameworks 5.23 (and probably later), my first post must be changed to:
    1) kde-frameworks/frameworkintegration must be installed
    2) The environment variable XDG_CURRENT_DESKTOP must be set to "XFCE" before starting a KDE app
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum