Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Installation of KDE SC 4 blocked by masked packages
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
DJ_Rubbie
n00b
n00b


Joined: 03 Jan 2004
Posts: 38
Location: /dev/null

PostPosted: Thu May 19, 2016 6:12 pm    Post subject: [Solved] Installation of KDE SC 4 blocked by masked packages Reply with quote

Emerge can't seem to get around package masks. I have a completely brand new system done per the guidebook, and followed the wiki but it just doesn't work. I also did mask the KDE 5 packages as per other forum posts, but this is what happens.

Code:

# emerge --newuse --update --ask kde-apps/kdebase-meta kde-apps/kdeartwork-meta kde-base/kdebindings-meta kde-apps/kdegraphics-meta kde-apps/kdemultimedia-meta kde-apps/kdenetwork-meta kde-apps/kdeutils-meta

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy ">=kde-apps/kdesu-4.14.3:4[aqua=]" have been masked.
!!! One of the following masked packages is required to complete your request:
- kde-apps/kdesu-16.04.1::gentoo (masked by: package.mask, ~amd64 keyword, invalid: DEPEND: USE flag 'handbook' referenced in conditional 'handbook?' is not in IUSE, invalid: RDEPEND: USE flag 'handbook' referenced in conditional 'handbook?' is not in IUSE)
- kde-apps/kdesu-15.12.3::gentoo (masked by: package.mask, ~amd64 keyword, invalid: DEPEND: USE flag 'handbook' referenced in conditional 'handbook?' is not in IUSE, invalid: RDEPEND: USE flag 'handbook' referenced in conditional 'handbook?' is not in IUSE)
- kde-apps/kdesu-15.08.3::gentoo (masked by: package.mask, invalid: DEPEND: USE flag 'handbook' referenced in conditional 'handbook?' is not in IUSE, invalid: RDEPEND: USE flag 'handbook' referenced in conditional 'handbook?' is not in IUSE)
- kde-apps/kdesu-4.14.3::gentoo (masked by: invalid: DEPEND: USE flag 'handbook' referenced in conditional 'handbook?' is not in IUSE, invalid: RDEPEND: USE flag 'handbook' referenced in conditional 'handbook?' is not in IUSE)

(dependency required by "kde-apps/khelpcenter-4.14.3::gentoo" [ebuild])
(dependency required by "kde-base/kdelibs-4.14.16::gentoo[handbook]" [ebuild])
(dependency required by "kde-apps/kcharselect-4.14.3::gentoo[handbook]" [ebuild])
(dependency required by "kde-apps/kdeutils-meta-4.14.3::gentoo" [ebuild])
(dependency required by "kde-apps/kdeutils-meta" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.



How do I get around and manually unmask kde-apps/kdesu-4.14.3::gentoo as that's the package I want to go with all the 4.x packages for KDE.


Last edited by DJ_Rubbie on Fri May 20, 2016 10:32 am; edited 1 time in total
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6822
Location: Austria

PostPosted: Thu May 19, 2016 6:57 pm    Post subject: Reply with quote

Nothing you can do there except `emerge --sync` to fix a bug in an eclass. It is already fixed, you're just on an outdated state of the tree.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
DJ_Rubbie
n00b
n00b


Joined: 03 Jan 2004
Posts: 38
Location: /dev/null

PostPosted: Fri May 20, 2016 10:32 am    Post subject: Reply with quote

Yup, that did it. It's been way too long since I had a Gentoo box, but after I weighed everything this seemed to be the only distribution that offers modern everything else selectively while keeping KDE 4. After the next sync the dependencies resolved correctly and the build succeeded.
_________________
Please direct all bug reports to /dev/null
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum