Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Skylake Intel GPU > X wont start
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
risq
Tux's lil' helper
Tux's lil' helper


Joined: 03 Dec 2004
Posts: 75

PostPosted: Sun May 15, 2016 5:40 pm    Post subject: Skylake Intel GPU > X wont start Reply with quote

Hi,

i recently bought a NUC6I5SYK with integrated Intel gpu. i used my gentoo installation from my other pc, which has nvidia setup, somehow i cant get X to run.

i removed nvidia-drivers and compile Intel Driver in den kernel

i dont use any xorg.conf, i thought it might start without. xorg -configure gave me a seg fault

Thx for any help or advice

Code:

lspci -v

00:02.0 VGA compatible controller: Intel Corporation Sky Lake Integrated Graphics (rev 0a) (prog-if 00 [VGA controller])
   DeviceName:  CPU
   Subsystem: Intel Corporation Sky Lake Integrated Graphics
   Flags: bus master, fast devsel, latency 0, IRQ 120
   Memory at de000000 (64-bit, non-prefetchable) [size=16M]
   Memory at c0000000 (64-bit, prefetchable) [size=256M]
   I/O ports at f000 [size=64]
   Expansion ROM at <unassigned> [disabled]
   Capabilities: [40] Vendor Specific Information: Len=0c <?>
   Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
   Capabilities: [ac] MSI: Enable+ Count=1/1 Maskable- 64bit-
   Capabilities: [d0] Power Management version 2
   Capabilities: [100] #1b
   Capabilities: [200] Address Translation Service (ATS)
   Capabilities: [300] #13
   Kernel driver in use: i915


when i start X i get this (dont know why the hell its still trying for nvidia?!)

Code:


[   647.515]
X.Org X Server 1.17.4
Release Date: 2015-10-28
[   647.520] X Protocol Version 11, Revision 0
[   647.522] Build Operating System: Linux 4.4.6-gentoo x86_64 Gentoo
[   647.524] Current Operating System: Linux localhost 4.4.6-gentoo #3 SMP Mon May 16 01:24:52 2016 x86_64
[   647.524] Kernel command line: root=/dev/ram0 init=/linuxrc ramdisk=8192 root_trim=yes crypt_root=/dev/sda2 real_root=/dev/vg1/system dolvm
[   647.527] Build Date: 16 May 2016  01:33:57AM
[   647.529] 
[   647.530] Current version of pixman: 0.32.8
[   647.534]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[   647.534] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   647.541] (==) Log file: "/var/log/Xorg.0.log", Time: Mon May 16 01:38:00 2016
[   647.542] (==) Using config file: "/etc/xorg.conf"
[   647.544] (==) Using config directory: "/etc/X11/xorg.conf.d"
[   647.546] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   647.546] (==) ServerLayout "X.org Configured"
[   647.546] (**) |-->Screen "Screen0" (0)
[   647.546] (**) |   |-->Monitor "Monitor0"
[   647.546] (**) |   |-->Device "Card0"
[   647.546] (**) |-->Input Device "Mouse0"
[   647.546] (**) |-->Input Device "Keyboard0"
[   647.546] (==) Automatically adding devices
[   647.546] (==) Automatically enabling devices
[   647.546] (==) Automatically adding GPU devices
[   647.546] (**) FontPath set to:
   /usr/share/fonts/misc/,
   /usr/share/fonts/TTF/,
   /usr/share/fonts/OTF/,
   /usr/share/fonts/Type1/,
   /usr/share/fonts/100dpi/,
   /usr/share/fonts/75dpi/,
   /usr/share/fonts/misc/,
   /usr/share/fonts/TTF/,
   /usr/share/fonts/OTF/,
   /usr/share/fonts/Type1/,
   /usr/share/fonts/100dpi/,
   /usr/share/fonts/75dpi/
[   647.546] (**) ModulePath set to "/usr/lib64/xorg/modules"
[   647.546] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[   647.546] (WW) Disabling Mouse0
[   647.546] (WW) Disabling Keyboard0
[   647.546] (II) Loader magic: 0x80fc80
[   647.546] (II) Module ABI versions:
[   647.546]    X.Org ANSI C Emulation: 0.4
[   647.546]    X.Org Video Driver: 19.0
[   647.546]    X.Org XInput driver : 21.0
[   647.546]    X.Org Server Extension : 9.0
[   647.547] (II) xfree86: Adding drm device (/dev/dri/card0)
[   647.549] (--) PCI:*(0:0:2:0) 8086:1926:8086:2063 rev 10, Mem @ 0xde000000/16777216, 0xc0000000/268435456, I/O @ 0x0000f000/64
[   647.549] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[   647.549] (II) LoadModule: "glx"
[   647.549] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[   647.550] (II) Module glx: vendor="X.Org Foundation"
[   647.550]    compiled for 1.17.4, module version = 1.0.0
[   647.550]    ABI class: X.Org Server Extension, version 9.0
[   647.550] (==) AIGLX enabled
[   647.550] (II) LoadModule: "nvidia"
[   647.550] (WW) Warning, couldn't open module nvidia
[   647.550] (II) UnloadModule: "nvidia"
[   647.550] (II) Unloading nvidia
[   647.550] (EE) Failed to load module "nvidia" (module does not exist, 0)
[   647.550] (EE) No drivers available.
[   647.550] (EE)
Fatal server error:
[   647.554] (EE) no screens found(EE)
[   647.556] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[   647.562] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   647.564] (EE)



Thx for any help or advice
Back to top
View user's profile Send private message
Buffoon
Veteran
Veteran


Joined: 17 Jun 2015
Posts: 1074
Location: EU or US

PostPosted: Sun May 15, 2016 5:45 pm    Post subject: Reply with quote

nvidia proprietary driver won't load unless you force it, there must be a conf file somewhere in your /etc/X11 forcing nvidia load.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum