Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
NetworkManager help [solved]
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message

Joined: 29 May 2004
Posts: 1751
Location: San Jose, CA

PostPosted: Fri May 13, 2016 8:10 pm    Post subject: NetworkManager help [solved] Reply with quote

I know this is ridiculous, but I've never gotten NetworkManager to work with my wifi connection, so I've never installed it before. Now I find that to accomplish my work as a contractor I need CiscoVPN Client to work which of course needs NetworkManager.

I've installed NetworkManager thus:

ebuild   R    ] net-misc/networkmanager-1.0.12-r1::gentoo  USE="bluetooth consolekit dhclient gnutls introspection modemmanager ncurses ppp wext wifi zeroconf -connection-sharing -dhcpcd -nss -resolvconf (-selinux) -systemd -teamd {-test} -vala" ABI_X86="32 (64) (-x32)" 0 KiB

And I have wpa_supplicant installed which works perfectly well without network manager. But when both are installed and active, wifi won't connect and I have no idea why.

ebuild   R    ] net-wireless/wpa_supplicant-2.5-r1::gentoo  USE="dbus gnutls hs2-0 qt5 readline ssl -ap -eap-sim -fasteap -libressl -p2p (-ps3) -qt4 (-selinux) -smartcard -tdls -uncommon-eap-types (-wimax) -wps" 0 KiB

I'm running an ethernet connection at the moment which is why I can see the web. wpa_supplicant scans and scans and finds nothing, even though I know the configuration works because it was working before I installed network manager.

I've looked at and, I believe, followed the network manager guide.

I dropped dhcpcd in favor of dhclient because it says dhclient is supported more by the networkmanager dev team, but I'm not sure it's actually working.

dmesg shows the attempts of wpa_supplicant to connect:

[ 1314.911226] wls1: authenticate with 1c:b7:2c:c2:4d:94
[ 1314.913935] wls1: send auth to 1c:b7:2c:c2:4d:94 (try 1/3)
[ 1314.914669] wls1: authenticated
[ 1314.916209] wls1: associate with 1c:b7:2c:c2:4d:94 (try 1/3)
[ 1314.924501] wls1: RX AssocResp from 1c:b7:2c:c2:4d:94 (capab=0x511 status=0 aid=9)
[ 1314.925817] wls1: associated
[ 1314.925949] wls1: deauthenticating from 1c:b7:2c:c2:4d:94 by local choice (Reason: 3=DEAUTH_LEAVING)

This appears in dmesg over and over again, as the connection fails.

Any help would surely be appreciated.

Thanks in advance.

So, the solution was this: network manager does not want wpa_supplicant running in the background.

1. Remove /etc/wpa_supplicant/wpa_supplicant.conf
2. /etc/init.d/wpa_supplicant stop
3. rc-update del wpa_supplicant
4. /etc/init.d/NetworkManager restart
5. Use the networkmanager icon to establish a wireless connection.
6. *Profit*

All's well that ends well.
Some day there will only be free software.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum