Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Letsencrypt 0.5 error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
NismoC32
Apprentice
Apprentice


Joined: 07 Apr 2003
Posts: 200

PostPosted: Thu May 12, 2016 5:48 am    Post subject: Letsencrypt 0.5 error Reply with quote

When I try to run letsencrypt I get this :

Quote:
# letsencrypt
Traceback (most recent call last):
File "/usr/lib/python-exec/python2.7/letsencrypt", line 5, in <module>
from pkg_resources import load_entry_point
File "/usr/lib64/python2.7/site-packages/pkg_resources/__init__.py", line 3080, in <module>
@_call_aside
File "/usr/lib64/python2.7/site-packages/pkg_resources/__init__.py", line 3066, in _call_aside
f(*args, **kwargs)
File "/usr/lib64/python2.7/site-packages/pkg_resources/__init__.py", line 3093, in _initialize_master_working_set
working_set = WorkingSet._build_master()
File "/usr/lib64/python2.7/site-packages/pkg_resources/__init__.py", line 653, in _build_master
return cls._build_from_requirements(__requires__)
File "/usr/lib64/python2.7/site-packages/pkg_resources/__init__.py", line 666, in _build_from_requirements
dists = ws.resolve(reqs, Environment())
File "/usr/lib64/python2.7/site-packages/pkg_resources/__init__.py", line 844, in resolve
raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (cryptography 1.1.2 (/usr/lib64/python2.7/site-packages), Requirement.parse('cryptography>=1.3'), set(['PyOpenSSL']))


I'm unable to find determine whats wrong.
Is it a python problem er letsencrypt problem.
Back to top
View user's profile Send private message
massimo
Veteran
Veteran


Joined: 22 Jun 2003
Posts: 1226

PostPosted: Thu May 12, 2016 9:01 am    Post subject: Reply with quote

Looks like that dev-python/cryptography has to be at least on version 1.3 and latest stable package in portage is on version 1.1.2.
_________________
Hello 911? How are you?
Back to top
View user's profile Send private message
NismoC32
Apprentice
Apprentice


Joined: 07 Apr 2003
Posts: 200

PostPosted: Thu May 12, 2016 8:15 pm    Post subject: Reply with quote

Thanks, unmasking the dev-python/cryptography and installed the 1.3.1 version, letsencrypt worked
and I could renew my sertificates :D
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 14180

PostPosted: Fri May 13, 2016 1:09 am    Post subject: Reply with quote

I was about to post that you should file a bug for this, but it looks like someone already filed app-crypt/letsencrypt-0.5.0: Requires >=dev-python/cryptography-1.3. It is very new and probably had not been filed when you posted this.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum