Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE not starting (Call to lnusertemp failed)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
winnfield
n00b
n00b


Joined: 15 Feb 2008
Posts: 17

PostPosted: Mon Jun 22, 2009 12:22 pm    Post subject: KDE not starting (Call to lnusertemp failed) Reply with quote

Hello there, my problem is that KDE crashes when I log in, showing a pop-up window that says "Call to lnusertemp failed (temporary directories full?)". Despite that I can log in as root in the console.

I have been reading posts of people who had a similar problem but none of them solved mine :( . I have enough space in tmp directories and I think it could be a permission issue.

When I log in the console as a normal user I get a "-bash: /dev/null: Permission denied". I checked /dev/null and it is set to 660, so I changed to 666 and then KDE starts but I get a lot of error pop-ups, and nothing works properly. Also, rebooting makes /dev/null's permissions to be set to 660 again.

Can anyone help me please? I'm really lost...

Thanks
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6316
Location: /usr/lib64/lv2

PostPosted: Tue Jun 23, 2009 1:15 am    Post subject: Reply with quote

Is this a fresh Gentoo install? I've never heard of this problem (not that that means anything!) and the first thing that comes to my mind is something went wrong during the basic install procedures.
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
rahulthewall
Veteran
Veteran


Joined: 01 Nov 2007
Posts: 1264
Location: Zürich

PostPosted: Tue Jun 23, 2009 6:50 am    Post subject: Reply with quote

I had exactly the same problem. I solved it by deleting the following directories (just check which exist when KDE is not running and delete them)

Code:

/var/tmp/kdecache-rahul
/var/tmp/kdecache-root
/tmp/kdecache-rahul
/tmp/kdecache-root

_________________
Who shall guard the guards?
Back to top
View user's profile Send private message
winnfield
n00b
n00b


Joined: 15 Feb 2008
Posts: 17

PostPosted: Tue Jun 23, 2009 12:51 pm    Post subject: Reply with quote

Hi, is not a fresh install, I was working as always, I updated the system and then I was trying to fix some troubles with alsa, so I modified the file /etc/modprobe.d/alsa. Then I restarted and everything crashed, I restored the alsa file but nothing happened.

Also, removing these kdecache directories doesn't help :cry:

Thanks anyway
Back to top
View user's profile Send private message
rahulthewall
Veteran
Veteran


Joined: 01 Nov 2007
Posts: 1264
Location: Zürich

PostPosted: Tue Jun 23, 2009 3:07 pm    Post subject: Reply with quote

Check /var/log/kdm.log - it might have something useful in there.

Source: http://www.kde-forum.org/artikel/17997/call-to-lnusertemp-failed-temporary-directories-full-check-your-installation.html

You might want to try the solution mentioned there.
_________________
Who shall guard the guards?
Back to top
View user's profile Send private message
winnfield
n00b
n00b


Joined: 15 Feb 2008
Posts: 17

PostPosted: Tue Jun 23, 2009 9:43 pm    Post subject: Reply with quote

The solution in the link you posted doesn't work for me...

This is the kdm.log:

Code:

X.Org X Server 1.5.3
Release Date: 5 November 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.28-gentoo-r5ender i686
Current Operating System: Linux xps 2.6.29-gentoo-r5ender #1 SMP PREEMPT Tue Jun 2 22:40:56 BST 2009 i686
Build Date: 22 May 2009  08:06:19PM
 
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Jun 22 13:51:34 2009
(==) Using config file: "/etc/X11/xorg.conf"
(EE) Failed to load module "v4l" (module does not exist, 0)
Couldn't open /dev/input
(EE) xf86OpenSerial: Cannot open device /dev/input/mouse0
   No such file or directory.
(EE) Synaptics driver unable to open device
(EE) PreInit failed for input device "Synaptics Touchpad"
Couldn't open /dev/input
Query no Synaptics: 000000
Couldn't open /dev/input
Query no Synaptics: 000000
Query no Synaptics: 000000
Query no Synaptics: 000000
Synaptics driver lost sync... got gigantic packet!
Query no Synaptics: 000000
Query no Synaptics: 000000
Query no Synaptics: 000000
Synaptics driver lost sync... got gigantic packet!
Query no Synaptics: 000000
Query no Synaptics: 000000
Query no Synaptics: 000000
Synaptics driver lost sync... got gigantic packet!
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
>                   Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server


Is strange because I don't have any /dev/input directory, the touchpad should be /dev/mouse0. I'm not sure in what to do, any idea?

Thanks
Back to top
View user's profile Send private message
rahulthewall
Veteran
Veteran


Joined: 01 Nov 2007
Posts: 1264
Location: Zürich

PostPosted: Tue Jun 23, 2009 10:10 pm    Post subject: Reply with quote

Please post your xorg.conf.

Thanks
Rahul
_________________
Who shall guard the guards?
Back to top
View user's profile Send private message
winnfield
n00b
n00b


Joined: 15 Feb 2008
Posts: 17

PostPosted: Tue Jun 23, 2009 10:27 pm    Post subject: Reply with quote

Here it is:

Code:

Section "Module"

        Load    "glx"
   Load   "v4l"
   Load   "extmod"

EndSection

Section "InputDevice"

       Identifier   "Generic Keyboard"
       Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "Xkbrules" "xorg"
   Option      "XkbModel" "pc104"
   Option      "XkbLayout" "es"

EndSection

Section "InputDevice"

   Identifier   "USB Mouse"
       Driver      "mouse"
   Option      "CorePointer"
       Option       "Protocol" "Auto"   
       Option       "Device" "/dev/input/mice"
   Option       "Emulate3Buttons" "true"
   Option      "ZAxisMapping" "4 5"

EndSection

Section "InputDevice"
   
   Identifier    "Synaptics Touchpad"
   Driver        "synaptics"
   Option        "SendCoreEvents" "true"
   Option      "SHMConfig" "on"
   Option      "Device" "/dev/input/mouse0"
   Option      "Protocol" "auto-dev"
   Option      "HorizEdgeScroll" "0"
   Option      "TapButton1" "1"
   Option      "VertEdgeScroll" "1"
   Option      "VertScrollDelta" "45"
   Option      "HorizEdgeScroll" "1"
   Option      "HorizScrollDelta" "45"

EndSection
 
Section "Monitor"

       Identifier     "WXGA TrueLife"
       modeline   "1280x800@60" 83.46 1280 1344 1480 1680 800 801 804 828 -hsync +vsync
   Gamma      1.0
   Option      "DPMS"

EndSection

Section "Device"

   Identifier   "nVIDIA GeForce 8400M GS"
       Busid      "PCI:1:0:0"
   Driver      "nvidia"
   Screen      0
   Option      "NoLogo" "true"
   VendorName   "NVIDIA"
       BoardName   "NVIDIA GeForce 8 Series"

EndSection

Section "Screen"

       Identifier     "Default Screen"
       Device         "nVIDIA GeForce 8400M GS"
       Monitor        "WXGA TrueLife"
       DefaultDepth    24   

       Subsection "Display"
       
      Depth   24
           Modes   "1280x800@60"

   EndSubsection

EndSection

Section "ServerLayout"
   
   Identifier   "Default Layout"
   Screen 0    "Default Screen" 0 0
       InputDevice    "USB Mouse"
       InputDevice    "Generic Keyboard"
   InputDevice   "Synaptics Touchpad"

EndSection

Section "ServerFlags"

EndSection


I have tried to change "/dev/input/mouse0" for "/dev/mouse0" and the same for mice, but doesn't solve the problem, kdm.log shows the same..
Back to top
View user's profile Send private message
rahulthewall
Veteran
Veteran


Joined: 01 Nov 2007
Posts: 1264
Location: Zürich

PostPosted: Wed Jun 24, 2009 10:34 am    Post subject: Reply with quote

Can you edit your Section "ServerLayout" and then try - maybe this works. However I believe that the problem is not related to your X config - because as far as I know lnusertemp creates temporary directories in /var/tmp and/or /tmp.
Check your permissions for both these directories - it should be something like drwxrwxrwt.
Code:


Section "ServerLayout"                                               
        Identifier      "Default Layout"                           
        Screen          0  "Default Screen" 0 0
        InputDevice     "Generic Keyboard" "CoreKeyboard"                   
        InputDevice     Synaptics Touchpad" "CorePointer"                     
        InputDevice     "USB Mouse" "SendCoreEvents"                     
EndSection                                                           

_________________
Who shall guard the guards?
Back to top
View user's profile Send private message
winnfield
n00b
n00b


Joined: 15 Feb 2008
Posts: 17

PostPosted: Thu Jun 25, 2009 7:38 pm    Post subject: Reply with quote

You were right, editing the xorg.conf file doesn't help as well, any other idea?

EDIT: And the /var/tmp and /tmp directories have the correct permissions.

Thanks
Back to top
View user's profile Send private message
rahulthewall
Veteran
Veteran


Joined: 01 Nov 2007
Posts: 1264
Location: Zürich

PostPosted: Sat Jun 27, 2009 2:59 pm    Post subject: Reply with quote

This is really strange, as far as I know lnusertemp is solely concerned with creating temporary directories.

Last effort - kill your X session, remove everything in /var/tmp and /tmp with X not running and then start KDE and hope.

Last ditch - wait till 30th June - KDE 4.3_rc1 would be out that day - add the kde-testing overlay and then update to kde-4.3_rc1 (it should be more or less stable - I am already using 4.3 and it is reasonably stable).

Cheers
Rahul
_________________
Who shall guard the guards?
Back to top
View user's profile Send private message
winnfield
n00b
n00b


Joined: 15 Feb 2008
Posts: 17

PostPosted: Sun Jun 28, 2009 2:44 pm    Post subject: Reply with quote

Still crashing :cry:

Thanks anyway for your help
Back to top
View user's profile Send private message
Gh0str1d3r
Guru
Guru


Joined: 27 May 2008
Posts: 411

PostPosted: Fri Jul 10, 2009 8:38 am    Post subject: Reply with quote

I had the same problem today after an emerge world. Please post the output of

Code:
ls -l /dev/null


It should be

Code:
crw-rw-rw- 1 root root 1, 3 10. Jul 2009  /dev/null
Back to top
View user's profile Send private message
winnfield
n00b
n00b


Joined: 15 Feb 2008
Posts: 17

PostPosted: Fri Jul 10, 2009 8:54 am    Post subject: Reply with quote

Hi Gh0str1d3r,

my /dev/null directory is set to 660, that's

Code:

crw-rw----


If I change it to what should be I can start kde, but after rebooting it has the same permissions above.
Back to top
View user's profile Send private message
rahulthewall
Veteran
Veteran


Joined: 01 Nov 2007
Posts: 1264
Location: Zürich

PostPosted: Fri Jul 10, 2009 10:33 am    Post subject: Reply with quote

winnfield wrote:
Hi Gh0str1d3r,

my /dev/null directory is set to 660, that's

Code:

crw-rw----


If I change it to what should be I can start kde, but after rebooting it has the same permissions above.


That could be the problem, because my /dev/null is also set to 666. (Quite a funny number that :P)
_________________
Who shall guard the guards?
Back to top
View user's profile Send private message
Gh0str1d3r
Guru
Guru


Joined: 27 May 2008
Posts: 411

PostPosted: Sat Jul 18, 2009 11:45 am    Post subject: Reply with quote

What helped for me:

- backup /etc/udev/rules.d
- remove /etc/udev
- reinstall udev, hal, dbus
- copy back /etc/udev/rules.d
Back to top
View user's profile Send private message
energyman76b
Advocate
Advocate


Joined: 26 Mar 2003
Posts: 2045
Location: Germany

PostPosted: Sun Jul 19, 2009 4:39 am    Post subject: Reply with quote

wow - my /dev/null is 777 ..hmhm

when you updated your system - did you run cfg-update/etc-update afterwards?

did you accidentally removed an update instead of applying it? udev-mount should create null with the right permissions. Is it even running on your system?
_________________
Study finds stunning lack of racial, gender, and economic diversity among middle-class white males

I identify as a dirty penismensch.
Back to top
View user's profile Send private message
barlog
n00b
n00b


Joined: 23 Sep 2014
Posts: 1
Location: Odessa

PostPosted: Tue Sep 23, 2014 1:10 pm    Post subject: Reply with quote

It's helped to me:
chmod -R 1777 /tmp /var/tmp
_________________
Путь к совершенству начинается с осознания собственной ничтожности.
Back to top
View user's profile Send private message
rajat.pandita
n00b
n00b


Joined: 24 May 2013
Posts: 10

PostPosted: Thu Jan 08, 2015 3:08 am    Post subject: Changing the Ownership of the User's Home Directory fixed it Reply with quote

I had issues with Creating the /home/username directory to begin with. during the user creation some how it did not create the user folder, so I Created the folder manually.

by # mkdir /home/username

However i did not set the ownership correctly hence this issue.

so I ran a # chown -R username /home/username and now the issue is fixed.

Hope this helps :D
Back to top
View user's profile Send private message
sirnickity
n00b
n00b


Joined: 23 Aug 2005
Posts: 16

PostPosted: Thu May 26, 2016 9:46 pm    Post subject: Reply with quote

Got this error after performing selective emerge -au of packages in world while logged in to KDE. Things got funny after that, so I decided to restart KDE. Didn't want to reboot the whole box because I'm going for some kind of world record for longest uptime of a Linux desktop (actually an older Dell laptop -- 539 days and counting.) It became a point of pride to fix this w/o init 6.

Here's what I did:

rm -r /tmp/*
rm -r /var/tmp/kde*
chown -R username:users /home/username (I had restarted one of the KDE services under a terminal su'd to root -- oops)
/etc/init.d/udev restart
/etc/init.d/dbus restart <-- pretty sure this is what actually did it
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum