Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] problems setting up samba
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
equaeghe
Guru
Guru


Joined: 22 Feb 2005
Posts: 463

PostPosted: Sat May 07, 2016 3:03 pm    Post subject: [solved] problems setting up samba Reply with quote

I'm using a systemd setup and want to create a share available by guests, specifically meant for saving scans from my network connected multifunctional. The setup used to work in the past, but at some point stopped working.

/etc/smb.conf:
Code:
# Samba config file created using SWAT
# from UNKNOWN (127.0.0.1)
# Date: 2013/01/12 19:15:59

[global]
   workgroup = MYWORKGROUPNAME
   server string = Samba Server
   map to guest = Bad User
   log file = /var/log/samba/log.%m
   max log size = 50
   dns proxy = No
   idmap config * : range =
   idmap config * : backend = tdb

[scans]
   path = /home/scans
   read only = No
   guest only = Yes
   guest ok = Yes
   hosts allow = 127.0.0.1 192.168.178.0/24
   hosts deny = 0.0.0.0/0


Issues:
  • samba.service doesn't start because /usr/sbin/samba does not exist (bug 573976). (But do I need it?)
  • After starting smbd.socket, I get
    Code:
    # smbclient -L localhost
    Enter root's password:
    Domain=[MYWORKGROUPNAME] OS=[Windows 6.1] Server=[Samba 4.2.9]

            Sharename       Type      Comment
            ---------       ----      -------
            scans           Disk     
            IPC$            IPC       IPC Service (Samba Server)
    Connection to localhost failed (Error NT_STATUS_CONNECTION_REFUSED)
    NetBIOS over TCP disabled -- no workgroup available

  • My multifunctional complains about name resolution (but I guess I should first fix my server setup).

I'm fine modifying my setup. I used guest access in the past for some reason I don't recall, but the multifunctional can be given a user name and password.

Any pointers appreciated.


Last edited by equaeghe on Thu Jun 09, 2016 8:25 am; edited 1 time in total
Back to top
View user's profile Send private message
vaxbrat
l33t
l33t


Joined: 05 Oct 2005
Posts: 731
Location: DC Burbs

PostPosted: Mon May 09, 2016 1:59 am    Post subject: Not familiar with systemd but... Reply with quote

Is smbd.socket supposed to be some systemd-ish version of the smbd service? With openrc my samba runs an smbd and an nmbd service in order to provide shares over workgroup to my winders clients and Android devices (using the ES file explorer app).

My first suggestion is to go poking around in /var/log/samba to see if you can find anything obvious with what's going wrong. Hopefully systemd will relent and allow samba to actually maintain useful logs, but my experience with misbehaving rhel7.x systems has been less than stellar.

Look in /etc/conf.d/samba if you need to turn up debugging log levels (the -D switch) from the default settings. Once I get to doing this, I'm probably also breaking out wireshark to see what's really going wrong over the wire.
Back to top
View user's profile Send private message
equaeghe
Guru
Guru


Joined: 22 Feb 2005
Posts: 463

PostPosted: Wed Jun 08, 2016 3:25 pm    Post subject: Re: Not familiar with systemd but... Reply with quote

vaxbrat wrote:
Is smbd.socket supposed to be some systemd-ish version of the smbd service? With openrc my samba runs an smbd and an nmbd service in order to provide shares over workgroup to my winders clients and Android devices (using the ES file explorer app).

Ok, I guess I forgot to enable the nmbd.service. After starting both smbd.service and nmbd.service, I get
Code:
# smbclient -L localhost
Enter root's password:
Domain=[MYWORKGROUPNAME] OS=[Windows 6.1] Server=[Samba 4.2.9]

        Sharename       Type      Comment
        ---------       ----      -------
        scans           Disk     
        IPC$            IPC       IPC Service (Samba Server)
Domain=[MYWORKGROUPNAME] OS=[Windows 6.1] Server=[Samba 4.2.9]

        Server               Comment
        ---------            -------
        ROUTERNASNAME            My Router's Name
        MYHOSTNAME             Samba Server

        Workgroup            Master
        ---------            -------
        MYWORKGROUPNAME          ROUTERNASNAME

Testing the multifunctional's access must wait until later, when I have some time again for this.
Back to top
View user's profile Send private message
equaeghe
Guru
Guru


Joined: 22 Feb 2005
Posts: 463

PostPosted: Thu Jun 09, 2016 8:25 am    Post subject: Re: Not familiar with systemd but... Reply with quote

equaeghe wrote:
Testing the multifunctional's access must wait until later, when I have some time again for this.

That just required enabling the samba service for my home zone in firewalld. (N.B.: smbd.socket didn't work for me, smbd.service did.)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum