Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] X doesn't want to start ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
teppergeg
n00b
n00b


Joined: 16 Apr 2016
Posts: 13

PostPosted: Fri Apr 29, 2016 5:52 pm    Post subject: [SOLVED] X doesn't want to start ? Reply with quote

This is a pretty new install, so I dunno if this ought to be in the installing gentoo subforum, but all of the other threads I found via Google that are related to this at all are in this subforum, so here goes...

Code:
gegtoo ~ # lspci | grep -i VGA
00:02.0 VGA compatible controller: Intel Corporation Sky Lake Integrated Graphics (rev 07)


The wiki says I need intel i965, so I put 'VIDEO_CARDS="intel i965"' in make.conf.

I emerged mesa.

I went and made sure my make menuconfig stuff was the same as that in https://wiki.gentoo.org/wiki/Intel.

Following the same wiki article:
Code:
gegtoo ~ # cat /etc/X11/xorg.conf.d/device_no_vesa.conf
Section "Device"
   Identifier "Device0"
   Driver "intel"
   Option "Monitor-LVDS" "Internal Panel"
   Option "Monitor-VGA" "External VGA Monitor"
EndSection



When I try to xinit, I get:
http://ix.io/y7U

(The xinit giving up bit is me ctrl+c-ing)

/var/log/Xorg.0.log gives me:
http://ix.io/y86

I really just don't know what to do. Can anybody give some guidance?


Last edited by teppergeg on Sun May 01, 2016 5:44 pm; edited 3 times in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42587
Location: 56N 3W

PostPosted: Fri Apr 29, 2016 6:01 pm    Post subject: Reply with quote

teppergeg,

Code:
[  2040.456] (EE) No devices detected.


Either your Intel Xorg driver is too old or something in the kernel has already bound to the graphics hardware.

Running as root is a very bad thing.
Code:
xauth:  file /root/.serverauth.26289 does not exist

_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
teppergeg
n00b
n00b


Joined: 16 Apr 2016
Posts: 13

PostPosted: Fri Apr 29, 2016 6:04 pm    Post subject: Reply with quote

And how would I go about finding out which?

And yes, I know, but I figured it would make it easier when I'm dealing with conf files and such if I didn't have to keep sudoing.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42587
Location: 56N 3W

PostPosted: Fri Apr 29, 2016 6:10 pm    Post subject: Reply with quote

teppergeg,

You don't keep sudoing. You have root on one VT and your normal user on another VT.

Just now, you have
Code:
X.Org X Server 1.17.4
. Try the testing Xorg and its drivers.
For the kernel, make friends with wgetpaste and post your kernel .config file.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
teppergeg
n00b
n00b


Joined: 16 Apr 2016
Posts: 13

PostPosted: Fri Apr 29, 2016 6:24 pm    Post subject: Reply with quote

NeddySeagoon wrote:
You don't keep sudoing. You have root on one VT and your normal user on another VT.

oh, whoops. That was obvious, I guess. Noted and started.

NeddySeagoon wrote:
. Try the testing Xorg and its drivers.


I'm unclear on what you mean here. As far as I knew, "testing Xorg" was synonymous with doing startx and seeing how often it yelled at you.

NeddySeagoon wrote:
For the kernel, make friends with wgetpaste and post your kernel .config file.

https://bpaste.net/show/9ef5f415c7ac
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42587
Location: 56N 3W

PostPosted: Fri Apr 29, 2016 6:38 pm    Post subject: Reply with quote

teppergeg,

Gentoo supplies two main branches, known as stable and testing. There is also the hemorrhaging edge in some areas but lets not go there yet.
Code:
$ eix xorg-server
[U] x11-base/xorg-server
     Available versions:  1.9.5-r2(0/1.9.5)[1] 1.9.5-r2(0/1.9.5)[2] 1.10.6-r2(0/1.10.6)[1] 1.10.6-r2(0/1.10.6)[2] 1.11.4-r2(0/1.11.4)[1] 1.11.4-r2(0/1.11.4)[2] 1.12.4-r1(0/1.12.4)[1] 1.12.4-r1(0/1.12.4)[2] 1.12.4-r5(0/1.12.4) 1.12.4-r7(0/1.12.4) 1.13.4(0/1.13.4)[1] 1.13.4(0/1.13.4)[2] (~)1.14.1(0/1.14.1)[1] (~)1.14.1(0/1.14.1)[2] (~)1.14.1-r100(0/1.14.1){tbz2}[1] (~)1.14.1-r100(0/1.14.1){tbz2}[2] 1.14.3-r2(0/1.14.3){tbz2}[1] 1.14.3-r2(0/1.14.3){tbz2}[2] 1.15.0(0/1.15.0){tbz2}[1] (~)1.15.1(0/1.15.1){tbz2}[1] 1.15.2-r2(0/1.15.2) 1.15.2-r4(0/1.15.2) (~)1.15.99.903(0/1.15.99.903){tbz2}[1] (~)1.16.0(0/1.16.0){tbz2}[1] 1.16.4(0/1.16.1) 1.16.4-r5(0/1.16.1) 1.17.4(0/1.17.4){tbz2} [m](~)1.18.0(0/1.18.0){tbz2} (~)1.18.1(0/1.18.1){tbz2} (~)1.18.2(0/1.18.2){tbz2} (~)1.18.3(0/1.18.3) {dmx doc glamor ipv6 kdrive libressl minimal nptl selinux static-libs +suid systemd tslib +udev unwind wayland xephyr xnest xorg xvfb}
     Installed versions:  1.18.2{tbz2}(14:11:29 03/26/16)(ipv6 suid xorg -dmx -doc -glamor -kdrive -libressl -minimal -selinux -static-libs -systemd -tslib -udev -unwind -wayland -xephyr -xnest -xvfb)
     Homepage:            http://xorg.freedesktop.org/
     Description:         X.Org X servers

That's ugly without the colour but it says that there are newer versions of Xorg than your 1.17.4 which is Gentoo stable. See the Gentoo Handbook for mixing branches.
With the testing xorg-server, you will need the testing drivers too. That is left as an exercise for the reader :).
I am not suggesting you switch your entire install to Gentoo testing.

Your kernel set up looks OK in the graphics department.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
teppergeg
n00b
n00b


Joined: 16 Apr 2016
Posts: 13

PostPosted: Fri Apr 29, 2016 6:47 pm    Post subject: Reply with quote

So you're telling me the issue may be that stable doesn't have support for my video controller?
Back to top
View user's profile Send private message
teppergeg
n00b
n00b


Joined: 16 Apr 2016
Posts: 13

PostPosted: Sat Apr 30, 2016 1:06 pm    Post subject: Reply with quote

I've noticed a couple of things on my end.

1) There are no graphics drivers here.

Code:
gegtoo ~ # lsmod
Module                  Size  Used by
iwlmvm                212241  0
iwlwifi               159566  1 iwlmvm
x86_pkg_temp_thermal     4647  0
efivarfs                5483  1


2) There is no /dev/dri.

That's something X depends on, right?



I feel like you were giving me too much credit for having any idea what I'm doing at all... That kernel conf and rebuilding and installing are all it takes to get i915 up and running, right?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42587
Location: 56N 3W

PostPosted: Sat Apr 30, 2016 1:39 pm    Post subject: Reply with quote

teppergeg,

If you don't have /dev/dri/ its a kernel issue or a module not loaded.
However, /dev/dri/ is only needed for 3D acceleration. Xorg will work without it.

Maybe you are not running the kernel you think you are?
Code:
uname -v
will tell the build time and date of the running kernel. If you remember building a newer one, its not being used.

The kernel .config you posted has
Code:
 CONFIG_DRM_I915=y
so the option is build into the kernel binary. As its not a loadable module, it will not appear in lsmod.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
teppergeg
n00b
n00b


Joined: 16 Apr 2016
Posts: 13

PostPosted: Sat Apr 30, 2016 4:59 pm    Post subject: Reply with quote

NeddySeagoon wrote:
Maybe you are not running the kernel you think you are?


You're on the money there. uname -v told me that the last time I made the kernel was Tuesday, when I've been doing it a lot since then trying to make this work.


So here's my problem, the kernel isn't rebuilding right.

I tried rebuilding again after seeing this post a few minutes ago just to make sure, and it still says it was built Tuesday.

My immediate thought was that perhaps it wasn't reading it from where I thought it was reading it, so I backed up the vmlinuz to another disk and deleted it from /boot. When I rebooted, gentoo wouldn't load (I've moved it back now and I can boot fine).

Evidently, grub _is_ pulling the kernel image from the place I thought it was pulling it from, but make isn't doing something right, and I have no idea why.

I'm following these steps (https://wiki.gentoo.org/wiki/Kernel/Rebuild) exactly.

Do you have any idea what my issue could be?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42587
Location: 56N 3W

PostPosted: Sat Apr 30, 2016 5:45 pm    Post subject: Reply with quote

teppergeg,

I'm not a grub2 user, yet.

Where that wiki page says to reboot. Do do that yet.

Pastebin the output of
Code:
ls -l /boot
and the content of /boot/grub/grub.cfg.

I suspect an install issue.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
teppergeg
n00b
n00b


Joined: 16 Apr 2016
Posts: 13

PostPosted: Sat Apr 30, 2016 6:24 pm    Post subject: Reply with quote

ls -l /boot:
https://bpaste.net/show/d31e32470b11
(notice that it was put there today, so something was added when I did make install)


grub.cfg:
https://bpaste.net/show/f878c8e14269
Back to top
View user's profile Send private message
teppergeg
n00b
n00b


Joined: 16 Apr 2016
Posts: 13

PostPosted: Sat Apr 30, 2016 6:46 pm    Post subject: Reply with quote

Okay. So I just did another make for old times' sake and it changed the build date and time. All I did differently this time around was changing the i915 to module. My first thought was that it didn't change because I hadn't changed the configuration since Tuesday, but I know that I have, so that can't be why. Sorry about this detour.

Regardless, that didn't solve my main issue.

Now I'm looking at lspci -v and getting https://bpaste.net/show/a99cfc6e3944

One thing I notice about that output is that it recognizes i915 as a kernel module, but doesn't say "Kernel driver in use: i915" like my network controller says about iwlwifi. I have no idea what this means.

Other than that I have no idea what the issue could be at this point.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42587
Location: 56N 3W

PostPosted: Sat Apr 30, 2016 6:59 pm    Post subject: Reply with quote

teppergeg,

More questions and observations ...
You have exactly one kernel in boot called
Code:
vmlinuz-4.1.15-gentoo-r1
dated 30 Apr 16. (Today).
You menuentry beginning at line 92 loads it too.

/boot is missing a lost+found directory. That suggests that its either not using the extX filesystem or its not a separate partition from root..
The
Code:
set root='hd0,gpt11'
suggets that /boot is sda11, so it is a separate partition from root, which is sda10.

Boot is missing the
Code:
lrwxrwxrwx 1 root root       1 Apr 12  2009 boot -> .
symlink, which suggests that it may be a FAT filesystem.
FAT does not support symbolic links, nor does it have a lost+found directory.

You appear to have a multiboot system. Windows and Arch are both mentioned in grub.conf.
There are no Arch kernels in boot, so they must be in another boot. Hold that thought.
How do you select among the assorted boot filesystems you seem to have?

The boot sequence in normally grub loads and reads the file /boot/grub/grub.cnf from the boot partition.
This means that you normally have exactly one boot partition shared by all your distros.
You appear to have more - how have you made that work?

If uname -v still shows Tuesday, its not using the vmlinuz-4.1.15-gentoo-r1 shown on the pastebin.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 6968

PostPosted: Sat Apr 30, 2016 7:10 pm    Post subject: Reply with quote

while you are it, fix your sound while you rebuild a new kernel, alas, having an intel card doesn't mean it must use intel codecs; distrubing no?
Back to top
View user's profile Send private message
teppergeg
n00b
n00b


Joined: 16 Apr 2016
Posts: 13

PostPosted: Sat Apr 30, 2016 10:49 pm    Post subject: Reply with quote

NeddySeagoon wrote:
You have exactly one kernel in boot called
Code:
vmlinuz-4.1.15-gentoo-r1
dated 30 Apr 16. (Today).
You menuentry beginning at line 92 loads it too.

Yes. That was why it became confusing. The kernel was put there on April 30, 2016 (today), but the uname -v said Tuesday because for some reason before when make wasn't working right.


NeddySeagoon wrote:
/boot is missing a lost+found directory. That suggests that its either not using the extX filesystem or its not a separate partition from root..

It's FAT because GRUB yelled at me whenever it wasn't because I'm UEFI.


NeddySeagoon wrote:
Boot is missing the
Code:
lrwxrwxrwx 1 root root       1 Apr 12  2009 boot -> .
symlink, which suggests that it may be a FAT filesystem.

Yeah.

NeddySeagoon wrote:
You appear to have a multiboot system. Windows and Arch are both mentioned in grub.conf.
There are no Arch kernels in boot, so they must be in another boot. Hold that thought.
How do you select among the assorted boot filesystems you seem to have?

I have no idea how GRUB figures it out, but it does. I've been meaning to combine them because I realize it's bad.


NeddySeagoon wrote:
The boot sequence in normally grub loads and reads the file /boot/grub/grub.cnf from the boot partition.
This means that you normally have exactly one boot partition shared by all your distros.
You appear to have more - how have you made that work?

GRUB figures it out. I gen a new GRUB conf and GRUB finds it on its own. If you're particularly interested, I can pastebin output of it discovering arch even though it's on a different partition.

Incidentally, I had GRUB installed on Arch before, but Arch worked in the way you expected, not being able to find gentoo because they were on separate /boot partitions. So I went and made a GRUB conf from gentoo and it could find both. The problem is that my computer's firmware can't find the gentoo GRUB (probably because I have it twice on two separate partitions--again, I'm gonna fix that), so I've ended up copying the conf from the gentoo /boot over to the Arch /boot. It's a disgusting mess.


NeddySeagoon wrote:
If uname -v still shows Tuesday, its not using the vmlinuz-4.1.15-gentoo-r1 shown on the pastebin.

It was definitely using that kernel. As I said, when I removed it, I couldn't boot into gentoo. Then I went and added it back and it worked fine. Then I booted into gentoo again, deleted it, and built it anew. The modified time said 30 April, but when I rebooted and did uname -v, it showed Tuesday. *That particular problem* is solved now. I have no idea what fixed it.

krinn wrote:
while you are it, fix your sound while you rebuild a new kernel, alas, having an intel card doesn't mean it must use intel codecs; distrubing no?

Thanks. I'll take a look.


---

None of that stuff ended up being particularly relevant to this particular issue apparently, though, because I can get it to make right again.

My problem is still present.

Here's something:

On Arch, lspci -v says at the end:
Code:
Kernel driver in use: i915
Kernel modules: i915


But on Gentoo, lspci -v only says at the end (https://bpaste.net/show/a99cfc6e3944):
Code:
Kernel modules: i915


So I guess for some reason i915 isn't being used, despite the fact that it's being recognized. What gives?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42587
Location: 56N 3W

PostPosted: Sun May 01, 2016 8:35 am    Post subject: Reply with quote

teppergeg,

I guess that something else is grabbing the video hardware and the intel driver can see that, so it stands aside.
I don't have any UEFI hardware, so I've not tried the EFI Framebuffer.

Conventional wisdom is not to set any framebuffer drivers in the kernel and wait until intel915 leads before you have a framebuffer console.
If you go that route, you need to ensure that the old VGA Text console in on in the kernel or you will have no kernel boot messages until after root is mounted and the i915 kernel module gets loaded. That might be scary.

You are using a 4.1.x kernel. That's about 6 months old now. It may be worth trying a gentoo testing kernel.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Sun May 01, 2016 11:54 am    Post subject: Reply with quote

NeddySeagoon wrote:
Conventional wisdom is not to set any framebuffer drivers in the kernel and wait until intel915 leads before you have a framebuffer console.

Neddy ... inteldrmfb is a framebuffer, and when kernel modeset is used it doesn't like other framebuffers enabled. That said, you can't trust to it work, either in kernel, or module (at least with the current stable line of kernels 3.12.58, 3.14.67, 3.18.31). Perviously (3.13) I had it in kernel, without any other framebuffer, and that worked fine, since then this would result in a black screen (starting x11 will resolve that but it means console, and so console login, is blind). With 3.12.58 I have to have efifb enabled, build i915 as a module, disable modesetting, login as root and 'modprobe i915 modeset=1 ; exit' then login (blind) and startx. With >4.4.6 the previous setup works, I can get a framebuffer ... but I have other issues, and so it's impossible for me to use 4.4.x.

I think I've built in the region of 100 kernels in the past eight months, and not one of them have been suitable (for various reasons, not all to do with i915). It's a sink hole of time and effort and I'm pretty much done with it.

NeddySeagoon wrote:
If you go that route, you need to ensure that the old VGA Text console in on in the kernel or you will have no kernel boot messages until after root is mounted and the i915 kernel module gets loaded. That might be scary.

You mean VGA_CONSOLE? This doesn't work as I remember, when switching to inteldrmfb the screen will black out and you're blind.

best ... khay
Back to top
View user's profile Send private message
teppergeg
n00b
n00b


Joined: 16 Apr 2016
Posts: 13

PostPosted: Sun May 01, 2016 5:43 pm    Post subject: Reply with quote

NeddySeagoon wrote:
You are using a 4.1.x kernel. That's about 6 months old now. It may be worth trying a gentoo testing kernel.


Bingo. I built 4.5.1 and now all is well. I guess this is a learning experience: "stable" doesn't always mean "working".
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum