Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
dev-java/icedtea-bin obsolete or not? what to do please?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo Chat
View previous topic :: View next topic  
Author Message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Wed Apr 27, 2016 7:45 am    Post subject: dev-java/icedtea-bin obsolete or not? what to do please? Reply with quote

Todays upgrade pulled in a new 40-50mb package. A new slot package for icedtea-bin

https://packages.gentoo.org/packages/dev-java/icedtea-bin

Quote:
This package is masked and could be removed soon!
The mask comment indicates that this package is scheduled for removal from our package repository.
Please review the mask information below for more details.


What I remember does the other java package has a fetch restriction which is annoying like hell.

Can someone suggest me a workaround which is easy to maintain without fetch restriction please?

I think the only reason i have java on my box is for libreoffice and those browsers called firefox, opera ang google-chrome-binary. And the adb, android debug bridge, which is a package from google for android smartphones (forgot the package name here)



Code:
equery y icedtea-bin
Keywords for dev-java/icedtea-bin:
               |                                 |   u   | 
               | a a   a         n   p r     s   |   n   | 
               | l m   r h i m m i   p i s   p   | e u s | r
               | p d a m p a 6 i o p c s 3   a x | a s l | e
               | h 6 r 6 p 6 8 p s p 6 c 9 s r 8 | p e o | p
               | a 4 m 4 a 4 k s 2 c 4 v 0 h c 6 | i d t | o
---------------+---------------------------------+-------+-------
3.0.0_pre10    | * ~ ~ * * * * * * * + * * * * ~ | 5 o 8 | gentoo
      3.0.1    | * ~ ~ * * * * * * * ~ * * * * ~ | 5 o   | gentoo
---------------+---------------------------------+-------+-------
 [I]7.2.6.5    | * + ~ * * * * * * * * * * * * + | 5 o 7 | gentoo
    7.2.6.6-r1 | * + * * * * * * * * * * * * * ~ | 5 o   | gentoo
ASUS-G75VW roman # equery depends icedtea-bin
 * These packages depend on icedtea-bin:
java-virtuals/jdk-with-com-sun-20111111-r3 (dev-java/icedtea-bin:6)
                                           (dev-java/icedtea-bin:7)
virtual/jdk-1.7.0-r1 (dev-java/icedtea-bin:7)
virtual/jdk-1.8.0-r3 (dev-java/icedtea-bin:8)
ASUS-G75VW roman # equery depends virtual/jdk
 * These packages depend on virtual/jdk:
app-office/libreoffice-5.1.2.2 (java ? >=virtual/jdk-1.6)
dev-db/hsqldb-1.8.1.3-r1 (>=virtual/jdk-1.5)
dev-java/ant-antlr-1.9.2-r1 (>=virtual/jdk-1.5)
dev-java/ant-core-1.9.2 (>=virtual/jdk-1.5)
dev-java/ant-nodeps-1.9.2 (>=virtual/jdk-1.4)
dev-java/antlr-2.7.7-r7 (>=virtual/jdk-1.6)
dev-java/antlr-3.2 (>=virtual/jdk-1.6)
dev-java/antlr-3.5.2 (>=virtual/jdk-1.6)
dev-java/antlr-4.5.1 (>=virtual/jdk-1.6)
dev-java/asm-5.0.4 (>=virtual/jdk-1.6)
dev-java/bcel-6.0_rc3 (>=virtual/jdk-1.5)
dev-java/commons-compress-1.10 (>=virtual/jdk-1.6)
dev-java/commons-logging-1.2 (>=virtual/jdk-1.6)
dev-java/gnu-regexp-1.1.4-r3 (>=virtual/jdk-1.6)
dev-java/guava-13.0.1-r3 (virtual/jdk:1.7)
dev-java/hawtjni-runtime-1.10 (>=virtual/jdk-1.5)
dev-java/icedtea-sound-1.0.1 (>=virtual/jdk-1.6.0)
dev-java/icedtea-web-1.6.1-r1 (>=virtual/jdk-1.7)
dev-java/icu4j-54.1.1 (>=virtual/jdk-1.6)
dev-java/jansi-1.5-r1 (>=virtual/jdk-1.6)
dev-java/jansi-native-1.5 (>=virtual/jdk-1.5)
dev-java/jarjar-1.4 (>=virtual/jdk-1.6)
dev-java/java-getopt-1.0.14 (>=virtual/jdk-1.4)
dev-java/javacc-5.0-r2 (>=virtual/jdk-1.6)
dev-java/javacup-0.11b_p20151001 (>=virtual/jdk-1.7)
dev-java/javassist-3.18.2 (>=virtual/jdk-1.6)
dev-java/jffi-1.2.9 (>=virtual/jdk-1.6)
dev-java/jflex-1.6.1 (>=virtual/jdk-1.6)
dev-java/jline-2.12.1-r1 (>=virtual/jdk-1.6)
dev-java/jnr-constants-0.8.6 (>=virtual/jdk-1.6)
dev-java/jnr-ffi-2.0.2 (>=virtual/jdk-1.5)
dev-java/jnr-netdb-1.1.4 (>=virtual/jdk-1.5)
dev-java/jnr-posix-3.0.10 (>=virtual/jdk-1.6)
dev-java/jnr-x86asm-1.0.2-r1 (>=virtual/jdk-1.6)
dev-java/jsr305-3.0.1 (>=virtual/jdk-1.6)
dev-java/junit-3.8.2-r1 (>=virtual/jdk-1.4)
dev-java/libreadline-java-0.8.0-r3 (>=virtual/jdk-1.4)
dev-java/log4j-1.2.17-r3 (>=virtual/jdk-1.6)
dev-java/lucene-analyzers-2.3.2 (>=virtual/jdk-1.4)
dev-java/netty-buffer-4.0.32 (>=virtual/jdk-1.6)
dev-java/netty-common-4.0.32 (>=virtual/jdk-1.7)
dev-java/netty-transport-4.0.32 (>=virtual/jdk-1.6)
dev-java/rhino-1.7.7-r1 (>=virtual/jdk-1.6)
dev-java/servletapi-2.3-r3 (>=virtual/jdk-1.4)
dev-java/servletapi-2.4-r5 (>=virtual/jdk-1.4)
dev-java/slf4j-api-1.7.7 (>=virtual/jdk-1.6)
dev-java/slf4j-nop-1.7.7 (>=virtual/jdk-1.6)
dev-java/stringtemplate-3.2.1-r1 (>=virtual/jdk-1.6)
dev-java/stringtemplate-4.0.8 (>=virtual/jdk-1.6)
dev-java/swt-3.7.2-r1 (>=virtual/jdk-1.4)
dev-java/tomcat-servlet-api-4.1.36 (>=virtual/jdk-1.4)
dev-java/tomcat-servlet-api-6.0.45 (>=virtual/jdk-1.6)
dev-java/tomcat-servlet-api-7.0.69 (>=virtual/jdk-1.6)
dev-java/tomcat-servlet-api-8.0.33 (>=virtual/jdk-1.7)
dev-java/treelayout-1.0.2 (>=virtual/jdk-1.6)
dev-java/xalan-2.7.2 (>=virtual/jdk-1.3)
dev-java/xalan-serializer-2.7.2 (>=virtual/jdk-1.3)
dev-java/xerces-2.11.0-r1 (>=virtual/jdk-1.6)
dev-java/xjavac-20110814 (>=virtual/jdk-1.4)
dev-java/xml-commons-external-1.3.04 (>=virtual/jdk-1.3)
dev-java/xml-commons-external-1.4.01-r1 (>=virtual/jdk-1.6)
dev-java/xml-commons-resolver-1.2 (>=virtual/jdk-1.3)
dev-java/xom-1.2.10 (>=virtual/jdk-1.4)
dev-java/xz-java-1.5 (>=virtual/jdk-1.4)
dev-libs/cyrus-sasl-2.1.26-r10 (java ? >=virtual/jdk-1.4)
dev-util/android-sdk-update-manager-24.4.1 (>=virtual/jdk-1.5)
dev-vcs/subversion-1.9.3 (java ? >=virtual/jdk-1.5)
media-libs/libjpeg-turbo-1.4.2 (java ? >=virtual/jdk-1.5)
net-dns/libidn-1.32-r1 (java ? >=virtual/jdk-1.5)
sys-devel/gettext-0.19.7 (java ? >=virtual/jdk-1.4)
sys-libs/db-4.8.30-r2 (java ? >=virtual/jdk-1.5)
sys-libs/db-6.0.35 (java ? >=virtual/jdk-1.5)
virtual/jre-1.7.0-r1 (virtual/jdk:1.7)
ASUS-G75VW roman #
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Wed Apr 27, 2016 7:55 am    Post subject: Reply with quote

I don't think anything else than icedtea-(bin-)6 is going to be removed. As you can see in your eshowkw output 7 and 8 are not masked.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo Chat All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum