Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] GTK+ conflict with XFCE and Gnome installation
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
victorsk
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2010
Posts: 92

PostPosted: Mon Apr 25, 2016 7:31 pm    Post subject: [SOLVED] GTK+ conflict with XFCE and Gnome installation Reply with quote

Hello everyone,

I am trying to install Gnome3 from Dantrell B overlay. I followed instructions but when trying to run:

Code:

emerge --deep --with-bdeps=y --changed-use --update --ask --verbose  @world


I get this result:
https://bpaste.net/show/754ca7745a7b

There seems to be conflict with GTK+ packages. I am not sure why any GTK+ is mentioned other than gtk+-3.20.3. In one of my attempts, I tried to mask:

Code:

echo "<x11-libs/gtk+-3.20.3" >> /etc/portage/package.mask/x11-libs


But the same message appeared nontheless:
Code:

 (x11-libs/gtk+-3.20.3:3/20::dantrell-gnome-3-20, installed) pulled in by
    >=x11-libs/gtk+-3.14:3/20= required by (xfce-base/garcon-0.5.0-r2:0/0::gentoo, installed)
                        ^^^^^^                                                                                                   
    >=x11-libs/gtk+-3.19.12:3[introspection?] required by (gnome-base/nautilus-3.20.0:0/0::dantrell-gnome-3-20, ebuild scheduled for merge)
    ^^              ^^^^^^^^^                                                                                                                                                                                       
    (and 3 more with the same problems)

  (x11-libs/gtk+-3.18.7:3/3::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/gtk+-3.6:3/3= required by (xfce-extra/xfce4-indicator-plugin-2.3.3-r1:0/0::gentoo, installed)


Besides, other packages like GFTP need gtk+-2.24.30 for smoother UI appearnce so I now have gtk+-3.20.3 and gtk+-2.24.30. But I still don't understand why gtk+-3.14, gtk+-3.19.12, gtk+-3.6, and gtk+-3.18.7 are being mentioned here.

I could remove these xfce-related packages but I need to use XFCE. And I also want to install Gnome 3. Is it possible for both these DE's to be installed? Could somebody please suggest how I can resolve this problem?

I also tried to mask these XFCE packages:
Code:

 package.mask # cat xfce-base
=xfce-base/garcon-0.5.0-r1
package.mask # cat xfce-extra
=xfce-extra/xfce4-power-manager-1.5.2
=xfce-extra/xfce4-pulseaudio-plugin-0.2.3
=xfce-extra/xfce4-indicator-plugin-2.3.3-r1


But that didn't help.

Thanks,
Victor.
Back to top
View user's profile Send private message
victorsk
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2010
Posts: 92

PostPosted: Mon Apr 25, 2016 8:04 pm    Post subject: Reply with quote

Ok, I solved it. I had to mask correct version for garcon package and after re-installing and masking these packages:

Code:

=xfce-extra/xfce4-power-manager-1.5.2
=xfce-extra/xfce4-pulseaudio-plugin-0.2.4
=xfce-extra/xfce4-indicator-plugin-2.3.3-r1


I can run the update command.
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 526
Location: Earth

PostPosted: Fri Apr 29, 2016 1:50 pm    Post subject: Reply with quote

victorsk wrote:
Ok, I solved it. [...]

Glad you got things resolved.

Just for the record, any issues related to my overlays should be reported either on the relevant forum topic (if you want more eyes on the issue) or to me directly (if you want my prompt attention).

That said, GNOME should work alongside other closely related Desktop Environments just fine although it may take some fiddling with, as you found, especially if they are based off of different GNOME release versions. I prefer not to spend my time diagnosing these kind of issues as they are typically too specialized, however, I am happy to look into them if they relate to conflicts with these packages.
_________________
Dantrell B.
Back to top
View user's profile Send private message
victorsk
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2010
Posts: 92

PostPosted: Fri Apr 29, 2016 3:25 pm    Post subject: Reply with quote

dantrell wrote:
victorsk wrote:
Ok, I solved it. [...]

Glad you got things resolved.

Just for the record, any issues related to my overlays should be reported either on the relevant forum topic (if you want more eyes on the issue) or to me directly (if you want my prompt attention).

That said, GNOME should work alongside other closely related Desktop Environments just fine although it may take some fiddling with, as you found, especially if they are based off of different GNOME release versions. I prefer not to spend my time diagnosing these kind of issues as they are typically too specialized, however, I am happy to look into them if they relate to conflicts with these packages.


Hi,

Thank you so much for providing an overlay for Gnome 3. I've installed it from your overlay and it works great! :D Just followed these instructions: https://wiki.gentoo.org/wiki/GNOME/GNOME_Without_systemd step-by-step and everything went smoothly. I think it's easier to mix XFCE with Gnome3 than with plasma but my plasma DE recently crashed on my other laptop so I might replace it with Gnome3 as well.

Kind regards,
Victor.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum