Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]: Does it make sense to upgrade or just re-install?
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3, 4, 5, 6, 7, 8  Next  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2772

PostPosted: Thu Apr 21, 2016 7:10 pm    Post subject: [SOLVED]: Does it make sense to upgrade or just re-install? Reply with quote

Hi, ALL,
I have a laptop which has Win7 and Gentoo as a dual-boot.
The Gentoo partition was not updated for a long period of time (6-7 years, maybe even more).

Does it make sense to upgrade it or it will be easier to just re-install it from scratch?

Thank you.


Last edited by ONEEYEMAN on Sat Jul 23, 2016 11:31 pm; edited 1 time in total
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 808

PostPosted: Thu Apr 21, 2016 7:24 pm    Post subject: Reply with quote

re-install it from scratch
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43383
Location: 56N 3W

PostPosted: Thu Apr 21, 2016 7:37 pm    Post subject: Reply with quote

ONEEYEMAN,

If you want a learning experience, do the upgrade. A reinstall will be a much faster route to an up to date Gentoo.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 3121
Location: Illinois, USA

PostPosted: Thu Apr 21, 2016 7:39 pm    Post subject: Reply with quote

You haven't updated your profile or changed to baselayout-2? If you haven't done those, reinstall. If you have but have a bunch of packages that are no longer in the tree, I'd say download a stage 3 and a fresh copy of the portage tree and update. OTOH, if you just installed it seven years ago and have no customizations, might as well reinstall. Still running LILO?
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2772

PostPosted: Thu Apr 21, 2016 10:21 pm    Post subject: Reply with quote

Tony0945,
Here is the info about the box:

Code:

IgorReinCloud igor # emerge --info
!!! SYNC setting found in make.conf.
    This setting is Deprecated and no longer used.  Please ensure your 'sync-type' and 'sync-uri' are set correctly in /etc/portage/repos.conf/gentoo.conf
Portage 2.2.18 (python 2.7.5-final-0, default/linux/amd64/13.0/desktop/gnome, gcc-4.7.3, glibc-2.15-r3, 3.12.13-gentoo x86_64)
=================================================================
System uname: Linux-3.12.13-gentoo-x86_64-AMD_E-350_Processor-with-gentoo-2.2
KiB Mem:     3769740 total,    863976 free
KiB Swap:     999708 total,    976328 free
Timestamp of repository gentoo: Wed, 20 Apr 2016 23:55:01 +0000
sh bash 4.2_p45
ld GNU ld (Gentoo 2.23.2 p1.0) 2.23.2
app-shells/bash:          4.2_p45::gentoo
dev-java/java-config:     2.2.0::gentoo
dev-lang/perl:            5.12.4-r1::gentoo
dev-lang/python:          2.7.5-r3::gentoo, 3.2.5-r1::gentoo
dev-util/cmake:           2.8.10.2-r2::gentoo
dev-util/pkgconfig:       0.28::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.12.4::gentoo
sys-apps/sandbox:         2.6-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.9.6-r3::gentoo, 1.11.6::gentoo, 1.12.6::gentoo, 1.13.4::gentoo
sys-devel/binutils:       2.23.2::gentoo
sys-devel/gcc:            4.7.3-r1::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.2::gentoo
sys-devel/make:           3.82-r4::gentoo
sys-kernel/linux-headers: 3.7::gentoo (virtual/os-headers)
sys-libs/glibc:           2.15-r3::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.us.gentoo.org/gentoo-portage
    priority: -1000

x-portage
    location: /usr/local/portage
    masters: gentoo
    priority: 0

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA AdobeFlash-11.x PUEL Oracle-BCLA-JavaSE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=barcelona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf \
/etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=barcelona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync \
news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs \
unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.osuosl.org/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress \
--force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 apm berkdb branding bzip2 cairo cdda cdr clamav cli colord consolekit cracklib crypt \
cxx dbus djvu dri dts dvd dvdr eds emboss encode evo exif fam firefox flac freetds gdbm gif glamor gnome gnome-keyring \
gnome-online-accounts gpm gstreamer gtk iconv introspection ipv6 java6 jpeg lcms ldap libnotify libsecret lm_sensors mad \
mmx mmxext mng modules mozilla mp3 mp4 mpeg mssql multilib mysql nautilus ncurses nls nptl odbc ogg opengl openmp \
oracle pam pango pch pcmcia pcre pdf perl png policykit ppds pulseaudio qt3support readline sdl seccomp session spell \
sqlite sse sse2 ssl startup-notification svg tcpd tiff tracker truetype udev udisks unicode upower usb vorbis wxwidgets x264 \
xattr xcb xml xv xvid zlib" ABI_X86="64" \
ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 \
hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" \
APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon \
authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex \
cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info \
log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" \
CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" \
CAMERAS="ptp2" \
COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" \
CPU_FLAGS_X86="mmx mmxext sse sse2" \
ELIBC="glibc" \
GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom \
oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" \
INPUT_DEVICES="evdev synaptics keyboard" \
KERNEL="linux" \
LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" \
LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" \
OFFICE_IMPLEMENTATION="libreoffice" \
PHP_TARGETS="php5-5" \
PYTHON_SINGLE_TARGET="python2_7" \
PYTHON_TARGETS="python2_7" \
RUBY_TARGETS="ruby20 ruby21" \
USERLAND="GNU" \
VIDEO_CARDS="radeon" \
XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee \
tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, \
PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


NeddySeagoon,
I will try to upgrade and if anything goes really bad, re-install. Besides kernel configuration, anything to backup?
Do you see any possible culprits with my current "emerge --info"?

Thank you.

P.S.: One more thing: I'm planning to do an upgrade to gcc-5.3. Can I do just that or reinstall and then upgrade?

Line breaks added by NeddySeagoon
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 3121
Location: Illinois, USA

PostPosted: Fri Apr 22, 2016 3:06 pm    Post subject: Reply with quote

GCC 4.7.3 is reasonably modern. Moving to the 5.x series should be deferred until after the other changes, unless you go the re-install route and I would still do it last. Just my two cents.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43383
Location: 56N 3W

PostPosted: Fri Apr 22, 2016 4:05 pm    Post subject: Reply with quote

ONEEYEMAN,

Keep /etc/portage for reference.
make.conf and the profile symlink have moved inside /etc/portage.

Keep your /var/lib/portage/world file. That makes a reinstall trivial.
Put it in your new install and run
Code:
emerge -e @world

You will still need to redo the configurations.

gcc and glibc are a bit odd. They mutually depend on one another, so you may need to update gcc, then glibc then do them both again.

The advice to stay away from gcc-5.x until everything else works is good.
gcc-5.x uses an incompatible C++ ABI. That means that when you move to gcc-5.x, you must rebuild all your C++ packages.
That's an issue go don't need right at the start of your upgrade.

You will need to upgrade portage and python right at the start. You need an EAPI 6 aware portage and a python that supports it.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2772

PostPosted: Sat Apr 23, 2016 1:26 am    Post subject: Reply with quote

Code:

2014-11-07-udev-upgrade
  Title                     Upgrade to udev >= 217 or eudev >= 2.1
  Author                    Samuli Suominen <ssuominen@gentoo.org>
  Posted                    2014-11-07
  Revision                  1

sys-fs/udev-217 and sys-fs/eudev-2.1 no longer provide a userspace
firmware loader. If you require firmware loading support, you must use
kernel 3.7 or greater with CONFIG_FW_LOADER_USER_HELPER=n. No action is
required if none of your kernel modules need firmware. See [1] for more
information on the upgrade.

[1] https://wiki.gentoo.org/wiki/Udev/upgrade#udev_216_to_217


How do I tell if I'm loading any firmware?

Thank you.
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7071

PostPosted: Sat Apr 23, 2016 1:26 am    Post subject: Reply with quote

if you want an easy upgrade (lowering fun), use a livecd and grab its newer toolchain and portage tools (including python so).
i would myself goes with the upgrade, because it's fun!
but you can just reinstall, nobody would called you a pussy ; because of the forum rules, but this would still what they would think :)
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2772

PostPosted: Sat Apr 23, 2016 1:49 am    Post subject: Reply with quote

krinn,
Nobody is looking for an easy way out. ;-)
But this is weird - it says that I need the appropriate kernel function to be turned on. But I don't remember if I have any hardware (WiFi Card, anything else?) that needs the firmware load.

Thank you.
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Sat Apr 23, 2016 2:51 am    Post subject: Reply with quote

ONEEYEMAN wrote:
But this is weird - it says that I need the appropriate kernel function to be turned on. But I don't remember if I have any hardware (WiFi Card, anything else?) that needs the firmware load.

ONEEYEMAN ... look under /lib/firmware ... if you have firmware you probably don't need to do anything (other than have the driver as a module).

I have one device that requires firmware and its loaded along with the driver with the following enabled:

zgrep FIRMWARE /proc/config.gz:
CONFIG_PREVENT_FIRMWARE_BUILD=y
# CONFIG_FIRMWARE_IN_KERNEL is not set
CONFIG_EXTRA_FIRMWARE=""
# CONFIG_DRM_LOAD_EDID_FIRMWARE is not set
# CONFIG_FIRMWARE_EDID is not set
CONFIG_FIRMWARE_MEMMAP=y
# CONFIG_GOOGLE_FIRMWARE is not set

best ... khay
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2772

PostPosted: Sat Apr 23, 2016 4:07 am    Post subject: Reply with quote

Code:

 * Messages for package app-emulation/virtualbox-4.3.32:

 * Failed to set XATTR_PAX markings -me /var/tmp/portage/app-emulation/virtualbox-4.3.32/image//usr/lib64/virtualbox/VBoxManage.
 * Failed to set XATTR_PAX markings -me /var/tmp/portage/app-emulation/virtualbox-4.3.32/image//usr/lib64/virtualbox/VBoxSVC.
 * Failed to set XATTR_PAX markings -me /var/tmp/portage/app-emulation/virtualbox-4.3.32/image//usr/lib64/virtualbox/VBoxXPCOMIPCD.
 * Failed to set XATTR_PAX markings -me /var/tmp/portage/app-emulation/virtualbox-4.3.32/image//usr/lib64/virtualbox/VBoxSDL.
 * Failed to set XATTR_PAX markings -me /var/tmp/portage/app-emulation/virtualbox-4.3.32/image//usr/lib64/virtualbox/VBoxTestOGL.
 * Failed to set XATTR_PAX markings -me /var/tmp/portage/app-emulation/virtualbox-4.3.32/image//usr/lib64/virtualbox/VirtualBox.
 * Failed to set XATTR_PAX markings -me /var/tmp/portage/app-emulation/virtualbox-4.3.32/image//usr/lib64/virtualbox/VBoxHeadless.
 * To launch VirtualBox just type: "VirtualBox".
 * You must be in the vboxusers group to use VirtualBox.
 *
 * The latest user manual is available for download at:
 * http://download.virtualbox.org/virtualbox/4.3.32/UserManual.pdf
 *
 * For advanced networking setups you should emerge:
 * net-misc/bridge-utils and sys-apps/usermode-utilities
 *
 * IMPORTANT!
 * If you upgrade from app-emulation/virtualbox-ose make sure to run
 * "env-update" as root and logout and relogin as the user you wish
 * to run virtualbox as.
 *
 * Starting with version 4.0.0, virtualbox has USB-1 support.
 * For USB-2 support, PXE-boot ability and VRDP support please emerge
 *   app-emulation/virtualbox-extpack-oracle
 * package.
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * Regenerating GNU info directory index...
 * Processed 136 info files.

 * IMPORTANT: 5 config files in '/etc' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.


The message "Failed to set..." - is it something to worry about?

Thank you.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43383
Location: 56N 3W

PostPosted: Sat Apr 23, 2016 2:52 pm    Post subject: Reply with quote

ONEEYEMAN,

Its nothing to worry about yet. You should enable extended attribute support for tmpfs in your kernel.
The USE flag will already be on in your profile.

Those things any allow extended attributes to be used. You need to use a filesystem that supports extended attributes to be able to use them.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2772

PostPosted: Sat Apr 23, 2016 8:40 pm    Post subject: Reply with quote

Here are the results of running "emerge -pvuD system":

Code:

[blocks B      ] <sys-devel/gcc-4.9 ("<sys-devel/gcc-4.9" is blocking sys-devel/gcc-4.9.3)
[blocks B      ] media-libs/jpeg:62 ("media-libs/jpeg:62" is blocking media-libs/libjpeg-turbo-1.4.2)
[blocks B      ] <x11-themes/gnome-themes-standard-3.14 ("<x11-themes/gnome-themes-standard-3.14" is blocking x11-themes/adwaita-icon-theme-3.18.0)
[blocks B      ] sys-fs/udev[gudev(-)] ("sys-fs/udev[gudev(-)]" is blocking dev-libs/libgudev-230)
[blocks B      ] <sys-fs/lvm2-2.02.103 ("<sys-fs/lvm2-2.02.103" is blocking sys-fs/udev-225)
[blocks B      ] <=app-emulation/emul-linux-x86-opengl-20140508 ("<=app-emulation/emul-linux-x86-opengl-20140508" is blocking app-eselect/eselect-opengl-1.3.1-r4)

Total: 254 packages (210 upgrades, 40 new, 4 in new slots, 16 uninstalls), Size of downloads: 575685 KiB
Conflict: 34 blocks (6 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/gtk+:3

  (x11-libs/gtk+-3.18.7:3/3::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/gtk+-3.12:3[X,introspection?] required by (app-crypt/gcr-3.18.0:0/1::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^                                                                                             

  (x11-libs/gtk+-3.4.4:3/3::gentoo, installed) pulled in by
    <x11-libs/gtk+-3.5:3 required by (x11-themes/gnome-themes-standard-3.4.2:0/0::gentoo, installed)
    ^              ^^^^^                                                                             

media-libs/libpng:0

  (media-libs/libpng-1.6.19:0/16::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/libpng-1.4:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,\
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] \
required by (x11-libs/gdk-pixbuf-2.32.3:2/2::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                               
    >=media-libs/libpng-1.2.51:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,\
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] \
required by (media-libs/freetype-2.5.5:2/2::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                 
    >=media-libs/libpng-1.6.10:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,\
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] \
required by (x11-libs/cairo-1.14.2:0/0::gentoo, ebuild scheduled for merge)
    ^^                  ^^^^^^^^^                                                                                                                                                                                                                                             

  (media-libs/libpng-1.5.15:0/0::gentoo, installed) pulled in by
    media-libs/libpng:0/0= required by (app-emulation/virtualbox-4.3.32:0/0::gentoo, installed)
                     ^^^^^                                                                     
    (and 4 more with the same problem)

virtual/udev:0

  (virtual/udev-215:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=virtual/udev-206 required by (sys-apps/hwids-20150717-r1:0/0::gentoo, ebuild scheduled for merge)
    ^^             ^^^                                                                                 
    =virtual/udev-215 required by (x11-base/xorg-server-1.13.4:0/1.13.4::gentoo, installed)
    ^             ^^^                                                                       
    (and 10 more with the same problems)

  (virtual/udev-200:0/0::gentoo, installed) pulled in by
    >=virtual/udev-200[gudev] required by (sys-power/upower-0.9.21:0/0::gentoo, installed)
                       ^^^^^                                                               
    virtual/udev:0/0=[gudev] required by (gnome-base/gvfs-1.12.3-r1:0/0::gentoo, installed)
                      ^^^^^                                                                 
    >=virtual/udev-143[hwdb] required by (media-sound/pulseaudio-2.1-r1:0/0::gentoo, installed)
                       ^^^^                                                                     
    >=virtual/udev-143[gudev] required by (media-plugins/gst-plugins-v4l2-0.10.31:0.10/0.10::gentoo, installed)
                       ^^^^^                                                                                   
    >=virtual/udev-197[gudev,hwdb] required by (sys-fs/udisks-1.0.4-r5:0/0::gentoo, installed)
                       ^^^^^ ^^^^                                                             

sys-fs/udev:0

  (sys-fs/udev-225:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/udev-208-r1:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,\
abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,static-libs?] \
required by (virtual/libudev-215-r1:0/1::gentoo, ebuild scheduled for merge)
    ^^            ^^^^^^^^^^                                                                                                                                                                                                                                                           
    (and 1 more with the same problem)

  (sys-fs/udev-204:0/0::gentoo, installed) pulled in by
    >=sys-fs/udev-200[gudev,hwdb,introspection,keymap,kmod] required by (virtual/udev-200:0/0::gentoo, installed)
                      ^^^^^ ^^^^ ^^^^^^^^^^^^^ ^^^^^^                                                             

dev-lang/perl:0

  (dev-lang/perl-5.20.2:0/5.20::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-lang/perl-5.16 required by (dev-perl/Devel-StackTrace-1.270.0:0/0::gentoo, installed)
    ^^              ^^^^                                                                       
    =dev-lang/perl-5.20* required by (virtual/perl-ExtUtils-ParseXS-3.240.0:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                             
    (and 51 more with the same problems)

  (dev-lang/perl-5.12.4-r1:0/0::gentoo, installed) pulled in by
    dev-lang/perl[-build] required by (dev-perl/Encode-Locale-1.30.0:0/0::gentoo, installed)
                  ^^^^^^                                                                     
    dev-lang/perl[-build] required by (perl-core/Digest-1.170.0:0/0::gentoo, installed)
                  ^^^^^^                                                               
    dev-lang/perl[-build] required by (dev-perl/File-MimeInfo-0.150.0:0/0::gentoo, installed)
                  ^^^^^^                                                                     
    dev-lang/perl[-build] required by (perl-core/Storable-2.390.0:0/0::gentoo, installed)
                  ^^^^^^                                                                 
    dev-lang/perl[-build] required by (perl-core/IO-1.25:0/0::gentoo, installed)
                  ^^^^^^                                                         
    dev-lang/perl[-build] required by (dev-perl/libwww-perl-6.30.0:0/0::gentoo, installed)
                  ^^^^^^                                                                   
    dev-lang/perl[-build] required by (dev-perl/WWW-RobotRules-6.10.0:0/0::gentoo, installed)
                  ^^^^^^                                                                     
    dev-lang/perl[-build] required by (dev-perl/HTML-Tagset-3.200.0:0/0::gentoo, installed)
                  ^^^^^^                                                                   
    dev-lang/perl[-build] required by (dev-perl/IO-Socket-SSL-1.840.0:0/0::gentoo, installed)
                  ^^^^^^                                                                     
    dev-lang/perl[-build] required by (dev-perl/Net-SSLeay-1.520.0:0/0::gentoo, installed)
                  ^^^^^^                                                                   
    dev-lang/perl[-build] required by (dev-perl/Net-Daemon-0.480.0:0/0::gentoo, installed)
                  ^^^^^^                                                                   
    dev-lang/perl[-build] required by (dev-perl/HTTP-Date-6.20.0:0/0::gentoo, installed)
                  ^^^^^^                                                                 
    dev-lang/perl[-build] required by (perl-core/Compress-Raw-Zlib-2.60.0:0/0::gentoo, installed)
                  ^^^^^^                                                                         
    dev-lang/perl[-build] required by (perl-core/Encode-2.470.0:0/0::gentoo, installed)
                  ^^^^^^                                                               
    dev-lang/perl[-build] required by (dev-perl/HTTP-Daemon-6.10.0:0/0::gentoo, installed)
                  ^^^^^^                                                                   
    dev-lang/perl[-build] required by (dev-perl/File-DesktopEntry-0.40.0:0/0::gentoo, installed)
                  ^^^^^^                                                                         
    dev-lang/perl[-build] required by (perl-core/IO-Compress-2.60.0:0/0::gentoo, installed)
                  ^^^^^^                                                                   
    dev-lang/perl[-build] required by (dev-perl/LWP-MediaTypes-6.20.0:0/0::gentoo, installed)
                  ^^^^^^                                                                     
    dev-lang/perl[-build] required by (dev-perl/File-BaseDir-0.30.0:0/0::gentoo, installed)
                  ^^^^^^                                                                   
    dev-lang/perl[-build] required by (dev-perl/URI-1.600.0:0/0::gentoo, installed)
                  ^^^^^^                                                           
    dev-lang/perl[-build] required by (dev-perl/HTML-Tree-4.200.0:0/0::gentoo, installed)
                  ^^^^^^                                                                 
    dev-lang/perl[-build] required by (dev-perl/File-Listing-6.40.0:0/0::gentoo, installed)
                  ^^^^^^                                                                   
    dev-lang/perl[-build] required by (dev-perl/PlRPC-0.202.0:0/0::gentoo, installed)
                  ^^^^^^                                                             
    dev-lang/perl[-build] required by (dev-perl/HTTP-Negotiate-6.0.0:0/0::gentoo, installed)
                  ^^^^^^                                                                     
    dev-lang/perl[-build] required by (dev-perl/HTML-Parser-3.690.0:0/0::gentoo, installed)
                  ^^^^^^                                                                   
    dev-lang/perl[-build] required by (perl-core/MIME-Base64-3.130.0:0/0::gentoo, installed)
                  ^^^^^^                                                                     
    dev-lang/perl[-build] required by (dev-perl/XML-SAX-0.990.0:0/0::gentoo, installed)
                  ^^^^^^                                                               
    dev-lang/perl[-build] required by (dev-perl/WWW-Mechanize-1.720.0:0/0::gentoo, installed)
                  ^^^^^^                                                                     
    dev-lang/perl[-build] required by (dev-perl/Date-Manip-6.310.0:0/0::gentoo, installed)
                  ^^^^^^                                                                   
    dev-lang/perl[-build] required by (dev-perl/XML-NamespaceSupport-1.110.0:0/0::gentoo, installed)
                  ^^^^^^                                                                             
    dev-lang/perl[-build] required by (dev-perl/XML-SAX-Base-1.80.0:0/0::gentoo, installed)
                  ^^^^^^                                                                   
    dev-lang/perl[-build] required by (dev-perl/Net-SMTP-SSL-1.10.0:0/0::gentoo, installed)
                  ^^^^^^                                                                   
    dev-lang/perl[-build] required by (dev-perl/XML-LibXML-1.900.0:0/0::gentoo, installed)
                  ^^^^^^                                                                   
    dev-lang/perl[-build] required by (dev-perl/YAML-Syck-1.200.0:0/0::gentoo, installed)
                  ^^^^^^                                                                 
    dev-lang/perl[-build] required by (perl-core/Compress-Raw-Bzip2-2.60.0:0/0::gentoo, installed)
                  ^^^^^^                                                                           
    dev-lang/perl[-build] required by (dev-perl/DBI-1.623.0:0/0::gentoo, installed)
                  ^^^^^^                                                           
    dev-lang/perl[-build] required by (perl-core/Sys-Syslog-0.320.0:0/0::gentoo, installed)
                  ^^^^^^                                                                   
    dev-lang/perl[-build] required by (perl-core/Time-Local-1.230.0:0/0::gentoo, installed)
                  ^^^^^^                                                                   
    dev-lang/perl[-build] required by (perl-core/Digest-MD5-2.520.0:0/0::gentoo, installed)
                  ^^^^^^                                                                   
    dev-lang/perl[-build] required by (dev-perl/HTTP-Message-6.30.0:0/0::gentoo, installed)
                  ^^^^^^                                                                   
    dev-lang/perl[-build] required by (dev-perl/HTTP-Cookies-6.0.0:0/0::gentoo, installed)
                  ^^^^^^                                                                   
    dev-lang/perl[-build] required by (dev-perl/HTML-Form-6.30.0:0/0::gentoo, installed)
                  ^^^^^^                                                                 
    dev-lang/perl:0/0= required by (dev-vcs/subversion-1.8.14:0/0::gentoo, installed)
                 ^^^^^                                                               

x11-libs/pango:0

  (x11-libs/pango-1.38.1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/pango-1.37.3[introspection?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,\
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] \
required by (x11-libs/gtk+-3.18.7:3/3::gentoo, ebuild scheduled for merge)
    ^^               ^^^^^^                                                                                                                                                                                                                                                           
    (and 2 more with the same problem)

  (x11-libs/pango-1.30.1:0/0::gentoo, installed) pulled in by
    <x11-libs/pango-1.31[X] required by (x11-libs/gtkglext-1.2.0-r1:0/0::gentoo, installed)
    ^               ^^^^                                                                   

dev-libs/libgcrypt:0

  (dev-libs/libgcrypt-1.6.5:0/20::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/libgcrypt-1.5.3:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,\
abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] \
required by (dev-libs/libxslt-1.1.28-r5:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                   

  (dev-libs/libgcrypt-1.5.3:0/11::gentoo, installed) pulled in by
    >=dev-libs/libgcrypt-1.1.90:0/11= required by (net-misc/vino-2.32.2-r1:0/0::gentoo, installed)
                               ^^^^^^                                                             

x11-proto/xcb-proto:0

  (x11-proto/xcb-proto-1.11:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-proto/xcb-proto-1.11[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,\
abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,python_targets_python2_7(-),\
python_single_target_python2_7(+)] required by (x11-libs/libxcb-1.11.1:0/1.11.1::gentoo, ebuild scheduled for merge)
    ^^                    ^^^^                                                                                                                                                                                                                                                                                                                 

  (x11-proto/xcb-proto-1.8-r3:0/0::gentoo, installed) pulled in by
    <x11-proto/xcb-proto-1.9 required by (x11-libs/xpyb-1.3.1-r2:0/0::gentoo, installed)
    ^                    ^^^                                                             

dev-libs/libtasn1:0

  (dev-libs/libtasn1-4.5:0/6::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/libtasn1-3.4[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,\
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,\
abi_s390_64(-)?] required by (app-crypt/p11-kit-0.20.7:0/0::gentoo, ebuild scheduled for merge)
    ^^                  ^^^                                                                                                                                                                                                                                               

  (dev-libs/libtasn1-2.14:0/0::gentoo, installed) pulled in by
    <dev-libs/libtasn1-3 required by (net-libs/gnutls-2.12.23-r1:0/0::gentoo, installed)
    ^                  ^                                                                 

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-libs/libgudev-230:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/libgudev:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,\
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,\
abi_s390_64(-)?,introspection?,static-libs?] (dev-libs/libgudev:0/0[abi_x86_64(-),introspection]) \
required by (virtual/libgudev-230:0/0::gentoo, ebuild scheduled for merge)

  (media-libs/jpeg-6b-r9:62/62::gentoo, installed) pulled in by
    =media-libs/jpeg-6* required by (net-misc/nxclient-3.5.0.7:0/0::gentoo, installed)

  (sys-fs/lvm2-2.02.97-r1:0/0::gentoo, installed) pulled in by
    sys-fs/lvm2 required by @selected
    >=sys-fs/lvm2-2.02.66 required by (sys-fs/udisks-1.0.4-r5:0/0::gentoo, installed)
    >=sys-fs/lvm2-2.02.45 required by (sys-block/parted-3.1-r1:0/0::gentoo, installed)

  (sys-devel/gcc-4.9.3:4.9.3/4.9.3::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-devel/gcc-4.3 required by (dev-java/icedtea-bin-6.1.12.6:6/6::gentoo, installed)
    sys-devel/gcc required by @selected
    sys-devel/gcc required by @system
    >=sys-devel/gcc-4.6 required by (sys-libs/glibc-2.22-r4:2.2/2.2::gentoo, ebuild scheduled for merge)
    >=sys-devel/gcc-3.0 required by (sys-devel/llvm-3.5.0:0/3.5::gentoo, ebuild scheduled for merge)

  (media-libs/libjpeg-turbo-1.4.2:0/0::gentoo, ebuild scheduled for merge) pulled in by
    media-libs/libjpeg-turbo required by @selected
    >=media-libs/libjpeg-turbo-1.3.0-r3:0[static-libs?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,\
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] \
(>=media-libs/libjpeg-turbo-1.3.0-r3:0[abi_x86_64(-)]) required by (virtual/jpeg-0-r2:0/0::gentoo, ebuild scheduled for merge)

  (app-eselect/eselect-opengl-1.3.1-r4:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=app-eselect/eselect-opengl-1.3.0 required by (x11-proto/glproto-1.4.17-r1:0/0::gentoo, ebuild scheduled for merge)
    >=app-eselect/eselect-opengl-1.0.8 required by (x11-base/xorg-server-1.13.4:0/1.13.4::gentoo, installed)
    >=app-eselect/eselect-opengl-1.3.0 required by (media-libs/mesa-11.0.6:0/0::gentoo, ebuild scheduled for merge)

  (x11-themes/gnome-themes-standard-3.4.2:0/0::gentoo, installed) pulled in by
    >=x11-themes/gnome-themes-standard-3.0.2 required by (gnome-base/gnome-2.32.1-r2:2.0/2.0::gentoo, installed)

  (x11-themes/adwaita-icon-theme-3.18.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-themes/adwaita-icon-theme-3.14 required by (x11-libs/gtk+-3.18.7:3/3::gentoo, ebuild scheduled for merge)

  (sys-devel/gcc-4.7.3-r1:4.7.4/4.7.4::gentoo, installed) pulled in by
    sys-devel/gcc:4.7.4 required by @selected

  (app-emulation/emul-linux-x86-opengl-20131008:0/0::gentoo, installed) pulled in by
    app-emulation/emul-linux-x86-opengl required by (app-emulation/emul-linux-x86-xlibs-20131008:0/0::gentoo, installed)
    app-emulation/emul-linux-x86-opengl required by @selected
    ~app-emulation/emul-linux-x86-opengl-20131008 required by (app-emulation/emul-linux-x86-gtklibs-20131008:0/0::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by app-crypt/gcr-3.18.0::gentoo[gtk]
# required by gnome-base/gnome-keyring-3.18.3::gentoo
# required by app-crypt/libsecret-0.18.4::gentoo
# required by app-crypt/pinentry-0.9.5::gentoo[gnome-keyring]
# required by app-crypt/gnupg-2.0.28::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=x11-libs/gtk+-3.18.7

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.

!!! The following installed packages are masked:
- app-emulation/emul-linux-x86-baselibs-20131008-r6::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Michał Górny <mgorny@gentoo.org> (28 Mar 2015)
# on behalf of gx86-multilib project <multilib@gentoo.org>
# Removed lastrited emul-linux-x86. The mask is kept post-removal
# per Arfrever's request so that the PM warns about masked packages
# being installed.

- dev-java/icedtea-bin-6.1.12.6::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# James Le Cuirot <chewi@gentoo.org> (14 Mar 2016)
# Bye bye Java 6! If you really still need it then gnu_andrew will
# continue to maintain icedtea:6 in java-overlay but it is not
# supported by Java team at all. IBM's JVM is still alive but
# downloads are behind a registration wall and Java team does not wish
# to support it. haubi may provide IBM updates though probably only
# for ppc-aix. Removal in 30 days.

- app-emulation/emul-linux-x86-gtklibs-20131008::gentoo (masked by: package.mask)
- app-emulation/emul-linux-x86-xlibs-20131008::gentoo (masked by: package.mask)
- virtual/jre-1.6.0-r1::gentoo (masked by: package.mask)
- sys-power/upower-0.9.21::gentoo (masked by: package.mask)
/usr/portage/profiles/base/package.mask:
# Rick Farina <zerochaos@gentoo.org> (6 Jun 2013)
# Pm-utils based hibernate and suspend support has discontinued.
# For continued support, use the upower-pm-utils fork or systemd.
# Systemd users can switch to a systemd profile or unmask <sys-power/upower-0.99.0
# Openrc users can "emerge -C upower && emerge -1 upower-pm-utils"

- dev-java/java-config-wrapper-0.16::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# James Le Cuirot <chewi@gentoo.org> (03 Apr 2016)
# Legacy migration package that is no longer needed. See
# bug #549508. Removal in 30 days.

- x11-libs/gtk+-3.4.4::gentoo (masked by: package.mask)
- app-emulation/emul-linux-x86-opengl-20131008::gentoo (masked by: package.mask)
- virtual/jdk-1.6.0-r2::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


The most important one is the first blocker as I can't uninstall gcc.

Any idea?

Thank you.

[EDIT]
It looks like that according to this, I will have to re-install. ;-)

Line breaks added by NeddySeagoon
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43383
Location: 56N 3W

PostPosted: Sat Apr 23, 2016 10:20 pm    Post subject: Reply with quote

ONEEYEMAN,

Look carefully at your blockers. The two that follow are just examples.
Code:
[blocks B      ] <sys-devel/gcc-4.9 ("<sys-devel/gcc-4.9" is blocking sys-devel/gcc-4.9.3)
[blocks B      ] media-libs/jpeg:62 ("media-libs/jpeg:62" is blocking media-libs/libjpeg-turbo-1.4.2)

The < is important. In the first case
Code:
<sys-devel/gcc-4.9" is blocking sys-devel/gcc-4.9.3
portage would like to upgrade to gcc-4.9.3 but your gcc is too old.
You need gcc-4.9 to build 4.93.
Try
Code:
emerge =sys-devel/gcc-4.9 -1av
to see if you can get gcc-4.9. Once you have that, you can use it to build gcc-4.9.3.
That looks like a typo or a bug as the tree only does not have gcc-4.9 any more. This may be the dance with glibc too.

eix gcc:
[I] sys-devel/gcc
     Available versions: 
     (2.95.3) (~*)2.95.3-r10^s
     (3.3.6) (~)3.3.6-r1^s
     (3.4.6) 3.4.6-r2^s
     (4.0.4) (**)4.0.4^s
     (4.1.2) 4.1.2^s
     (4.2.4) (~)4.2.4-r1^s
     (4.3.6) 4.3.6-r1^s
     (4.4.7) 4.4.7^s
     (4.5.4) 4.5.4^s
     (4.6.4) 4.6.4^s
     (4.7.4) 4.7.4^s
     (4.8.5) 4.8.5^s
     (4.9.3) 4.9.3^s{tbz2}
     (5.1.0) (**)5.1.0^s
     (5.2.0) (**)5.2.0^s{tbz2}
     (5.3.0) (~)5.3.0^s{tbz2}
as you say, its a very bad idea to remove gcc but the less than (<) hint is a suggestion to upgrade, eves if you must upgrade in small steps.

Code:
media-libs/jpeg:62" is blocking media-libs/libjpeg-turbo-1.4.2
Here you need to choose one.
Look carefully at what needs each package - you can't have both.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 3121
Location: Illinois, USA

PostPosted: Sun Apr 24, 2016 12:32 am    Post subject: Reply with quote

Looking ahead, I see some major steps:

1. libpng upgrade - this gave everyone fits - twice!
2. udev / eudev split
3. deprecation and removal of Gnome 2.x
4. perl upgrade

Run "eselect news list" and you will some some news items on these, some are vague and poorly written, but I highly encourage reading them.

If you know about the Windows 8 like desktop on Gnome 3 and don't want it, you can install Mate. This is a choice you have to make.
I preferred to migrate to Mate, YMMV. Gnome and udev are highly tied to systemd, this is another choice you have to make. I chose eudev, then migrated to mdev. Again, YMMV.
Even if you chuck it all and re-install, you have to make those three choices.

Independent of those choices, I would first update perl and the system tools. Read the perl news and do your system update as "emerge -auvND system --exclude sys-devel-gcc", possibly adding "--with-bdeps=y" Try it and see if there is a problem. I think your portage 2.2.18 is good. Mine (up to date as of yesterday) is 2.2.26

NeddySeagoon is guiding you and I am just kibitzing. If anything I've said conflicts with his advice - follow his advice!

I'm a big believer in planning, but sometimes you have to just blunder through. In a case like this, define your goals, make a high level plan, then blunder your way through the details.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2772

PostPosted: Sun Apr 24, 2016 1:52 am    Post subject: Reply with quote

NeddySeagoon,
NeddySeagoon wrote:

ONEEYEMAN,

Look carefully at your blockers. The two that follow are just examples.
Code:

[blocks B      ] <sys-devel/gcc-4.9 ("<sys-devel/gcc-4.9" is blocking sys-devel/gcc-4.9.3)
[blocks B      ] media-libs/jpeg:62 ("media-libs/jpeg:62" is blocking media-libs/libjpeg-turbo-1.4.2)

The < is important. In the first case
Code:
<sys-devel/gcc-4.9" is blocking sys-devel/gcc-4.9.3
portage would like to upgrade to gcc-4.9.3 but your gcc is too old.
You need gcc-4.9 to build 4.93.
Try
Code:
emerge =sys-devel/gcc-4.9 -1av
to see if you can get gcc-4.9. Once you have that, you can use it to build gcc-4.9.3.
That looks like a typo or a bug as the tree only does not have gcc-4.9 any more. This may be the dance with glibc too.

Apparently, the ebuild for gcc-4.9 is no longer present:

Code:

IgorReinCloud buildGTK # emerge -pv =sys-devel/gcc-4.9 -1
!!! SYNC setting found in make.conf.
    This setting is Deprecated and no longer used.  Please ensure your 'sync-type' and 'sync-uri' are set correctly in /etc/portage/repos.conf/gentoo.conf

These are the packages that would be merged, in order:

Calculating dependencies \ * ERROR: dev-util/anjuta-2.32.1.1-r1::x-portage failed (depend phase):
 *   EAPI=3 is not supported
 *
 * Call stack:
 *                   ebuild.sh, line 624:  Called source '/usr/local/portage/dev-util/anjuta/anjuta-2.32.1.1-r1.ebuild'
 *   anjuta-2.32.1.1-r1.ebuild, line   9:  Called inherit 'eutils' 'gnome2' 'flag-o-matic' 'multilib' 'python'
 *                   ebuild.sh, line 320:  Called __qa_source '/usr/portage/eclass/gnome2.eclass'
 *                   ebuild.sh, line 120:  Called source '/usr/portage/eclass/gnome2.eclass'
 *               gnome2.eclass, line  13:  Called inherit 'eutils' 'libtool' 'gnome.org' 'gnome2-utils' 'xdg'
 *                   ebuild.sh, line 320:  Called __qa_source '/usr/portage/eclass/xdg.eclass'
 *                   ebuild.sh, line 120:  Called source '/usr/portage/eclass/xdg.eclass'
 *                  xdg.eclass, line  21:  Called die
 * The specific snippet of code:
 *      *) die "EAPI=${EAPI} is not supported" ;;
 *
 * If you need support, post the output of `emerge --info '=dev-util/anjuta-2.32.1.1-r1::x-portage'`,
 * the complete build log and the output of `emerge -pqv '=dev-util/anjuta-2.32.1.1-r1::x-portage'`.
 * The ebuild environment file is located at '/var/tmp/portage/dev-util/anjuta-2.32.1.1-r1/temp/die.env'.
 * Working directory: '/usr/lib64/python2.7/site-packages'
 * S: '/var/tmp/portage/dev-util/anjuta-2.32.1.1-r1/work/anjuta-2.32.1.1'
... done!

emerge: there are no ebuilds to satisfy "=sys-devel/gcc-4.9".
IgorReinCloud buildGTK # ls -la /usr/portage/s
sci-astronomy/     sci-electronics/   sci-misc/          sec-policy/        sys-auth/          sys-devel/         sys-infiniband/    sys-process/
sci-biology/       sci-geosciences/   sci-physics/       skel.ebuild        sys-block/         sys-firmware/      sys-kernel/       
sci-calculators/   sci-libs/          sci-visualization/ skel.metadata.xml  sys-boot/          sys-freebsd/       sys-libs/         
sci-chemistry/     sci-mathematics/   scripts/           sys-apps/          sys-cluster/       sys-fs/            sys-power/         
IgorReinCloud buildGTK # ls -la /usr/portage/sys-devel/gcc
total 320
drwxr-xr-x  3 portage portage   4096 Apr 20 20:29 .
drwxr-xr-x 52 portage portage   4096 Apr 20 20:29 ..
-rw-r--r--  1 portage portage  10102 Mar 21 08:33 ChangeLog
-rw-r--r--  1 portage portage 112483 Nov  8 19:28 ChangeLog-2006
-rw-r--r--  1 portage portage  73367 Nov  8 20:11 ChangeLog-2015
-rw-r--r--  1 portage portage  36116 Mar 21 08:33 Manifest
drwxr-xr-x  7 portage portage   4096 Apr 20 20:29 files
-rw-r--r--  1 portage portage    759 Aug  8  2015 gcc-2.95.3-r10.ebuild
-rw-r--r--  1 portage portage   1256 Aug  8  2015 gcc-3.3.6-r1.ebuild
-rw-r--r--  1 portage portage   1379 Aug  8  2015 gcc-3.4.6-r2.ebuild
-rw-r--r--  1 portage portage    254 Jan 13 07:51 gcc-4.0.4.ebuild
-rw-r--r--  1 portage portage    668 Jan 13 07:51 gcc-4.1.2.ebuild
-rw-r--r--  1 portage portage    413 Jan 13 07:51 gcc-4.2.4-r1.ebuild
-rw-r--r--  1 portage portage    637 Jan 13 07:51 gcc-4.3.6-r1.ebuild
-rw-r--r--  1 portage portage    681 Jan 13 07:51 gcc-4.4.7.ebuild
-rw-r--r--  1 portage portage    694 Jan 13 07:51 gcc-4.5.4.ebuild
-rw-r--r--  1 portage portage    775 Dec  5 13:13 gcc-4.6.4.ebuild
-rw-r--r--  1 portage portage   1298 Aug  8  2015 gcc-4.7.4.ebuild
-rw-r--r--  1 portage portage   1408 Dec 28 16:07 gcc-4.8.5.ebuild
-rw-r--r--  1 portage portage   1447 Mar 15 10:56 gcc-4.9.3.ebuild
-rw-r--r--  1 portage portage   1274 Aug 29  2015 gcc-5.1.0.ebuild
-rw-r--r--  1 portage portage   1274 Oct 26 21:41 gcc-5.2.0.ebuild
-rw-r--r--  1 portage portage   1334 Mar 15 10:56 gcc-5.3.0.ebuild
-rw-r--r--  1 portage portage   2265 Mar 20 19:50 metadata.xml
IgorReinCloud buildGTK # gcc-config -l
 [1] x86_64-pc-linux-gnu-4.7.3 *


Is there anything I can do?

Thank you.

eix gcc:
[I] sys-devel/gcc
     Available versions: 
     (2.95.3) (~*)2.95.3-r10^s
     (3.3.6) (~)3.3.6-r1^s
     (3.4.6) 3.4.6-r2^s
     (4.0.4) (**)4.0.4^s
     (4.1.2) 4.1.2^s
     (4.2.4) (~)4.2.4-r1^s
     (4.3.6) 4.3.6-r1^s
     (4.4.7) 4.4.7^s
     (4.5.4) 4.5.4^s
     (4.6.4) 4.6.4^s
     (4.7.4) 4.7.4^s
     (4.8.5) 4.8.5^s
     (4.9.3) 4.9.3^s{tbz2}
     (5.1.0) (**)5.1.0^s
     (5.2.0) (**)5.2.0^s{tbz2}
     (5.3.0) (~)5.3.0^s{tbz2}
as you say, its a very bad idea to remove gcc but the less than (<) hint is a suggestion to upgrade, eves if you must upgrade in small steps.

Code:
media-libs/jpeg:62" is blocking media-libs/libjpeg-turbo-1.4.2
Here you need to choose one.
Look carefully at what needs each package - you can't have both.[/quote]
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7071

PostPosted: Sun Apr 24, 2016 6:30 am    Post subject: Reply with quote

USE="multislot" emerge -u1 gcc
keep the fun going.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2772

PostPosted: Sun Apr 24, 2016 1:14 pm    Post subject: Reply with quote

krinn,
Yes, gcc is now being merged.

So after that II should switch to gcc and recompile it, right? Just run:

Code:

emerge gcc

so that it will be recompiled "properly" and then do

Code:

emerge -1av libtool


then try

Code:

emerge -pvuD system

again.

Am I right? Or I can skip rebuilding gcc and just select it with "gcc-config"?

Thank you.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43383
Location: 56N 3W

PostPosted: Sun Apr 24, 2016 1:37 pm    Post subject: Reply with quote

ONEEYEMAN,

gcc is merged properly. You can just select it.

When you emerge system packages, as you are just now, always use the -1 option or they will be added to your world file.
Right now, its mostly harmless but in time to come it will cause dependency issues.

If in doubt, when you are rebuilding something yau already have installed' --oneshot is safe.
If its already in the world file it will stay there. If its not, it won't be added and you do check what --depclean wants to do before you do it don't you?
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2772

PostPosted: Sun Apr 24, 2016 1:49 pm    Post subject: Reply with quote

NeddySeagoon,
OK, so I can just select it, emerge libtool, and then continue to resolve another blocker, right?

No need to do revdep-rebuild as everything wil be rebuilt anyway

Thank you.
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7071

PostPosted: Sun Apr 24, 2016 3:45 pm    Post subject: Reply with quote

ONEEYEMAN wrote:
NeddySeagoon,
OK, so I can just select it, emerge libtool, and then continue to resolve another blocker, right?

No need to do revdep-rebuild as everything wil be rebuilt anyway

Thank you.


Just stay focus on @system, and do @world when @system is ready.
As safety you can always <quickpkg> a package you think is sensible before upgrading it.
Another thing i always do, emerge -f prior anything (because it sucks to have wget broken and need to download a package)
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2772

PostPosted: Mon Apr 25, 2016 1:38 am    Post subject: Reply with quote

OK, guys,
gcc 4.9.3 is installed and was automatically selected.
I then install libtool without any issues.

Now to the next blockder:

Code:

IgorReinCloud buildGTK # emerge -pv --depclean jpeg
!!! SYNC setting found in make.conf.
    This setting is Deprecated and no longer used.  Please ensure your 'sync-type' and 'sync-uri' are set correctly in /etc/portage/repos.conf/gentoo.conf

Calculating dependencies / * ERROR: dev-util/anjuta-2.32.1.1-r1::x-portage failed (depend phase):
 *   EAPI=3 is not supported
 *
 * Call stack:
 *                   ebuild.sh, line 624:  Called source '/usr/local/portage/dev-util/anjuta/anjuta-2.32.1.1-r1.ebuild'
 *   anjuta-2.32.1.1-r1.ebuild, line   9:  Called inherit 'eutils' 'gnome2' 'flag-o-matic' 'multilib' 'python'
 *                   ebuild.sh, line 320:  Called __qa_source '/usr/portage/eclass/gnome2.eclass'
 *                   ebuild.sh, line 120:  Called source '/usr/portage/eclass/gnome2.eclass'
 *               gnome2.eclass, line  13:  Called inherit 'eutils' 'libtool' 'gnome.org' 'gnome2-utils' 'xdg'
 *                   ebuild.sh, line 320:  Called __qa_source '/usr/portage/eclass/xdg.eclass'
 *                   ebuild.sh, line 120:  Called source '/usr/portage/eclass/xdg.eclass'
 *                  xdg.eclass, line  21:  Called die
 * The specific snippet of code:
 *      *) die "EAPI=${EAPI} is not supported" ;;
 *
 * If you need support, post the output of `emerge --info '=dev-util/anjuta-2.32.1.1-r1::x-portage'`,
 * the complete build log and the output of `emerge -pqv '=dev-util/anjuta-2.32.1.1-r1::x-portage'`.
 * The ebuild environment file is located at '/var/tmp/portage/dev-util/anjuta-2.32.1.1-r1/temp/die.env'.
 * Working directory: '/usr/lib64/python2.7/site-packages'
 * S: '/var/tmp/portage/dev-util/anjuta-2.32.1.1-r1/work/anjuta-2.32.1.1'
... done!
  media-libs/jpeg-6b-r9 pulled in by:
    net-misc/nxclient-3.5.0.7 requires =media-libs/jpeg-6*

>>> No packages selected for removal by depclean
Packages installed:   979
Packages in world:    519
Packages in system:   44
Required packages:    979
Number to remove:     0
IgorReinCloud buildGTK # emerge -pv nxclient
!!! SYNC setting found in make.conf.
    This setting is Deprecated and no longer used.  Please ensure your 'sync-type' and 'sync-uri' are set correctly in /etc/portage/repos.conf/gentoo.conf

These are the packages that would be merged, in order:

Calculating dependencies | * ERROR: dev-util/anjuta-2.32.1.1-r1::x-portage failed (depend phase):
 *   EAPI=3 is not supported
 *
 * Call stack:
 *                   ebuild.sh, line 624:  Called source '/usr/local/portage/dev-util/anjuta/anjuta-2.32.1.1-r1.ebuild'
 *   anjuta-2.32.1.1-r1.ebuild, line   9:  Called inherit 'eutils' 'gnome2' 'flag-o-matic' 'multilib' 'python'
 *                   ebuild.sh, line 320:  Called __qa_source '/usr/portage/eclass/gnome2.eclass'
 *                   ebuild.sh, line 120:  Called source '/usr/portage/eclass/gnome2.eclass'
 *               gnome2.eclass, line  13:  Called inherit 'eutils' 'libtool' 'gnome.org' 'gnome2-utils' 'xdg'
 *                   ebuild.sh, line 320:  Called __qa_source '/usr/portage/eclass/xdg.eclass'
 *                   ebuild.sh, line 120:  Called source '/usr/portage/eclass/xdg.eclass'
 *                  xdg.eclass, line  21:  Called die
 * The specific snippet of code:
 *      *) die "EAPI=${EAPI} is not supported" ;;
 *
 * If you need support, post the output of `emerge --info '=dev-util/anjuta-2.32.1.1-r1::x-portage'`,
 * the complete build log and the output of `emerge -pqv '=dev-util/anjuta-2.32.1.1-r1::x-portage'`.
 * The ebuild environment file is located at '/var/tmp/portage/dev-util/anjuta-2.32.1.1-r1/temp/die.env'.
 * Working directory: '/usr/lib64/python2.7/site-packages'
 * S: '/var/tmp/portage/dev-util/anjuta-2.32.1.1-r1/work/anjuta-2.32.1.1'
... done!

emerge: there are no ebuilds to satisfy "nxclient".

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


If I remember correctly the nxclient is the GUI interface for the ssh.
I can probably live without it as I needed it for work and now I no longer work for that company.

And it looks like nothing depends on it:

Code:

IgorReinCloud buildGTK # emerge -pv --depclean nxclient
!!! SYNC setting found in make.conf.
    This setting is Deprecated and no longer used.  Please ensure your 'sync-type' and 'sync-uri' are set correctly in /etc/portage/repos.conf/gentoo.conf

Calculating dependencies / * ERROR: dev-util/anjuta-2.32.1.1-r1::x-portage failed (depend phase):
 *   EAPI=3 is not supported
 *
 * Call stack:
 *                   ebuild.sh, line 624:  Called source '/usr/local/portage/dev-util/anjuta/anjuta-2.32.1.1-r1.ebuild'
 *   anjuta-2.32.1.1-r1.ebuild, line   9:  Called inherit 'eutils' 'gnome2' 'flag-o-matic' 'multilib' 'python'
 *                   ebuild.sh, line 320:  Called __qa_source '/usr/portage/eclass/gnome2.eclass'
 *                   ebuild.sh, line 120:  Called source '/usr/portage/eclass/gnome2.eclass'
 *               gnome2.eclass, line  13:  Called inherit 'eutils' 'libtool' 'gnome.org' 'gnome2-utils' 'xdg'
 *                   ebuild.sh, line 320:  Called __qa_source '/usr/portage/eclass/xdg.eclass'
 *                   ebuild.sh, line 120:  Called source '/usr/portage/eclass/xdg.eclass'
 *                  xdg.eclass, line  21:  Called die
 * The specific snippet of code:
 *      *) die "EAPI=${EAPI} is not supported" ;;
 *
 * If you need support, post the output of `emerge --info '=dev-util/anjuta-2.32.1.1-r1::x-portage'`,
 * the complete build log and the output of `emerge -pqv '=dev-util/anjuta-2.32.1.1-r1::x-portage'`.
 * The ebuild environment file is located at '/var/tmp/portage/dev-util/anjuta-2.32.1.1-r1/temp/die.env'.
 * Working directory: '/usr/lib64/python2.7/site-packages'
 * S: '/var/tmp/portage/dev-util/anjuta-2.32.1.1-r1/work/anjuta-2.32.1.1'
... done!
>>> Calculating removal order...

>>> These are the packages that would be unmerged:

 net-misc/nxclient
    selected: 3.5.0.7
   protected: none
     omitted: none

All selected packages: =net-misc/nxclient-3.5.0.7

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.

Packages installed:   979
Packages in world:    519
Packages in system:   44
Required packages:    978
Number to remove:     1


which means I can safely remove one and then the other, right?

And if I will need something like this I'm sure there will be a different package with the same functionality. ;-)

Thank you.

Fixed you code tags ;) --The Doctor
Back to top
View user's profile Send private message
The Doctor
Moderator
Moderator


Joined: 27 Jul 2010
Posts: 2585

PostPosted: Mon Apr 25, 2016 1:45 am    Post subject: Reply with quote

I'd say anything that is causing problems that you don't need right now should go. You can always reinstall later if you want/need it.

Although, other packages are going to have this problem. You need to update portage. That is what the EAPI errors mean. I'm not sure if you are going to be able to do that directly. You may need the oldest portage in the tree and step up from there or maybe an even older one.
_________________
First things first, but not necessarily in that order.

Apologies if I take a while to respond. I'm currently working on the dematerialization circuit for my blue box.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2772

PostPosted: Mon Apr 25, 2016 1:51 am    Post subject: Reply with quote

The Doctor,

I do have a latest Portage:

Code:

IgorReinCloud buildGTK # emerge -pv portage
!!! SYNC setting found in make.conf.
    This setting is Deprecated and no longer used.  Please ensure your 'sync-type' and 'sync-uri' are set correctly in /etc/portage/repos.conf/gentoo.conf

These are the packages that would be merged, in order:

Calculating dependencies | * ERROR: dev-util/anjuta-2.32.1.1-r1::x-portage failed (depend phase):
 *   EAPI=3 is not supported
 *
 * Call stack:
 *                   ebuild.sh, line 624:  Called source '/usr/local/portage/dev-util/anjuta/anjuta-2.32.1.1-r1.ebuild'
 *   anjuta-2.32.1.1-r1.ebuild, line   9:  Called inherit 'eutils' 'gnome2' 'flag-o-matic' 'multilib' 'python'
 *                   ebuild.sh, line 320:  Called __qa_source '/usr/portage/eclass/gnome2.eclass'
 *                   ebuild.sh, line 120:  Called source '/usr/portage/eclass/gnome2.eclass'
 *               gnome2.eclass, line  13:  Called inherit 'eutils' 'libtool' 'gnome.org' 'gnome2-utils' 'xdg'
 *                   ebuild.sh, line 320:  Called __qa_source '/usr/portage/eclass/xdg.eclass'
 *                   ebuild.sh, line 120:  Called source '/usr/portage/eclass/xdg.eclass'
 *                  xdg.eclass, line  21:  Called die
 * The specific snippet of code:
 *      *) die "EAPI=${EAPI} is not supported" ;;
 *
 * If you need support, post the output of `emerge --info '=dev-util/anjuta-2.32.1.1-r1::x-portage'`,
 * the complete build log and the output of `emerge -pqv '=dev-util/anjuta-2.32.1.1-r1::x-portage'`.
 * The ebuild environment file is located at '/var/tmp/portage/dev-util/anjuta-2.32.1.1-r1/temp/die.env'.
 * Working directory: '/usr/lib64/python2.7/site-packages'
 * S: '/var/tmp/portage/dev-util/anjuta-2.32.1.1-r1/work/anjuta-2.32.1.1'
... done!
[ebuild   R    ] sys-apps/portage-2.2.26::gentoo  USE="(ipc) -build -doc -epydoc (-selinux) -xattr" LINGUAS="-ru" PYTHON_TARGETS="python2_7 (-pypy) -python3_3 -python3_4 (-python3_5)" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


Thank you.

P.S.: I will uninstall nxclient, and see if something else depends on jpeg.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page 1, 2, 3, 4, 5, 6, 7, 8  Next
Page 1 of 8

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum