Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE5 slow and lagging after upgrade from KDE 4 [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
nagmat84
Tux's lil' helper
Tux's lil' helper


Joined: 27 Mar 2007
Posts: 119

PostPosted: Thu Apr 21, 2016 2:29 pm    Post subject: KDE5 slow and lagging after upgrade from KDE 4 [SOLVED] Reply with quote

Hello,

I have two KDE 5 installation. The first and older one was a clean install on a new laptop some month ago, when KDE5 was still in the unstable branch. This installation is running smoothly and responsive. Yesterday, I decided to upgrade my KDE 4 installation to KDE 5 on my (productive) desktop PC, because of the message from the portage news system. I expected no problems due to my experiences from the experimental setup on my laptop. Although my desktop PC is much more powerful than my laptop in every respect, KDE 5 is slow and lagging. The UI randomly gets unresponsive for some seconds and then everything goes on.

For example, if I right click somewhere for the first time, everything pauses for 1-2 seconds until the context menu pops up. Same thing holds if I open a menu, an application, a dialog for the first time. After that the same item is very quick, if I repeat the same action. But if I do not use the same menu/.../... for some hours the same slack appears again.

I guess it has something to do with broken caches that still contain old and outdated items from the previous KDE 4 installation. But I might be wrong.

Any ideas what I could try out? At the moment working with my desktop PC is fun at all.

Thanks, Matthias


Last edited by nagmat84 on Sat Apr 23, 2016 10:40 am; edited 1 time in total
Back to top
View user's profile Send private message
mrbassie
Guru
Guru


Joined: 31 May 2013
Posts: 555

PostPosted: Thu Apr 21, 2016 4:02 pm    Post subject: Reply with quote

I had the same little issues but they seemed to just go away on their own after a couple of days. Do you use preload? That's what I put it down to on my machines, although it's purely a guess.
Back to top
View user's profile Send private message
nagmat84
Tux's lil' helper
Tux's lil' helper


Joined: 27 Mar 2007
Posts: 119

PostPosted: Thu Apr 21, 2016 4:09 pm    Post subject: Reply with quote

What is "preload" and how do I enable/disable it?
Back to top
View user's profile Send private message
kharitonow
n00b
n00b


Joined: 10 Dec 2015
Posts: 38

PostPosted: Fri Apr 22, 2016 6:26 am    Post subject: Re: KDE5/Plasma/KF5 slow and lagging after upgrade from KDE Reply with quote

nagmat84 wrote:
Hello,

I have two KDE 5 installation. The first and older one was a clean install on a new laptop some month ago, when KDE5 was still in the unstable branch. This installation is running smoothly and responsive. Yesterday, I decided to upgrade my KDE 4 installation to KDE 5 on my (productive) desktop PC, because of the message from the portage news system. I expected no problems due to my experiences from the experimental setup on my laptop. Although my desktop PC is much more powerful than my laptop in every respect, KDE 5 is slow and lagging. The UI randomly gets unresponsive for some seconds and then everything goes on.

For example, if I right click somewhere for the first time, everything pauses for 1-2 seconds until the context menu pops up. Same thing holds if I open a menu, an application, a dialog for the first time. After that the same item is very quick, if I repeat the same action. But if I do not use the same menu/.../... for some hours the same slack appears again.

I guess it has something to do with broken caches that still contain old and outdated items from the previous KDE 4 installation. But I might be wrong.

Any ideas what I could try out? At the moment working with my desktop PC is fun at all.

Thanks, Matthias


I had the same issue. The problem for me was in the baloo file indexer, which took the whole time of a processor core for indexing of my pretty big home folder. After switching it off I got pretty responsive system. Exactly the same issue like you have happens for me at the file deletion in dolphin but nowhere else more.
Back to top
View user's profile Send private message
mrbassie
Guru
Guru


Joined: 31 May 2013
Posts: 555

PostPosted: Fri Apr 22, 2016 2:08 pm    Post subject: Reply with quote

nagmat84 wrote:
What is "preload" and how do I enable/disable it?


https://wiki.archlinux.org/index.php/Preload

If you don't know what it is then you're not using it.
Back to top
View user's profile Send private message
davidm
Guru
Guru


Joined: 26 Apr 2009
Posts: 557
Location: US

PostPosted: Fri Apr 22, 2016 2:19 pm    Post subject: Re: KDE5/Plasma/KF5 slow and lagging after upgrade from KDE Reply with quote

kharitonow wrote:
nagmat84 wrote:
Hello,

I have two KDE 5 installation. The first and older one was a clean install on a new laptop some month ago, when KDE5 was still in the unstable branch. This installation is running smoothly and responsive. Yesterday, I decided to upgrade my KDE 4 installation to KDE 5 on my (productive) desktop PC, because of the message from the portage news system. I expected no problems due to my experiences from the experimental setup on my laptop. Although my desktop PC is much more powerful than my laptop in every respect, KDE 5 is slow and lagging. The UI randomly gets unresponsive for some seconds and then everything goes on.

For example, if I right click somewhere for the first time, everything pauses for 1-2 seconds until the context menu pops up. Same thing holds if I open a menu, an application, a dialog for the first time. After that the same item is very quick, if I repeat the same action. But if I do not use the same menu/.../... for some hours the same slack appears again.

I guess it has something to do with broken caches that still contain old and outdated items from the previous KDE 4 installation. But I might be wrong.

Any ideas what I could try out? At the moment working with my desktop PC is fun at all.

Thanks, Matthias


I had the same issue. The problem for me was in the baloo file indexer, which took the whole time of a processor core for indexing of my pretty big home folder. After switching it off I got pretty responsive system. Exactly the same issue like you have happens for me at the file deletion in dolphin but nowhere else more.


Hi, it could be baloo. You are quite right. However they've worked quite a bit to try to make it less of a problem. What I believe happens is that when you switch to Plasma and the qt5 baloo it has to regenerate the index or otherwise scan the files on the filesystem.

If you want to use baloo then you can just be patient and probably overnight it will finish. If not you can use balooctl to control the file indexer by pausing or even stopping and disabling it:

Code:

$ balooctl help
Usage: balooctl [options] command status enable disable start stop restart suspend resume check index clear config

Options:
  -v, --version  Displays version information.
  -h, --help     Displays this help.

Arguments:
  command        The command to execute
  status         Print the status of the indexer
  enable         Enable the file indexer
  disable        Disable the file indexer
  start          Start the file indexer
  stop           Stop the file indexer
  restart        Restart the file indexer
  suspend        Suspend the file indexer
  resume         Resume the file indexer
  check          Check for any unindexed files and index them
  index          Index the specified files
  clear          Forget the specified files
  config         Modify the Baloo configuration


So to pause it do:

$balooctl suspend

To disable:

$balooctl disable

I guess I am an odd one though because I actually use baloo extensively and love it.

Btw if baloo is the issue it should show up in the system monitor utilities (top, etc) where it is using a lot of cpu. I wouldn't disable it unless it is a problem as it will limit some other functionality.
Back to top
View user's profile Send private message
kharitonow
n00b
n00b


Joined: 10 Dec 2015
Posts: 38

PostPosted: Fri Apr 22, 2016 3:42 pm    Post subject: Re: KDE5/Plasma/KF5 slow and lagging after upgrade from KDE Reply with quote

davidm wrote:
kharitonow wrote:
nagmat84 wrote:
Hello,

I have two KDE 5 installation. The first and older one was a clean install on a new laptop some month ago, when KDE5 was still in the unstable branch. This installation is running smoothly and responsive. Yesterday, I decided to upgrade my KDE 4 installation to KDE 5 on my (productive) desktop PC, because of the message from the portage news system. I expected no problems due to my experiences from the experimental setup on my laptop. Although my desktop PC is much more powerful than my laptop in every respect, KDE 5 is slow and lagging. The UI randomly gets unresponsive for some seconds and then everything goes on.

For example, if I right click somewhere for the first time, everything pauses for 1-2 seconds until the context menu pops up. Same thing holds if I open a menu, an application, a dialog for the first time. After that the same item is very quick, if I repeat the same action. But if I do not use the same menu/.../... for some hours the same slack appears again.

I guess it has something to do with broken caches that still contain old and outdated items from the previous KDE 4 installation. But I might be wrong.

Any ideas what I could try out? At the moment working with my desktop PC is fun at all.

Thanks, Matthias


I had the same issue. The problem for me was in the baloo file indexer, which took the whole time of a processor core for indexing of my pretty big home folder. After switching it off I got pretty responsive system. Exactly the same issue like you have happens for me at the file deletion in dolphin but nowhere else more.


Hi, it could be baloo. You are quite right. However they've worked quite a bit to try to make it less of a problem. What I believe happens is that when you switch to Plasma and the qt5 baloo it has to regenerate the index or otherwise scan the files on the filesystem.

If you want to use baloo then you can just be patient and probably overnight it will finish. If not you can use balooctl to control the file indexer by pausing or even stopping and disabling it:

Code:

$ balooctl help
Usage: balooctl [options] command status enable disable start stop restart suspend resume check index clear config

Options:
  -v, --version  Displays version information.
  -h, --help     Displays this help.

Arguments:
  command        The command to execute
  status         Print the status of the indexer
  enable         Enable the file indexer
  disable        Disable the file indexer
  start          Start the file indexer
  stop           Stop the file indexer
  restart        Restart the file indexer
  suspend        Suspend the file indexer
  resume         Resume the file indexer
  check          Check for any unindexed files and index them
  index          Index the specified files
  clear          Forget the specified files
  config         Modify the Baloo configuration


So to pause it do:

$balooctl suspend

To disable:

$balooctl disable

I guess I am an odd one though because I actually use baloo extensively and love it.

Btw if baloo is the issue it should show up in the system monitor utilities (top, etc) where it is using a lot of cpu. I wouldn't disable it unless it is a problem as it will limit some other functionality.


Thanks. I've also added some path exceptions for indexing and baloo did the job in ca. 2 hours. I forgot to mention that during the indexing baloo wasn't shy to eat a lot of memory. In my case it was about 1.4 GB.

Now searching seems to work fine for me.

The problem is that baloo starts indexing after first login instantly e.g. after an update from kde4 and can make the very first impression of a sluggish DE.
Back to top
View user's profile Send private message
nagmat84
Tux's lil' helper
Tux's lil' helper


Joined: 27 Mar 2007
Posts: 119

PostPosted: Fri Apr 22, 2016 6:07 pm    Post subject: Reply with quote

Balloo was not part of my problem. I had and still have:
Code:

$> LC_ALL= LANG= balooctl status
Baloo File Indexer is running
Indexer state: Idle
Indexed 67451 / 67451 files
Current size of index is 1.14 GiB

And I did not want to disable Baloo because I actually use the semantic search. But anyway, as one can see Baloo is idle.

It was actually a cashing problem. I did the following:

  • Log out of KDE
  • Switch to console
  • And for every user $user
    Code:

    $> cd /var/tmp/kdecache-$user/
    $> find . -type f -exec rm '{}' ';'
    $> cd ~$user/.cache
    $> find . -type f -exec rm '{}' ';'
    $> cd ~$user/.thumbnails
    $> find . -type f -exec rm '{}' ';'



Now, KDE bolts.
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3257
Location: Gainesville, Florida

PostPosted: Mon Apr 25, 2016 6:20 pm    Post subject: Reply with quote

Thanks nagmat84,

Nice tip!
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r6, gcc-9.2.0 kernel-5.3.7-gentoo USE=experimental
Back to top
View user's profile Send private message
John5788
Advocate
Advocate


Joined: 06 Apr 2004
Posts: 2140
Location: 127.0.0.1

PostPosted: Sat Apr 30, 2016 8:37 am    Post subject: Reply with quote

nagmat84 wrote:
Balloo was not part of my problem. I had and still have:
Code:

$> LC_ALL= LANG= balooctl status
Baloo File Indexer is running
Indexer state: Idle
Indexed 67451 / 67451 files
Current size of index is 1.14 GiB

And I did not want to disable Baloo because I actually use the semantic search. But anyway, as one can see Baloo is idle.

It was actually a cashing problem. I did the following:

  • Log out of KDE
  • Switch to console
  • And for every user $user
    Code:

    $> cd /var/tmp/kdecache-$user/
    $> find . -type f -exec rm '{}' ';'
    $> cd ~$user/.cache
    $> find . -type f -exec rm '{}' ';'
    $> cd ~$user/.thumbnails
    $> find . -type f -exec rm '{}' ';'



Now, KDE bolts.


Thanks for providing that tip. Running those commands helped clear up a lot of problems I was experiencing when upgrading from KDE4 to the new Plasma desktop
_________________
John5788
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum