Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
unfixable graphics hangs with nouveau
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
typos
n00b
n00b


Joined: 17 Apr 2016
Posts: 1
Location: Finland

PostPosted: Mon Apr 18, 2016 11:39 am    Post subject: unfixable graphics hangs with nouveau Reply with quote

It has usually happened to me when running graphics intensive applications through wine but has also occurred when just playing video with mpv.

I have recently upgraded everything on the system but it did not cure it

The scenario is usually like this:
all graphics other than mouse cursor freezes and TTY canging does not work, mouse cursor does not leave a "trail", but can't interact with anything on the screen.
Keyboard does not change the led when trying to toggle numlock
Everything else seems to work like before, graphical applications do not crash, they still continue normally playing audio if they were before the freeze.
Nothing seems unusual when observed through htop or other tools through SSH.
One of some of the graphical applications' threads stay in D state for a few seconds before exiting if killed
X stays for several to tens of seconds in Z state with one thread in D state before exiting if killed


if I try to startx again it just hangs doing nothing.
if X (from this attempt) is killed, one of its threads goes to D state like before but takes several minutes to die.

this can rarely be saved with
Code:
rmmod -f nouveau && modprobe nouveau

usually rmmod stays in D state forever or gets killed but it has worked maybe three times so far
(without -f it just says nouveau is in use but it does not tell what is using it)

when shut down it stalls every time and I have to pull the plug to restart.

I put some related logs and other files here: http://54.213.154.174:777/nouveau/?C=M
Code:
uname -a
Linux Fern 4.0.9-gentoo-gnu #6 SMP PREEMPT Wed Apr 13 23:26:15 EEST 2016 x86_64 AMD FX(tm)-8320 Eight-Core Processor AuthenticAMD GNU/Linux


Just before making this post, I got a different kind of hang, one I could switch TTYs in. I killed startx with SIGINT, after waiting for several seconds, it said 'X server refuses to die'. I killed X and tried to startx again, which very slowly printed the usual lines, both monitors started displaying a blinking underscore cursor at top left.
Changing TTY the screen appeared frozen (the cursor staying there but without blinking), switching back resulted in it blinking like before.
SSH in and did this:
Code:
export DISPLAY=:0
xrandr --output VGA-1 --off --output HDMI-1 --mode 1920x1080

To my surprise, it somehow worked, the output to VGA monitor dropped and stayed off while the HDMI monitor displayed a "1920x1080 / 60p" box (monitor's builtin message). the same underscore cursor top left stayed there.
With different resolutions the monitor still said 1920x1080.
I have no idea what happened next, SSH connection froze and I couldn't SSH in any more. The screen scrolled messages so fast I could not read them. Music from MPD was still playing but the machine did not respond to any inputs, the WLAN network it hosts shut down and both HTTP and SSH were unreachable through internet.
Two pictures of the fast scrolling screen are at the logs directory.

Please tell me if I didn't provide something that would be of help.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum