Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ca-certificates work only after reinstallation of openssl
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
mv
Watchman
Watchman


Joined: 20 Apr 2005
Posts: 6276

PostPosted: Sun Apr 17, 2016 4:08 pm    Post subject: ca-certificates work only after reinstallation of openssl Reply with quote

It happens sometimes (not often enough that I was able to track the cause yet - perhaps with every upgrade of app-misc/ca-certificates) that wget (and probably also other programs) is not able to find some "standard" certificates it should have.

When comparing with a "working" system, I realize that a lot of symlinks are missing: Most of the type "hexnumber.0 -> somename.pam" are absent.

When this happens, reinstalling app-misc/ca-certificates[cacert] does not solve the problem. However, reinstalling dev-libs/openssl and then ca-certificates creates the necessary symlinks. Is this a known inconvenience or a bug in one of these two packages? The first time I observed the issue was when c_rehash was split off as a separate package, but this might be accidental.
Back to top
View user's profile Send private message
Schnulli
Guru
Guru


Joined: 25 Jun 2010
Posts: 320
Location: Bremen DE

PostPosted: Wed Aug 24, 2016 12:00 am    Post subject: Reply with quote

hi

pam???
i think so, allways the same old problems ;)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum