Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Who not cleaning up on logout?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
Target
Apprentice
Apprentice


Joined: 25 Apr 2002
Posts: 199

PostPosted: Thu Apr 25, 2002 8:55 am    Post subject: Who not cleaning up on logout? Reply with quote

Now here's an odd one, and I haven't got a clue why it's doing this... Whenever someone logs in, they show up on a "who", but for some reason when they log out, they aren't removed from it.

I've literally got 5 pages of who entries dating back to the last time this machine was booted. I haven't got a clue why it's doing this.
Is anyone else experiencing something similar?
Back to top
View user's profile Send private message
ozric100
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2002
Posts: 136

PostPosted: Thu Apr 25, 2002 1:48 pm    Post subject: Reply with quote

Same problem here. I have not had time to look into it. Any fixes out there.
Back to top
View user's profile Send private message
Sylhouette
n00b
n00b


Joined: 18 Apr 2002
Posts: 70
Location: Beverwijk , Holland

PostPosted: Thu Apr 25, 2002 7:29 pm    Post subject: Reply with quote

There are 2 user logged in at the moment

# who
#

It is showing nobody at all

???
Back to top
View user's profile Send private message
pof
n00b
n00b


Joined: 23 Apr 2002
Posts: 13

PostPosted: Fri Apr 26, 2002 11:08 am    Post subject: Update baselayout Reply with quote

This was answered here.
Back to top
View user's profile Send private message
Target
Apprentice
Apprentice


Joined: 25 Apr 2002
Posts: 199

PostPosted: Fri Apr 26, 2002 7:06 pm    Post subject: Reply with quote

Excellent, thanks.

Since these boards are easily searched, I'll just paste the solution for future reference:

rm -rf /var/run/utmpx && reboot
Also make sure that /etc/init.d/bootmisc is the latest version.
Back to top
View user's profile Send private message
Zack
n00b
n00b


Joined: 13 Apr 2002
Posts: 3

PostPosted: Fri Apr 26, 2002 7:21 pm    Post subject: Reply with quote

I followed all the steps in the above listed fix, yet who still shows no local users. Users logged in via ssh show up properly however. Any more suggestions?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum