Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xrandr ignoring 2nd GPU output [Nouveau]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
GassedUpOldMan
n00b
n00b


Joined: 13 Apr 2016
Posts: 2

PostPosted: Wed Apr 13, 2016 4:17 pm    Post subject: Xrandr ignoring 2nd GPU output [Nouveau] Reply with quote

I have three monitors - Two connected to my primary GPU, and a third connected to a secondary GPU.
When I setup X, I use arandr to change the positions of my monitors. However, monitor 3 is not a possible output to select.
I am using the Nouveau drivers with
USE="deblob"
and
VIDEO_CARDS="nouveau"

I do not use an xorg.conf.

Here is the output of xrandr:
Code:

Screen 0: minimum 320 x 200, current 2446 x 1920, maximum 8192 x 8192
DVI-I-1 connected 1080x1920+0+0 left (normal left inverted right x axis y axis)
   1920x1080     60.00*+
   1600x1200     60.00 
   1680x1050     59.88 
   1280x1024     60.02 
   1440x900      59.90 
   1280x960      60.00 
   1280x720      60.00 
   1024x768      60.00 
   800x600       60.32 
   640x480       60.00 
   720x400       70.08 
VGA-1 connected primary 1366x768+1080+1152 (normal left inverted right x axis y
   1366x768      59.79*+
   1360x768      60.02 
   1024x768      75.08    72.00    70.07    60.00 
   832x624       74.55 
   800x600       72.19    75.00    60.32    56.25 
   640x480       75.00    72.81    66.67    60.00


However, xrandr knows I have two GPUs, as here is the output of `xrandr --listproviders`
Code:

Providers: number : 2
Provider 0: id: 0xb6 cap: 0x7, Source Output, Sink Output, Source Offload crtcs: 2 outputs: 2 associated providers: 0 name:nouveau
Provider 1: id: 0x64 cap: 0x7, Source Output, Sink Output, Source Offload crtcs: 2 outputs: 3 associated providers: 0 name:nouveau


lspci:
Code:

01:01.0 VGA compatible controller: ASPEED Technology, Inc. ASPEED Graphics Family (rev 10)
02:00.0 VGA compatible controller: NVIDIA Corporation G98 [GeForce 8400 GS Rev. 2] (rev a1)
05:00.0 VGA compatible controller: NVIDIA Corporation GT218 [GeForce 8400 GS Rev. 3] (rev a2)


I do have x11-libs/libXinerama and x11-proto/xineramaproto installed, as well as x11-apps/xrandr and x11-libs/libXrandr. I see no reason why this setup shouldn't work.
If anyone would be willing to help me that would be great. I can provide any more logs if needed.

EDIT:
Here is Xorg.0.log, which seems to show the other monitor being detected.
Hosted at ghostbin, as pastebin does not work from within Dillo.
https://ghostbin.com/paste/hzymv
Back to top
View user's profile Send private message
GassedUpOldMan
n00b
n00b


Joined: 13 Apr 2016
Posts: 2

PostPosted: Tue Apr 19, 2016 5:57 pm    Post subject: Reply with quote

...bump
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum