Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[annulé] libc-2.21.so segfault que sur certains site web
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
T0MuX
n00b
n00b


Joined: 12 Apr 2016
Posts: 64

PostPosted: Tue Apr 12, 2016 8:14 pm    Post subject: [annulé] libc-2.21.so segfault que sur certains site web Reply with quote

Bonjour à tous !

Je rencontre un problème très bizarre mais surtout très désagreable.

Cela fait 2 semaines que j'installe Gentoo, oui ça prend du temps lol. J'ai quasiment terminé, j'en suis au fignolage, résoudre les ptits trucs (résolution maxi non persistente, options manquantes dans le clic droit etc...). Sauf que dans les "petits trucs" restant, il y en a un qui prend de très grande proportion puisque ça fait une semaine que je suis dessus et que je ne trouve RIEN à ce sujet. J'explique :

- Peut importe le navigateur que j'utilise, certains sites web ne vont pas au bout du chargement. Ils s'arrêtent en plein milieu et j'ai droit à un magnifique
Code:
Oups - https://duckduckgo.com/

Quelque chose a mal tournél avec « https://duckduckgo.com/ ».


- Quand ce problème survient, je retrouve cette information avec dmesg :
Code:
[  134.058281] WebKitWebProces[3772]: segfault at 7fe70c138000 ip 00007fe7247ccac9 sp 00007ffcccc8cc88 error 7 in libc-2.21.so[7fe72473c000+192000]
[  504.466264] WebKitWebProces[4084]: segfault at 7fcc12e60000 ip 00007fcc74866ac9 sp 00007fffc56d9b48 error 7 in libc-2.21.so[7fcc747d6000+192000]


- Visiblement cela ne se produit qu'avec des navigateurs utilisants WebKit. Car j'ai testé avec Aurora (Firefox Dev), et je n'ai pas du tout ce problème.

On dirait que certains éléments des pages en questions, solicite la librairie libc mais que celle ci est éronnée. Ou peut être que ça vient de Webkit... Seulement, je viens de repasser une journée entière à compiler WebKit et rencontre toujours le problème. J'ai également réinstallé glibc (qui visiblement contient cette librairie), cela n'a pas résolu.

Je viens donc crié au secour sur le forum Gentoo, et remercie d'avance quiconque qui m'aiderai à avancer sur ce problème.

à bientôt !
_________________
T0MuX
" Le seul autoradio véritable est celui qui ne se règle que du pied droit. "


Last edited by T0MuX on Sun May 08, 2016 10:10 am; edited 1 time in total
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8070
Location: ~Brussels - Belgique

PostPosted: Tue Apr 12, 2016 8:35 pm    Post subject: Reply with quote

Bonjour,

Pourrais-tu nous donner le résultat de
Code:
emerge --info
? Merci d'avance!
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Syl20
Guru
Guru


Joined: 04 Aug 2005
Posts: 564
Location: France

PostPosted: Thu Apr 14, 2016 8:38 am    Post subject: Re: dmesg=libc-2.21.so segfault que sur certains site web Reply with quote

T0MuX wrote:
J'ai également réinstallé glibc (qui visiblement contient cette librairie), cela n'a pas résolu.

Glibc a été mis à jour cette semaine : https://packages.gentoo.org/packages/sys-libs/glibc
Si tu es toujours en version 2.21, essaie de mettre à jour ton système, puis de recompiler WebKit.

Ensuite, beaucoup de programmes appellent les bibliothèques libc. Si tu ne veux pas trop te prendre la tête à tout relancer, reboote ta machine.
Back to top
View user's profile Send private message
T0MuX
n00b
n00b


Joined: 12 Apr 2016
Posts: 64

PostPosted: Tue Apr 26, 2016 6:28 am    Post subject: Reply with quote

Salut, je vous remercie pour vos réponses.

Depuis, j'ai continué à fouiller sur l'IRC, quelqu'un m'a fait mettre à jour mon portage et j'ai pu installer la v2.22... qui n'a pas du tout résolu le problème. J'ai jamais vu ça.

Comme c'était le 2nd PC, que ma femme est censée utiliser et que ça commençait vraiment à me prendre la tête j'ai tout viré et j'ai mis Manjaro + JWM, ça marche impec et je monopolise plus 2 PC lol.

Par contre, j'ai installé Gentoo + BSPWM sur mon PC principal, une petite merveille ! Et je rencontre un tas de petits problèmes dont certains donneront surement naissance à quelques topic :)
_________________
T0MuX
" Le seul autoradio véritable est celui qui ne se règle que du pied droit. "
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum