Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Why does upgrade to plasma 5 pull wayland? And ruby(?)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
as.gentoo
Guru
Guru


Joined: 07 Aug 2004
Posts: 318

PostPosted: Mon Apr 11, 2016 6:28 pm    Post subject: Why does upgrade to plasma 5 pull wayland? And ruby(?) Reply with quote

Hello,

I'm trying to do the update to plasma 5. I followed the guide from https://wiki.gentoo.org/wiki/KDE/Plasma_5_upgrade until "Apply the changes".

Does plasma 5 really need wayland(-support) by mesa? I've set USE "-wayland" in the make.conf but portage still demands that use flag.
Code:
#> emerge --ask --changed-use --newrepo --deep world
The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by kde-plasma/kwin-5.6.2::gentoo
# required by kde-plasma/plasma-desktop-5.6.2::gentoo
# required by kde-plasma/plasma-meta-5.6.2::gentoo
# required by kde-apps/kdebase-meta-15.12.3::gentoo
# required by @selected
# required by @world (argument)
>=media-libs/mesa-11.2.0 wayland
Explicitly setting "-wayland" for kwin doesn't have any influence.

As well, there is something going on with ruby. I've set "-ruby" in the make.conf. Whatsoever I get (same command as above) this:
Code:
[...]
# required by dev-ruby/net-telnet-0.1.1-r1::gentoo[ruby_targets_ruby23,-test]
# required by dev-lang/ruby-2.3.0::gentoo
# required by dev-ruby/racc-1.4.14::gentoo[ruby_targets_ruby23]
# required by dev-ruby/rdoc-4.2.2::gentoo[ruby_targets_ruby20]
# required by dev-lang/ruby-2.1.10::gentoo[rdoc]
# required by dev-ruby/power_assert-0.2.7::gentoo[ruby_targets_ruby21]
# required by dev-ruby/test-unit-3.1.8::gentoo[ruby_targets_ruby20]
>=virtual/rubygems-11 ruby_targets_ruby23
# required by dev-lang/ruby-2.3.0::gentoo
# required by dev-ruby/racc-1.4.14::gentoo[ruby_targets_ruby23]
# required by dev-ruby/rdoc-4.2.2::gentoo[ruby_targets_ruby20]
# required by dev-lang/ruby-2.1.10::gentoo[rdoc]
# required by dev-ruby/power_assert-0.2.7::gentoo[ruby_targets_ruby21]
>=dev-ruby/test-unit-3.1.8 ruby_targets_ruby23
# required by dev-lang/ruby-2.3.0::gentoo
# required by dev-ruby/racc-1.4.14::gentoo[ruby_targets_ruby23]
# required by dev-ruby/rdoc-4.2.2::gentoo[ruby_targets_ruby20]
# required by dev-lang/ruby-2.1.10::gentoo[rdoc]
# required by dev-ruby/power_assert-0.2.7::gentoo[ruby_targets_ruby21]
# required by dev-ruby/test-unit-3.1.8::gentoo[ruby_targets_ruby20]
>=dev-ruby/minitest-5.8.4 ruby_targets_ruby23
# required by media-libs/mesa-11.2.0::gentoo[wayland]
# required by kde-plasma/kwayland-5.6.2::gentoo
# required by kde-plasma/libkscreen-5.6.2::gentoo
# required by kde-plasma/plasma-workspace-5.6.2::gentoo
# required by kde-plasma/plasma-desktop-5.6.2::gentoo
# required by kde-plasma/plasma-meta-5.6.2::gentoo
# required by kde-apps/kdebase-meta-15.12.3::gentoo
# required by @selected
# required by @world (argument)
>=dev-libs/wayland-1.10.0-r1 abi_x86_32
[...]
Is that related to the wayland USE flag?

Am I doing something wrong?
Code:
# just in case
$> eselect profile list | grep '*'
  [8]   default/linux/amd64/13.0/desktop/plasma *
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1692

PostPosted: Tue Apr 12, 2016 12:02 am    Post subject: Reply with quote

well, for the ruby; I probably have a reason why (even though you didn't show the full output to be sure); is because qtwebkit-5 has a unconditional build time dependency on it (does not use it at run time, and have no use of it after qtwebkit been compiled, unless you turn on those bindings).
Back to top
View user's profile Send private message
as.gentoo
Guru
Guru


Joined: 07 Aug 2004
Posts: 318

PostPosted: Tue Apr 12, 2016 7:22 am    Post subject: Reply with quote

ct85711 wrote:
well, for the ruby; I probably have a reason why (even though you didn't show the full output to be sure); is because qtwebkit-5 has a unconditional build time dependency on it (does not use it at run time, and have no use of it after qtwebkit been compiled, unless you turn on those bindings).
So this means that portage needs ruby in order to build qtwebkit and it can be unmerged after that? And then it will be needed each time there is an update for qtwebkit, right?

Here is the complete output:
Code:
These are the packages that would be merged, in order:

Calculating dependencies           ... done!                   
[ebuild  N     ] dev-libs/libyaml-0.1.6::gentoo  USE="-doc -examples -static-libs {-test}" 492 KiB
[ebuild  N     ] media-libs/libuninameslist-20091231::gentoo  556 KiB
[ebuild  N     ] dev-db/lmdb-0.9.18:0/0.9.18::gentoo  USE="-static-libs" 136 KiB
[ebuild  N     ] net-wireless/wireless-regdb-20160208::gentoo  16 KiB
[ebuild  N     ] sys-libs/libunwind-1.1:7::gentoo  USE="-debug -debug-frame -libatomic lzma -static-libs" 1,073 KiB
[ebuild  N     ] dev-util/google-perftools-2.0-r2:0/4::gentoo  USE="debug -largepages -minimal -static-libs {-test}" 1,232 KiB
[ebuild   R    ] sys-libs/libseccomp-2.3.0::gentoo  USE="-static-libs*" ABI_X86="-32 (64) (-x32)" 0 KiB
[ebuild  N     ] dev-libs/leveldb-1.18-r1::gentoo  USE="snappy -static-libs tcmalloc" 205 KiB
[ebuild  N     ] dev-util/ragel-6.9::gentoo  USE="-vim-syntax" 1,199 KiB
[ebuild  N     ] net-misc/dhcp-4.3.4::gentoo  USE="client -ipv6 -ldap -libressl (-selinux) server ssl -vim-syntax" 9,085 KiB
[ebuild   R    ] dev-qt/qtcore-4.8.7-r1:4::gentoo  USE="(-aqua) -debug exceptions glib iconv icu* -libressl pch qt3support ssl" ABI_X86="-32 (64) (-x32)" 235,426 KiB
[ebuild  N     ] app-eselect/eselect-ruby-20151229::gentoo  2 KiB
[ebuild  N     ] net-misc/socat-1.7.3.1::gentoo  USE="-ipv6 readline ssl tcpd" 478 KiB
[ebuild  N     ] dev-lang/swig-3.0.8::gentoo  USE="-ccache -doc pcre" 7,752 KiB
[ebuild  N     ] dev-qt/qtconcurrent-5.5.1:5::gentoo  USE="-debug {-test}" 0 KiB
[ebuild  N     ] dev-qt/qtpaths-5.5.1-r1:5::gentoo  USE="-debug {-test}" 0 KiB
[ebuild   R    ] dev-qt/qtlockedfile-2.4.1_p20150629::gentoo  USE="-doc qt4* qt5" 0 KiB
[ebuild  N     ] dev-libs/newt-0.52.18::gentoo  USE="gpm nls -tcl" PYTHON_TARGETS="python2_7" 177 KiB
[ebuild  N     ] dev-libs/wayland-1.10.0-r1::gentoo  USE="-doc -static-libs" ABI_X86="32 (64) (-x32)" 361 KiB
[ebuild  N     ] dev-libs/libpwquality-1.3.0::gentoo  USE="pam -python -static-libs" PYTHON_TARGETS="python2_7 -python3_3 python3_4" 414 KiB
[ebuild  N     ] net-libs/libndp-1.5::gentoo  ABI_X86="-32 (64) (-x32)" 330 KiB
[ebuild  N     ] dev-python/m2crypto-0.24.0::gentoo  USE="-libressl" PYTHON_TARGETS="python2_7" 181 KiB
[ebuild  N     ] net-wireless/crda-3.18-r1::gentoo  USE="-gcrypt -libressl" 61 KiB
[ebuild  N     ] dev-lang/ruby-2.3.0:2.3::gentoo  USE="berkdb -debug -doc -examples gdbm -ipv6 -jemalloc -libressl ncurses rdoc readline -rubytests -socks5 ssl -xemacs" 11,032 KiB
[ebuild  N     ] dev-lang/ruby-2.0.0_p648:2.0::gentoo  USE="berkdb -debug -doc -examples gdbm -ipv6 ncurses rdoc readline -rubytests -socks5 ssl -xemacs" CPU_FLAGS_X86="sse2" 8,113 KiB
[ebuild  N     ] dev-lang/ruby-2.1.10:2.1::gentoo  USE="berkdb -debug -doc -examples gdbm -ipv6 ncurses rdoc readline -rubytests -socks5 ssl -xemacs" 9,146 KiB
[ebuild  N     ] dev-ruby/rubygems-2.6.2::gentoo  USE="-server {-test}" RUBY_TARGETS="ruby20 ruby21 -ruby22 ruby23" 468 KiB
[ebuild  N     ] virtual/rubygems-11::gentoo  RUBY_TARGETS="(-rbx) (-ruby19) ruby20 ruby21 -ruby22 ruby23" 0 KiB
[ebuild  N     ] dev-ruby/minitest-5.8.4:5::gentoo  USE="-doc {-test}" RUBY_TARGETS="ruby20 ruby21 -ruby22 ruby23" 71 KiB
[ebuild  N     ] dev-ruby/rake-11.1.2::gentoo  USE="-doc {-test}" RUBY_TARGETS="ruby20 ruby21 -ruby22 ruby23" 126 KiB
[ebuild  N     ] dev-ruby/json-1.8.3::gentoo  USE="-doc {-test}" RUBY_TARGETS="ruby20 ruby21 -ruby22 ruby23" 149 KiB
[ebuild  N     ] dev-ruby/net-telnet-0.1.1-r1:1::gentoo  USE="-doc {-test}" RUBY_TARGETS="ruby20 ruby21 -ruby22 ruby23" 13 KiB
[ebuild  N     ] dev-ruby/did_you_mean-1.0.0:1::gentoo  USE="{-test}" RUBY_TARGETS="ruby23" 170 KiB
[ebuild  N     ] dev-ruby/power_assert-0.2.7::gentoo  USE="-doc {-test}" RUBY_TARGETS="ruby20 ruby21 -ruby22 ruby23" 13 KiB
[ebuild  N     ] dev-ruby/test-unit-3.1.8:2::gentoo  USE="-doc {-test}" RUBY_TARGETS="ruby20 ruby21 -ruby22 ruby23" 122 KiB
[ebuild  N     ] dev-ruby/racc-1.4.14::gentoo  USE="-doc {-test}" RUBY_TARGETS="ruby20 ruby21 -ruby22 ruby23" 114 KiB
[ebuild  N     ] dev-ruby/rdoc-4.2.2::gentoo  USE="-doc {-test}" RUBY_TARGETS="ruby20 ruby21 -ruby22 ruby23" 722 KiB
[ebuild   R    ] media-libs/mesa-11.2.0::gentoo  USE="-bindist classic d3d9 -debug dri3 egl gallium gbm -gles1 gles2 llvm nptl opencl openmax osmesa -pax_kernel -pic (-selinux) udev vaapi vdpau wayland* xa xvmc" ABI_X86="32 (64) (-x32)" VIDEO_CARDS="(-freedreno) -i915 -i965 -ilo -intel -nouveau -r100 -r200 -r300 r600 radeon -radeonsi -vmware" 0 KiB
[ebuild  N     ] dev-libs/libinput-1.2.2:0/10::gentoo  USE="{-test}" INPUT_DEVICES="-wacom" 838 KiB
[ebuild  N     ] kde-frameworks/kf-env-3:5::gentoo  0 KiB
[ebuild  N     ] dev-qt/qdbus-5.5.1-r1:5::gentoo  USE="-debug {-test}" 0 KiB
[ebuild  N     ] sys-auth/polkit-pkla-compat-0.1::gentoo  285 KiB
[ebuild  NS    ] dev-qt/qtsvg-5.5.1-r1:5::gentoo [4.8.7:4::gentoo] USE="-debug {-test}" 1,761 KiB
[ebuild  NS    ] dev-qt/qtscript-5.5.1-r1:5::gentoo [4.8.7:4::gentoo] USE="-debug jit scripttools {-test}" 2,544 KiB
[ebuild  N     ] kde-frameworks/extra-cmake-modules-5.21.0:5/5.21::gentoo  USE="-doc {-test}" 279 KiB
[ebuild  N     ] dev-qt/linguist-tools-5.5.1-r1:5::gentoo  USE="-debug qml {-test}" 0 KiB
[ebuild  N     ] dev-qt/qtgraphicaleffects-5.5.1-r1:5::gentoo  USE="-debug {-test}" 13,994 KiB
[ebuild   R    ] app-crypt/qca-2.1.1:2::gentoo  USE="-botan -debug -doc -examples -gcrypt -gpg -libressl -logger -nss -openssl pkcs11 qt4 qt5* -sasl -softstore {-test}" 673 KiB
[ebuild  NS    ] dev-qt/qtwebkit-5.5.1-r1:5::gentoo [4.8.7:4::gentoo] USE="-debug -geolocation -gstreamer -gstreamer010 jit -multimedia opengl -orientation -printsupport qml {-test} -webchannel webp" 32,706 KiB
[ebuild  N     ] dev-qt/qtquickcontrols-5.5.1-r1:5::gentoo  USE="-debug {-test} widgets" 5,837 KiB
[ebuild  N     ] kde-plasma/kwallet-pam-5.6.2-r1:5::gentoo  USE="-debug oldwallet" 18 KiB
[ebuild  N     ] x11-misc/sddm-0.13.0-r3::gentoo  USE="consolekit pam -systemd" 3,779 KiB
[ebuild  N     ] kde-plasma/plasma-workspace-wallpapers-5.6.2:5::gentoo  44,841 KiB
[ebuild  N     ] media-fonts/noto-20160305::gentoo  USE="X" 482,461 KiB
[ebuild  N     ] media-gfx/fontforge-20150824::gentoo  USE="X cairo -gif -gtk jpeg png python readline svg -tiff -truetype-debugger unicode" PYTHON_SINGLE_TARGET="python2_7 -python3_3 -python3_4" PYTHON_TARGETS="python2_7 -python3_3 python3_4" 20,310 KiB
[ebuild  N     ] kde-plasma/oxygen-fonts-5.4.3:5::gentoo  USE="X" 158 KiB
[ebuild  N     ] kde-frameworks/breeze-icons-5.21.0:5/5.21::gentoo  USE="{-test}" 1,408 KiB
[ebuild  NS    ] kde-apps/libkexiv2-15.12.3:5::gentoo [15.08.3:4/15.08::gentoo] USE="-debug xmp" 64 KiB
[ebuild  NS    ] kde-apps/libkdcraw-15.12.3:5::gentoo [15.08.3:4/15.08::gentoo] USE="-debug" 42 KiB
[ebuild  N     ] net-wireless/wpa_supplicant-2.5-r1::gentoo  USE="-ap dbus -eap-sim -fasteap gnutls hs2-0 -libressl -p2p (-ps3) -qt4 qt5 readline (-selinux) -smartcard ssl -tdls -uncommon-eap-types (-wimax) -wps" 2,547 KiB
[ebuild   R    ] app-text/poppler-0.41.0:0/58::gentoo  USE="cairo -cjk -curl cxx -debug -doc introspection jpeg -jpeg2k lcms png qt4 qt5* -tiff utils" 0 KiB
[ebuild   R    ] dev-qt/qtsingleapplication-2.6.1_p20150629::gentoo  USE="X -doc qt4* qt5" 0 KiB
[ebuild   R    ] media-sound/pulseaudio-8.0::gentoo  USE="X alsa alsa-plugin asyncns -bluetooth caps dbus -doc equalizer gdbm glib -gnome gtk -ipv6 jack -libressl -libsamplerate -lirc -native-headset (-neon) -ofono-headset orc (-oss) qt4* -realtime (-selinux) -sox ssl (-system-wide) -systemd tcpd {-test} udev webrtc-aec -xen -zeroconf" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild   R    ] app-misc/strigi-0.7.8-r1::gentoo  USE="-clucene dbus -debug exif (-fam) ffmpeg inotify -libav (-log) qt4* {-test}" 0 KiB
[ebuild   R    ] dev-qt/qtmultimedia-5.5.1-r2:5::gentoo  USE="alsa -debug -gles2 -gstreamer -gstreamer010 -openal pulseaudio qml* {-test} widgets*" 0 KiB
[ebuild   R    ] kde-apps/kde4-l10n-15.12.3-r1:4/15.12::gentoo  USE="(-aqua) handbook minimal*" LINGUAS="-ar -bg -bs -ca -ca@valencia -cs -da de -el -en_GB -eo -es -et -eu -fa -fi -fr -ga -gl -he -hi -hr -hu -ia -id -is -it -ja -kk -km -ko -lt -lv -mr -nb -nds -nl -nn -pa -pl -pt -pt_BR -ro -ru -sk -sl -sr -sv -tr -ug -uk -wa -zh_CN -zh_TW" 0 KiB
[ebuild  N     ] kde-frameworks/kcoreaddons-5.21.0:5/5.21::gentoo  USE="-debug -doc (-fam) nls {-test}" 306 KiB
[ebuild  N     ] kde-frameworks/ki18n-5.21.0:5/5.21::gentoo  USE="-debug -doc {-test}" 590 KiB
[ebuild  N     ] kde-frameworks/kconfig-5.21.0:5/5.21::gentoo  USE="-debug -doc nls {-test}" 220 KiB
[ebuild  N     ] kde-frameworks/kwidgetsaddons-5.21.0:5/5.21::gentoo  USE="-debug -doc nls {-test}" 2,083 KiB
[ebuild  N     ] kde-frameworks/kwindowsystem-5.21.0:5/5.21::gentoo  USE="X -debug -doc nls {-test}" 160 KiB
[ebuild  N     ] kde-frameworks/kdbusaddons-5.21.0:5/5.21::gentoo  USE="X -debug -doc nls {-test}" 34 KiB
[ebuild  N     ] kde-frameworks/kcrash-5.21.0:5/5.21::gentoo  USE="X -debug -doc nls {-test}" 20 KiB
[ebuild  N     ] kde-frameworks/kcodecs-5.21.0:5/5.21::gentoo  USE="-debug -doc nls {-test}" 213 KiB
[ebuild  N     ] kde-frameworks/kcompletion-5.21.0:5/5.21::gentoo  USE="-debug -doc nls {-test}" 114 KiB
[ebuild  N     ] kde-frameworks/kitemviews-5.21.0:5/5.21::gentoo  USE="-debug -doc nls {-test}" 73 KiB
[ebuild  N     ] kde-frameworks/kguiaddons-5.21.0:5/5.21::gentoo  USE="-debug -doc {-test}" 39 KiB
[ebuild  N     ] kde-frameworks/knotifications-5.21.0:5/5.21::gentoo  USE="X dbus -debug -doc nls (-speech)" 94 KiB
[ebuild  N     ] kde-frameworks/kglobalaccel-5.21.0:5/5.21::gentoo  USE="-debug -doc nls {-test}" 80 KiB
[ebuild  N     ] kde-frameworks/karchive-5.21.0:5/5.21::gentoo  USE="bzip2 -debug -doc lzma {-test}" 107 KiB
[ebuild  N     ] kde-frameworks/kdoctools-5.21.0:5/5.21::gentoo  USE="-debug -doc {-test}" 399 KiB
[ebuild  N     ] kde-frameworks/kservice-5.21.0:5/5.21::gentoo  USE="-debug -doc man {-test}" 263 KiB
[ebuild  N     ] kde-frameworks/kjobwidgets-5.21.0:5/5.21::gentoo  USE="X -debug -doc nls {-test}" 87 KiB
[ebuild  N     ] kde-frameworks/solid-5.21.0:5/5.21::gentoo  USE="-debug -doc nls {-test}" 262 KiB
[ebuild  N     ] kde-frameworks/kpackage-5.21.0:5/5.21::gentoo  USE="-debug -doc -man {-test}" 106 KiB
[ebuild  N     ] kde-plasma/kwayland-5.6.2:5::gentoo  USE="-debug {-test}" 165 KiB
[ebuild  N     ] kde-frameworks/sonnet-5.21.0:5/5.21::gentoo  USE="aspell -debug -doc -hunspell nls {-test}" 276 KiB
[ebuild  N     ] kde-frameworks/kidletime-5.21.0:5/5.21::gentoo  USE="-debug -doc" 26 KiB
[ebuild  N     ] kde-frameworks/kpty-5.21.0:5/5.21::gentoo  USE="-debug -doc {-test}" 56 KiB
[ebuild  N     ] kde-plasma/libkscreen-5.6.2:5/7::gentoo  USE="X -debug {-test}" 82 KiB
[ebuild  N     ] kde-plasma/kdecoration-5.6.2:5::gentoo  USE="-debug {-test}" 35 KiB
[ebuild  N     ] kde-frameworks/kjs-5.21.0:5/5.21::gentoo  USE="-debug -doc {-test}" 284 KiB
[ebuild  N     ] kde-frameworks/attica-5.21.0:5/5.21::gentoo  USE="-debug -doc {-test}" 59 KiB
[ebuild  N     ] kde-frameworks/kunitconversion-5.21.0:5/5.21::gentoo  USE="-debug -doc {-test}" 604 KiB
[ebuild  N     ] kde-frameworks/kemoticons-5.21.0:5/5.21::gentoo  USE="-debug -doc {-test}" 212 KiB
[ebuild  N     ] kde-frameworks/kitemmodels-5.21.0:5/5.21::gentoo  USE="-debug -doc {-test}" 378 KiB
[ebuild  N     ] kde-frameworks/kdesu-5.21.0:5/5.21::gentoo  USE="X -debug -doc" 44 KiB
[ebuild  N     ] kde-frameworks/threadweaver-5.21.0:5/5.21::gentoo  USE="-debug -doc {-test}" 1,376 KiB
[ebuild  N     ] kde-plasma/kwayland-integration-5.6.2:5::gentoo  USE="-debug" 17 KiB
[ebuild  N     ] kde-frameworks/kdesignerplugin-5.21.0:5/5.21::gentoo  USE="-debug -designer -doc nls -webkit" 86 KiB
[ebuild  N     ] kde-frameworks/kjsembed-5.21.0:5/5.21::gentoo  USE="-debug -doc" 162 KiB
[ebuild  N     ] kde-frameworks/kdnssd-5.21.0:5/5.21::gentoo  USE="-debug -doc nls {-test} -zeroconf" 56 KiB
[ebuild  N     ] kde-frameworks/kfilemetadata-5.21.0:5/5.21::gentoo  USE="-debug -doc -epub exif ffmpeg -libav pdf -taglib {-test}" 124 KiB
[ebuild  N     ] kde-frameworks/kpeople-5.21.0:5/5.21::gentoo  USE="-debug -doc {-test}" 57 KiB
[ebuild  N     ] net-misc/networkmanager-1.0.12::gentoo  USE="-bluetooth -connection-sharing consolekit dhclient -dhcpcd gnutls introspection -modemmanager ncurses -nss -ppp -resolvconf (-selinux) -systemd -teamd {-test} -vala wext wifi -zeroconf" ABI_X86="-32 (64) (-x32)" 3,410 KiB
[ebuild  N     ] kde-frameworks/networkmanager-qt-5.21.0:5/5.21::gentoo  USE="-debug -doc -teamd {-test}" 155 KiB
[ebuild  N     ] kde-frameworks/kauth-5.21.0:5/5.21::gentoo  USE="-debug -doc nls (policykit) {-test}" 81 KiB
[ebuild  N     ] kde-frameworks/kconfigwidgets-5.21.0:5/5.21::gentoo  USE="-debug -doc man {-test}" 351 KiB
[ebuild  N     ] kde-frameworks/kiconthemes-5.21.0:5/5.21::gentoo  USE="-debug -doc {-test}" 192 KiB
[ebuild  N     ] kde-frameworks/ktextwidgets-5.21.0:5/5.21::gentoo  USE="-debug -doc (-speech) {-test}" 300 KiB
[ebuild  N     ] kde-frameworks/kxmlgui-5.21.0:5/5.21::gentoo  USE="-attica -debug -doc {-test}" 848 KiB
[ebuild  N     ] kde-frameworks/kwallet-5.21.0:5/5.21::gentoo  USE="-debug -doc -gpg man {-test}" 282 KiB
[ebuild  N     ] kde-frameworks/kbookmarks-5.21.0:5/5.21::gentoo  USE="-debug -doc nls {-test}" 113 KiB
[ebuild  N     ] kde-plasma/ksshaskpass-5.6.2:5::gentoo  USE="-debug" 25 KiB
[ebuild  NS    ] kde-apps/libksane-15.12.3:5::gentoo [15.08.3:4/15.08::gentoo] USE="-debug" 80 KiB
[ebuild  N     ] kde-frameworks/kio-5.21.0:5/5.21::gentoo  USE="X acl -debug -doc handbook -kerberos kwallet {-test}" 2,828 KiB
[ebuild  N     ] kde-frameworks/kparts-5.21.0:5/5.21::gentoo  USE="-debug -doc {-test}" 151 KiB
[ebuild  N     ] kde-frameworks/kinit-5.21.0:5/5.21::gentoo  USE="caps -debug -doc man" 115 KiB
[ebuild  N     ] kde-frameworks/kded-5.21.0:5/5.21::gentoo  USE="-debug -doc man" 36 KiB
[ebuild  N     ] kde-frameworks/kdelibs4support-5.21.0:5/5.21::gentoo  USE="X -debug -doc {-test}" 3,153 KiB
[ebuild  N     ] kde-frameworks/khtml-5.21.0:5/5.21::gentoo  USE="X -debug -doc {-test}" 2,028 KiB
[ebuild  N     ] kde-frameworks/kdeclarative-5.21.0:5/5.21::gentoo  USE="-debug -doc" 164 KiB
[ebuild  N     ] kde-frameworks/kcmutils-5.21.0:5/5.21::gentoo  USE="-debug -doc {-test}" 230 KiB
[ebuild  N     ] kde-plasma/kde-cli-tools-5.6.2:5::gentoo  USE="X -debug handbook kdesu {-test}" 494 KiB
[ebuild  N     ] kde-frameworks/knewstuff-5.21.0:5/5.21::gentoo  USE="-debug -doc" 840 KiB
[ebuild  N     ] kde-frameworks/knotifyconfig-5.21.0:5/5.21::gentoo  USE="-debug -doc phonon" 82 KiB
[ebuild  N     ] kde-frameworks/frameworkintegration-5.21.0:5/5.21::gentoo  USE="X -debug -doc {-test}" 1,743 KiB
[ebuild  N     ] kde-frameworks/ktexteditor-5.21.0:5/5.21::gentoo  USE="-debug -doc -git {-test}" 2,808 KiB
[ebuild  N     ] kde-apps/kio-extras-15.12.3:5::gentoo  USE="-debug exif handbook -mtp -openexr phonon -samba sftp -slp {-test}" 261 KiB
[ebuild  N     ] kde-plasma/user-manager-5.6.2:5::gentoo  USE="-debug" 71 KiB
[ebuild  N     ] kde-plasma/sddm-kcm-5.6.2:5::gentoo  USE="-debug" 56 KiB
[ebuild  N     ] kde-plasma/kgamma-5.6.2:5::gentoo  USE="-debug handbook" 71 KiB
[ebuild  N     ] kde-frameworks/kross-5.21.0:5/5.21::gentoo  USE="-debug -doc {-test}" 132 KiB
[ebuild  N     ] kde-frameworks/kxmlrpcclient-5.21.0:5/5.21::gentoo  USE="-debug -doc {-test}" 28 KiB
[ebuild   R    ] media-video/avidemux-2.6.8:2.6::gentoo  USE="-debug nls opengl qt4* sdl vaapi vdpau xv" LINGUAS="-ca -cs de -el -es -fr -it -ja -pt_BR -ru -sr -sr@latin -tr" VIDEO_CARDS="-fglrx" 0 KiB
[ebuild   R    ] media-libs/avidemux-plugins-2.6.8:2.6::gentoo  USE="a52 -aac -aften alsa -amr -debug dts fontconfig -fribidi jack -lame libsamplerate opengl -oss pulseaudio qt4* truetype -twolame vdpau vorbis vpx -x264 xv -xvid" CPU_FLAGS_X86="mmx" PYTHON_TARGETS="python2_7" 0 KiB
[ebuild  N     ] kde-plasma/polkit-kde-agent-5.6.2:5::gentoo  USE="-debug" 50 KiB
[uninstall     ] sys-auth/polkit-kde-agent-0.99.1-r1:4::gentoo  USE="(-aqua) -debug -minimal" LINGUAS="-ar -bs -ca -ca@valencia -cs -da de -el -en_GB -eo -es -et -fi -fr -ga -gl -hr -hu -is -it -ja -kk -km -lt -mai -mr -ms -nb -nds -nl -pa -pl -pt -pt_BR -ro -ru -sk -sl -sr -sr@ijekavian -sr@ijekavianlatin -sr@latin -sv -th -tr -ug -uk -vi -zh_CN -zh_TW"
[blocks b      ] sys-auth/polkit-kde-agent:4[-minimal(-)] ("sys-auth/polkit-kde-agent:4[-minimal(-)]" is blocking kde-plasma/polkit-kde-agent-5.6.2)
[ebuild  N     ] kde-plasma/oxygen-5.6.2:5::gentoo  USE="-debug" 4,385 KiB
[uninstall     ] kde-base/kdebase-cursors-4.11.22:4/4.11::gentoo  USE="(-aqua)"
[blocks b      ] kde-base/kdebase-cursors:4 ("kde-base/kdebase-cursors:4" is blocking kde-plasma/oxygen-5.6.2)
[ebuild  N     ] kde-plasma/kscreen-5.6.2:5::gentoo  USE="-debug {-test}" 115 KiB
[uninstall     ] kde-misc/kscreen-1.0.71_p20150824:4::gentoo  USE="(-aqua) -debug {-test}" LINGUAS="-ast -bg -bs -ca -ca@valencia -cs -da de -el -en_GB -es -et -fi -fr -ga -gl -hu -it -ja -ko -lt -mr -nb -nds -nl -nn -pa -pl -pt -pt_BR -ro -ru -sk -sl -sv -tr -ug -uk -zh_CN -zh_TW"
[blocks b      ] kde-misc/kscreen ("kde-misc/kscreen" is blocking kde-plasma/kscreen-5.6.2)
[ebuild  N     ] kde-frameworks/baloo-5.21.0:5/5.21::gentoo  USE="-debug -doc {-test}" 180 KiB
[ebuild   R    ] kde-base/baloo-4.14.3:4/4.14::gentoo  USE="(-aqua) -debug minimal*" 143 KiB
[blocks b      ] kde-base/baloo:4[-minimal(-)] ("kde-base/baloo:4[-minimal(-)]" is blocking kde-frameworks/baloo-5.21.0)
[ebuild  N     ] kde-plasma/kscreenlocker-5.6.2:5::gentoo  USE="-debug pam {-test}" 102 KiB
[uninstall     ] kde-base/kdebase-pam-10::gentoo
[blocks b      ] kde-base/kdebase-pam:0 ("kde-base/kdebase-pam:0" is blocking kde-plasma/kscreenlocker-5.6.2)
[ebuild  N     ] kde-plasma/kwrited-5.6.2:5::gentoo  USE="-debug" 20 KiB
[uninstall     ] kde-base/kwrited-4.11.22:4/4.11::gentoo  USE="(-aqua) -debug"
[blocks b      ] kde-base/kwrited:4 ("kde-base/kwrited:4" is blocking kde-plasma/kwrited-5.6.2)
[ebuild  NS    ] kde-apps/thumbnailers-15.12.3:5::gentoo [15.08.3:4/15.08::gentoo] USE="-debug" 41 KiB
[uninstall     ] kde-apps/thumbnailers-15.08.3:4/15.08::gentoo  USE="(-aqua) -debug"
[blocks b      ] kde-apps/thumbnailers:4 ("kde-apps/thumbnailers:4" is blocking kde-apps/thumbnailers-15.12.3)
[ebuild  NS    ] kde-apps/dolphin-15.12.3-r1:5::gentoo [4.14.3-r1:4/4.14::gentoo] USE="-debug handbook -semantic-desktop {-test} thumbnail" 644 KiB
[uninstall     ] kde-apps/dolphin-4.14.3-r1:4/4.14::gentoo  USE="(-aqua) -debug handbook -semantic-desktop thumbnail"
[blocks b      ] kde-apps/dolphin:4 ("kde-apps/dolphin:4" is blocking kde-apps/dolphin-15.12.3-r1)
[ebuild  NS    ] kde-apps/kde-wallpapers-15.08.3-r2:5::gentoo [15.08.3:4/15.08::gentoo] 0 KiB
[uninstall     ] kde-apps/kde-wallpapers-15.08.3:4/15.08::gentoo  USE="(-aqua) minimal"
[blocks b      ] kde-apps/kde-wallpapers:4 ("kde-apps/kde-wallpapers:4" is blocking kde-apps/kde-wallpapers-15.08.3-r2)
[ebuild  NS    ] kde-apps/konsole-15.12.3:5::gentoo [4.14.3-r2:4/4.14::gentoo] USE="X -debug handbook {-test}" 449 KiB
[uninstall     ] kde-apps/konsole-4.14.3-r2:4/4.14::gentoo  USE="(-aqua) -debug handbook {-test}"
[blocks b      ] kde-apps/konsole:4 ("kde-apps/konsole:4" is blocking kde-apps/konsole-15.12.3)
[ebuild  NS    ] kde-misc/skanlite-2.0:5::gentoo [1.1-r1:4::gentoo] USE="-debug" 2,473 KiB
[uninstall     ] kde-misc/skanlite-1.1-r1:4::gentoo  USE="(-aqua) -debug handbook" LINGUAS="-be -bs -ca -ca@valencia -cs -da de -el -en_GB -eo -es -et -eu -fi -fr -ga -gl -hr -hu -ia -is -it -ja -km -ko -lt -lv -mai -mr -nb -nds -nl -nn -pa -pl -pt -pt_BR -ro -ru -sk -sl -sq -sv -tr -ug -uk -wa -zh_CN -zh_TW"
[blocks b      ] kde-misc/skanlite:4 ("kde-misc/skanlite:4" is blocking kde-misc/skanlite-2.0)
[ebuild  NS    ] kde-apps/ark-15.12.3:5::gentoo [4.14.3-r1:4/4.14::gentoo] USE="bzip2 -debug handbook lzma {-test} zlib" 248 KiB
[uninstall     ] kde-apps/ark-4.14.3-r1:4/4.14::gentoo  USE="(-aqua) archive bzip2 -debug handbook lzma"
[blocks b      ] kde-apps/ark:4 ("kde-apps/ark:4" is blocking kde-apps/ark-15.12.3)
[ebuild  N     ] kde-plasma/khelpcenter-5.6.2:5::gentoo  USE="-debug handbook" 1,683 KiB
[uninstall     ] kde-base/khelpcenter-4.14.3:4/4.14::gentoo  USE="(-aqua) -debug"
[blocks b      ] kde-base/khelpcenter:4 ("kde-base/khelpcenter:4" is blocking kde-plasma/khelpcenter-5.6.2)
[ebuild   R    ] app-emulation/q4wine-1.2_p2::gentoo  USE="dbus -debug icoutils qt5* wineappdb" LINGUAS="-af_ZA -cs_CZ de_DE en_US es_ES -fa_IR -he_IL -it_IT -pl_PL -pt_BR -ru_RU -uk_UA" 0 KiB
[ebuild   R    ] kde-apps/libkipi-15.08.3:4/15.08::gentoo  USE="(-aqua) -debug minimal*" 0 KiB
[ebuild   R    ] media-libs/openal-1.17.2::gentoo  USE="alsa (-coreaudio) -debug jack (-neon) -oss -portaudio pulseaudio qt4*" ABI_X86="-32 (64) (-x32)" CPU_FLAGS_X86="sse sse2 sse4_1" 0 KiB
[ebuild   R    ] dev-util/kdevelop-4.7.3:4::gentoo  USE="(-aqua) cmake cxx -debug -gdbui* okteta qthelp {-test}" LINGUAS="-bs -ca -ca@valencia -da de -el -en_GB -es -et -fi -fr -gl -hu -it -kk -nb -nds -nl -pl -pt -pt_BR -ru -sk -sl -sv -th -tr -uk -zh_CN -zh_TW" 0 KiB
[ebuild   R    ] net-libs/telepathy-qt-0.9.6.1::gentoo  USE="-debug -farstream qt4 qt5* {-test}" 5,926 KiB
[ebuild  N     ] kde-plasma/kactivitymanagerd-5.6.2:5::gentoo  USE="-debug" 83 KiB
[ebuild  N     ] kde-frameworks/kactivities-5.21.0:5/5.21::gentoo  USE="-debug -doc {-test}" 57 KiB
[uninstall     ] kde-base/kactivitymanagerd-4.13.3-r1:4/4.13::gentoo  USE="(-aqua)"
[blocks b      ] kde-frameworks/kactivities ("kde-frameworks/kactivities" is blocking kde-base/kactivitymanagerd-4.13.3-r1)
[blocks b      ] kde-base/kactivitymanagerd ("kde-base/kactivitymanagerd" is blocking kde-plasma/kactivitymanagerd-5.6.2)
[ebuild  N     ] kde-frameworks/plasma-5.21.0:5/5.21::gentoo  USE="X -debug -doc -egl -gles2 {-test}" 3,919 KiB
[ebuild  N     ] kde-frameworks/krunner-5.21.0:5/5.21::gentoo  USE="-debug -doc {-test}" 66 KiB
[ebuild  N     ] kde-plasma/plasma-pa-5.6.2:5::gentoo  USE="-debug" 59 KiB
[ebuild  N     ] kde-plasma/breeze-5.6.2:5::gentoo  USE="-debug qt4" 19,215 KiB
[ebuild  N     ] kde-plasma/milou-5.6.2:5::gentoo  USE="-debug" 56 KiB
[ebuild  NS    ] kde-apps/marble-15.12.3:5::gentoo [4.14.3:4/4.14::gentoo] USE="-aprs -debug -designer-plugin -gps handbook kde phonon -shapefile {-test}" 23,215 KiB
[uninstall     ] kde-apps/marble-4.14.3:4/4.14::gentoo  USE="(-aqua) -debug -designer-plugin -gps handbook kde phonon plasma (-python) -shapefile {-test} -zip" PYTHON_TARGETS="python2_7"
[blocks b      ] kde-apps/marble:4 ("kde-apps/marble:4" is blocking kde-apps/marble-15.12.3)
[ebuild  N     ] kde-plasma/kinfocenter-5.6.2:5::gentoo  USE="X -debug -egl -gles handbook -ieee1394 -nfs opengl pci -samba -wayland" 1,314 KiB
[uninstall     ] kde-base/kinfocenter-4.11.22:4/4.11::gentoo  USE="(-aqua) -debug handbook -ieee1394 opengl"
[blocks b      ] kde-base/kinfocenter:4 ("kde-base/kinfocenter:4" is blocking kde-plasma/kinfocenter-5.6.2)
[ebuild  NS    ] kde-apps/kdebase-runtime-meta-15.12.3:5::gentoo [4.14.3:4::gentoo] USE="oldwallet pam" 0 KiB
[uninstall     ] kde-apps/kdebase-runtime-meta-4.14.3:4::gentoo  USE="(-aqua) crash-reporter handbook -minimal"
[blocks b      ] kde-apps/kdebase-runtime-meta:4 ("kde-apps/kdebase-runtime-meta:4" is blocking kde-apps/kdebase-runtime-meta-15.12.3)
[ebuild  NS    ] kde-apps/kwrite-15.12.3:5::gentoo [4.14.3:4/4.14::gentoo] USE="-debug handbook" 1,425 KiB
[uninstall     ] kde-apps/kwrite-4.14.3:4/4.14::gentoo  USE="(-aqua) -debug handbook"
[blocks b      ] kde-apps/kwrite:4 ("kde-apps/kwrite:4" is blocking kde-apps/kwrite-15.12.3)
[ebuild  N     ] kde-apps/kdecore-meta-15.12.3:5::gentoo  USE="-minimal wallpapers" 0 KiB
[ebuild  NS    ] kde-apps/kmix-15.12.3:5::gentoo [4.14.3-r1:4/4.14::gentoo] USE="alsa -debug pulseaudio" 381 KiB
[uninstall     ] kde-apps/kmix-4.14.3-r1:4/4.14::gentoo  USE="alsa (-aqua) -canberra -debug handbook pulseaudio"
[blocks b      ] kde-apps/kmix:4 ("kde-apps/kmix:4" is blocking kde-apps/kmix-15.12.3)
[ebuild  N     ] kde-plasma/libksysguard-5.6.2:5::gentoo  USE="X -debug detailedmemory {-test}" 684 KiB
[ebuild  N     ] kde-plasma/ksysguard-5.6.2:5::gentoo  USE="-debug handbook lm_sensors" 602 KiB
[uninstall     ] kde-base/ksysguard-4.11.22:4/4.11::gentoo  USE="(-aqua) -debug handbook lm_sensors {-test}"
[blocks b      ] kde-base/ksysguard:4 ("kde-base/ksysguard:4" is blocking kde-plasma/libksysguard-5.6.2, kde-plasma/ksysguard-5.6.2)
[ebuild  N     ] kde-plasma/kwin-5.6.2:5::gentoo  USE="-debug -gles2 handbook -multimedia {-test}" 3,824 KiB
[ebuild  N     ] kde-plasma/systemsettings-5.6.2:5::gentoo  USE="-classic -debug -gtk handbook" 178 KiB
[uninstall     ] kde-base/kwin-4.11.22:4/4.11::gentoo  USE="(-aqua) -debug -gles opengl -wayland"
[blocks b      ] kde-base/kwin:4 ("kde-base/kwin:4" is blocking kde-plasma/kwin-5.6.2)
[ebuild  N     ] kde-plasma/plasma-workspace-5.6.2:5::gentoo  USE="dbus -debug geolocation -gps handbook (-prison) -qalculate {-test}" 6,866 KiB
[uninstall     ] kde-base/ksplash-4.11.22:4/4.11::gentoo  USE="(-altivec) (-aqua) -debug xinerama" CPU_FLAGS_X86="-3dnow mmx sse sse2"
[blocks b      ] kde-base/ksplash:4 ("kde-base/ksplash:4" is blocking kde-plasma/plasma-workspace-5.6.2)
[uninstall     ] kde-base/krunner-4.11.22:4/4.11::gentoo  USE="(-aqua) -debug opengl"
[blocks b      ] kde-base/krunner:4 ("kde-base/krunner:4" is blocking kde-plasma/plasma-workspace-5.6.2)
[uninstall     ] kde-base/kdebase-startkde-4.11.22-r1:4/4.11::gentoo  USE="(-aqua) wallpapers"
[blocks b      ] kde-base/kdebase-startkde:4 ("kde-base/kdebase-startkde:4" is blocking kde-plasma/plasma-workspace-5.6.2)
[uninstall     ] kde-base/klipper-4.11.22:4/4.11::gentoo  USE="(-aqua) -debug handbook -prison"
[blocks b      ] kde-base/klipper:4 ("kde-base/klipper:4" is blocking kde-plasma/plasma-workspace-5.6.2)
[uninstall     ] kde-base/libtaskmanager-4.11.22:4/4.11::gentoo  USE="(-aqua) -debug"
[blocks b      ] kde-base/libtaskmanager:4 ("kde-base/libtaskmanager:4" is blocking kde-plasma/plasma-workspace-5.6.2)
[uninstall     ] kde-base/freespacenotifier-4.11.22:4/4.11::gentoo  USE="(-aqua) -debug"
[blocks b      ] kde-base/freespacenotifier:4 ("kde-base/freespacenotifier:4" is blocking kde-plasma/plasma-workspace-5.6.2)
[uninstall     ] kde-base/kcminit-4.11.22:4/4.11::gentoo  USE="(-aqua) -debug"
[blocks b      ] kde-base/kcminit:4 ("kde-base/kcminit:4" is blocking kde-plasma/plasma-workspace-5.6.2)
[uninstall     ] kde-base/ksmserver-4.11.22:4/4.11::gentoo  USE="(-aqua) -debug"
[blocks b      ] kde-base/ksmserver:4 ("kde-base/ksmserver:4" is blocking kde-plasma/plasma-workspace-5.6.2)
[ebuild  N     ] kde-plasma/kdeplasma-addons-5.6.2:5::gentoo  USE="-debug -share" 2,024 KiB
[ebuild  N     ] kde-plasma/powerdevil-5.6.2:5::gentoo  USE="-debug handbook -systemd" 346 KiB
[uninstall     ] kde-base/powerdevil-4.11.22:4/4.11::gentoo  USE="(-aqua) -debug pm-utils"
[blocks b      ] kde-base/powerdevil:4 ("kde-base/powerdevil:4" is blocking kde-plasma/powerdevil-5.6.2)
[ebuild  N     ] kde-plasma/khotkeys-5.6.2:5::gentoo  USE="-debug handbook" 654 KiB
[uninstall     ] kde-base/khotkeys-4.11.22:4/4.11::gentoo  USE="(-aqua) -debug"
[blocks b      ] kde-base/khotkeys:4 ("kde-base/khotkeys:4" is blocking kde-plasma/khotkeys-5.6.2)
[ebuild  N     ] kde-plasma/kmenuedit-5.6.2:5::gentoo  USE="-debug handbook hotkeys" 469 KiB
[uninstall     ] kde-base/kmenuedit-4.11.22:4/4.11::gentoo  USE="(-aqua) -debug handbook"
[blocks b      ] kde-base/kmenuedit:4 ("kde-base/kmenuedit:4" is blocking kde-plasma/kmenuedit-5.6.2)
[ebuild  N     ] kde-plasma/plasma-desktop-5.6.2:5::gentoo  USE="-debug fontconfig -gtk2 -gtk3 handbook -ibus -legacy-systray pulseaudio qt4 -scim {-test}" INPUT_DEVICES="evdev -synaptics" 6,242 KiB
[uninstall     ] kde-base/systemsettings-4.11.22-r1:4/4.11::gentoo  USE="(-aqua) -debug gtk handbook kscreen opengl {-test} usb"
[blocks b      ] kde-base/systemsettings:4[handbook] ("kde-base/systemsettings:4[handbook]" is blocking kde-plasma/powerdevil-5.6.2)
[blocks b      ] kde-base/systemsettings:4 ("kde-base/systemsettings:4" is blocking kde-plasma/kwin-5.6.2, kde-plasma/systemsettings-5.6.2, kde-plasma/plasma-desktop-5.6.2, kde-plasma/khotkeys-5.6.2)
[uninstall     ] kde-base/plasma-workspace-4.11.22:4/4.11::gentoo  USE="(-aqua) -debug -gps handbook -json kdepim -python -qalculate" PYTHON_TARGETS="python2_7"
[blocks b      ] kde-base/plasma-workspace:4 ("kde-base/plasma-workspace:4" is blocking kde-plasma/plasma-workspace-5.6.2, kde-plasma/plasma-desktop-5.6.2)
[uninstall     ] kde-base/solid-actions-kcm-4.11.22:4/4.11::gentoo  USE="(-aqua) -debug"
[blocks b      ] kde-base/solid-actions-kcm:4 ("kde-base/solid-actions-kcm:4" is blocking kde-plasma/plasma-desktop-5.6.2)
[uninstall     ] kde-apps/knetattach-15.12.3:4/15.12::gentoo  USE="(-aqua) -debug handbook"
[blocks b      ] kde-apps/knetattach[handbook] ("kde-apps/knetattach[handbook]" is blocking kde-plasma/plasma-desktop-5.6.2)
[uninstall     ] kde-apps/kdepasswd-15.12.3:4/15.12::gentoo  USE="(-aqua) -debug handbook"
[blocks b      ] kde-apps/kdepasswd ("kde-apps/kdepasswd" is blocking kde-plasma/plasma-desktop-5.6.2)
[uninstall     ] kde-apps/kcontrol-15.12.3:4/15.12::gentoo  USE="(-aqua) -debug handbook"
[blocks b      ] kde-apps/kcontrol ("kde-apps/kcontrol" is blocking kde-plasma/plasma-desktop-5.6.2)
[ebuild  N     ] kde-plasma/plasma-meta-5.6.2:5::gentoo  USE="-bluetooth display-manager -grub -gtk handbook -mediacenter -networkmanager pam -plymouth pulseaudio sddm -sdk wallpapers" 0 KiB
[ebuild  NS    ] kde-apps/kdebase-meta-15.12.3:5::gentoo [4.14.3-r2:4::gentoo] 0 KiB
[uninstall     ] kde-apps/kdebase-meta-4.14.3-r2:4::gentoo  USE="(-aqua) display-manager -minimal wallpapers"
[blocks b      ] kde-apps/kdebase-meta:4 ("kde-apps/kdebase-meta:4" is blocking kde-apps/kdebase-meta-15.12.3)
[blocks B      ] <kde-apps/kapptemplate-15.12.3-r1 ("<kde-apps/kapptemplate-15.12.3-r1" is blocking kde-frameworks/krunner-5.21.0)
[blocks B      ] net-misc/ksshaskpass ("net-misc/ksshaskpass" is blocking kde-plasma/ksshaskpass-5.6.2)

Total: 180 packages (144 new, 17 in new slots, 19 reinstalls, 38 uninstalls), Size of downloads: 1,022,520 KiB
Conflict: 43 blocks (2 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-apps/kapptemplate-4.14.3:4/4.14::gentoo, installed) pulled in by
    >=kde-apps/kapptemplate-4.4:4[aqua=] (>=kde-apps/kapptemplate-4.4:4[-aqua]) required by (dev-util/kdevelop-4.7.3:4/4::gentoo, ebuild scheduled for merge)

  (net-misc/ksshaskpass-0.5.3-r1:4/4::gentoo, installed) pulled in by
    net-misc/ksshaskpass required by @selected

  (kde-plasma/ksshaskpass-5.6.2:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-plasma/ksshaskpass-5.6.2:5 required by (kde-plasma/plasma-meta-5.6.2:5/5::gentoo, ebuild scheduled for merge)

  (kde-frameworks/krunner-5.21.0:5/5.21::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-frameworks/krunner-5.18.0:5 required by (kde-plasma/milou-5.6.2:5/5::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/krunner-5.18.0:5 required by (kde-plasma/kdeplasma-addons-5.6.2:5/5::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/krunner-5.18.0:5 required by (kde-plasma/plasma-workspace-5.6.2:5/5::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/krunner-5.20.0:5 required by (kde-plasma/plasma-desktop-5.6.2:5/5::gentoo, ebuild scheduled for merge)
    >=kde-frameworks/krunner-5.18.0:5 required by (kde-apps/marble-15.12.3:5/5::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by kde-plasma/kwin-5.6.2::gentoo
# required by kde-plasma/plasma-desktop-5.6.2::gentoo
# required by kde-plasma/plasma-meta-5.6.2::gentoo
# required by kde-apps/kdebase-meta-15.12.3::gentoo
# required by @selected
# required by @world (argument)
>=media-libs/mesa-11.2.0 wayland
# required by dev-ruby/net-telnet-0.1.1-r1::gentoo[ruby_targets_ruby23,-test]
# required by dev-lang/ruby-2.3.0::gentoo
# required by dev-ruby/racc-1.4.14::gentoo[ruby_targets_ruby23]
# required by dev-ruby/rdoc-4.2.2::gentoo[ruby_targets_ruby20]
# required by dev-lang/ruby-2.1.10::gentoo[rdoc]
# required by dev-ruby/power_assert-0.2.7::gentoo[ruby_targets_ruby21]
# required by dev-ruby/test-unit-3.1.8::gentoo[ruby_targets_ruby20]
>=virtual/rubygems-11 ruby_targets_ruby23
# required by dev-lang/ruby-2.3.0::gentoo
# required by dev-ruby/racc-1.4.14::gentoo[ruby_targets_ruby23]
# required by dev-ruby/rdoc-4.2.2::gentoo[ruby_targets_ruby20]
# required by dev-lang/ruby-2.1.10::gentoo[rdoc]
# required by dev-ruby/power_assert-0.2.7::gentoo[ruby_targets_ruby21]
>=dev-ruby/test-unit-3.1.8 ruby_targets_ruby23
# required by dev-lang/ruby-2.3.0::gentoo
# required by dev-ruby/racc-1.4.14::gentoo[ruby_targets_ruby23]
# required by dev-ruby/rdoc-4.2.2::gentoo[ruby_targets_ruby20]
# required by dev-lang/ruby-2.1.10::gentoo[rdoc]
# required by dev-ruby/power_assert-0.2.7::gentoo[ruby_targets_ruby21]
# required by dev-ruby/test-unit-3.1.8::gentoo[ruby_targets_ruby20]
>=dev-ruby/minitest-5.8.4 ruby_targets_ruby23
# required by media-libs/mesa-11.2.0::gentoo[wayland]
# required by kde-plasma/kwayland-5.6.2::gentoo
# required by kde-plasma/libkscreen-5.6.2::gentoo
# required by kde-plasma/plasma-workspace-5.6.2::gentoo
# required by kde-plasma/plasma-desktop-5.6.2::gentoo
# required by kde-plasma/plasma-meta-5.6.2::gentoo
# required by kde-apps/kdebase-meta-15.12.3::gentoo
# required by @selected
# required by @world (argument)
>=dev-libs/wayland-1.10.0-r1 abi_x86_32
# required by virtual/rubygems-11::gentoo[ruby_targets_ruby23]
# required by dev-lang/ruby-2.0.0_p648::gentoo
# required by dev-ruby/power_assert-0.2.7::gentoo[ruby_targets_ruby20]
# required by dev-ruby/test-unit-3.1.8::gentoo[ruby_targets_ruby20]
# required by dev-lang/ruby-2.3.0::gentoo
# required by dev-ruby/racc-1.4.14::gentoo[ruby_targets_ruby23]
# required by dev-ruby/rdoc-4.2.2::gentoo[ruby_targets_ruby20]
# required by dev-lang/ruby-2.1.10::gentoo[rdoc]
# required by dev-ruby/net-telnet-0.1.1-r1::gentoo[ruby_targets_ruby21]
>=dev-ruby/rubygems-2.6.2 ruby_targets_ruby23
# required by dev-lang/ruby-2.3.0::gentoo
# required by dev-ruby/racc-1.4.14::gentoo[ruby_targets_ruby23]
# required by dev-ruby/rdoc-4.2.2::gentoo[ruby_targets_ruby20]
# required by dev-lang/ruby-2.1.10::gentoo[rdoc]
# required by dev-ruby/power_assert-0.2.7::gentoo[ruby_targets_ruby21]
# required by dev-ruby/test-unit-3.1.8::gentoo[ruby_targets_ruby20]
>=dev-ruby/rake-11.1.2 ruby_targets_ruby23
# required by dev-ruby/rdoc-4.2.2::gentoo[ruby_targets_ruby23]
# required by dev-lang/ruby-2.1.10::gentoo[rdoc]
# required by dev-ruby/power_assert-0.2.7::gentoo[ruby_targets_ruby21]
# required by dev-ruby/test-unit-3.1.8::gentoo[ruby_targets_ruby20]
# required by dev-lang/ruby-2.3.0::gentoo
# required by dev-ruby/racc-1.4.14::gentoo[ruby_targets_ruby23]
>=dev-ruby/json-1.8.3 ruby_targets_ruby23
# required by dev-lang/ruby-2.3.0::gentoo[rdoc]
# required by dev-ruby/racc-1.4.14::gentoo[ruby_targets_ruby23]
>=dev-ruby/rdoc-4.2.2 ruby_targets_ruby23
# required by dev-lang/ruby-2.3.0::gentoo
# required by dev-ruby/racc-1.4.14::gentoo[ruby_targets_ruby23]
# required by dev-ruby/rdoc-4.2.2::gentoo[ruby_targets_ruby20]
# required by dev-lang/ruby-2.1.10::gentoo[rdoc]
# required by dev-ruby/power_assert-0.2.7::gentoo[ruby_targets_ruby21]
# required by dev-ruby/test-unit-3.1.8::gentoo[ruby_targets_ruby20]
>=dev-ruby/net-telnet-0.1.1-r1 ruby_targets_ruby23
# required by dev-lang/ruby-2.3.0::gentoo
# required by dev-ruby/racc-1.4.14::gentoo[ruby_targets_ruby23]
# required by dev-ruby/rdoc-4.2.2::gentoo[ruby_targets_ruby20]
# required by dev-lang/ruby-2.1.10::gentoo[rdoc]
# required by dev-ruby/power_assert-0.2.7::gentoo[ruby_targets_ruby21]
# required by dev-ruby/test-unit-3.1.8::gentoo[ruby_targets_ruby20]
>=dev-ruby/did_you_mean-1.0.0 ruby_targets_ruby23
# required by dev-lang/ruby-2.3.0::gentoo
# required by dev-ruby/racc-1.4.14::gentoo[ruby_targets_ruby23]
# required by dev-ruby/rdoc-4.2.2::gentoo[ruby_targets_ruby20]
# required by dev-lang/ruby-2.1.10::gentoo[rdoc]
# required by dev-ruby/net-telnet-0.1.1-r1::gentoo[ruby_targets_ruby21]
>=dev-ruby/power_assert-0.2.7 ruby_targets_ruby23
# required by dev-ruby/rdoc-4.2.2::gentoo[ruby_targets_ruby23]
# required by dev-lang/ruby-2.1.10::gentoo[rdoc]
# required by dev-ruby/power_assert-0.2.7::gentoo[ruby_targets_ruby21]
# required by dev-ruby/test-unit-3.1.8::gentoo[ruby_targets_ruby20]
# required by dev-lang/ruby-2.3.0::gentoo
# required by dev-qt/qtwebkit-5.5.1-r1::gentoo
# required by kde-plasma/libksysguard-5.6.2::gentoo[detailedmemory]
# required by kde-plasma/plasma-workspace-5.6.2::gentoo
# required by kde-plasma/plasma-desktop-5.6.2::gentoo
# required by kde-plasma/plasma-meta-5.6.2::gentoo
# required by kde-apps/kdebase-meta-15.12.3::gentoo
# required by @selected
# required by @world (argument)
>=dev-ruby/racc-1.4.14 ruby_targets_ruby23

Would you like to add these changes to your config files? [Yes/No] ^CInterrupted.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Tue Apr 12, 2016 10:16 am    Post subject: Re: Why does upgrade to plasma 5 pull wayland? And ruby(?) Reply with quote

as.gentoo wrote:
Does plasma 5 really need wayland(-support) by mesa? I've set USE "-wayland" in the make.conf but portage still demands that use flag.
Code:
#> emerge --ask --changed-use --newrepo --deep world
The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by kde-plasma/kwin-5.6.2::gentoo
# required by kde-plasma/plasma-desktop-5.6.2::gentoo
# required by kde-plasma/plasma-meta-5.6.2::gentoo
# required by kde-apps/kdebase-meta-15.12.3::gentoo
# required by @selected
# required by @world (argument)
>=media-libs/mesa-11.2.0 wayland

Yes it does, even if you do not start a wayland session, parts of workspace/kscreenlocker use libwayland stuff.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum