Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
samba 4 errors in compiling :-(
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Krog
Guru
Guru


Joined: 26 Jun 2007
Posts: 330
Location: Roma, Italy

PostPosted: Sun Apr 10, 2016 5:56 pm    Post subject: samba 4 errors in compiling :-( Reply with quote

output of emerge samba: http://pastebin.com/Pa5uzY60
emerge --info '=net-fs/samba-4.2.9::gentoo' http://pastebin.com/NeNybQhx

I tried to search on the forum and follow this or that suggestion (heimdal with -thread and others) but always fails!

please help :-(
Back to top
View user's profile Send private message
schorsch_76
Guru
Guru


Joined: 19 Jun 2012
Posts: 450

PostPosted: Sun Apr 10, 2016 6:24 pm    Post subject: Reply with quote

Code:
 * gcc-config: No gcc profile is active!
 * gcc-config: No gcc profile is active!
 * gcc-config: No gcc profile is active!


Try to set a gcc profile ;)
_________________
// valid again: I forgot about the git access. Now 1.2GB big. Start: 2015-06-25
git daily portage tree
Web: https://portage.schorsch-tech.de
git clone https://portage.schorsch-tech.de/portage.git
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43764
Location: 56N 3W

PostPosted: Sun Apr 10, 2016 6:31 pm    Post subject: Reply with quote

Krog,

You have --depclean ed your active gcc.

This happens when you upgraded to a newer gcc but didn't select it, so the older one continues to be used.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Krog
Guru
Guru


Joined: 26 Jun 2007
Posts: 330
Location: Roma, Italy

PostPosted: Sun Apr 10, 2016 6:33 pm    Post subject: Reply with quote

Quote:
krogpc krog # gcc-config -l
[1] x86_64-pc-linux-gnu-4.8.5
[2] x86_64-pc-linux-gnu-4.9.3 *


to be sure I did a gcc-config 2
let's see... compiling again
Back to top
View user's profile Send private message
Krog
Guru
Guru


Joined: 26 Jun 2007
Posts: 330
Location: Roma, Italy

PostPosted: Sun Apr 10, 2016 6:37 pm    Post subject: Reply with quote

it says the same! trying the other profile :-(
Back to top
View user's profile Send private message
Krog
Guru
Guru


Joined: 26 Jun 2007
Posts: 330
Location: Roma, Italy

PostPosted: Sun Apr 10, 2016 7:19 pm    Post subject: Reply with quote

strange thing, samba searches for /etc/env.d/gcc/config-i686-pc-linux-gnu
but my gcc-config profile is x86_64-pc-linux-gnu-4.9.3
so i have:
Code:
ls /etc/env.d/gcc/ -l
totale 12
-rw-r--r-- 1 root root  34 10 apr 21.15 config-x86_64-pc-linux-gnu
-rw-r--r-- 1 root root 360 18 feb 10.07 x86_64-pc-linux-gnu-4.8.5
-rw-r--r-- 1 root root 360 18 feb 09.42 x86_64-pc-linux-gnu-4.9.3


it says: Checking for program gcc or cc : x86_64-pc-linux-gnu-gcc
but then: usr/bin/gcc-config: riga 72: /etc/env.d/gcc/config-i686-pc-linux-gnu: File o directory non esistente
gcc-config: error: could not run/locate 'i686-pc-linux-gnu-cpp'
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43764
Location: 56N 3W

PostPosted: Sun Apr 10, 2016 8:12 pm    Post subject: Reply with quote

Krog,

config-x86_64-pc-linux-gnu contains the name of the currently selected x86_64-pc-linux-gnu compiler.
What does that file contain?
Its just one line of text.

Code:
gcc-config: error: could not run/locate 'i686-pc-linux-gnu-cpp'
That's a 32 bit compiler. It has i686 in its name.
Why is samba looking for that?

Pastebin the entire build log.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Krog
Guru
Guru


Joined: 26 Jun 2007
Posts: 330
Location: Roma, Italy

PostPosted: Sun Apr 10, 2016 8:41 pm    Post subject: Reply with quote

NeddySeagoon wrote:

Why is samba looking for that?

Pastebin the entire build log.


it's not the first pastebin i did?
samba compiled with this:

ABI_X86="64" emerge samba

my make.conf has:
ABI_X86="64 32"
Is this wrong? I tought ABI_X86 is to have 32bit libraries too, but samba should be enough with 64 bit only...
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43764
Location: 56N 3W

PostPosted: Sun Apr 10, 2016 9:07 pm    Post subject: Reply with quote

Krog,

Sorry about missing your pastebin.

The build system will build samba twice, once for each ABI.

At line 55 Checking for program gcc or cc : ['x86_64-pc-linux-gnu-gcc', '-m32'] Thats getting your 64 bit compiler to emit 32 bit code.
At line 1240, Checking for program gcc or cc : x86_64-pc-linux-gnu-gcc that's for the 64 bit compiler.

At line 2646 /usr/bin/gcc-config: riga 72: /etc/env.d/gcc/config-i686-pc-linux-gnu: File o directory non esistente
Its trying to select the i686 compiler.

That looks wrong to me but I'm /no-multilib/ so I don't see these issues myself.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Krog
Guru
Guru


Joined: 26 Jun 2007
Posts: 330
Location: Roma, Italy

PostPosted: Mon Apr 11, 2016 6:17 am    Post subject: Reply with quote

I compiled samba 64 bits only but now ffmpeg wants to recompile it with 64 bit...
Back to top
View user's profile Send private message
allistarM
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jul 2004
Posts: 78

PostPosted: Thu Apr 14, 2016 12:19 am    Post subject: Reply with quote

Krog wrote:
I compiled samba 64 bits only but now ffmpeg wants to recompile it with 64 bit...


I get the exact same issue. When I try and force ffmpeg to not compile a 32bit binary the issue compounds and further packages start complaining. My fix so far is to mask this version of samba. It seems that samba is using a different compiler or looking in a different place when compiling a 32bit binary than other packages that do the same.
Back to top
View user's profile Send private message
Krog
Guru
Guru


Joined: 26 Jun 2007
Posts: 330
Location: Roma, Italy

PostPosted: Thu Apr 14, 2016 3:09 am    Post subject: Reply with quote

i'm too old for this
i have problems with apache now, finally it compiled but other errors launching it
not at home at the moment, I will post the log later
Back to top
View user's profile Send private message
Saundersx
Apprentice
Apprentice


Joined: 11 Apr 2005
Posts: 251

PostPosted: Sat Apr 23, 2016 9:06 pm    Post subject: Reply with quote

I have the exact same problem. In my situation though I have a laptop and desktop that are both gentoo, the laptop is a newer install and has no problem compiling the latest samba with exactly the same use flags and almost identical make.conf . The desktop used to have crossdev installed (iirc for audrino-related stuff a looong time ago) so I'm willing to bet there are some bad env files kicking around.

For me adding "-abi_x86_32" to the packages.use was a quick fix and it compiled right away without, hopefully, any issues.
Back to top
View user's profile Send private message
Saundersx
Apprentice
Apprentice


Joined: 11 Apr 2005
Posts: 251

PostPosted: Sat Apr 23, 2016 9:31 pm    Post subject: Reply with quote

Lucky guess on my part, reinstalled crossdev, removed the cruft and samba compiled fine.

Code:
# crossdev -C avr
 * Uninstalling target 'avr' ...
/usr/avr: directory still exists; remove recursively? [y/N] y
# crossdev -C i686
 * Uninstalling target 'i686-pc-linux-gnu' ...
Back to top
View user's profile Send private message
dr41nU
n00b
n00b


Joined: 24 Apr 2016
Posts: 1
Location: France

PostPosted: Sun Apr 24, 2016 8:47 am    Post subject: Reply with quote

Hi,

Same problem for me. I had been using crossdev in the past and it seems that I have not removed it properly. Indeed, there was still things in the directory /usr/i686-pc-linux-gnu.
So I installed once again crossdev :
Code:
emerge -avq1 crossdev

Afterwards I removed the old remaining target, paying attention to remove directory /usr/i686-pc-linux-gnu :
Code:
athlonx4 ~ # crossdev -C i686
 * Uninstalling target 'i686-pc-linux-gnu' ...
<<< cross-i686-pc-linux-gnu/linux-headers-4.0
<<< cross-i686-pc-linux-gnu/glibc-2.20-r2
/usr/i686-pc-linux-gnu: directory still exists; remove recursively? [y/N] y

Then, I was able to upgrade samba :
Code:
emerge -avqu1 samba

And finally uninstall crossdev
Code:
emerge -C crossdev


Laurent
Back to top
View user's profile Send private message
raddaqii
Tux's lil' helper
Tux's lil' helper


Joined: 27 Mar 2005
Posts: 102
Location: Berlin, Old Europe

PostPosted: Thu May 26, 2016 8:27 am    Post subject: Reply with quote

Tremendously helpful advice, Neddy, dr41nU and Saundersx!

Fixing crossdev was what I needed, and it just had not occurred to me despite looking at the build log. Didn't see the wood for the trees, now I do. Thank you all.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum