Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]My Xorg takes too long..
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
qwpo1030
n00b
n00b


Joined: 28 Jun 2015
Posts: 12

PostPosted: Fri Apr 08, 2016 4:04 am    Post subject: [SOLVED]My Xorg takes too long.. Reply with quote

As the title says. My Xorg instantly halts at 13.782 secs. And resumes at 41.822 secs. So the system halts about 30 secs in conclusion.

Below log file which is Xorg.0.log in my system says there are two warnings. One is 'I can't found specific font directory.', and another is 'xf86OpenConsole trying to access to setpgid and setsid but operations are denied.'.

Google says these warnings are not that matter that fonts problem is just that you don't install certain fonts like OTF, TTF, etc and these don't affect Xorg process, and also setpgid and setsid.

So what's the problem? Where should I throw a question?


Code:
[    12.541]
X.Org X Server 1.17.4
Release Date: 2015-10-28
[    12.541] X Protocol Version 11, Revision 0
[    12.542] Build Operating System: Linux 4.1.15-gentoo-r1 x86_64 Gentoo
[    12.542] Current Operating System: Linux hkimgentoo 4.1.15-gentoo-r1 #1 SMP Sun Mar 20 00:13:34 KST 2016 x86_64
[    12.542] Kernel command line: BOOT_IMAGE=/vmlinuz-4.1.15-gentoo-r1 root=/dev/sda4 ro
[    12.542] Build Date: 20 March 2016  11:58:07AM
[    12.542] 
[    12.542] Current version of pixman: 0.32.8
[    12.542]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[    12.542] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    12.542] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Apr  8 12:36:38 2016
[    12.595] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    12.595] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    12.648] (==) No Layout section.  Using the first Screen section.
[    12.648] (==) No screen section available. Using defaults.
[    12.648] (**) |-->Screen "Default Screen Section" (0)
[    12.648] (**) |   |-->Monitor "<default monitor>"
[    12.648] (==) No monitor specified for screen "Default Screen Section".
   Using a default monitor configuration.
[    12.648] (==) Automatically adding devices
[    12.648] (==) Automatically enabling devices
[    12.648] (==) Automatically adding GPU devices
[    12.825] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/misc/".
[    12.825]    Entry deleted from font path.
[    12.825]    (Run 'mkfontdir' on "/usr/share/fonts/misc/").
[    12.828] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/TTF/".
[    12.828]    Entry deleted from font path.
[    12.828]    (Run 'mkfontdir' on "/usr/share/fonts/TTF/").
[    12.829] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/OTF/".
[    12.829]    Entry deleted from font path.
[    12.829]    (Run 'mkfontdir' on "/usr/share/fonts/OTF/").
[    12.833] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/Type1/".
[    12.833]    Entry deleted from font path.
[    12.833]    (Run 'mkfontdir' on "/usr/share/fonts/Type1/").
[    12.849] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    12.849]    Entry deleted from font path.
[    12.849]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[    12.860] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    12.860]    Entry deleted from font path.
[    12.860]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[    12.860] (==) FontPath set to:
   
[    12.860] (==) ModulePath set to "/usr/lib64/xorg/modules"
[    12.860] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[    12.881] (II) Loader magic: 0x80fc80
[    12.881] (II) Module ABI versions:
[    12.881]    X.Org ANSI C Emulation: 0.4
[    12.881]    X.Org Video Driver: 19.0
[    12.881]    X.Org XInput driver : 21.0
[    12.881]    X.Org Server Extension : 9.0
[    12.881] (II) xfree86: Adding drm device (/dev/dri/card0)
[    12.883] (--) PCI:*(0:0:2:0) 8086:0f31:1558:5470 rev 14, Mem @ 0xd0000000/4194304, 0xc0000000/268435456, I/O @ 0x0000f080/8
[    12.884] (II) LoadModule: "glx"
[    12.904] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[    13.071] (II) Module glx: vendor="X.Org Foundation"
[    13.071]    compiled for 1.17.4, module version = 1.0.0
[    13.071]    ABI class: X.Org Server Extension, version 9.0
[    13.071] (==) AIGLX enabled
[    13.071] (==) Matched intel as autoconfigured driver 0
[    13.071] (==) Matched intel as autoconfigured driver 1
[    13.071] (==) Matched modesetting as autoconfigured driver 2
[    13.071] (==) Matched fbdev as autoconfigured driver 3
[    13.071] (==) Matched vesa as autoconfigured driver 4
[    13.071] (==) Assigned the driver to the xf86ConfigLayout
[    13.071] (II) LoadModule: "intel"
[    13.088] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
[    13.127] (II) Module intel: vendor="X.Org Foundation"
[    13.127]    compiled for 1.17.4, module version = 2.99.917
[    13.127]    Module class: X.Org Video Driver
[    13.127]    ABI class: X.Org Video Driver, version 19.0
[    13.127] (II) LoadModule: "modesetting"
[    13.127] (II) Loading /usr/lib64/xorg/modules/drivers/modesetting_drv.so
[    13.134] (II) Module modesetting: vendor="X.Org Foundation"
[    13.134]    compiled for 1.17.4, module version = 1.17.4
[    13.134]    Module class: X.Org Video Driver
[    13.134]    ABI class: X.Org Video Driver, version 19.0
[    13.134] (II) LoadModule: "fbdev"
[    13.134] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
[    13.143] (II) Module fbdev: vendor="X.Org Foundation"
[    13.143]    compiled for 1.17.4, module version = 0.4.4
[    13.143]    Module class: X.Org Video Driver
[    13.143]    ABI class: X.Org Video Driver, version 19.0
[    13.143] (II) LoadModule: "vesa"
[    13.143] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
[    13.147] (II) Module vesa: vendor="X.Org Foundation"
[    13.147]    compiled for 1.17.4, module version = 2.3.4
[    13.147]    Module class: X.Org Video Driver
[    13.147]    ABI class: X.Org Video Driver, version 19.0
[    13.147] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
   i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
   915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
   Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
   GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[    13.148] (II) intel: Driver for Intel(R) HD Graphics: 2000-6000
[    13.148] (II) intel: Driver for Intel(R) Iris(TM) Graphics: 5100, 6100
[    13.148] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics: 5200, 6200, P6300
[    13.148] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    13.148] (II) FBDEV: driver for framebuffer: fbdev
[    13.148] (II) VESA: driver for VESA chipsets: vesa
[    13.148] (++) using VT number 7

[    13.148] (WW) xf86OpenConsole: setpgid failed: Operation not permitted
[    13.148] (WW) xf86OpenConsole: setsid failed: Operation not permitted
[    13.155] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20150327
[    13.156] (WW) Falling back to old probe method for modesetting
[    13.156] (WW) Falling back to old probe method for fbdev
[    13.156] (II) Loading sub module "fbdevhw"
[    13.156] (II) LoadModule: "fbdevhw"
[    13.170] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
[    13.170] (II) Module fbdevhw: vendor="X.Org Foundation"
[    13.170]    compiled for 1.17.4, module version = 0.0.2
[    13.170]    ABI class: X.Org Video Driver, version 19.0
[    13.170] (WW) Falling back to old probe method for vesa
[    13.171] (--) intel(0): Integrated Graphics Chipset: Intel(R) HD Graphics
[    13.171] (--) intel(0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2
[    13.171] (II) intel(0): Creating default Display subsection in Screen section
   "Default Screen Section" for depth/fbbpp 24/32
[    13.171] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[    13.171] (==) intel(0): RGB weight 888
[    13.171] (==) intel(0): Default visual is TrueColor
[    13.171] (II) intel(0): Output eDP1 has no monitor section
[    13.172] (--) intel(0): Found backlight control interface intel_backlight (type 'raw') for output eDP1
[    13.172] (II) intel(0): Enabled output eDP1
[    13.172] (II) intel(0): Output VGA1 has no monitor section
[    13.172] (II) intel(0): Enabled output VGA1
[    13.172] (II) intel(0): Output HDMI1 has no monitor section
[    13.172] (II) intel(0): Enabled output HDMI1
[    13.172] (II) intel(0): Output DP1 has no monitor section
[    13.172] (II) intel(0): Enabled output DP1
[    13.172] (--) intel(0): Using a maximum size of 256x256 for hardware cursors
[    13.172] (II) intel(0): Output VIRTUAL1 has no monitor section
[    13.172] (II) intel(0): Enabled output VIRTUAL1
[    13.172] (--) intel(0): Output eDP1 using initial mode 1366x768 on pipe 0
[    13.172] (==) intel(0): TearFree disabled
[    13.172] (==) intel(0): DPI set to (96, 96)
[    13.172] (II) Loading sub module "dri2"
[    13.172] (II) LoadModule: "dri2"
[    13.172] (II) Module "dri2" already built-in
[    13.172] (II) Loading sub module "present"
[    13.172] (II) LoadModule: "present"
[    13.172] (II) Module "present" already built-in
[    13.172] (II) UnloadModule: "modesetting"
[    13.172] (II) Unloading modesetting
[    13.173] (II) UnloadModule: "fbdev"
[    13.173] (II) Unloading fbdev
[    13.173] (II) UnloadSubModule: "fbdevhw"
[    13.173] (II) Unloading fbdevhw
[    13.173] (II) UnloadModule: "vesa"
[    13.173] (II) Unloading vesa
[    13.173] (==) Depth 24 pixmap format is 32 bpp
[    13.199] (II) intel(0): SNA initialized with Baytrail (gen7) backend
[    13.199] (==) intel(0): Backing store enabled
[    13.199] (==) intel(0): Silken mouse enabled
[    13.199] (II) intel(0): HW Cursor enabled
[    13.199] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[    13.200] (==) intel(0): DPMS enabled
[    13.200] (==) intel(0): display hotplug detection enabled
[    13.200] (II) intel(0): [DRI2] Setup complete
[    13.200] (II) intel(0): [DRI2]   DRI driver: i965
[    13.200] (II) intel(0): [DRI2]   VDPAU driver: i965
[    13.200] (II) intel(0): direct rendering: DRI2 enabled
[    13.200] (II) intel(0): hardware support for Present enabled
[    13.200] (--) RandR disabled
[    13.385] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[    13.385] (II) AIGLX: enabled GLX_ARB_create_context
[    13.385] (II) AIGLX: enabled GLX_ARB_create_context_profile
[    13.385] (II) AIGLX: enabled GLX_EXT_create_context_es2_profile
[    13.385] (II) AIGLX: enabled GLX_INTEL_swap_event
[    13.385] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
[    13.385] (II) AIGLX: enabled GLX_EXT_framebuffer_sRGB
[    13.385] (II) AIGLX: enabled GLX_ARB_fbconfig_float
[    13.385] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[    13.385] (II) AIGLX: enabled GLX_ARB_create_context_robustness
[    13.386] (II) AIGLX: Loaded and initialized i965
[    13.386] (II) GLX: Initialized DRI2 GL provider for screen 0
[    13.413] (II) intel(0): switch to mode 1366x768@60.0 on eDP1 using pipe 0, position (0, 0), rotation normal, reflection none
[    13.422] (II) intel(0): Setting screen physical size to 361 x 203
[    13.687] (II) config/udev: Adding input device Power Button (/dev/input/event3)
[    13.687] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    13.687] (II) LoadModule: "evdev"
[    13.687] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[    13.725] (II) Module evdev: vendor="X.Org Foundation"
[    13.725]    compiled for 1.17.4, module version = 2.9.2
[    13.725]    Module class: X.Org XInput Driver
[    13.725]    ABI class: X.Org XInput driver, version 21.0
[    13.725] (II) Using input driver 'evdev' for 'Power Button'
[    13.725] (**) Power Button: always reports core events
[    13.726] (**) evdev: Power Button: Device: "/dev/input/event3"
[    13.726] (--) evdev: Power Button: Vendor 0 Product 0x1
[    13.726] (--) evdev: Power Button: Found keys
[    13.726] (II) evdev: Power Button: Configuring as keyboard
[    13.726] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input3/event3"
[    13.726] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[    13.726] (**) Option "xkb_rules" "evdev"
[    13.726] (**) Option "xkb_model" "pc104"
[    13.726] (**) Option "xkb_layout" "us"
[    13.775] (II) config/udev: Adding input device Video Bus (/dev/input/event4)
[    13.775] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[    13.775] (II) Using input driver 'evdev' for 'Video Bus'
[    13.775] (**) Video Bus: always reports core events
[    13.775] (**) evdev: Video Bus: Device: "/dev/input/event4"
[    13.775] (--) evdev: Video Bus: Vendor 0 Product 0x6
[    13.775] (--) evdev: Video Bus: Found keys
[    13.775] (II) evdev: Video Bus: Configuring as keyboard
[    13.775] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input4/event4"
[    13.775] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 7)
[    13.775] (**) Option "xkb_rules" "evdev"
[    13.775] (**) Option "xkb_model" "pc104"
[    13.775] (**) Option "xkb_layout" "us"
[    13.776] (II) config/udev: Adding input device Power Button (/dev/input/event0)
[    13.776] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    13.776] (II) Using input driver 'evdev' for 'Power Button'
[    13.776] (**) Power Button: always reports core events
[    13.776] (**) evdev: Power Button: Device: "/dev/input/event0"
[    13.776] (--) evdev: Power Button: Vendor 0 Product 0x1
[    13.776] (--) evdev: Power Button: Found keys
[    13.776] (II) evdev: Power Button: Configuring as keyboard
[    13.776] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input0/event0"
[    13.776] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 8)
[    13.776] (**) Option "xkb_rules" "evdev"
[    13.776] (**) Option "xkb_model" "pc104"
[    13.776] (**) Option "xkb_layout" "us"
[    13.777] (II) config/udev: Adding input device Lid Switch (/dev/input/event2)
[    13.777] (II) No input driver specified, ignoring this device.
[    13.777] (II) This device may have been added with another device file.
[    13.778] (II) config/udev: Adding input device Sleep Button (/dev/input/event1)
[    13.778] (**) Sleep Button: Applying InputClass "evdev keyboard catchall"
[    13.778] (II) Using input driver 'evdev' for 'Sleep Button'
[    13.778] (**) Sleep Button: always reports core events
[    13.778] (**) evdev: Sleep Button: Device: "/dev/input/event1"
[    13.778] (--) evdev: Sleep Button: Vendor 0 Product 0x3
[    13.778] (--) evdev: Sleep Button: Found keys
[    13.778] (II) evdev: Sleep Button: Configuring as keyboard
[    13.778] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input1/event1"
[    13.778] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD, id 9)
[    13.778] (**) Option "xkb_rules" "evdev"
[    13.778] (**) Option "xkb_model" "pc104"
[    13.778] (**) Option "xkb_layout" "us"
[    13.779] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event5)
[    13.779] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[    13.779] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[    13.779] (**) AT Translated Set 2 keyboard: always reports core events
[    13.779] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event5"
[    13.779] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
[    13.779] (--) evdev: AT Translated Set 2 keyboard: Found keys
[    13.780] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
[    13.780] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input5/event5"
[    13.780] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 10)
[    13.780] (**) Option "xkb_rules" "evdev"
[    13.780] (**) Option "xkb_model" "pc104"
[    13.780] (**) Option "xkb_layout" "us"
[    13.780] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event7)
[    13.781] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
[    13.781] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
[    13.781] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "Default clickpad buttons"
[    13.781] (II) LoadModule: "synaptics"
[    13.781] (II) Loading /usr/lib64/xorg/modules/input/synaptics_drv.so
[    13.781] (II) Module synaptics: vendor="X.Org Foundation"
[    13.782]    compiled for 1.17.4, module version = 1.8.2
[    13.782]    Module class: X.Org XInput Driver
[    13.782]    ABI class: X.Org XInput driver, version 21.0
[    13.782] (II) Using input driver 'synaptics' for 'SynPS/2 Synaptics TouchPad'
[    13.782] (**) SynPS/2 Synaptics TouchPad: always reports core events
[    13.782] (**) Option "Device" "/dev/input/event7"
[    41.822] (II) synaptics: SynPS/2 Synaptics TouchPad: ignoring touch events for semi-multitouch device
[    41.822] (--) synaptics: SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5692 (res 66)
[    41.822] (--) synaptics: SynPS/2 Synaptics TouchPad: y-axis range 1408 - 4680 (res 102)
[    41.822] (--) synaptics: SynPS/2 Synaptics TouchPad: pressure range 0 - 255
[    41.822] (--) synaptics: SynPS/2 Synaptics TouchPad: finger width range 0 - 15
[    41.822] (--) synaptics: SynPS/2 Synaptics TouchPad: buttons: left right double triple
[    41.822] (--) synaptics: SynPS/2 Synaptics TouchPad: Vendor 0x2 Product 0x7
[    41.822] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[    41.822] (**) SynPS/2 Synaptics TouchPad: always reports core events
[    41.834] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio2/input/input12/event7"
[    41.834] (II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD, id 11)
[    41.834] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) MinSpeed is now constant deceleration 2.5
[    41.834] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) MaxSpeed is now 1.75
[    41.834] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) AccelFactor is now 0.037
[    41.834] (**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
[    41.834] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration profile 1
[    41.834] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
[    41.834] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
[    41.834] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[    41.835] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse0)
[    41.835] (**) SynPS/2 Synaptics TouchPad: Ignoring device from InputClass "touchpad ignore duplicates"
[    41.835] (II) config/udev: Adding input device PC Speaker (/dev/input/event6)
[    41.835] (II) No input driver specified, ignoring this device.
[    41.835] (II) This device may have been added with another device file.


Last edited by qwpo1030 on Fri Apr 08, 2016 10:57 am; edited 1 time in total
Back to top
View user's profile Send private message
qwpo1030
n00b
n00b


Joined: 28 Jun 2015
Posts: 12

PostPosted: Fri Apr 08, 2016 4:43 am    Post subject: Reply with quote

problem solved. I turned off netmount at boot. The kernel waits for ethernet connection but I dont have internet so the system halts at that moment.

But, may i delete that process on boot? What is netmount?
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2583

PostPosted: Fri Apr 08, 2016 6:44 am    Post subject: Reply with quote

qwpo1030 wrote:
problem solved. I turned off netmount at boot. The kernel waits for ethernet connection but I dont have internet so the system halts at that moment.

But, may i delete that process on boot? What is netmount?

There is no need for having netmount in any runlevel unless you need or want automagical mounting of some network storage.
See https://wiki.gentoo.org/wiki/Fstab#Services
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum