Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
How to roll back to stable?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
RayDude
Veteran
Veteran


Joined: 29 May 2004
Posts: 1758
Location: San Jose, CA

PostPosted: Mon Mar 20, 2017 10:13 pm    Post subject: How to roll back to stable? Reply with quote

For people who have this problem in the future. The secret to get it to figure things out is this command. --backtrack was not enough.

Code:
emerge -DNuv --verbose-conflicts --backtrack=100 kde-apps-meta


Update: I gave up and added all the qt accept_keywords back.

I tried, and failed to roll back to stable plasma / KDE.

I'm stuck. I can't get emerge -DNuv @world to work. It says that qt ... 5.7.1 is blocking everything.

I did an emerge -DNuv --verbose-conflicts and removed everything that conflicted. But still it complains about qt 5.7.1 blocking.

Everything is interdependent. I can't find any packages that depend on QT that are still installed, yet, it still wants QT 5.7.1.

I'm going to try masking it off next...

Here's where I stand at the moment:

Code:
Total: 180 packages (30 upgrades, 149 new, 1 in new slot), Size of downloads: 226,594 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtcore:5

  (dev-qt/qtcore-5.6.2-r1:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-5.6.2 required by (dev-qt/qtquickcontrols-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                           
    ~dev-qt/qtcore-5.6.2 required by (dev-qt/qtwidgets-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                     
    ~dev-qt/qtcore-5.6.2 required by (dev-qt/designer-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                     
    ~dev-qt/qtcore-5.6.2 required by (dev-qt/qtx11extras-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                       
    ~dev-qt/qtcore-5.6.2 required by (dev-qt/qtpaths-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                   
    ~dev-qt/qtcore-5.6.2[icu] required by (dev-qt/qtwebkit-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                         
    ~dev-qt/qtcore-5.6.2 required by (dev-qt/qtgui-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                 
    ~dev-qt/qtcore-5.6.2 required by (dev-qt/qdbus-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                 
    ~dev-qt/qtcore-5.6.2 required by (dev-qt/qtdbus-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                   
    ~dev-qt/qtcore-5.6.2 required by (dev-qt/qtdeclarative-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                         
    ~dev-qt/qtcore-5.6.2 required by (dev-qt/qtconcurrent-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                         
    ~dev-qt/qtcore-5.6.2 required by (dev-qt/qttest-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                   
    ~dev-qt/qtcore-5.6.2 required by (dev-qt/qtprintsupport-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                           
    ~dev-qt/qtcore-5.6.2 required by (dev-qt/qtgraphicaleffects-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                               
    ~dev-qt/qtcore-5.6.2 required by (dev-qt/qtopengl-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                     
    ~dev-qt/qtcore-5.6.2 required by (dev-qt/qtwayland-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                     
    ~dev-qt/qtcore-5.6.2 required by (dev-qt/qtsql-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                 
    ~dev-qt/qtcore-5.6.2 required by (dev-qt/qtxmlpatterns-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                         
    ~dev-qt/qtcore-5.6.2 required by (dev-qt/qtnetwork-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                     
    ~dev-qt/qtcore-5.6.2 required by (dev-qt/qtxml-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                 
    ~dev-qt/qtcore-5.6.2 required by (dev-qt/qtscript-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                     
    ~dev-qt/qtcore-5.6.2 required by (dev-qt/qtsvg-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                 

  (dev-qt/qtcore-5.7.1-r2:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtdeclarative-5.7.1:5/5.7::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                         
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtxml-5.7.1:5/5.7::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                 
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtxmlpatterns-5.7.1:5/5.7::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                         
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/linguist-tools-5.7.1:5/5.7::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                           
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qttest-5.7.1:5/5.7::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                   
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtnetwork-5.7.1:5/5.7::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                     
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtdbus-5.7.1:5/5.7::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                   
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtgui-5.7.1:5/5.7::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                 
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtwidgets-5.7.1:5/5.7::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                     

dev-qt/qtgui:5

  (dev-qt/qtgui-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtgui-5.6.2[egl=] required by (dev-qt/qtwayland-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                           
    ~dev-qt/qtgui-5.6.2[gles2=] required by (dev-qt/qtprintsupport-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                                   
    ~dev-qt/qtgui-5.6.2 required by (dev-qt/qtquickcontrols-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                           
    ~dev-qt/qtgui-5.6.2[xcb] required by (dev-qt/qtx11extras-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                             
    ~dev-qt/qtgui-5.6.2 required by (dev-qt/qtsvg-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                 
    ~dev-qt/qtgui-5.6.2 required by (dev-qt/designer-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                     
    ~dev-qt/qtgui-5.6.2 required by (dev-qt/qtwebkit-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                     
    ~dev-qt/qtgui-5.6.2 required by (dev-qt/qtgraphicaleffects-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                               
    ~dev-qt/qtgui-5.6.2[gles2=] required by (dev-qt/qtdeclarative-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                                 
    ~dev-qt/qtgui-5.6.2 required by (dev-qt/qtscript-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                     
    ~dev-qt/qtgui-5.6.2[gles2=,gtkstyle=,png=,xcb?] required by (dev-qt/qtwidgets-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                                                 
    ~dev-qt/qtgui-5.6.2[gles2=] required by (dev-qt/qtopengl-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                             

  (dev-qt/qtgui-5.7.1:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtgui-5.7.1[gles2=,png=,xcb?] required by (dev-qt/qtwidgets-5.7.1:5/5.7::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                                       
    ~dev-qt/qtgui-5.7.1[gles2=] required by (dev-qt/qtdeclarative-5.7.1:5/5.7::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                                 

dev-qt/qtdbus:5

  (dev-qt/qtdbus-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtdbus-5.6.2 required by (dev-qt/qdbus-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                 
    ~dev-qt/qtdbus-5.6.2 required by (dev-qt/qtgui-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                 

  (dev-qt/qtdbus-5.7.1:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtdbus-5.7.1 required by (dev-qt/qtgui-5.7.1:5/5.7::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                 

dev-qt/qtdeclarative:5

  (dev-qt/qtdeclarative-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtdeclarative-5.6.2[widgets] required by (dev-qt/designer-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                                                                             
    ~dev-qt/qtdeclarative-5.6.2 required by (dev-qt/qtwebkit-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                                                                     
    ~dev-qt/qtdeclarative-5.6.2 required by (dev-qt/qtquickcontrols-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                                                                           
    ~dev-qt/qtdeclarative-5.6.2 required by (dev-qt/qtgraphicaleffects-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                                                                               

  (dev-qt/qtdeclarative-5.7.1:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtdeclarative-5.7.1 required by (dev-qt/linguist-tools-5.7.1:5/5.7::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                                                                           

dev-qt/qtxml:5

  (dev-qt/qtxml-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtxml-5.6.2 required by (dev-qt/qdbus-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                 
    ~dev-qt/qtxml-5.6.2 required by (dev-qt/designer-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                     

  (dev-qt/qtxml-5.7.1:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtxml-5.7.1 required by (dev-qt/linguist-tools-5.7.1:5/5.7::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                           

dev-qt/qtwidgets:5

  (dev-qt/qtwidgets-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtwidgets-5.6.2 required by (dev-qt/qtsvg-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                                                                 
    ~dev-qt/qtwidgets-5.6.2 required by (dev-qt/qtscript-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                                                                     
    ~dev-qt/qtwidgets-5.6.2 required by (dev-qt/designer-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                                                                     
    ~dev-qt/qtwidgets-5.6.2[gles2=] required by (dev-qt/qtprintsupport-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                                                                                   
    ~dev-qt/qtwidgets-5.6.2[gles2=] required by (dev-qt/qtopengl-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                                                                             
    ~dev-qt/qtwidgets-5.6.2[gles2=] required by (dev-qt/qtdeclarative-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                                                                                 
    ~dev-qt/qtwidgets-5.6.2 required by (dev-qt/qtquickcontrols-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                                                                           
    ~dev-qt/qtwidgets-5.6.2 required by (dev-qt/qtwebkit-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                                                                     

  (dev-qt/qtwidgets-5.7.1:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtwidgets-5.7.1[gles2=] required by (dev-qt/qtdeclarative-5.7.1:5/5.7::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                                                                                 

dev-qt/qttest:5

  (dev-qt/qttest-5.7.1:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qttest-5.7.1 required by (dev-qt/qtdeclarative-5.7.1:5/5.7::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                         

  (dev-qt/qttest-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qttest-5.6.2 required by (dev-qt/qtdeclarative-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                         

dev-qt/qtxmlpatterns:5

  (dev-qt/qtxmlpatterns-5.7.1:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtxmlpatterns-5.7.1 required by (dev-qt/qtdeclarative-5.7.1:5/5.7::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                                                                         

  (dev-qt/qtxmlpatterns-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtxmlpatterns-5.6.2 required by (dev-qt/qtdeclarative-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                                                                         

dev-qt/qtnetwork:5

  (dev-qt/qtnetwork-5.7.1:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtnetwork-5.7.1 required by (dev-qt/qtdeclarative-5.7.1:5/5.7::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                                                                         
    ~dev-qt/qtnetwork-5.7.1 required by (dev-qt/qtxmlpatterns-5.7.1:5/5.7::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                                                                         

  (dev-qt/qtnetwork-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtnetwork-5.6.2 required by (dev-qt/qtdeclarative-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                                                                         
    ~dev-qt/qtnetwork-5.6.2 required by (dev-qt/qtwebkit-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                                                                     
    ~dev-qt/qtnetwork-5.6.2 required by (dev-qt/qtxmlpatterns-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                                                                         
    ~dev-qt/qtnetwork-5.6.2 required by (dev-qt/designer-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                                                                     

dev-libs/libevent:0

  (dev-libs/libevent-2.1.8:0/2.1-6::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/libevent-2.0.22:0/0::gentoo, installed) pulled in by
    >=dev-libs/libevent-2.0.9:0/0=[threads] required by (net-misc/ntp-4.2.8_p9:0/0::gentoo, installed)
                             ^^^^^                                                                                                       
    <=dev-libs/libevent-2.1 required by (net-fs/nfs-utils-1.3.1-r5:0/0::gentoo, installed)
    ^^                  ^^^                                                                                                                     


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by dev-qt/qtgui-5.7.1::gentoo[dbus]
# required by dev-qt/qtdeclarative-5.7.1::gentoo
# required by dev-qt/linguist-tools-5.7.1::gentoo[qml]
# required by kde-frameworks/kglobalaccel-5.29.0::gentoo[nls]
# required by kde-frameworks/plasma-5.29.0::gentoo
# required by kde-frameworks/krunner-5.29.0::gentoo
# required by kde-plasma/milou-5.8.5::gentoo
# required by kde-plasma/plasma-workspace-5.8.5::gentoo
# required by virtual/notification-daemon-0::gentoo[kde]
# required by x11-libs/libnotify-0.7.6-r3::gentoo
# required by media-video/vlc-2.2.4-r1::gentoo[libnotify]
# required by media-libs/phonon-vlc-0.9.0::gentoo
# required by media-libs/phonon-4.9.0::gentoo[vlc]
# required by kde-frameworks/kdelibs-4.14.29-r1::gentoo
# required by kde-apps/katepart-4.14.3::gentoo[handbook]
=dev-qt/qtdbus-5.7.1 ~amd64
# required by dev-qt/qtdeclarative-5.7.1::gentoo[-test]
# required by dev-qt/linguist-tools-5.7.1::gentoo[qml]
# required by kde-frameworks/kglobalaccel-5.29.0::gentoo[nls]
# required by kde-frameworks/plasma-5.29.0::gentoo
# required by kde-frameworks/krunner-5.29.0::gentoo
# required by kde-plasma/milou-5.8.5::gentoo
# required by kde-plasma/plasma-workspace-5.8.5::gentoo
# required by virtual/notification-daemon-0::gentoo[kde]
# required by x11-libs/libnotify-0.7.6-r3::gentoo
# required by media-video/vlc-2.2.4-r1::gentoo[libnotify]
# required by media-libs/phonon-vlc-0.9.0::gentoo
# required by media-libs/phonon-4.9.0::gentoo[vlc]
# required by kde-frameworks/kdelibs-4.14.29-r1::gentoo
# required by kde-apps/katepart-4.14.3::gentoo[handbook]
=dev-qt/qttest-5.7.1 ~amd64
# required by dev-qt/linguist-tools-5.7.1::gentoo[qml]
# required by kde-frameworks/kglobalaccel-5.29.0::gentoo[nls]
# required by kde-frameworks/plasma-5.29.0::gentoo
# required by kde-frameworks/krunner-5.29.0::gentoo
# required by kde-plasma/milou-5.8.5::gentoo
# required by kde-plasma/plasma-workspace-5.8.5::gentoo
# required by virtual/notification-daemon-0::gentoo[kde]
# required by x11-libs/libnotify-0.7.6-r3::gentoo
# required by media-video/vlc-2.2.4-r1::gentoo[libnotify]
# required by media-libs/phonon-vlc-0.9.0::gentoo
# required by media-libs/phonon-4.9.0::gentoo[vlc]
# required by kde-frameworks/kdelibs-4.14.29-r1::gentoo
# required by kde-apps/katepart-4.14.3::gentoo[handbook]
=dev-qt/qtdeclarative-5.7.1 ~amd64
# required by dev-qt/linguist-tools-5.7.1::gentoo
# required by kde-frameworks/kglobalaccel-5.29.0::gentoo[nls]
# required by kde-frameworks/plasma-5.29.0::gentoo
# required by kde-frameworks/krunner-5.29.0::gentoo
# required by kde-plasma/milou-5.8.5::gentoo
# required by kde-plasma/plasma-workspace-5.8.5::gentoo
# required by virtual/notification-daemon-0::gentoo[kde]
# required by x11-libs/libnotify-0.7.6-r3::gentoo
# required by media-video/vlc-2.2.4-r1::gentoo[libnotify]
# required by media-libs/phonon-vlc-0.9.0::gentoo
# required by media-libs/phonon-4.9.0::gentoo[vlc]
# required by kde-frameworks/kdelibs-4.14.29-r1::gentoo
# required by kde-apps/katepart-4.14.3::gentoo[handbook]
=dev-qt/qtxml-5.7.1 ~amd64
# required by dev-qt/qtdeclarative-5.7.1::gentoo
# required by dev-qt/linguist-tools-5.7.1::gentoo[qml]
# required by kde-frameworks/kglobalaccel-5.29.0::gentoo[nls]
# required by kde-frameworks/plasma-5.29.0::gentoo
# required by kde-frameworks/krunner-5.29.0::gentoo
# required by kde-plasma/milou-5.8.5::gentoo
# required by kde-plasma/plasma-workspace-5.8.5::gentoo
# required by virtual/notification-daemon-0::gentoo[kde]
# required by x11-libs/libnotify-0.7.6-r3::gentoo
# required by media-video/vlc-2.2.4-r1::gentoo[libnotify]
# required by media-libs/phonon-vlc-0.9.0::gentoo
# required by media-libs/phonon-4.9.0::gentoo[vlc]
# required by kde-frameworks/kdelibs-4.14.29-r1::gentoo
# required by kde-apps/katepart-4.14.3::gentoo[handbook]
=dev-qt/qtgui-5.7.1 ~amd64
# required by dev-qt/qtdbus-5.7.1::gentoo
# required by dev-qt/qtgui-5.7.1::gentoo[dbus]
# required by dev-qt/qtdeclarative-5.7.1::gentoo
# required by dev-qt/linguist-tools-5.7.1::gentoo[qml]
# required by kde-frameworks/kglobalaccel-5.29.0::gentoo[nls]
# required by kde-frameworks/plasma-5.29.0::gentoo
# required by kde-frameworks/krunner-5.29.0::gentoo
# required by kde-plasma/milou-5.8.5::gentoo
# required by kde-plasma/plasma-workspace-5.8.5::gentoo
# required by virtual/notification-daemon-0::gentoo[kde]
# required by x11-libs/libnotify-0.7.6-r3::gentoo
# required by media-video/vlc-2.2.4-r1::gentoo[libnotify]
# required by media-libs/phonon-vlc-0.9.0::gentoo
# required by media-libs/phonon-4.9.0::gentoo[vlc]
# required by kde-frameworks/kdelibs-4.14.29-r1::gentoo
# required by kde-apps/katepart-4.14.3::gentoo[handbook]
=dev-qt/qtcore-5.7.1-r2 ~amd64
# required by dev-qt/qtdeclarative-5.7.1::gentoo[xml]
# required by dev-qt/linguist-tools-5.7.1::gentoo[qml]
# required by kde-frameworks/kglobalaccel-5.29.0::gentoo[nls]
# required by kde-frameworks/plasma-5.29.0::gentoo
# required by kde-frameworks/krunner-5.29.0::gentoo
# required by kde-plasma/milou-5.8.5::gentoo
# required by kde-plasma/plasma-workspace-5.8.5::gentoo
# required by virtual/notification-daemon-0::gentoo[kde]
# required by x11-libs/libnotify-0.7.6-r3::gentoo
# required by media-video/vlc-2.2.4-r1::gentoo[libnotify]
# required by media-libs/phonon-vlc-0.9.0::gentoo
# required by media-libs/phonon-4.9.0::gentoo[vlc]
# required by kde-frameworks/kdelibs-4.14.29-r1::gentoo
# required by kde-apps/katepart-4.14.3::gentoo[handbook]
=dev-qt/qtnetwork-5.7.1 ~amd64
# required by dev-qt/qtdeclarative-5.7.1::gentoo[widgets]
# required by dev-qt/linguist-tools-5.7.1::gentoo[qml]
# required by kde-frameworks/kglobalaccel-5.29.0::gentoo[nls]
# required by kde-frameworks/plasma-5.29.0::gentoo
# required by kde-frameworks/krunner-5.29.0::gentoo
# required by kde-plasma/milou-5.8.5::gentoo
# required by kde-plasma/plasma-workspace-5.8.5::gentoo
# required by virtual/notification-daemon-0::gentoo[kde]
# required by x11-libs/libnotify-0.7.6-r3::gentoo
# required by media-video/vlc-2.2.4-r1::gentoo[libnotify]
# required by media-libs/phonon-vlc-0.9.0::gentoo
# required by media-libs/phonon-4.9.0::gentoo[vlc]
# required by kde-frameworks/kdelibs-4.14.29-r1::gentoo
# required by kde-apps/katepart-4.14.3::gentoo[handbook]
=dev-qt/qtwidgets-5.7.1 ~amd64
# required by dev-qt/qtdeclarative-5.7.1::gentoo[xml]
# required by dev-qt/linguist-tools-5.7.1::gentoo[qml]
# required by kde-frameworks/kglobalaccel-5.29.0::gentoo[nls]
# required by kde-frameworks/plasma-5.29.0::gentoo
# required by kde-frameworks/krunner-5.29.0::gentoo
# required by kde-plasma/milou-5.8.5::gentoo
# required by kde-plasma/plasma-workspace-5.8.5::gentoo
# required by virtual/notification-daemon-0::gentoo[kde]
# required by x11-libs/libnotify-0.7.6-r3::gentoo
# required by media-video/vlc-2.2.4-r1::gentoo[libnotify]
# required by media-libs/phonon-vlc-0.9.0::gentoo
# required by media-libs/phonon-4.9.0::gentoo[vlc]
# required by kde-frameworks/kdelibs-4.14.29-r1::gentoo
# required by kde-apps/katepart-4.14.3::gentoo[handbook]
=dev-qt/qtxmlpatterns-5.7.1 ~amd64

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.

_________________
Some day there will only be free software.
Back to top
View user's profile Send private message
Syl20
Guru
Guru


Joined: 04 Aug 2005
Posts: 569
Location: France

PostPosted: Tue Mar 21, 2017 1:10 pm    Post subject: Reply with quote

Add "-t" (or "--tree") to your emerge command, to see which package wants which version.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 8221
Location: Austria

PostPosted: Tue Mar 21, 2017 1:13 pm    Post subject: Reply with quote

Don't ever downgrade Qt.

Also, Qt-5.7.1 is fine, just keep a package.keywords file around for it.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
RayDude
Veteran
Veteran


Joined: 29 May 2004
Posts: 1758
Location: San Jose, CA

PostPosted: Tue Mar 21, 2017 4:23 pm    Post subject: Reply with quote

asturm wrote:
Don't ever downgrade Qt.

Also, Qt-5.7.1 is fine, just keep a package.keywords file around for it.


I agree QT is fine. It's the latest version of plasma that I dislike. I was able to downgrade that.

My latest problem is mythtv can't find opengl... I actually found the define it can't find in /usr/include.

Oh well, just keep swimming...
_________________
Some day there will only be free software.
Back to top
View user's profile Send private message
RayDude
Veteran
Veteran


Joined: 29 May 2004
Posts: 1758
Location: San Jose, CA

PostPosted: Tue Mar 21, 2017 4:25 pm    Post subject: Reply with quote

Syl20 wrote:
Add "-t" (or "--tree") to your emerge command, to see which package wants which version.


Thanks. I'll try that next time.
_________________
Some day there will only be free software.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 8221
Location: Austria

PostPosted: Tue Mar 21, 2017 4:29 pm    Post subject: Reply with quote

RayDude wrote:
It's the latest version of plasma that I dislike. I was able to downgrade that.


Out of curiosity, why? I don't see the difference.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
RayDude
Veteran
Veteran


Joined: 29 May 2004
Posts: 1758
Location: San Jose, CA

PostPosted: Tue Mar 21, 2017 5:51 pm    Post subject: Reply with quote

asturm wrote:
RayDude wrote:
It's the latest version of plasma that I dislike. I was able to downgrade that.


Out of curiosity, why? I don't see the difference.


The scroll bars are broken on some apps.

The new logo triggers my Trypophobia.
_________________
Some day there will only be free software.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 8221
Location: Austria

PostPosted: Tue Mar 21, 2017 6:32 pm    Post subject: Reply with quote

Can you give examples? I haven't seen that.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
RayDude
Veteran
Veteran


Joined: 29 May 2004
Posts: 1758
Location: San Jose, CA

PostPosted: Tue Mar 21, 2017 7:05 pm    Post subject: Reply with quote

asturm wrote:
Can you give examples? I haven't seen that.


I still have this version on my laptop:

Code:
equery list plasma-meta
 * Searching for plasma-meta ...
[IP-] [  ] kde-plasma/plasma-meta-5.9.3:5


Image of bad scroll bars here:
http://imgur.com/a/7j7Cf

There are no arrows, so they are hard to find. I can't get multi-touch to work on my laptops touch pad so I'm stuck using the scroll bars and ... it's a bit of a bummer.

As for the Trypophobia... I have changed all the logos away from their default. Let me see if I can find it online.

Here it is: https://www.kde.org/announcements/plasma5.0/plasma-5-banner.png

The dots in the logo trigger it every so slightly and it's an ugly logo anyway.

Do not google trypophobia if you have it. Holy crap...
_________________
Some day there will only be free software.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 8221
Location: Austria

PostPosted: Tue Mar 21, 2017 7:19 pm    Post subject: Reply with quote

You can change the logo.

You can re-enable the scrollbar buttons.
systemsettings -> widget style -> [breeze] configure -> scrollbars:
top arrow button type [no buttons|one|two]
bottom arrow type [no buttons|one|two]
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
RayDude
Veteran
Veteran


Joined: 29 May 2004
Posts: 1758
Location: San Jose, CA

PostPosted: Tue Mar 21, 2017 7:27 pm    Post subject: Reply with quote

asturm wrote:
You can change the logo.

You can re-enable the scrollbar buttons.
systemsettings -> widget style -> [breeze] configure -> scrollbars:
top arrow button type [no buttons|one|two]
bottom arrow type [no buttons|one|two]


Thanks. I have changed the logos. Too bad there isn't any installed to choose from. I had to download a png from the internet.

I didn't know about controlling the scroll bars. I just changed it. Thanks!
_________________
Some day there will only be free software.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum