Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ solved]err connection timed out
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Eimantas
n00b
n00b


Joined: 30 Mar 2016
Posts: 4

PostPosted: Wed Apr 06, 2016 2:45 pm    Post subject: [ solved]err connection timed out Reply with quote

Hi everybody I'm running lighttpd web server(website) but I have encountered a problem.
When I try to access it from school internet using Google chrome I get err connection timed out,I tried using other browsers but it did't work neither.Also my father reported that he can't access it from public wifi neither But strangely once I send the link
to my friends or other people they report that website is working,also I can access it from my home network.


Here is some information

http://www.yougetsignal.com/tools/open-ports/ website reports that ports are open.

I'm using ADB Broadband for hosting

here is my lighttpd.conf file
server.modules = (
"mod_access",
"mod_alias",
"mod_compress",

"mod_redirect",
# "mod_rewrite",
)

server.document-root = "/Afinity"
server.upload-dirs = ( "/var/cache/lighttpd/uploads" )
server.errorlog = "/var/log/lighttpd/error.log"
server.pid-file = "/var/run/lighttpd.pid"
server.username = "eimantas"
server.groupname = "eimantas"
server.port = 2016


index-file.names = ( "index.php", "index.html", "index.lighttpd.html" )
url.access-deny = ( "~", ".inc" )
static-file.exclude-extensions = ( ".php", ".pl", ".fcgi" )

#compress.cache-dir = "/var/cache/lighttpd/compress/"
#compress.filetype = ( "application/javascript", "text/css", "text/html", "text/plain" )

# default listening port for IPv6 falls back to the IPv4 port
include_shell "/usr/share/lighttpd/use-ipv6.pl " + server.port
include_shell "/usr/share/lighttpd/create-mime.assign.pl"
include_shell "/usr/share/lighttpd/include-conf-enabled.pl"


website adress is 78.56.107.42:2016


Last edited by Eimantas on Mon Apr 11, 2016 8:50 am; edited 1 time in total
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Wed Apr 06, 2016 3:43 pm    Post subject: Re: err connection timed out while trying to access my websi Reply with quote

Eimantas wrote:
When I try to access it from school internet using Google chrome I get err connection timed out,I tried using other browsers but it did't work neither.Also my father reported that he can't access it from public wifi neither But strangely once I send the link to my friends or other people they report that website is working,also I can access it from my home network.

Eimantas ... this all suggests that your school, and the public wifi, don't allow traffic to port 2016 (something common for both school networks, and public wifi) ... but your friends are on networks that do. Use port 80 or port 8080, these are both standard http ports and so traffic will pass whatever port restrictions are in place in the above locations.

best ... khay
Back to top
View user's profile Send private message
Eimantas
n00b
n00b


Joined: 30 Mar 2016
Posts: 4

PostPosted: Wed Apr 06, 2016 3:49 pm    Post subject: Thanks for the answer Reply with quote

Thanks for the answer.I'l mark it as solved if it will work.
Back to top
View user's profile Send private message
Eimantas
n00b
n00b


Joined: 30 Mar 2016
Posts: 4

PostPosted: Thu Apr 07, 2016 3:00 pm    Post subject: It didn't worked Reply with quote

I tried switching to port 8080 but it still doesn't work
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Thu Apr 07, 2016 8:36 pm    Post subject: Re: It didn't worked Reply with quote

Eimantas wrote:
I tried switching to port 8080 but it still doesn't work

Eimantas ... "doesn't work" is not a description of a problem, information is key in asking for help with such issues.

best ... khay
Back to top
View user's profile Send private message
Eimantas
n00b
n00b


Joined: 30 Mar 2016
Posts: 4

PostPosted: Mon Apr 11, 2016 8:51 am    Post subject: Reply with quote

I switched to port 80 and now it works
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum