Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
How to get rid of highlighted paste in xterm
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
nickk
n00b
n00b


Joined: 04 Jun 2009
Posts: 36

PostPosted: Tue Apr 05, 2016 12:39 pm    Post subject: How to get rid of highlighted paste in xterm Reply with quote

Hi.

After some system updates i've faced with the problem with highlighting paste in xterm. In freshly started xterm copy and paste works fine, but after some actions (cant identify which ones, usually i work in mc within xterm, run some utils like ssh, grep, diff etc, switch between different xterm and other X windows) any paste from clipboard in xterm comes highlighted : i.e. when i paste
Code:
text
, i get
Code:
200~text201~
instead of
Code:
text
How to get rid of this?
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7051
Location: almost Mile High in the USA

PostPosted: Wed Apr 06, 2016 4:57 pm    Post subject: Reply with quote

Are you using xterm or some variant that looks like xterm (vte? aterm?)

Just want to make sure, I've never seen this behavior before from xterm...
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
nickk
n00b
n00b


Joined: 04 Jun 2009
Posts: 36

PostPosted: Thu Apr 07, 2016 9:28 am    Post subject: Reply with quote

Yes, i use xterm. Currently installed version is x11-terms/xterm-320
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Thu Apr 07, 2016 11:15 am    Post subject: Re: How to get rid of highlighted paste in xterm Reply with quote

nickk wrote:
i.e. when i paste 'text', i get '200~text201~' [...] How to get rid of this?

nickk ... what you are seeing is bracketed paste mode (more details here). Xterm supports this, but it would seem bash/readline doesn't (this post/thread suggests it won't be available until readline 7.0).

I suspect there is some xresource to disable this xterm feature (though I didn't find anything on a brief search), so you either do that or switch to a shell (such as zsh) that supports this.

best ... khay
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum