Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Two minor Plasma 5 issues
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
BastiL
n00b
n00b


Joined: 15 Aug 2004
Posts: 20

PostPosted: Sat Apr 02, 2016 8:37 am    Post subject: Two minor Plasma 5 issues Reply with quote

Hello,

after my upgrade to Plasma 5 which finally was sucessfull I have two minor issues:

- WLAN is not connecting automatically. I am asked to open "kwallet" by entering a password. I never configured it and therefore have no password for it ... After cancel I can enter the WLAN password manually, but I need to do it every time.
- Keyboard is set to US every time after start even if I define German layout as prefered one. I need to switch it manually in the taskbar.

Thanks for some hints.
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1763
Location: United Kingdom

PostPosted: Sat Apr 02, 2016 12:43 pm    Post subject: Reply with quote

Do you mean the keyboard in the SDDM Desktop Manager?

I am using Plasma 5 in Gentoo Linux ~amd64 with OpenRC on my Compal NBLB2 laptop. The Display Manager I am using is SDDM, and the log-in screen was using the US keyboard layout, the only keyboard layout available in the log-in screen’s keyboard menu. Searching the Web told me that SDDM uses the keyboard layout specified in the file /etc/X11/xorg.conf.d/00-keyboard.conf. The trouble is, it doesn’t (at least not in my case). The file already existed in my installation, and its contents are listed below:

Code:
Section "InputClass"
    Identifier "keyboard"
    MatchIsKeyboard "yes"
    Option "XkbLayout" "gb,us,br,es"
    Option "XkbVariant" ""
    Option "XkbOptions" "grp:alt_shift_toggle"
EndSection


The X.Org keyboard layouts specified in the file are available once I have logged in to the Plasma 5 Desktop, but none of the four keyboards that I use (gb, us, br and es) were displayed by SDDM in its log-in screen menu. Eventually I discovered it is possible to specify the keyboard layouts in the file /usr/share/sddm/scripts/Xsetup which, by default, contains only the following:

Code:
#!/bin/sh
# Xsetup - run as root before the login dialog appears


I edited the file to contain the list of keyboards I wanted SDDM to allow me to choose from on the log-in screen:

Code:
#!/bin/sh
# Xsetup - run as root before the login dialog appears
setxkbmap gb,us,br,es


Now the SDDM log-in screen displays the national flags of those four keyboard languages in its keyboard menu, and I can select which keyboard layout to use for typing my password to log in to the Plasma 5 Desktop.
_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
BastiL
n00b
n00b


Joined: 15 Aug 2004
Posts: 20

PostPosted: Sat Apr 02, 2016 9:44 pm    Post subject: Reply with quote

No, I mean Plasma itself. It has the US layout even I defined the German one as the prefered. I alway have to switch this manually by the task bar symbol.
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1763
Location: United Kingdom

PostPosted: Tue Apr 05, 2016 9:35 pm    Post subject: Reply with quote

I don't have that problem with KDE Plasma 5, so I'll list here how my installation is configured in case it gives you any clues. If none of that helps, at the end of this post I give a work-around that should achieve the desired effect.

1. 'System Settings' > 'Hardware' > 'Input Devices'

a) 'Keyboard' in left pane > 'Layouts' tab

'Configure layouts' is ticked.

My preferred keyboard layout ('gb' in my case) is at the top of the list. I have the following keyboard layouts listed, as those are the keyboards I specified:

gb
us
br
es

b) 'Keyboard' in left pane > 'Advanced' tab

'Switching to another layout' is ticked, and, under that, 'Alt+Shift' is ticked.

2. I have both kde-apps/kde-l10n and kde-apps/kde4-l10n installed (I suppose some KDE 4 packages must have pulled the latter in).

3. My X11 keyboard configuration is in the directory /etc/X11/xorg.conf.d/ and I edited it to contain the same keyboards that I specified via the System Settings GUI in Plasma 5:

Code:
fitzcarraldo@meshedgedx ~ $ cat /etc/X11/xorg.conf
Section "ServerLayout"                                                                                                                                   
        Identifier     "Main Layout"                                                                                                                     
        Screen      0  "aticonfig-Screen[0]-0" 0 0                                                                                                       
EndSection                                                                                                                                               
                                                                                                                                                         
Section "Module"                                                                                                                                         
        Load  "vbe"                                                                                                                                     
EndSection                                                                                                                                               
                                                                                                                                                         
Section "ServerFlags"                                                                                                                                   
        Option      "AllowMouseOpenFail" "true"
EndSection

Section "Monitor"
        Identifier   "aticonfig-Monitor[0]-0"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
EndSection

Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        BusID       "PCI:1:0:0"
EndSection

Section "Screen"
        Identifier "aticonfig-Screen[0]-0"
        Device     "aticonfig-Device[0]-0"
        Monitor    "aticonfig-Monitor[0]-0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection

Section "DRI"
        Mode         0666
EndSection


Code:
fitzcarraldo@meshedgedx ~ $ cat /etc/X11/xorg.conf.d/00-keyboard.conf
Section "InputClass"
    Identifier "keyboard"
    MatchIsKeyboard "yes"
    Option "XkbLayout" "gb,us,br,es"
    Option "XkbVariant" ""
    Option "XkbOptions" "grp:alt_shift_toggle"
EndSection


4. For the console, I specified my preferred keyboard layout in /etc/conf.d/keymaps:

Code:
fitzcarraldo@meshedgedx ~ $ grep keymap /etc/conf.d/keymaps
# Use keymap to specify the default console keymap.  There is a complete tree
# of keymaps in /usr/share/keymaps to choose from.
keymap="uk"
# Should we first load the 'windowkeys' console keymap?  Most x86 users will
# Loading this keymap will enable VT switching (like ALT+Left/Right)
extended_keymaps=""
#extended_keymaps="backspace keypad euro2"


5. I have set up my locale for my preferred language (which coincides with my preferred keyboard layout):

Code:
fitzcarraldo@meshedgedx ~ $ locale
LANG=en_GB.UTF-8
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY="en_GB.UTF-8"
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"
LC_IDENTIFICATION="en_GB.UTF-8"
LC_ALL=en_GB.UTF-8


6. The file /usr/share/sddm/scripts/Xsetup contains the list of keyboard layouts I use:

Code:
#!/bin/sh
# Xsetup - run as root before the login dialogue appears
setxkbmap gb,us,br,es


If you still cannot find the cause of your problem, you could create a simple Bash script that uses the setxkbmap command to set the keyboard layout to the one you want to use, and specify that script to run when you login to Plasma 5 ('System Settings' > 'Startup and Shutdown', 'Autostart' in left pane > 'Add Script...'). In my installation that does switch the layout shown on the Panel to the one specified by the command.

Code:
#!/bin/bash
setxkbmap de

_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
davidm
Guru
Guru


Joined: 26 Apr 2009
Posts: 557
Location: US

PostPosted: Thu Apr 07, 2016 11:20 pm    Post subject: Re: Two minor Plasma 5 issues Reply with quote

BastiL wrote:
Hello,

after my upgrade to Plasma 5 which finally was sucessfull I have two minor issues:

- WLAN is not connecting automatically. I am asked to open "kwallet" by entering a password. I never configured it and therefore have no password for it ... After cancel I can enter the WLAN password manually, but I need to do it every time.


It's been a while since I messed with wlan and kwallet but I believe you can just set it to a blank password and it will no longer hassle you.
Back to top
View user's profile Send private message
BastiL
n00b
n00b


Joined: 15 Aug 2004
Posts: 20

PostPosted: Mon Apr 11, 2016 7:45 pm    Post subject: Reply with quote

Well for me a blank password does not work.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum