Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
libreoffice-bin bus error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
PhiJ
Apprentice
Apprentice


Joined: 20 Dec 2005
Posts: 173
Location: UK

PostPosted: Sat Mar 26, 2016 8:35 pm    Post subject: libreoffice-bin bus error Reply with quote

Hi all,
I've just updated my system (including the usual crash half way through), and now libreoffice-bin doesn't work. The logo comes up, but then it just quits, and the terminal reports 'bus error'. I'm not sure what to do.

Info:
I have app-office/libreoffice-bin-5.0.5.2-r1.

This sounds like the kind of problem strace might help with? In case it's useful, the end of the output is here:
Code:
poll([{fd=3, events=POLLIN|POLLOUT}], 1, 4294967295) = 1 ([{fd=3, revents=POLLOUT}])
writev(3, [{"SRR\0]\\\\\0WVV\0\340\340\340\0\356\356\356\0\356\356\356\0\356\356\356\0\356\356\356\0"..., 41520}, {"", 0}], 2) = 41520
poll([{fd=3, events=POLLIN|POLLOUT}], 1, 4294967295) = 1 ([{fd=3, revents=POLLOUT}])
writev(3, [{"H\2\20<\3\0\0\2\4\0\0\2\22\2\35\0\0\0q\1\0\30\0\0", 24}, {"\254\254\254\0\254\254\254\0\254\254\254\0\255\255\255\0\255\255\255\0\255\255\255\0\255\255\255\0\255\255\255\0"..., 61480}, {"", 0}], 3) = 61504
munmap(0x7fadb932a000, 847872)          = 0
poll([{fd=3, events=POLLIN|POLLOUT}], 1, 4294967295) = 1 ([{fd=3, revents=POLLOUT}])
writev(3, [{"\2\2\4\0\1\0\0\2\1\0\0\0\3\0\0\2<\0\2\0\4\0\0\0026\0\2\0\3\0\0\2"..., 112}, {NULL, 0}, {"", 0}], 3) = 112
recvmsg(3, 0x7fff3d9e0470, 0)           = -1 EAGAIN (Resource temporarily unavailable)
recvmsg(3, 0x7fff3d9e0460, 0)           = -1 EAGAIN (Resource temporarily unavailable)
open("/usr/lib64/libreoffice/program/pagein-common", O_RDONLY) = 4
fstat(4, {st_mode=S_IFREG|0644, st_size=330, ...}) = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7fadbccde000
read(4, "libmergedlo.so\nlibi18nlangtag.so"..., 4096) = 330
open("/usr/lib64/libreoffice/program/libmergedlo.so", O_RDONLY) = 5
fstat(5, {st_mode=S_IFREG|0755, st_size=63599848, ...}) = 0
mmap(NULL, 63599848, PROT_READ, MAP_PRIVATE, 5, 0) = 0x7fadb5751000
close(5)                                = 0
madvise(0x7fadb5751000, 63599848, MADV_WILLNEED) = 0
--- SIGBUS {si_signo=SIGBUS, si_code=BUS_ADRERR, si_addr=0x7fadb59c2000} ---
+++ killed by SIGBUS +++


Any ideas? Any more information you'd like?
Back to top
View user's profile Send private message
Simdol
n00b
n00b


Joined: 27 Mar 2016
Posts: 11

PostPosted: Wed Mar 30, 2016 3:28 am    Post subject: Re: libreoffice-bin bus error Reply with quote

PhiJ wrote:
Hi all,
I've just updated my system (including the usual crash half way through), and now libreoffice-bin doesn't work. The logo comes up, but then it just quits, and the terminal reports 'bus error'. I'm not sure what to do.

Info:
I have app-office/libreoffice-bin-5.0.5.2-r1.

This sounds like the kind of problem strace might help with? In case it's useful, the end of the output is here:
Code:
poll([{fd=3, events=POLLIN|POLLOUT}], 1, 4294967295) = 1 ([{fd=3, revents=POLLOUT}])
writev(3, [{"SRR\0]\\\\\0WVV\0\340\340\340\0\356\356\356\0\356\356\356\0\356\356\356\0\356\356\356\0"..., 41520}, {"", 0}], 2) = 41520
poll([{fd=3, events=POLLIN|POLLOUT}], 1, 4294967295) = 1 ([{fd=3, revents=POLLOUT}])
writev(3, [{"H\2\20<\3\0\0\2\4\0\0\2\22\2\35\0\0\0q\1\0\30\0\0", 24}, {"\254\254\254\0\254\254\254\0\254\254\254\0\255\255\255\0\255\255\255\0\255\255\255\0\255\255\255\0\255\255\255\0"..., 61480}, {"", 0}], 3) = 61504
munmap(0x7fadb932a000, 847872)          = 0
poll([{fd=3, events=POLLIN|POLLOUT}], 1, 4294967295) = 1 ([{fd=3, revents=POLLOUT}])
writev(3, [{"\2\2\4\0\1\0\0\2\1\0\0\0\3\0\0\2<\0\2\0\4\0\0\0026\0\2\0\3\0\0\2"..., 112}, {NULL, 0}, {"", 0}], 3) = 112
recvmsg(3, 0x7fff3d9e0470, 0)           = -1 EAGAIN (Resource temporarily unavailable)
recvmsg(3, 0x7fff3d9e0460, 0)           = -1 EAGAIN (Resource temporarily unavailable)
open("/usr/lib64/libreoffice/program/pagein-common", O_RDONLY) = 4
fstat(4, {st_mode=S_IFREG|0644, st_size=330, ...}) = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7fadbccde000
read(4, "libmergedlo.so\nlibi18nlangtag.so"..., 4096) = 330
open("/usr/lib64/libreoffice/program/libmergedlo.so", O_RDONLY) = 5
fstat(5, {st_mode=S_IFREG|0755, st_size=63599848, ...}) = 0
mmap(NULL, 63599848, PROT_READ, MAP_PRIVATE, 5, 0) = 0x7fadb5751000
close(5)                                = 0
madvise(0x7fadb5751000, 63599848, MADV_WILLNEED) = 0
--- SIGBUS {si_signo=SIGBUS, si_code=BUS_ADRERR, si_addr=0x7fadb59c2000} ---
+++ killed by SIGBUS +++


Any ideas? Any more information you'd like?


Since you've just updated your system, you might as well just compile LibreOffice (I know, it takes ages but it worked for me.) as I am currently globally using '~amd64' accept_keyword flag, and the LibreOffice does not support the latest version of Gentoo with '~arch' system. https://wiki.gentoo.org/wiki/LibreOffice

As for as I know, you may have some outdated binaries in your system that may have caused that issue. Try fully updating your system (emerge --update --deep --with-bdeps=y --newuse @world), check your USE flag, and rebuild the reverse dependencies by revdep-rebuild. If this does not work, like I mentioned, try compiling the LibreOffice.

Good luck,
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum