Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Red text in Firefox on some web and GUI elements
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
equeim
n00b
n00b


Joined: 14 Jun 2014
Posts: 19

PostPosted: Tue Mar 22, 2016 7:11 pm    Post subject: [SOLVED] Red text in Firefox on some web and GUI elements Reply with quote

Screenshots: http://imgur.com/a/bZmXV
Code:
emerge -pv www-client/firefox

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] www-client/firefox-45.0.1::gentoo  USE="dbus ffmpeg gtk3 hwaccel jemalloc3 jit startup-notification system-icu system-jpeg system-libevent system-libvpx system-sqlite -bindist -custom-cflags -custom-optimization -debug -gmp-autoupdate -gstreamer -gstreamer-0 -hardened (-neon) (-pgo) -pulseaudio (-selinux) -system-cairo {-test} -wifi" LINGUAS="ru -af -ar -as -ast -be -bg -bn_BD -bn_IN -br -bs -ca -cs -cy -da -de -el -en_GB -en_ZA -eo -es_AR -es_CL -es_ES -es_MX -et -eu -fa -fi -fr -fy_NL -ga_IE -gd -gl -gu_IN -he -hi_IN -hr -hu -hy_AM -id -is -it -ja -kk -km -kn -ko -lt -lv -mai -mk -ml -mr -nb_NO -nl -nn_NO -or -pa_IN -pl -pt_BR -pt_PT -rm -ro -si -sk -sl -son -sq -sr -sv_SE -ta -te -th -tr -uk -vi -xh -zh_CN -zh_TW" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB

emerge --info: http://pastebin.com/rhSpijAD

This happens also on clean profile and with official Firefox builds.


Last edited by equeim on Wed Mar 23, 2016 3:24 pm; edited 1 time in total
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2583

PostPosted: Tue Mar 22, 2016 7:25 pm    Post subject: Reply with quote

Did you forget setting all dom.disable stuff to true in about:config?
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5592

PostPosted: Tue Mar 22, 2016 7:29 pm    Post subject: Reply with quote

Try with USE="-hwaccel" - it's known to be pretty buggy in firefox.
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Tue Mar 22, 2016 7:42 pm    Post subject: Reply with quote

Ant P. wrote:
Try with USE="-hwaccel" - it's known to be pretty buggy in firefox.

Ant ... I think that can be disabled in Perference => Advanced => Use hardware acceleration when available. The OP might try unchecking this before recompiling with the use change.

best ... khay
Back to top
View user's profile Send private message
equeim
n00b
n00b


Joined: 14 Jun 2014
Posts: 19

PostPosted: Tue Mar 22, 2016 9:39 pm    Post subject: Reply with quote

charles17 wrote:
Did you forget setting all dom.disable stuff to true in about:config?

All these options are set to their defaults.

Ant P. wrote:
Try with USE="-hwaccel" - it's known to be pretty buggy in firefox.

Didn't help. I have tried to disable hardware acceleration in settings and then rebuilt with USE="-hwaccel". Also tried official build. No effect except that Firefox became slower.
Also, if it is buggy, why it enabled by default? Official Firefox builds also compiled with this option enabled.

It seems that it is not related to Firefox (and kernel, I have tried to boot with Arch Linux kernel, no changes).

Code:
emerge -pv media-libs/mesa

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] media-libs/mesa-11.1.2-r1::gentoo  USE="dri3 egl gallium gbm llvm nptl udev vaapi wayland -bindist -classic -d3d9 -debug -gles1 -gles2 -opencl -openmax -osmesa -pax_kernel -pic (-selinux) -vdpau -xa -xvmc" ABI_X86="(64) -32 (-x32)" VIDEO_CARDS="radeonsi (-freedreno) -i915 -i965 -ilo -intel -nouveau -r100 -r200 -r300 -r600 -radeon -vmware" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2583

PostPosted: Wed Mar 23, 2016 5:59 am    Post subject: Reply with quote

equeim wrote:
charles17 wrote:
Did you forget setting all dom.disable stuff to true in about:config?

All these options are set to their defaults.

So there is good chance the red color is pushed in by some ugly js cruft on the web pages you are visiting. How is with js disabled?
Back to top
View user's profile Send private message
equeim
n00b
n00b


Joined: 14 Jun 2014
Posts: 19

PostPosted: Wed Mar 23, 2016 10:05 am    Post subject: Reply with quote

charles17 wrote:
So there is good chance the red color is pushed in by some ugly js cruft on the web pages you are visiting. How is with js disabled?

Didn't help. Firefox location bar text is also red when it's empty. So this is not about web pages (and they look fine on other systems).

I think there is something with my system libraries. I tried to rebuild all graphics stack (mesa, xorg etc.) but nothing has changed.
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2583

PostPosted: Wed Mar 23, 2016 11:34 am    Post subject: Reply with quote

Sounds strage. Could you post firefox' about:buildconfig for us to compare? And, did you try another wm?
Back to top
View user's profile Send private message
equeim
n00b
n00b


Joined: 14 Jun 2014
Posts: 19

PostPosted: Wed Mar 23, 2016 12:03 pm    Post subject: Reply with quote

buildconfig: http://imgur.com/RXV9uJF
I have tried to run Firefox in plain X (by putting "exec firefox" in .xinitrc), no changes.
Back to top
View user's profile Send private message
jyelloz
n00b
n00b


Joined: 14 Jan 2004
Posts: 28

PostPosted: Wed Mar 23, 2016 3:06 pm    Post subject: Reply with quote

I have experienced this too. I'm using an AMD graphics card with open source drivers. It seems to have been caused by =x11-base/xorg-server-1.18.2 . I just masked that package and automatically downgraded to 1.18.1 and things are back to normal for me.
Back to top
View user's profile Send private message
equeim
n00b
n00b


Joined: 14 Jun 2014
Posts: 19

PostPosted: Wed Mar 23, 2016 3:24 pm    Post subject: Reply with quote

jyelloz wrote:
I have experienced this too. I'm using an AMD graphics card with open source drivers. It seems to have been caused by =x11-base/xorg-server-1.18.2 . I just masked that package and automatically downgraded to 1.18.1 and things are back to normal for me.

Thanks, this solved the issue!
Back to top
View user's profile Send private message
jamesawagner3
n00b
n00b


Joined: 01 Apr 2016
Posts: 1

PostPosted: Fri Apr 01, 2016 6:03 pm    Post subject: Reply with quote

This also happens on Debian with xserver-xorg-core 1.18.2 as well. Clearly it affects multiple users. I've googled around but not found anything. Has anyone alredy filed this bug either directly in Gentoo, or upstream?
Back to top
View user's profile Send private message
xming
Guru
Guru


Joined: 02 Jul 2002
Posts: 441

PostPosted: Sat Apr 02, 2016 7:03 pm    Post subject: Reply with quote

here is the fix https://cgit.freedesktop.org/xorg/xserver/commit/?h=server-1.18-branch&id=fb8ddcf1cb0f47257370c3d6a895a5a41bea8dc0
_________________
http://wojia.be
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum