Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
PBM: can't change keyboard layout under lightdm
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4974
Location: Dark side of the mood

PostPosted: Sun Mar 20, 2016 11:06 am    Post subject: PBM: can't change keyboard layout under lightdm Reply with quote

Hi all.

I've changed my Logitech wireless keyboard recently, from model 220 (IIRC) to K330. They're both AZERTY. Since I plugged in the new K330 lightdm sticks on QWERTY layout and I have no indication why and what layout it chooses. I have a drop down menu in lightdm that allows me to select between fr_BE, fr_FR, en_US and en_GB (all are UTF8). Just that since I have changed my keyboard that menu does nothing and my keyboard layout is stuck with an English layout. And I have changed none of my configuration parameters before — why would I have had to since everything was running fine!

So here's my Xorg input configuration:
/etc/X11/xorg.conf.d/10-input.conf:
Section "InputClass"
        Identifier "evdev keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
        Option "XkbModel" "pc104"
        Option "XkbLayout" "be"
EndSection

Here's my locale.gen file:
/etc/locale.gen:
en_US      ISO-8859-1
en_US.UTF-8   UTF-8
en_GB      ISO-8859-1
en_GB.UTF-8   UTF-8
fr_BE      ISO-8859-1
fr_BE@euro   ISO-8859-15
fr_BE.UTF-8   UTF-8
fr_FR      ISO-8859-1
fr_FR@euro   ISO-8859-15
fr_FR.UTF-8   UTF-8

And my console keys configuration:
/etc/conf.d/keymaps:
keymap="be-latin1"
windowkeys="YES"
extended_keymaps=""
dumpkeys_charset=""
fix_euro="NO"

As you expect, keyboard layout is correct in TTY consoles! It's also correct *after* I log in from lightdm. Only Lightdm bugs me like this and I have no clue why. And to top it all, Xorg log shows that the correct layout was loaded!
/var/log/Xorg.0.log:
[    21.672] (II) XINPUT: Adding extended input device "Logitech K330" (type: KEYBOARD, id 8)
[    21.672] (**) Option "xkb_rules" "evdev"
[    21.672] (**) Option "xkb_model" "pc104"
[    21.672] (**) Option "xkb_layout" "be"
[    21.672] (II) evdev: Logitech K330: initialized for relative axes.
[    21.672] (WW) evdev: Logitech K330: ignoring absolute axes.
[    21.672] (**) Logitech K330: (accel) keeping acceleration scheme 1
[    21.672] (**) Logitech K330: (accel) acceleration profile 0
[    21.672] (**) Logitech K330: (accel) acceleration factor: 2.000
[    21.672] (**) Logitech K330: (accel) acceleration threshold: 4

But no, the keyboard layout is *not* "be". It cannot even be changed at all from lightdm login manager.

Any idea where/what to look for?

Thanks in advance for any hint/suggestion.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
1739!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum