Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Make Kwallet not try to manage git authentication
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
TheMachinesTeacher
n00b
n00b


Joined: 09 Sep 2017
Posts: 46
Location: Somewhere over there

PostPosted: Sun Oct 01, 2017 5:09 pm    Post subject: [Solved] Make Kwallet not try to manage git authentication Reply with quote

In KDE Plasma, is there a way to make git not try to use the kwallet to authenticate when you are pushing? When I do it, it gives a bunch of D-Bus errors related to the kwalletd service not being registered, and then eventually pops up a window asking for my password. I don't even want to use the wallet, so that is why it is not registered. Is it advisable to just unmerge the wallet if I don't want to use it?

Last edited by TheMachinesTeacher on Sun Oct 01, 2017 6:26 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22176
Location: here

PostPosted: Sun Oct 01, 2017 5:27 pm    Post subject: Reply with quote

Try to see ~/.config/kwalletrc and section [Wallet] and [Auto Deny] (not personally tested).
https://stackoverflow.com/questions/29594260/how-to-disable-kwallet-in-kde-plasma-5
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7112
Location: Austria

PostPosted: Sun Oct 01, 2017 5:35 pm    Post subject: Reply with quote

https://wiki.gentoo.org/wiki/KDE#Disabling_KWallet
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
TheMachinesTeacher
n00b
n00b


Joined: 09 Sep 2017
Posts: 46
Location: Somewhere over there

PostPosted: Sun Oct 01, 2017 6:08 pm    Post subject: Reply with quote

That stackoverflow post wanted me to use KWalletManager, which I don't have installed and don't intend to install. The other solutions on that post were recommended the same thing as the Disabling_KWallet part of the wiki. The wiki solution also did not solve the problem, even after a reboot, although, now it doesn't give D-Bus errors, which I suppose is good.

What is says now is:
Code:

Pass a valid window to KWallet::Wallet::openWallet().
The wallet service was disabled by the user
User disabled the wallet system so returning 0 here.


And it still shows the window asking for me to give it my credentials. Any more ideas? There isn't a USE flag for git to install without support for the wallet, otherwise that is what I would do. Maybe there is a git config files somewhere? I am going to go searching.
Back to top
View user's profile Send private message
TheMachinesTeacher
n00b
n00b


Joined: 09 Sep 2017
Posts: 46
Location: Somewhere over there

PostPosted: Sun Oct 01, 2017 6:26 pm    Post subject: Reply with quote

After searching the web, and finding that a lot of the solutions are for previous versions of KDE or that I do not have the files they are talking about, I did find a solution.

There is an environment variable called SSH_ASKPASS that the default for it is /usr/bin/ksshaskpass. When you set the variable to an empty string with
Code:
export SSH_ASKPASS=""
, git won't try to use kwallet, even if you aren't ssh'd in! Strange behavior.

And just to make sure, I can in fact still SSH to my box still, if somebody reading this incorrectly thought that disabling that variable would disable ssh login via password.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum