Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE 5 - How is it?
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9, 10  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
i4dnf
Apprentice
Apprentice


Joined: 18 Sep 2005
Posts: 265
Location: Bucharest, Romania

PostPosted: Thu Sep 15, 2016 5:22 pm    Post subject: Reply with quote

Yes
Code:
Terminal=true
works now.
Frameworks 5.26, Plasma 5.7.5 [, Qt 5.7, but I doubt qt version is relevant]
_________________
"The only difference between me and a madman is that I am not MAD" (SALVATOR DALI)
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7114
Location: Austria

PostPosted: Thu Sep 15, 2016 5:28 pm    Post subject: Reply with quote

Great, that's exactly what the patch to kio was about.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
i4dnf
Apprentice
Apprentice


Joined: 18 Sep 2005
Posts: 265
Location: Bucharest, Romania

PostPosted: Thu Sep 15, 2016 5:37 pm    Post subject: Reply with quote

Indeed worth it, thanks.
Too bad that due to this kind of "small" annoyances, and some awkward decisions by the kde devs, the whole experience is still ruined this many years into kf5/plasma :(.
Now let's see how 5.8 will be like... supposed to be LTS.
_________________
"The only difference between me and a madman is that I am not MAD" (SALVATOR DALI)
Back to top
View user's profile Send private message
mouacyk
n00b
n00b


Joined: 23 Mar 2009
Posts: 13

PostPosted: Fri Sep 16, 2016 2:04 am    Post subject: Reply with quote

Latest ebuilds from kde overlay are working great for me now. A couple versions ago, used to have an issue with display port not resuming after locking desktop but that is resolved now. After a full day of locked desktop with monitor off, I can resume and unlock without issue.
_________________
OCed24/7: 9900K5.0GHz//16GB4000MHzC16//1080Ti2.10GHz
OCed24/7: 1680v24.5GHz//32GB2333MHzC10//750Ti[GHz
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7114
Location: Austria

PostPosted: Fri Sep 16, 2016 6:32 pm    Post subject: Reply with quote

mouacyk wrote:
A couple versions ago, used to have an issue with display port not resuming after locking desktop but that is resolved now.

Unfortunately, on certain Intel hardware that could be a driver bug as well, so you may have been lucky with a recent driver snapshot.


In case some of you didn't notice, KDE PIM 16.08.1 made it to tree as well with the recent upgrade, but masked for testing. Updated Wiki section here: https://wiki.gentoo.org/wiki/KDE#KDE_PIM
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22209
Location: here

PostPosted: Sat Sep 17, 2016 10:26 am    Post subject: Reply with quote

asturm wrote:
In case some of you didn't notice, KDE PIM 16.08.1 made it to tree as well with the recent upgrade, but masked for testing. Updated Wiki section here: https://wiki.gentoo.org/wiki/KDE#KDE_PIM

I use kdepim from version 16.08.0 (kmail, korganizer, kontact) on kde overlay with davmail (for (s)exchange connection at work) and I notice that for the moment working well, but sometimes I need to restart akonadi.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
gerard27
Advocate
Advocate


Joined: 04 Jan 2004
Posts: 2377
Location: Netherlands

PostPosted: Wed Sep 21, 2016 3:34 pm    Post subject: What happened to .xsession-errors in Plasma? Reply with quote

I am running kde-plasma now and generally like it.
I have one question though:
What happened to .xsession-errors?
Running "iscan" it freezes at >150 px.
Hoping to find something for trouble shooting I thought of looking there.
Alas it seems to be gone.
Gerard.
_________________
To install Gentoo I use sysrescuecd.Based on Gentoo,has firefox to browse Gentoo docs and mc to browse (and edit) files.
The same disk can be used for 32 and 64 bit installs.
You can follow the Handbook verbatim.
http://www.sysresccd.org/Download
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1703
Location: United Kingdom

PostPosted: Wed Sep 21, 2016 3:53 pm    Post subject: Reply with quote

Gerard,

Have you seen the thread No more .xsession-errors log. SDDM 0.14. *Solved*? Perhaps that has the answer to your problem.
_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
gerard27
Advocate
Advocate


Joined: 04 Jan 2004
Posts: 2377
Location: Netherlands

PostPosted: Wed Sep 21, 2016 6:31 pm    Post subject: Reply with quote

@Fitzcarraldo,
Thanks a million.
With your link I found what to do.
.xsession-errors is back in it's old place.
Gerard.
_________________
To install Gentoo I use sysrescuecd.Based on Gentoo,has firefox to browse Gentoo docs and mc to browse (and edit) files.
The same disk can be used for 32 and 64 bit installs.
You can follow the Handbook verbatim.
http://www.sysresccd.org/Download
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7114
Location: Austria

PostPosted: Wed Nov 30, 2016 6:43 pm    Post subject: Reply with quote

Now's the time to give Qt-5.6.2, Applications-16.08.3 and Plasma-5.8.3 some testing, before it finally is kicking Plasma-4 off Portage.

Also in the stable pipeline: digikam-5.3.0 and kdevelop-5.0.2.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22209
Location: here

PostPosted: Wed Nov 30, 2016 6:52 pm    Post subject: Reply with quote

asturm wrote:
Now's the time to give Qt-5.6.2,

I'm waiting for the release of qt-5.7.1 for update kdepim-16.08.3 :D :P
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
gerard27
Advocate
Advocate


Joined: 04 Jan 2004
Posts: 2377
Location: Netherlands

PostPosted: Wed Nov 30, 2016 6:59 pm    Post subject: Reply with quote

I'm running ~amd64.
So plasma is at 5.8.4.
Wacomtablet still no joy in system-settings.
Upstream devs don't care about pc's and graphics I guess.
Gerard.
_________________
To install Gentoo I use sysrescuecd.Based on Gentoo,has firefox to browse Gentoo docs and mc to browse (and edit) files.
The same disk can be used for 32 and 64 bit installs.
You can follow the Handbook verbatim.
http://www.sysresccd.org/Download
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7114
Location: Austria

PostPosted: Wed Nov 30, 2016 7:18 pm    Post subject: Reply with quote

For wacomtablet, there's just no one there anymore it seems who would be working on it. Last commit 13 months ago...
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
msst
Apprentice
Apprentice


Joined: 07 Jun 2011
Posts: 219

PostPosted: Wed Nov 30, 2016 10:54 pm    Post subject: Reply with quote

After being certainly a bit underwhelmed at at plasma so far I have to concede that slowly it is making progress and becoming more useable. Currently trying out plasma-5.8.4, frameworks-5.28.0 and kde-16.08.3 it seems more stable than before and the session management is almost useable also on multiple virtual desktops.

The akonadi and kdepim restart bugs seem to also have subsided.

So maybe in a year or two it may be ok for general use. 8-P
Back to top
View user's profile Send private message
krotuss
Apprentice
Apprentice


Joined: 01 Aug 2008
Posts: 157

PostPosted: Mon Dec 19, 2016 10:21 pm    Post subject: Reply with quote

Upgraded to 16.12.0 over weekend:

konqueror - straight segfault
akonadi (kmail) - wont start - completely broken
ktp - (that replacement for kopete) - segfaults, both contatct list and chat window, unable to even remove accounts

Good times have passed, what else to say...
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7114
Location: Austria

PostPosted: Mon Dec 19, 2016 10:25 pm    Post subject: Reply with quote

No issues here, except konqueror. I'm wondering what's wrong on your system, how did you upgrade Qt? No fancy tricks like --nodeps I hope?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
krotuss
Apprentice
Apprentice


Joined: 01 Aug 2008
Posts: 157

PostPosted: Mon Dec 19, 2016 10:31 pm    Post subject: Reply with quote

asturm wrote:
No issues here, except konqueror. I'm wondering what's wrong on your system, how did you upgrade Qt? No fancy tricks like --nodeps I hope?


Probably same as https://forums.gentoo.org/viewtopic-t-1056302.html, emerge -uND world with keywords from here https://gitweb.gentoo.org/proj/kde.git/tree/Documentation/package.accept_keywords
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7114
Location: Austria

PostPosted: Mon Dec 19, 2016 10:38 pm    Post subject: Reply with quote

Yes, I don't really care about konqueror, the other two issues of yours are out of the ordinary.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
krotuss
Apprentice
Apprentice


Joined: 01 Aug 2008
Posts: 157

PostPosted: Mon Dec 19, 2016 10:41 pm    Post subject: Reply with quote

It aligns nicely with what I experienced after migration from KD4 so far.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7114
Location: Austria

PostPosted: Mon Dec 19, 2016 10:43 pm    Post subject: Reply with quote

Well, if you feel ready to stop complaining and start pasting your errors you might get help, but that way this doesn't go anywhere.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
krotuss
Apprentice
Apprentice


Joined: 01 Aug 2008
Posts: 157

PostPosted: Mon Dec 19, 2016 10:56 pm    Post subject: Reply with quote

I just wanted to post my experience with "KDE5". But I appreciate that you want to help, even though I am not sure that I longer care.
Kmail displays error "The Akonadi personal information management service is not operational" (text is not even copyable) below is "Details..." button that does nothing. ktp does not display any error, it just asks for passwords for account that have been removed. In GUI it also replicates accounts that are kept to take place of removed ones. As for crashes there is probably core left somewhere, but I am not in the mood to debug it. I will rather switch to pidgin. Password saving doesn't work either.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7114
Location: Austria

PostPosted: Mon Dec 19, 2016 11:14 pm    Post subject: Reply with quote

Did you upgrade from kdepim:4 to kdepim:5? Same for ktp, did you use kopete so far and this is your first migration?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
krotuss
Apprentice
Apprentice


Joined: 01 Aug 2008
Posts: 157

PostPosted: Mon Dec 19, 2016 11:26 pm    Post subject: Reply with quote

Yes, I have upgraded from kdepim:4 to kdepim:5. I have used ktp before (even wtih KDE4) to try it out, but I was mainly using kopete until now.
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2870
Location: Bay Area, CA

PostPosted: Tue Dec 20, 2016 5:35 pm    Post subject: Reply with quote

allistarM wrote:
Cons:
- After about a week the plasma application can run away with memory usage forcing me to kill X and relog back in.
You can 'pkill plasmashell ; sleep 1; plasmashell & disown %1' from a konsole window.
allistarM wrote:

- there's no way to remote Plasma because of the requirement for GL, so I now use LXDE to remote connect in using X2Go.
Have a look at x11vnc. If remoting into :0 is an infrequent operation to manage the machine once in a while, x11vnc is best to connect to :0
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7114
Location: Austria

PostPosted: Tue Dec 20, 2016 8:09 pm    Post subject: Reply with quote

krotuss wrote:
Yes, I have upgraded from kdepim:4 to kdepim:5.

Do you only have kmail installed? Or did you use the kdepim-meta package?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9, 10  Next
Page 8 of 10

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum