Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] kde-apps/kde-apps-meta:5 pulling qt4 stuff & blockin
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
KeksExpert
n00b
n00b


Joined: 08 Mar 2016
Posts: 6
Location: Germany / Bavaria

PostPosted: Tue Mar 08, 2016 7:36 pm    Post subject: [SOLVED] kde-apps/kde-apps-meta:5 pulling qt4 stuff & bl Reply with quote

I am absolutely new to Linux and Gentoo but I wanted to install Gentoo as an experiment.
Working on it since 5 days or so.
Forgive me pls if I act very stupid.

I managed to install Gentoo and get most of the stuff running X, sddm and kde-plasma/plasma-meta following the official guides.
My profile is desktop/plasma no systemd and these are the make.conf USE flags "bindist mmx sse sse2 -qt4 branding -handbook -minimal"

I want to install the
Code:
kde-apps/kde-apps-meta:5
package because KDE5 looks empty and even the browser is missing.

Emerge started:
First error: Missing USE flags
Code:

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by kde-apps/artikulate-4.14.3::gentoo
# required by kde-apps/kdeedu-meta-4.14.3::gentoo
# required by kde-apps/kde-apps-meta-15.08.3-r3::gentoo
# required by kde-apps/kde-apps-meta:5 (argument)
>=media-libs/qt-gstreamer-1.2.0-r1 qt4
# required by kde-apps/kdenlive-15.12.2::gentoo
# required by kde-apps/kdemultimedia-meta-15.12.2::gentoo
# required by kde-apps/kde-apps-meta-15.08.3-r3::gentoo
# required by kde-apps/kde-apps-meta:5 (argument)
>=media-libs/mlt-0.9.8-r2 ffmpeg kdenlive melt
# required by kde-apps/kdepimlibs-4.14.10::gentoo
# required by kde-apps/kopete-15.08.3::gentoo
# required by kde-apps/kdenetwork-meta-15.08.3-r1::gentoo
# required by kde-apps/kde-apps-meta-15.08.3-r3::gentoo
# required by kde-apps/kde-apps-meta:5 (argument)
>=app-office/akonadi-server-1.13.0-r2 qt4
# required by kde-apps/kde-apps-meta-15.08.3-r3::gentoo[nls]
# required by kde-apps/kde-apps-meta:5 (argument)
>=kde-apps/kde4-l10n-15.08.3-r2 minimal

I thought whatever, put in kde4 stuff if you want

Starting emerge again
Code:

[blocks B      ] <kde-apps/kde4-l10n-15.12.1 ("<kde-apps/kde4-l10n-15.12.1" is blocking kde-apps/kde-l10n-15.12.1)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-apps/kde-l10n-15.12.1:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/kde-l10n-15.08.3 required by (kde-apps/kde-apps-meta-15.08.3-r3:5/5::gentoo, ebuild scheduled for merge)

  (kde-apps/kde4-l10n-15.08.3-r2:4/15.08::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/kde4-l10n-15.08.3[minimal] required by (kde-apps/kde-apps-meta-15.08.3-r3:5/5::gentoo, ebuild scheduled for merge)


Next, I masked kde4-l10n
echo "kde-apps/kde4-l10n" >> /etc/portage/package.mask
I also removed it from package.unmask
Error from above again not working because missing packages.

How do I get rid of qt4?

Thanks for being cool penguins,
KeksExpert


Last edited by KeksExpert on Wed Mar 09, 2016 2:55 pm; edited 1 time in total
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6828
Location: Austria

PostPosted: Tue Mar 08, 2016 8:24 pm    Post subject: Reply with quote

It's rather easy, don't set USE=-qt4 globally. You're using the correct profile already (plasma) that is switching off qt4 in packages where it conflicts, but leaves it on where you need it. If you want to have a full KDE experience, you can't get rid of KDE4-based applications at this point, simple as that.

If you want to go without KDE4-based and Qt4-based applications, you've got a lot of work to do and can not use any of the provided meta packages except those for Plasma.

Code:
USE flags "bindist mmx sse sse2 -qt4 branding -handbook -minimal"

Also, don't set the minimal flag globally on your own. In kde-base/ and kde-apps/ category packages, this flag enables compatibility to be able to install Plasma-5 and kf5-based applications together with KDE4 in the first place.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
KeksExpert
n00b
n00b


Joined: 08 Mar 2016
Posts: 6
Location: Germany / Bavaria

PostPosted: Tue Mar 08, 2016 8:27 pm    Post subject: Reply with quote

Thanks, I'll close this asap! :oops:
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6828
Location: Austria

PostPosted: Tue Mar 08, 2016 8:33 pm    Post subject: Reply with quote

It's not all that obvious, but that's why we have a guide: https://wiki.gentoo.org/wiki/KDE#KDE_Frameworks.2C_Plasma.2C_and_Applications_5

Feel free to revisit this thread if you encounter any further issues. ;)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
KeksExpert
n00b
n00b


Joined: 08 Mar 2016
Posts: 6
Location: Germany / Bavaria

PostPosted: Wed Mar 09, 2016 2:52 pm    Post subject: Solved it :D Reply with quote

Thanks genstorm, you deserve your name :)

After removing the wrong USE flags (-qt and -minimal) everything it needed was a simple mask
I'll explain the mask for other users that have the same problem liek me:

Emerge tried to pull different versions of kde4-l10n and kde-l10n: 15.08.3-r2 anbd 15.12.1 which were incompatible
Code:
[blocks B      ] <kde-apps/kde4-l10n-15.12.1 ("<kde-apps/kde4-l10n-15.12.1" is blocking kde-apps/kde-l10n-15.12.1)



So I added this to package.mask
Code:
<kde-apps/kde4-l10n-15.12.1
<kde-apps/kde-l10n-15.12.1

Which tells emerge not to pull versions below 15.12.1

Then I had to keyword ~amd64 onto kde4-l10n (Don't keyword that if you are on 32-bit / i386)
Code:
echo "=kde-apps/kde4-l10n-15.12.1-r1 ~amd64" >> /etc/portage/package.accept_keywords


And then I could install all those packages :o

Thanks,
KeksExpert
Back to top
View user's profile Send private message
dewhite
Tux's lil' helper
Tux's lil' helper


Joined: 16 Mar 2003
Posts: 77
Location: Houston, Texas, USA

PostPosted: Thu Mar 10, 2016 4:00 am    Post subject: Re: Solved it :D Reply with quote

KeksExpert wrote:
After removing the wrong USE flags (-qt and -minimal) everything it needed was a simple mask
I'll explain the mask for other users that have the same problem liek me:


How fortuitous for me that another brave soul was running into the same problem as me on the same day (and that they took the time to update with their final solution)!

I've been hacking my way through blockers left and right for the past couple of days, upgrading from plasma 4 to 5 and I was just starting to lose my patience with this last hangup.

Your solution cleared my final hurdle. Thanks to you and genstorm both, and welcome to the Gentoo community!
_________________
Work WS: R7-1700x | 2x8Gb DDR4 | GT1030 | 275Gb & 1Tb SSD Root/Home
Work FS: i5-6500 | 8Gb DDR4 | 275Gb SSD | 3x 1TB RAID5
Home WS: NUC7i5BNH | 2x8Gb DDR4 | 275Gb SSD (running ARCH Linux)
Home FS: FX-8320e | 8Gb DDR3 | 8400GS | 4x 5TB RAID5
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6828
Location: Austria

PostPosted: Thu Mar 10, 2016 8:44 am    Post subject: Reply with quote

Just curious, in case you also had -minimal in your make.conf, why did you add that in the first place?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
KeksExpert
n00b
n00b


Joined: 08 Mar 2016
Posts: 6
Location: Germany / Bavaria

PostPosted: Thu Mar 10, 2016 4:19 pm    Post subject: Re: Solved it :D Reply with quote

dewhite wrote:
Thanks to you and genstorm both, and welcome to the Gentoo community!


I'm glad I could help :D

genstorm wrote:
Just curious, in case you also had -minimal in your make.conf, why did you add that in the first place?


If that question is targeted to dewhite, I don't think he added that and I think the whole error was emerge trying to pull different, incompatible versions kde4-l10n and kde-l10n...
The gentoo package website even shows different versions on both packages... They are supposed to be the same right?
Correct me if I'm wrong.

I added "-minimal" after that error occured, forgot to mention.

[strike]Oh and I just found out that I removed the USE flags from the original post I'll put them back in.[/strike] I didn't I'm just blind :o

Anyway, my original post last codeblock said kde4-l10n was about to get merged with flag "-minimal"
I didn't know what that was, so I looked it up in the USE Flag Index
It said install "a very minimal build" which sounded wrong to me. I didn't know that it was required for some packages and the devs put it in on purpose. (I don't like to think very much, I rather do something and see if it works :wink: )
Same with "-qt4".
--changed-use saves days and gentoo installations :)
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6828
Location: Austria

PostPosted: Thu Mar 10, 2016 5:07 pm    Post subject: Re: Solved it :D Reply with quote

KeksExpert wrote:
I think the whole error was emerge trying to pull different, incompatible versions kde4-l10n and kde-l10n...
The gentoo package website even shows different versions on both packages... They are supposed to be the same right?
Correct me if I'm wrong.

I don't see that:
https://packages.gentoo.org/packages/kde-apps/kde4-l10n
https://packages.gentoo.org/packages/kde-apps/kde-l10n

Here's what happened: While kde4-l10n-15.08.3 has gone stable for the KDE4 users, kde-l10n-15.08.3 isn't yet. Since you only accept amd64 keyword, you relied on autounmasking of those packages that are ~amd64 keyworded but were required for your installation of kde-apps-meta. Portage will always unmask the latest available version, which is 15.12.1 already - it has no knowledge of what would actually be best in your case. But kde-l10n-15.12.1 always needs to block older kde4-l10n versions, because between releases there is a constant transition from kde4-l10n to kde-l10n translations that would otherwise result in file conflicts.

No masking would have been required to fix this - you just need to demote your kde-l10n entry inside package.keywords from 15.12.1 to 15.08.3.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
KeksExpert
n00b
n00b


Joined: 08 Mar 2016
Posts: 6
Location: Germany / Bavaria

PostPosted: Thu Mar 10, 2016 5:11 pm    Post subject: Re: Solved it :D Reply with quote

I think I learned much about portage!
Thanks for taking the time and explaining it to me.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum