Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
rdesktop-1.8.3 connect to Windows 8.1? [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
tld
Veteran
Veteran


Joined: 09 Dec 2003
Posts: 1373

PostPosted: Mon Mar 07, 2016 9:23 pm    Post subject: rdesktop-1.8.3 connect to Windows 8.1? [SOLVED] Reply with quote

I'm hesitant to post this here as it's probably not a Gentoo issue, though I can't be sure. I'm running the current stable version of rdesktop (net-misc/rdesktop-1.8.3). I'm able to connect to Windows Server 2012 among others (even over an ssh tunnel over the Internet).

I'm trying to connect to a Windows 8.1 system on my LAN, and all it does is hang:

Code:
rdesktop 192.168.1.118
Autoselected keyboard map en-us


It just hangs there with no response indefinitely. I've exhausted about everything I can find around this and I'm stumped:

1. This is in fact Windows 8.1 Pro (not Basic).
2. I have Remote Destop enabled in System -> Remote and the Remote Desktop service is running.
3. While it may not be necessary I've de-selected "Allow connections only from computers running Remote Desktop with Network Level Authentication", as it can apparently cause issues.
4. I've allowed Remote Desktop in the firewall settings.

I'm not sure where I might be able to find something in the Godless travesty that is the Windows event log that might give some clues, though it seems as though it's not getting through at all.

Any suggestions are welcome. Thanks!

Tom


Last edited by tld on Mon Mar 07, 2016 11:19 pm; edited 1 time in total
Back to top
View user's profile Send private message
tld
Veteran
Veteran


Joined: 09 Dec 2003
Posts: 1373

PostPosted: Mon Mar 07, 2016 11:19 pm    Post subject: Reply with quote

OMG...it turns out that the firewall was blocking it because my LAN was considered a "public" network, apparently because sharing wasn't enabled for that. I knew it had to be firewall related when I couldn't telnet to port 3389.

I won't even get into the fruitless hours I've wasted trying to change that, because windows can't seem to differentiate my wired connection from the WiFi on the same router. Windows is such a total piece of shit.
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 2876
Location: Illinois, USA

PostPosted: Mon Mar 07, 2016 11:36 pm    Post subject: Reply with quote

tld wrote:
OMG...it turns out that the firewall was blocking it because my LAN was considered a "public" network, apparently because sharing wasn't enabled for that. I knew it had to be firewall related when I couldn't telnet to port 3389.

I won't even get into the fruitless hours I've wasted trying to change that, because windows can't seem to differentiate my wired connection from the WiFi on the same router. Windows is such a total piece of shit.


Glad you found it and I concur. I was going to advise that you ban IP's outside your LAN. The XP setup was apparently simpler. Windows keeps on simplifying those technical terms into their own made up language.
Back to top
View user's profile Send private message
tld
Veteran
Veteran


Joined: 09 Dec 2003
Posts: 1373

PostPosted: Wed Mar 09, 2016 5:43 pm    Post subject: Reply with quote

Tony0945 wrote:
Windows keeps on simplifying those technical terms into their own made up language.
You've exactly summed it up right there. This is my gripe whenever operating systems try to "dumb down" everything. In the process they fail to explain the actual ramifications of any settings and choices to to anyone who actually knowns what they are doing! When adding a network connection they ask about "sharing printers" and all sorts of other crap without actually telling you that answering "no" means treating that network as if it were the Internet. I mean FFS. You can't even imagine what I went through changing it. I almost lost my mind looking for that change on my own. I then found the Wondows 8 section here:

http://www.tekrevue.com/tip/change-network-location-windows-8

I made that setting, and it DOES NOT WORK. That public vs. private location has nothing to do with this at all. After literally hours, I was able to fix it as per this:

https://tinkertry.com/how-to-change-windows-8-1-network-type-from-public-to-private

Note how that dopey little Yes/No toggle switch is labeled "Find PCs, devices, and content on the network, and automatically connect to devices like printers and TVs. Turn this off for public networks to keep your stuff safe.". From that you're apparently supposed to understand that the Yes/No toggle is in fact what makes the network public or private. What is wrong with these people. It does all remind me why I started using Linux 15 years ago, and why I don't use systemd now...to get away from all the back-box-don't-worry-your-pretty-little-head-about-it "features"...but I digress.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum