Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Disappearing mouse in Gnome 3.18
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Sprchkn
n00b
n00b


Joined: 04 Mar 2016
Posts: 3
Location: Kansas

PostPosted: Fri Mar 04, 2016 1:19 am    Post subject: Disappearing mouse in Gnome 3.18 Reply with quote

I upgraded to Gnome 3.18 on Feb 24th and unfortunately my mouse cursor now disappears when over any of the gnome-shell stuff, such as the top panel, alt-tab view, or activities overview. It's the typical thing you read about when you search for it, though the dconf trick with the cursor plugin doesn't fix it. I tried updating from nvidia-drivers 358.16-r1 which I've had installed since early Feb to 361.28-r2, but that did not fix it. As soon as my mouse pointer tip moves into the top panel, it completely disappears, a tiny movement down and it's back. It seems likely that since I haven't been able to find any posts on this, that it's the interplay between the proprietary nvidia driver and gnome-shell 3.18. Before I went to the trouble of switching to the nouveau driver and retesting then submitting a bug report, I figured I'd see if anyone had any ideas first.

Thanks!
Back to top
View user's profile Send private message
splurben
Apprentice
Apprentice


Joined: 03 Feb 2004
Posts: 197
Location: Augusta, Southwest Western Australia

PostPosted: Thu Mar 10, 2016 8:22 am    Post subject: Same problem caused by Maximus Reply with quote

I got the same problem when I installed Maximus (for getting rid of title bars in full-screen windows) and I haven't been able to fix it. It's driving me mad!

Even worse, the problem isn't fixed when all of Maximus features are turned back off!
_________________
--=>Like... Goodness had nothing to do with it.<=--
Back to top
View user's profile Send private message
subrabien
n00b
n00b


Joined: 15 Mar 2016
Posts: 1

PostPosted: Tue Mar 15, 2016 1:43 pm    Post subject: Reply with quote

Hi,
I think you have multiple monitors! If yes, your bug is already reported: https://bugzilla.gnome.org/show_bug.cgi?id=763159
the issue seem to appear if no monitor is set on 0,0 (show comment #13). A simple workaround is to modify your display configuration to have a monitor on the top left corner (from Settings -> hardware -> Displays).
That solve the issue for me

I hope the bugfix submitted on gnome bugzilla would be merged in portage.
Back to top
View user's profile Send private message
splurben
Apprentice
Apprentice


Joined: 03 Feb 2004
Posts: 197
Location: Augusta, Southwest Western Australia

PostPosted: Sun Apr 10, 2016 4:34 am    Post subject: Ta, Thanks, I'll give that a look and report back… Reply with quote

I do have two monitors.

subrabien wrote:
Hi,
I think you have multiple monitors! If yes, your bug is already reported: https://bugzilla.gnome.org/show_bug.cgi?id=763159
the issue seem to appear if no monitor is set on 0,0 (show comment #13). A simple workaround is to modify your display configuration to have a monitor on the top left corner (from Settings -> hardware -> Displays).
That solve the issue for me

I hope the bugfix submitted on gnome bugzilla would be merged in portage.

_________________
--=>Like... Goodness had nothing to do with it.<=--
Back to top
View user's profile Send private message
mr-simon
Guru
Guru


Joined: 22 Nov 2002
Posts: 362
Location: Leamington Spa, Warks, UK

PostPosted: Wed Jun 01, 2016 8:38 am    Post subject: Reply with quote

Apologies for necro-posting, but for those of you landing here from Google like I did here's how to apply the patch to your current version:

Code:

# make a directory for the patch, for the current version of mutter you have installed
sudo mkdir -p /etc/portage/patches/`equery --quiet l mutter`

# download the patch into the directory
sudo wget sudo wget https://git.gnome.org/browse/mutter/patch/?id=8b801aac772f92b2c6d8341931b03bbe8d5f8cd6 -O /etc/portage/patches/`equery --quiet l mutter`/mouse-pointer-fix.patch

# reinstall mutter
sudo emerge mutter


Problem went away for me. :)

If you don't have equery installed, just run `emerge -p mutter` to find out which version you have installed, and replace the backticks with x11-wm/mutter-<your_version>
_________________
"Pokey, are you drunk on love?"
"Yes. Also whiskey. But mostly love... and whiskey."
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum