Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Mate 1.10 and systemd
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
saellaven
Guru
Guru


Joined: 23 Jul 2006
Posts: 493

PostPosted: Wed Feb 24, 2016 1:31 pm    Post subject: Reply with quote

I have -systemd in my USE flags normally, but even without it, dbus isn't pulling in systemd on my system. Have you synced recently? Have you tried explicitly adding -systemd to USE?
Back to top
View user's profile Send private message
cwr
Veteran
Veteran


Joined: 17 Dec 2005
Posts: 1968

PostPosted: Wed Feb 24, 2016 3:06 pm    Post subject: Reply with quote

I found the problem with dbus - it was a package.use file I'd overlooked, since
I usually put all USE flags in one file. Emerging mate 1.10 then showed that
totem was pulling in systemd, which was cured by adding USE=-extra to mate.
The final result was a single blocker, shown below: I'll get to that in due
course.

Thanks for all the help - Will

[blocks B ] <x11-libs/gtk+-3.18:3 ("<x11-libs/gtk+-3.18:3" is blocking x11-themes/mate-themes-1.10.5-r180)
Conflict: 1 block (1 unsatisfied)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(x11-libs/gtk+-3.16.7:3/3::gentoo, installed) pulled in by
x11-libs/gtk+:3 required by (gnome-extra/polkit-gnome-0.105-r1:0/0::gentoo, installed)
x11-libs/gtk+:3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,
abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (x11-libs/gtk+:3
[abi_x86_32(-)]) required by (media-libs/libcanberra-0.30-r5:0/0::gentoo,
installed)
>=x11-libs/gtk+-3:3 required by (gnome-extra/zenity-3.16.3:0/0::gentoo,
ebuild scheduled for merge)
>=x11-libs/gtk+-3.5.1:3 required by (x11-misc/xdg-user-dirs-gtk-0.10:0/0::
gentoo, installed)
>=x11-libs/gtk+-3.14:3[X] required by (net-libs/webkit-gtk-2.8.5:4/37::
gentoo, ebuild scheduled for merge)
>=x11-libs/gtk+-3.14:3[introspection?] (>=x11-libs/gtk+-3.14:3
[introspection]) required by (net-libs/webkit-gtk-2.8.5:4/37::gentoo,
ebuild scheduled for merge)
>=x11-libs/gtk+-3.0:3 required by (gnome-base/gvfs-1.24.2-r1:0/0::gentoo,
installed)
x11-libs/gtk+:3 required by (app-text/ghostscript-gpl-9.15-r1:0/0::gentoo,
installed)
>=x11-libs/gtk+-3.8:3 required by (x11-misc/notification-daemon-3.14.1:0/0::
gentoo, installed)

(x11-themes/mate-themes-1.10.5-r180:0/0::gentoo, ebuild scheduled for merge)
pulled in by
=x11-themes/mate-themes-1.10*:0 required by (mate-base/mate-1.10.0:0/0::
gentoo, ebuild scheduled for merge)
Back to top
View user's profile Send private message
Princess Nell
l33t
l33t


Joined: 15 Apr 2005
Posts: 738

PostPosted: Wed Feb 24, 2016 9:33 pm    Post subject: Reply with quote

If you sync your portage tree, you'll find that gtk+-3 has now been updated to 3.8.17, so a world update should fix it. If you don't want to sync, you'll need to unmask one of the 3.18 versions in your current tree, and there are a few dependencies I don't quite remember; I think pango-1.38 is one of them.
Back to top
View user's profile Send private message
OldTango
Guru
Guru


Joined: 21 Feb 2004
Posts: 598

PostPosted: Sun Feb 28, 2016 6:29 pm    Post subject: Reply with quote

Leio wrote:
Why do you need USE=-gnome? What is default enabling it that pulls in systemd or whatnot? Can you check with emerge .. --tree or something? I don't think we need to default enable these things to need an explicit disable when it interfers with a good experience to MATE. But given the information, I can't quickly figure out what IUSE default on gnome is doing it.
I had both -gnome and -systemd in my make.conf until today. I removed them and ran
Code:

emerge -avuND --with-bdeps=y @world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] gnome-base/gsettings-desktop-schemas-3.18.1::gentoo  USE="introspection" 561 KiB
[ebuild   R    ] net-libs/glib-networking-2.46.1::gentoo  USE="gnome* libproxy ssl -smartcard {-test}" ABI_X86="32 (64) (-x32)" 0 KiB

Total: 2 packages (1 new, 1 reinstall), Size of downloads: 561 KiB

Would you like to merge these packages? [Yes/No]


A quick equery shows
Code:

equery d gsettings-desktop-schemas
 * These packages depend on gsettings-desktop-schemas:
media-libs/libcanberra-0.30-r5 (gnome ? gnome-base/gsettings-desktop-schemas)
net-libs/glib-networking-2.46.1 (gnome ? gnome-base/gsettings-desktop-schemas)

equery d libcanberra
 * These packages depend on libcanberra:
app-cdr/brasero-3.12.1-r1 (media-libs/libcanberra[gtk3])
mate-base/mate-control-center-1.10.2 (media-libs/libcanberra:0[gtk])
mate-base/mate-panel-1.10.1 (>=media-libs/libcanberra-0.23:0[gtk])
mate-base/mate-settings-daemon-1.10.3 (pulseaudio ? media-libs/libcanberra:0[gtk])
mate-extra/mate-media-1.10.1 (>=media-libs/libcanberra-0.13:0[gtk])
mate-extra/mate-power-manager-1.10.2 (>=media-libs/libcanberra-0.10:0[gtk])
mate-extra/mate-utils-1.10.4 (>=media-libs/libcanberra-0.4:0[gtk])
x11-misc/mate-notification-daemon-1.8.0 (>=media-libs/libcanberra-0.4:0[gtk])
x11-wm/marco-1.10.3 (media-libs/libcanberra:0[gtk])


Nothing systemd related is being pulled in at all, however the ebuild net-libs/glib-networking-2.46.1 has the gnome flag enabled by default resulting in gnome-base/gsettings-desktop-schemas-3.18.1 being pulled in. Is the gnome flag absolutely necessary on glib-networking or can/should it be disabled to achieve a proper MATE install?
Back to top
View user's profile Send private message
Leio
Developer
Developer


Joined: 27 Feb 2003
Posts: 480
Location: Estonia

PostPosted: Sun Feb 28, 2016 9:19 pm    Post subject: Reply with quote

OldTango wrote:

Nothing systemd related is being pulled in at all, however the ebuild net-libs/glib-networking-2.46.1 has the gnome flag enabled by default resulting in gnome-base/gsettings-desktop-schemas-3.18.1 being pulled in. Is the gnome flag absolutely necessary on glib-networking or can/should it be disabled to achieve a proper MATE install?


gsettings-desktop-schemas isn't all that evil to have, it's some desktop-wide configuration stuff for GSettings use under GNOME and similar things. I do not know if MATE uses it, or duplicates it under a different schema. USE=gnome on glib-networking enables the GNOME proxy backend, or like metadata.xml says: "Extract HTTP/HTTPS/SOCKS proxy configuration stored using GSettings"; gsettings-desktop-schemas contains the configuration schemas for GSettings in there, amongst other schemas, hence the dependency. If you don't use it, it shouldn't hurt, other than tiny amount of extra disk space used. How proxy configuration is done in MATE is for people more familiar to MATE to say.
_________________
GNOME team lead; GStreamer; MIPS/ARM64
Back to top
View user's profile Send private message
Amaroq
n00b
n00b


Joined: 19 May 2008
Posts: 11
Location: Red Wing, MN

PostPosted: Sat Sep 10, 2016 6:56 am    Post subject: Reply with quote

Heya. Sorry for reviving a dead (though recent) thread. But this is my first (successful) Gentoo install and I'm trying to install Mate as well.

I may have some insight into why some people are requiring "-gnome" and some people are not. I think it comes down to which system profile you chose when installing Gentoo in the first place.

If you're like me, maybe at first you decided you wanted Gnome on your system. Then you learned the hard way that Gnome requires systemd, and you don't want systemd. So you looked into Mate as an alternative.

Well, if you thought you wanted Gnome at first, you probably chose a system profile that included Gnome when you were installing. I assume this throws "gnome" into the inheritance system that USE flags are derived from.

The people who don't have to use "-gnome" must not have chosen a Gnome profile when they installed Gentoo.

I do require "-gnome" as a USE flag for it to not bring in systemd. And I did pick a Gnome profile during installation. So that's what I suspect the problem is.

However, I'm still having trouble installing Mate. If you guys don't mind me asking for advice here...

As of my most recent change to the USE flags, I've run,
Code:
emerge --update --newuse --deep @world
emerge --depclean


My profile.
Code:
default/linux/x86/13.0/gnome


My make.conf USE flags. (Including some really niche ones in hopes that this works.)
Code:
USE="bindist -systemd -qt3support -qt4 -gnome gtk gtk2 gtk2only -gtk3 mate bash-completion css curl fbcon ftp gd gimpgstreamer lm_sensors mplayer mysql mysqli offensive openal oss php python samba smbclient sndfile sockets ssl wifi"


Mate-specific USE flags.
Code:
mate-base/mate base extras theme


The errors from emerge mate-base/mate:
Code:

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (x11-themes/mate-themes-3.20.10:0/3.20::gentoo, ebuild scheduled for merge) pulled in by
    x11-themes/mate-themes:0 required by (x11-themes/mate-themes-meta-3:0/0::gentoo, ebuild scheduled for merge)

  (x11-libs/gtk+-3.18.9:3/3::gentoo, installed) pulled in by
    >=x11-libs/gtk+-3.16.0:3[introspection?] (>=x11-libs/gtk+-3.16.0:3[introspection]) required by (app-text/evince-3.18.2:0/evd3.4-evv3.3::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-3.14:3[introspection?] (>=x11-libs/gtk+-3.14:3[introspection]) required by (net-libs/webkit-gtk-2.10.9:4/37::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-3.16:3[introspection?] (>=x11-libs/gtk+-3.16:3[introspection]) required by (x11-libs/gtksourceview-3.18.2:3.0/3::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-3.12:3[X,introspection?] (>=x11-libs/gtk+-3.12:3[X,introspection]) required by (app-crypt/gcr-3.18.0:0/1::gentoo, installed)
    >=x11-libs/gtk+-3.15:3[X?,wayland?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,
abi_s390_32(-)?,abi_s390_64(-)?] (>=x11-libs/gtk+-3.15:3[X,abi_x86_32(-)]) required by (media-libs/gst-plugins-bad-1.6.3:1.0/1.0::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-3.16.0:3 required by (sys-apps/gnome-disk-utility-3.18.3.1:0/0::gentoo, ebuild scheduled for merge)
    x11-libs/gtk+:3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,
abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (x11-libs/gtk+:3[abi_x86_32(-)]) required by (media-libs/libcanberra-0.30-r5:0/0::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-3.3.18:3[aqua?] (>=x11-libs/gtk+-3.3.18:3) required by (media-libs/clutter-1.24.2:1.0/1.0::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-3.0:3 required by (gnome-base/gvfs-1.26.3:0/0::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-3.12:3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=x11-libs/gtk+-3.12:3[abi_x86_32(-)]) required by (x11-themes/gnome-themes-standard-3.18.0:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.8.0:3[X=,introspection?,wayland=] (>=x11-libs/gtk+-3.8.0:3[X,introspection,-wayland]) required by (media-libs/clutter-gtk-1.6.6-r1:1.0/1.0::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-3.14:3[X] required by (net-libs/webkit-gtk-2.10.9:4/37::gentoo, ebuild scheduled for merge)
    x11-libs/gtk+:3 required by (dev-libs/appstream-glib-0.5.15:0/8::gentoo, ebuild scheduled for merge)
    x11-libs/gtk+:3 required by (dev-libs/gjs-1.44.0:0/0::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-3.11.6:3 required by (gnome-extra/gnome-calculator-3.18.3:0/0::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-3.3.6:3[X,introspection?] (>=x11-libs/gtk+-3.3.6:3[X,introspection]) required by (gnome-base/gnome-desktop-3.18.2:3/12::gentoo, ebuild scheduled for merge)
    x11-libs/gtk+:3 required by (gnome-extra/polkit-gnome-0.105-r1:0/0::gentoo, installed)
    x11-libs/gtk+:3 required by (gnome-extra/nautilus-tracker-tags-1.6.2:0/0::gentoo, ebuild scheduled for merge)
    x11-libs/gtk+:3 required by (app-text/ghostscript-gpl-9.15-r1:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.18.5:3[introspection?] (>=x11-libs/gtk+-3.18.5:3[introspection]) required by (gnome-base/nautilus-3.18.5:0/0::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-3.11.1:3 required by (net-libs/gnome-online-accounts-3.18.4:0/1::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-3:3 required by (app-misc/tracker-1.6.2:0/100::gentoo, ebuild scheduled for merge)
    x11-libs/gtk+:3 required by (media-sound/pulseaudio-8.0:0/0::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-3.5.1:3 required by (x11-misc/xdg-user-dirs-gtk-0.10:0/0::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-3.13.2:3[introspection] required by (gnome-extra/sushi-3.18.0:0/0::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-3:3 required by (gnome-extra/zenity-3.18.1.1:0/0::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-3:3[introspection?] (>=x11-libs/gtk+-3:3[introspection]) required by (app-cdr/brasero-3.12.1-r1:0/3.1::gentoo, ebuild scheduled for merge)
    x11-libs/gtk+:3 required by (x11-misc/lightdm-gtk-greeter-2.0.1-r1:0/0::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by gnome-base/gvfs-1.26.3::gentoo[samba]
# required by gnome-base/nautilus-3.18.5::gentoo
# required by gnome-extra/sushi-3.18.0::gentoo
>=net-fs/samba-4.2.11 client
# required by sys-apps/gnome-disk-utility-3.18.3.1::gentoo
# required by mate-base/mate-1.10.0-r3::gentoo[extras]
# required by mate-base/mate (argument)
>=media-libs/libcanberra-0.30-r5 gtk3

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.


It looks like it's trying to use gtk3, but I specified that I want gtk2. Is gtk3 required for Mate?
(The reason I want gtk2 is because I'm coding something that will use it and I figured I might as well just have the whole system use it.)

And I don't understand what that last part means. I already have that version of samba installed.

How do I fix these errors?

[Moderator edit: broke long whitespace-free lines in code tags to fix thread layout. -Hu]
Back to top
View user's profile Send private message
Leio
Developer
Developer


Joined: 27 Feb 2003
Posts: 480
Location: Estonia

PostPosted: Sat Sep 10, 2016 7:40 am    Post subject: Reply with quote

mate[extras] pulls in sys-apps/gnome-disk-utility, which is an utility to partition disks, run SMART tests, etc. It requires libcanberra[gtk3] to do event sounds from a gtk3 based program.
gnome-disk-utility itself already uses gtk3, so enabling USE=gtk3 for libcanberra won't pull in gtk3 or anything, gnome-disk-utility (and probably many others things) already do.

gnome-base/gvfs samba support via USE=samba requires client support from net-fs/samba. So you need to either enable that, or disable samba support from gvfs.
gvfs provides the non-basic filesystem support for GIO (part of glib), so it benefits all things glib/gtk+ that open/save files and don't specifically disable remote support.
gvfs provides Trash virtual filesystem, but more importantly various networked filesystem support, including sftp (ssh), ftp, smb/cifs (via samba) and so on,
so that in your gtk file open/save dialogs, you can directly open/save files from/to the network, edit them "online" via editors, etc.

Not quite sure what the other spam is about, should be clearer after fixing the above.

For your project thing, I would heavily suggest using gtk3, not gtk2.
gtk3.22 later this month will be the last gtk3 and a LTS release, supported for at least 3 years afterwards.
gtk2 has been effectively unmaintained by upstream for a year already...
MATE is also converting over to gtk3 gradually; I believe next release is fully gtk3, but I might be mistaken.

USE=gnome or USE=-gnome shouldn't have any effect towards pulling in systemd or not, so I have no idea why people think it does. If it actually does, that might be a bug we can fix.
_________________
GNOME team lead; GStreamer; MIPS/ARM64
Back to top
View user's profile Send private message
Amaroq
n00b
n00b


Joined: 19 May 2008
Posts: 11
Location: Red Wing, MN

PostPosted: Sat Sep 10, 2016 8:19 am    Post subject: Reply with quote

I'm not exactly sure what's going on with systemd getting pulled in. If you say it shouldn't make a difference, then you know better than I do.

However, I can confirm it gets pulled in without "-gnome" for me.

I feel embarrassed about this, but I just now figured out what that block of error text at the end wants from me. It wants samba and libcanberra to have a use flag that I didn't specify.

I made a package-specific flag for samba, which eliminated that error.

Removing "extras" from mate still tries to pull in gnome-disk-utility. So I put in "-extras", which fixed that error.

However, I'm still getting a block of errors about stuff being required by stuff.

However, I've switched my profile from default/linux/x86/13.0/gnome to default/linux/x86/13.0/.
About half of the remaining errors are gone now.

So I'm doing,
Code:
emerge --update --newuse --deep @world && emerge --depclean


and then I'll try installing mate again. I'll post the output when that time (eventually) comes.

The reason I'm doing my project in gtk2 is because I'm making it cross-platform for windows and linux. I'm using python and pygtk, which only supports gtk2. (At least on windows. Not sure about linux.)

If a system can have gtk 2 and 3 on it together, then I guess there's no reason to make my life harder than it has to be...

EDIT: I'm dumb. You said it isn't -gnome or gnome making a difference. It's mate[extras]. I'll test with a --pretend to double check this.
Back to top
View user's profile Send private message
Leio
Developer
Developer


Joined: 27 Feb 2003
Posts: 480
Location: Estonia

PostPosted: Sat Sep 10, 2016 9:23 am    Post subject: Reply with quote

Amaroq wrote:
Removing "extras" from mate still tries to pull in gnome-disk-utility. So I put in "-extras", which fixed that error.

Now you don't get various other "extra" applications pulled in either; might want to check what else is there and get some of these manually that you might want.
Or just have gnome-disk-utility too with gtk3.

Amaroq wrote:
So I'm doing,
Code:
emerge --update --newuse --deep @world && emerge --depclean


and then I'll try installing mate again. I'll post the output when that time (eventually) comes.

I'd use something like "emerge -uDvaN @world" instead then. -uDN is just short for what you already have; -a will show the upgrades list and ask if you are satisfied with it to proceed; -v for --verbose will output USE flag information for each of those from that -a output. Additionally --tree can be useful sometimes to find out what pulls in what new stuff.

Amaroq wrote:
The reason I'm doing my project in gtk2 is because I'm making it cross-platform for windows and linux. I'm using python and pygtk, which only supports gtk2. (At least on windows. Not sure about linux.)

gtk3 works fine with python. You don't need pygtk, just pygobject and gobject-introspection, rest is done with introspection. Works much better than pygtk2. https://wiki.gnome.org/Projects/PyGObject

Amaroq wrote:
If a system can have gtk 2 and 3 on it together, then I guess there's no reason to make my life harder than it has to be...

They are fully parallel installable and almost everyone having a desktop has both right now unless they consciously avoid it in favor of Qt things. With firefox gtk3 support being matured now, I think we can fix a few GNOME3 packages where we can't configure at build time to only support gtk3 and support having a gtk2-less system easily (mostly caribou and a few other things that need fixing, that's for example just a GNOME3 accessibility thing - other distros split it from binaries, we need to work on patching it to be configureable at build time).
_________________
GNOME team lead; GStreamer; MIPS/ARM64
Back to top
View user's profile Send private message
Amaroq
n00b
n00b


Joined: 19 May 2008
Posts: 11
Location: Red Wing, MN

PostPosted: Sat Sep 10, 2016 11:29 am    Post subject: Reply with quote

Ooh. I haven't actually started coding the interface yet. I'll look into this. I was under the impression windows and pygtk only gets gtk2. That page is implying windows can get gtk3.

An update: I'm not sure how well it did. I tested "gnome" in the USE flag. It tries to bring in libcanberra, but doesn't seem to be trying to bring in systemd. Consistent with what you said about it being extras that does it.

I'm not sure but I think there's only one thing blocking Mate now. x11-libs/gtk+-3.20:3 is blocking x11-themes/mate-themes.

...So it looks like I could install if I did it without themes.

At the bottom there it looks like a lot of Mate stuff is pulling in gtk3 stuff even though I have -gtk3 in my global use flags still.

EDIT// I kind of don't feel like rebuilding world again so I can just do without themes for now.

Using "-themes" as a temporary flag, Mate is now compiling! //EDIT

Code:

These are the packages that would be merged, in order:

Calculating dependencies  .. .... done!
[ebuild  N     ] mate-base/mate-common-1.10.0
[ebuild  N     ] media-libs/libogg-1.3.1  USE="-static-libs"
[ebuild  N     ] app-crypt/p11-kit-0.20.7  USE="asn1 libffi trust -debug"
[ebuild  N     ] dev-perl/XML-NamespaceSupport-1.110.0-r1
[ebuild  N     ] dev-perl/XML-SAX-Base-1.80.0-r1
[ebuild  N     ] virtual/perl-Storable-2.490.100-r1
[ebuild  N     ] x11-libs/xcb-util-renderutil-0.3.9-r1  USE="-doc -static-libs {-test}"
[ebuild  N     ] x11-proto/xf86miscproto-0.9.3
[ebuild  N     ] media-libs/libvorbis-1.3.4  USE="-static-libs"
[ebuild  N     ] x11-libs/libXres-1.0.7  USE="-static-libs"
[ebuild  N     ] x11-libs/xcb-util-wm-0.4.1-r1  USE="-doc -static-libs {-test}"
[ebuild  N     ] x11-libs/xcb-util-keysyms-0.4.0  USE="-doc -static-libs {-test}"
[ebuild  N     ] x11-apps/xmodmap-1.0.9
[ebuild  N     ] x11-libs/libXScrnSaver-1.2.2-r1  USE="-static-libs"
[ebuild  N     ] x11-apps/xdpyinfo-1.3.2  USE="-dga -dmx -xinerama"
[ebuild  N     ] x11-libs/libXxf86misc-1.0.3  USE="-static-libs"
[ebuild  N     ] x11-libs/xcb-util-0.4.0  USE="-doc -static-libs {-test}"
[ebuild  N     ] x11-libs/xcb-util-image-0.4.0  USE="-doc -static-libs {-test}"
[ebuild  N     ] x11-libs/xcb-util-cursor-0.1.2  USE="-doc -static-libs {-test}"
[ebuild  N     ] x11-libs/startup-notification-0.12-r1  USE="-static-libs"
[ebuild  N     ] dev-db/sqlite-3.12.0  USE="readline -debug -doc -icu -secure-delete -static-libs -tcl {-test} -tools"
[ebuild  N     ] virtual/awk-1
[ebuild  N     ] media-libs/alsa-lib-1.0.29  USE="python -alisp -debug -doc" PYTHON_TARGETS="python2_7"
[ebuild  N     ] x11-libs/xpyb-1.3.1-r3  USE="(-selinux) -static-libs" PYTHON_TARGETS="python2_7"
[ebuild  N     ] app-text/scrollkeeper-dtd-1.0
[ebuild  N     ] dev-util/itstool-2.0.2  PYTHON_TARGETS="python2_7"
[ebuild  N     ] dev-perl/XML-SAX-0.990.0-r1
[ebuild  N     ] dev-python/pygobject-2.28.6-r55  USE="-examples -libffi {-test}" PYTHON_TARGETS="python2_7"
[ebuild  N     ] dev-python/numpy-1.9.2  USE="-doc -lapack {-test}" PYTHON_TARGETS="python2_7 python3_4 (-python3_3)"
[ebuild  N     ] media-libs/libexif-0.6.21-r1  USE="nls -doc -static-libs"
[ebuild  N     ] dev-libs/libcdio-0.92  USE="cxx -cddb -minimal -static-libs {-test}"
[ebuild  N     ] x11-libs/gnome-pty-helper-0.40.2  USE="hardened"
[ebuild  N     ] dev-perl/XML-LibXML-2.12.100  USE="{-test}"
[ebuild  N     ] x11-themes/mate-backgrounds-1.10.0
[ebuild  N     ] app-eselect/eselect-notify-send-0.1
[ebuild  N     ] x11-themes/sound-theme-freedesktop-0.8
[ebuild  N     ] app-eselect/eselect-cdparanoia-0.1
[ebuild  N     ] net-libs/libproxy-0.4.13-r1  USE="python -gnome -kde -mono -networkmanager -perl -spidermonkey {-test} -webkit" PYTHON_TARGETS="python2_7"
[ebuild  N     ] gnome-extra/yelp-xsl-3.18.1
[ebuild  N     ] dev-perl/XML-Simple-2.200.0-r1
[ebuild  N     ] app-text/yelp-tools-3.18.0
[ebuild  N     ] x11-misc/icon-naming-utils-0.8.90
[ebuild  N     ] dev-libs/libcdio-paranoia-0.90_p1-r1  USE="cxx -static-libs {-test}"
[ebuild  N     ] x11-themes/mate-icon-theme-1.10.1
[ebuild  N     ] net-libs/glib-networking-2.46.1  USE="libproxy ssl -gnome -smartcard {-test}"
[ebuild  N     ] gnome-base/libgtop-2.32.0  USE="introspection -debug"
[ebuild  N     ] media-libs/gstreamer-1.6.3  USE="caps introspection nls orc {-test}"
[ebuild  N     ] x11-libs/libnotify-0.7.6-r3  USE="introspection {-test}"
[ebuild  N     ] app-text/scrollkeeper-9999-r1
[ebuild  N     ] app-text/rarian-0.8.1-r2  USE="-static-libs"
[ebuild  N     ] dev-libs/dbus-glib-0.102  USE="-debug -doc -static-libs {-test}"
[ebuild  N     ] media-libs/libmatemixer-1.10.1  USE="alsa oss -debug -pulseaudio"
[ebuild  N     ] dev-python/pycairo-1.10.0-r4  USE="svg xcb -doc -examples {-test}" PYTHON_TARGETS="python2_7 python3_4 (-python3_3)"
[ebuild  NS    ] app-text/docbook-xml-dtd-4.3-r1 [4.1.2-r6, 4.2-r2, 4.4-r2]
[ebuild  N     ] dev-libs/libatasmart-0.19-r1  USE="-static-libs"
[ebuild  N     ] sys-apps/gptfdisk-1.0.1  USE="ncurses -static"
[ebuild  N     ] sys-block/parted-3.2  USE="debug nls readline -device-mapper (-selinux) -static-libs"
[ebuild  N     ] dev-python/pygobject-3.18.2  USE="cairo threads -examples {-test}" PYTHON_TARGETS="python2_7 python3_4 (-python3_3) (-python3_5)"
[ebuild  N     ] sys-power/cpupower-3.18  USE="nls -cpufreq_bench -debug"
[ebuild  N     ] dev-libs/libgudev-230  USE="introspection -debug -static-libs"
[ebuild  N     ] virtual/libgudev-230  USE="introspection -static-libs"
[ebuild  N     ] sys-power/upower-0.99.4  USE="introspection -doc -ios (-selinux)"
[ebuild  N     ] virtual/eject-0
[ebuild  N     ] mate-base/mate-desktop-1.10.2  USE="X introspection startup-notification user-guide -debug" PYTHON_TARGETS="python2_7"
[ebuild  N     ] media-libs/libcanberra-0.30-r5  USE="alsa gstreamer gtk oss sound udev -gnome -gtk3 -pulseaudio -tdb"
[ebuild  N     ] x11-libs/libwnck-2.31.0  USE="introspection startup-notification"
[ebuild  N     ] x11-misc/mate-notification-daemon-1.10.2  USE="-debug"
[ebuild  N     ] virtual/notification-daemon-0  USE="-gnome"
[ebuild  N     ] dev-libs/libunique-1.1.6-r1  USE="dbus introspection -debug -doc {-test}"
[ebuild  N     ] mate-base/libmatekbd-1.10.1  USE="X {-test}"
[ebuild  N     ] gnome-base/libglade-2.6.4-r2  USE="-static-libs {-test} -tools" PYTHON_SINGLE_TARGET="python2_7 (-pypy)" PYTHON_TARGETS="python2_7 (-pypy)"
[ebuild  N     ] app-crypt/gcr-3.18.0  USE="gtk introspection -debug {-test} -vala"
[ebuild  N     ] gnome-extra/zenity-3.18.1.1  USE="libnotify -debug {-test} -webkit"
[ebuild  N     ] gnome-extra/gucharmap-3.0.1-r200  USE="introspection -cjk -debug -doc"
[ebuild  N     ] x11-libs/gtksourceview-2.10.5-r3  USE="{-test}"
[ebuild  N     ] x11-themes/gtk-engines-2.20.2-r2  USE="-accessibility -lua"
[ebuild  N     ] dev-python/pygtk-2.24.0-r4  USE="-doc -examples {-test}" PYTHON_TARGETS="python2_7"
[ebuild  N     ] x11-wm/marco-1.10.3  USE="startup-notification {-test} -xinerama"
[ebuild  N     ] net-libs/libsoup-2.52.2  USE="introspection samba ssl -debug {-test} -vala"
[ebuild  N     ] mate-base/mate-menus-1.10.1  USE="introspection python -debug" PYTHON_TARGETS="python2_7"
[ebuild  N     ] dev-libs/libmateweather-1.10.0  USE="python -debug" PYTHON_TARGETS="python2_7"
[ebuild  N     ] x11-libs/vte-0.28.2-r207  USE="introspection python -debug" PYTHON_TARGETS="python2_7"
[ebuild  N     ] mate-base/mate-panel-1.10.1  USE="X introspection"
[ebuild  N     ] x11-terms/mate-terminal-1.10.2
[ebuild  N     ] mate-extra/mate-media-1.10.1  USE="-debug"
[ebuild  N     ] x11-misc/mozo-1.10.1  PYTHON_TARGETS="python2_7"
[ebuild  N     ] x11-misc/xdg-user-dirs-0.15  USE="gtk"
[ebuild  N     ] x11-misc/xdg-user-dirs-gtk-0.10
[ebuild  N     ] mate-base/mate-session-manager-1.10.3  USE="ipv6 upower -debug -gnome-keyring -systemd"
[ebuild  N     ] x11-themes/gtk-engines-murrine-0.98.2-r1  USE="themes -animation-rtl"
[ebuild  N     ] x11-themes/murrine-themes-0.98.0
[ebuild  N     ] x11-themes/mate-themes-3.20.10
[ebuild  N     ] x11-themes/mate-themes-meta-3  USE="gtk2-only"
[ebuild  N     ] mate-base/mate-settings-daemon-1.10.3  USE="X libnotify policykit sound -debug -pulseaudio -smartcard"
[ebuild  N     ] sys-fs/udisks-2.1.7  USE="acl gptfdisk introspection -cryptsetup -debug (-selinux) -systemd"
[ebuild  N     ] mate-base/mate-applets-1.10.4-r1  USE="X ipv6 policykit upower" PYTHON_TARGETS="python2_7"
[ebuild  N     ] mate-base/mate-applets-meta-1.10  USE="-appindicator -sensors"
[ebuild  N     ] gnome-base/gvfs-1.26.3  USE="cdda gtk http samba udev udisks -afp -archive -bluray -fuse -gnome-keyring -gnome-online-accounts -google -gphoto2 -ios -mtp -nfs -systemd {-test} -zeroconf"
[ebuild  N     ] mate-base/caja-1.10.4  USE="introspection mate -debug {-test} -xmp"
[ebuild  N     ] mate-base/mate-control-center-1.10.2  USE="-debug"
[ebuild  N     ] mate-base/mate-1.10.0-r3  USE="base notification themes (-bluetooth) -extras"
[blocks B      ] <x11-libs/gtk+-3.20:3 ("<x11-libs/gtk+-3.20:3" is blocking x11-themes/mate-themes-3.20.10)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (x11-themes/mate-themes-3.20.10:0/3.20::gentoo, ebuild scheduled for merge) pulled in by
    x11-themes/mate-themes:0 required by (x11-themes/mate-themes-meta-3:0/0::gentoo, ebuild scheduled for merge)

  (x11-libs/gtk+-3.18.9:3/3::gentoo, installed) pulled in by
    x11-libs/gtk+:3 required by (x11-misc/lightdm-gtk-greeter-2.0.1-r1:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.5.1:3 required by (x11-misc/xdg-user-dirs-gtk-0.10:0/0::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-3:3 required by (gnome-extra/zenity-3.18.1.1:0/0::gentoo, ebuild scheduled for merge)
    x11-libs/gtk+:3 required by (app-text/ghostscript-gpl-9.15-r1:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.12:3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=x11-libs/gtk+-3.12:3[abi_x86_32(-)]) required by (x11-themes/gnome-themes-standard-3.18.0:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.0:3 required by (gnome-base/gvfs-1.26.3:0/0::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-3.12:3[X,introspection?] (>=x11-libs/gtk+-3.12:3[X,introspection]) required by (app-crypt/gcr-3.18.0:0/1::gentoo, ebuild scheduled for merge)
    x11-libs/gtk+:3 required by (gnome-extra/polkit-gnome-0.105-r1:0/0::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


[Moderator edit: broke long whitespace-free lines in code tags to fix thread layout. -Hu]
Back to top
View user's profile Send private message
Leio
Developer
Developer


Joined: 27 Feb 2003
Posts: 480
Location: Estonia

PostPosted: Sat Sep 10, 2016 12:15 pm    Post subject: Reply with quote

Amaroq wrote:
I'm not sure but I think there's only one thing blocking Mate now. x11-libs/gtk+-3.20:3 is blocking x11-themes/mate-themes.

...So it looks like I could install if I did it without themes.

At the bottom there it looks like a lot of Mate stuff is pulling in gtk3 stuff even though I have -gtk3 in my global use flags still.

EDIT// I kind of don't feel like rebuilding world again so I can just do without themes for now.

Using "-themes" as a temporary flag, Mate is now compiling! //EDIT


You need matching gtk+ and mate-themes version for now (well, mate-themes-3.20* with gtk3.20* and mate-themes-3.18* with gtk3.18*, third micro version number doesn't matter) and there's the virtual/ mate themes package that tries to lock them in tandem, but package manager can't quite figure things out on its own like this in all situations.
I've told MATE maintainers how to support multiple gtk versions with themes package at once, and they are looking into implementing it and also talking with upstream.
Meanwhile they stabled mate-themes-3.20 to not block gtk3.20 stabilization, but this seems to trigger such issues as you are having; limit mate-themes to 3.18 if you are getting gtk3.18 otherwise (if you use stable tree). For example by just listing \<x11-themes/mate-themes-3.19 togetherwith with @world or temporarily package.masking it in /etc/portage/package.mask until you see gtk3.20 going stable.
_________________
GNOME team lead; GStreamer; MIPS/ARM64
Back to top
View user's profile Send private message
NP-Hardass
Developer
Developer


Joined: 24 Mar 2013
Posts: 36

PostPosted: Sat Sep 10, 2016 5:27 pm    Post subject: Reply with quote

Leio wrote:
Amaroq wrote:
I'm not sure but I think there's only one thing blocking Mate now. x11-libs/gtk+-3.20:3 is blocking x11-themes/mate-themes.

...So it looks like I could install if I did it without themes.

At the bottom there it looks like a lot of Mate stuff is pulling in gtk3 stuff even though I have -gtk3 in my global use flags still.

EDIT// I kind of don't feel like rebuilding world again so I can just do without themes for now.

Using "-themes" as a temporary flag, Mate is now compiling! //EDIT


You need matching gtk+ and mate-themes version for now (well, mate-themes-3.20* with gtk3.20* and mate-themes-3.18* with gtk3.18*, third micro version number doesn't matter) and there's the virtual/ mate themes package that tries to lock them in tandem, but package manager can't quite figure things out on its own like this in all situations.
I've told MATE maintainers how to support multiple gtk versions with themes package at once, and they are looking into implementing it and also talking with upstream.
Meanwhile they stabled mate-themes-3.20 to not block gtk3.20 stabilization, but this seems to trigger such issues as you are having; limit mate-themes to 3.18 if you are getting gtk3.18 otherwise (if you use stable tree). For example by just listing \<x11-themes/mate-themes-3.19 togetherwith with @world or temporarily package.masking it in /etc/portage/package.mask until you see gtk3.20 going stable.


This problem only arises with the current packaging when two gtk+ versions are visible, and you are on the lower of the two. In this case, this means that you have unkeyworded (or are using an overlay where it is unkeyworded). In this case, the best way for you to proceed is to emerge -1 \=mate-themes-3.18*, then go back to emerge mate-base/mate.

Yes, having separate CSS dirs is the optimal solution, and we are working toward that.
Back to top
View user's profile Send private message
NP-Hardass
Developer
Developer


Joined: 24 Mar 2013
Posts: 36

PostPosted: Sat Sep 10, 2016 5:52 pm    Post subject: Reply with quote

Amaroq wrote:
Ooh. I haven't actually started coding the interface yet. I'll look into this. I was under the impression windows and pygtk only gets gtk2. That page is implying windows can get gtk3.

An update: I'm not sure how well it did. I tested "gnome" in the USE flag. It tries to bring in libcanberra, but doesn't seem to be trying to bring in systemd. Consistent with what you said about it being extras that does it.

I'm not sure but I think there's only one thing blocking Mate now. x11-libs/gtk+-3.20:3 is blocking x11-themes/mate-themes.

...So it looks like I could install if I did it without themes.

At the bottom there it looks like a lot of Mate stuff is pulling in gtk3 stuff even though I have -gtk3 in my global use flags still.

EDIT// I kind of don't feel like rebuilding world again so I can just do without themes for now.

Using "-themes" as a temporary flag, Mate is now compiling! //EDIT

Code:

These are the packages that would be merged, in order:

Calculating dependencies  .. .... done!
[ebuild  N     ] mate-base/mate-common-1.10.0
[ebuild  N     ] media-libs/libogg-1.3.1  USE="-static-libs"
[ebuild  N     ] app-crypt/p11-kit-0.20.7  USE="asn1 libffi trust -debug"
[ebuild  N     ] dev-perl/XML-NamespaceSupport-1.110.0-r1
[ebuild  N     ] dev-perl/XML-SAX-Base-1.80.0-r1
[ebuild  N     ] virtual/perl-Storable-2.490.100-r1
[ebuild  N     ] x11-libs/xcb-util-renderutil-0.3.9-r1  USE="-doc -static-libs {-test}"
[ebuild  N     ] x11-proto/xf86miscproto-0.9.3
[ebuild  N     ] media-libs/libvorbis-1.3.4  USE="-static-libs"
[ebuild  N     ] x11-libs/libXres-1.0.7  USE="-static-libs"
[ebuild  N     ] x11-libs/xcb-util-wm-0.4.1-r1  USE="-doc -static-libs {-test}"
[ebuild  N     ] x11-libs/xcb-util-keysyms-0.4.0  USE="-doc -static-libs {-test}"
[ebuild  N     ] x11-apps/xmodmap-1.0.9
[ebuild  N     ] x11-libs/libXScrnSaver-1.2.2-r1  USE="-static-libs"
[ebuild  N     ] x11-apps/xdpyinfo-1.3.2  USE="-dga -dmx -xinerama"
[ebuild  N     ] x11-libs/libXxf86misc-1.0.3  USE="-static-libs"
[ebuild  N     ] x11-libs/xcb-util-0.4.0  USE="-doc -static-libs {-test}"
[ebuild  N     ] x11-libs/xcb-util-image-0.4.0  USE="-doc -static-libs {-test}"
[ebuild  N     ] x11-libs/xcb-util-cursor-0.1.2  USE="-doc -static-libs {-test}"
[ebuild  N     ] x11-libs/startup-notification-0.12-r1  USE="-static-libs"
[ebuild  N     ] dev-db/sqlite-3.12.0  USE="readline -debug -doc -icu -secure-delete -static-libs -tcl {-test} -tools"
[ebuild  N     ] virtual/awk-1
[ebuild  N     ] media-libs/alsa-lib-1.0.29  USE="python -alisp -debug -doc" PYTHON_TARGETS="python2_7"
[ebuild  N     ] x11-libs/xpyb-1.3.1-r3  USE="(-selinux) -static-libs" PYTHON_TARGETS="python2_7"
[ebuild  N     ] app-text/scrollkeeper-dtd-1.0
[ebuild  N     ] dev-util/itstool-2.0.2  PYTHON_TARGETS="python2_7"
[ebuild  N     ] dev-perl/XML-SAX-0.990.0-r1
[ebuild  N     ] dev-python/pygobject-2.28.6-r55  USE="-examples -libffi {-test}" PYTHON_TARGETS="python2_7"
[ebuild  N     ] dev-python/numpy-1.9.2  USE="-doc -lapack {-test}" PYTHON_TARGETS="python2_7 python3_4 (-python3_3)"
[ebuild  N     ] media-libs/libexif-0.6.21-r1  USE="nls -doc -static-libs"
[ebuild  N     ] dev-libs/libcdio-0.92  USE="cxx -cddb -minimal -static-libs {-test}"
[ebuild  N     ] x11-libs/gnome-pty-helper-0.40.2  USE="hardened"
[ebuild  N     ] dev-perl/XML-LibXML-2.12.100  USE="{-test}"
[ebuild  N     ] x11-themes/mate-backgrounds-1.10.0
[ebuild  N     ] app-eselect/eselect-notify-send-0.1
[ebuild  N     ] x11-themes/sound-theme-freedesktop-0.8
[ebuild  N     ] app-eselect/eselect-cdparanoia-0.1
[ebuild  N     ] net-libs/libproxy-0.4.13-r1  USE="python -gnome -kde -mono -networkmanager -perl -spidermonkey {-test} -webkit" PYTHON_TARGETS="python2_7"
[ebuild  N     ] gnome-extra/yelp-xsl-3.18.1
[ebuild  N     ] dev-perl/XML-Simple-2.200.0-r1
[ebuild  N     ] app-text/yelp-tools-3.18.0
[ebuild  N     ] x11-misc/icon-naming-utils-0.8.90
[ebuild  N     ] dev-libs/libcdio-paranoia-0.90_p1-r1  USE="cxx -static-libs {-test}"
[ebuild  N     ] x11-themes/mate-icon-theme-1.10.1
[ebuild  N     ] net-libs/glib-networking-2.46.1  USE="libproxy ssl -gnome -smartcard {-test}"
[ebuild  N     ] gnome-base/libgtop-2.32.0  USE="introspection -debug"
[ebuild  N     ] media-libs/gstreamer-1.6.3  USE="caps introspection nls orc {-test}"
[ebuild  N     ] x11-libs/libnotify-0.7.6-r3  USE="introspection {-test}"
[ebuild  N     ] app-text/scrollkeeper-9999-r1
[ebuild  N     ] app-text/rarian-0.8.1-r2  USE="-static-libs"
[ebuild  N     ] dev-libs/dbus-glib-0.102  USE="-debug -doc -static-libs {-test}"
[ebuild  N     ] media-libs/libmatemixer-1.10.1  USE="alsa oss -debug -pulseaudio"
[ebuild  N     ] dev-python/pycairo-1.10.0-r4  USE="svg xcb -doc -examples {-test}" PYTHON_TARGETS="python2_7 python3_4 (-python3_3)"
[ebuild  NS    ] app-text/docbook-xml-dtd-4.3-r1 [4.1.2-r6, 4.2-r2, 4.4-r2]
[ebuild  N     ] dev-libs/libatasmart-0.19-r1  USE="-static-libs"
[ebuild  N     ] sys-apps/gptfdisk-1.0.1  USE="ncurses -static"
[ebuild  N     ] sys-block/parted-3.2  USE="debug nls readline -device-mapper (-selinux) -static-libs"
[ebuild  N     ] dev-python/pygobject-3.18.2  USE="cairo threads -examples {-test}" PYTHON_TARGETS="python2_7 python3_4 (-python3_3) (-python3_5)"
[ebuild  N     ] sys-power/cpupower-3.18  USE="nls -cpufreq_bench -debug"
[ebuild  N     ] dev-libs/libgudev-230  USE="introspection -debug -static-libs"
[ebuild  N     ] virtual/libgudev-230  USE="introspection -static-libs"
[ebuild  N     ] sys-power/upower-0.99.4  USE="introspection -doc -ios (-selinux)"
[ebuild  N     ] virtual/eject-0
[ebuild  N     ] mate-base/mate-desktop-1.10.2  USE="X introspection startup-notification user-guide -debug" PYTHON_TARGETS="python2_7"
[ebuild  N     ] media-libs/libcanberra-0.30-r5  USE="alsa gstreamer gtk oss sound udev -gnome -gtk3 -pulseaudio -tdb"
[ebuild  N     ] x11-libs/libwnck-2.31.0  USE="introspection startup-notification"
[ebuild  N     ] x11-misc/mate-notification-daemon-1.10.2  USE="-debug"
[ebuild  N     ] virtual/notification-daemon-0  USE="-gnome"
[ebuild  N     ] dev-libs/libunique-1.1.6-r1  USE="dbus introspection -debug -doc {-test}"
[ebuild  N     ] mate-base/libmatekbd-1.10.1  USE="X {-test}"
[ebuild  N     ] gnome-base/libglade-2.6.4-r2  USE="-static-libs {-test} -tools" PYTHON_SINGLE_TARGET="python2_7 (-pypy)" PYTHON_TARGETS="python2_7 (-pypy)"
[ebuild  N     ] app-crypt/gcr-3.18.0  USE="gtk introspection -debug {-test} -vala"
[ebuild  N     ] gnome-extra/zenity-3.18.1.1  USE="libnotify -debug {-test} -webkit"
[ebuild  N     ] gnome-extra/gucharmap-3.0.1-r200  USE="introspection -cjk -debug -doc"
[ebuild  N     ] x11-libs/gtksourceview-2.10.5-r3  USE="{-test}"
[ebuild  N     ] x11-themes/gtk-engines-2.20.2-r2  USE="-accessibility -lua"
[ebuild  N     ] dev-python/pygtk-2.24.0-r4  USE="-doc -examples {-test}" PYTHON_TARGETS="python2_7"
[ebuild  N     ] x11-wm/marco-1.10.3  USE="startup-notification {-test} -xinerama"
[ebuild  N     ] net-libs/libsoup-2.52.2  USE="introspection samba ssl -debug {-test} -vala"
[ebuild  N     ] mate-base/mate-menus-1.10.1  USE="introspection python -debug" PYTHON_TARGETS="python2_7"
[ebuild  N     ] dev-libs/libmateweather-1.10.0  USE="python -debug" PYTHON_TARGETS="python2_7"
[ebuild  N     ] x11-libs/vte-0.28.2-r207  USE="introspection python -debug" PYTHON_TARGETS="python2_7"
[ebuild  N     ] mate-base/mate-panel-1.10.1  USE="X introspection"
[ebuild  N     ] x11-terms/mate-terminal-1.10.2
[ebuild  N     ] mate-extra/mate-media-1.10.1  USE="-debug"
[ebuild  N     ] x11-misc/mozo-1.10.1  PYTHON_TARGETS="python2_7"
[ebuild  N     ] x11-misc/xdg-user-dirs-0.15  USE="gtk"
[ebuild  N     ] x11-misc/xdg-user-dirs-gtk-0.10
[ebuild  N     ] mate-base/mate-session-manager-1.10.3  USE="ipv6 upower -debug -gnome-keyring -systemd"
[ebuild  N     ] x11-themes/gtk-engines-murrine-0.98.2-r1  USE="themes -animation-rtl"
[ebuild  N     ] x11-themes/murrine-themes-0.98.0
[ebuild  N     ] x11-themes/mate-themes-3.20.10
[ebuild  N     ] x11-themes/mate-themes-meta-3  USE="gtk2-only"
[ebuild  N     ] mate-base/mate-settings-daemon-1.10.3  USE="X libnotify policykit sound -debug -pulseaudio -smartcard"
[ebuild  N     ] sys-fs/udisks-2.1.7  USE="acl gptfdisk introspection -cryptsetup -debug (-selinux) -systemd"
[ebuild  N     ] mate-base/mate-applets-1.10.4-r1  USE="X ipv6 policykit upower" PYTHON_TARGETS="python2_7"
[ebuild  N     ] mate-base/mate-applets-meta-1.10  USE="-appindicator -sensors"
[ebuild  N     ] gnome-base/gvfs-1.26.3  USE="cdda gtk http samba udev udisks -afp -archive -bluray -fuse -gnome-keyring -gnome-online-accounts -google -gphoto2 -ios -mtp -nfs -systemd {-test} -zeroconf"
[ebuild  N     ] mate-base/caja-1.10.4  USE="introspection mate -debug {-test} -xmp"
[ebuild  N     ] mate-base/mate-control-center-1.10.2  USE="-debug"
[ebuild  N     ] mate-base/mate-1.10.0-r3  USE="base notification themes (-bluetooth) -extras"
[blocks B      ] <x11-libs/gtk+-3.20:3 ("<x11-libs/gtk+-3.20:3" is blocking x11-themes/mate-themes-3.20.10)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (x11-themes/mate-themes-3.20.10:0/3.20::gentoo, ebuild scheduled for merge) pulled in by
    x11-themes/mate-themes:0 required by (x11-themes/mate-themes-meta-3:0/0::gentoo, ebuild scheduled for merge)

  (x11-libs/gtk+-3.18.9:3/3::gentoo, installed) pulled in by
    x11-libs/gtk+:3 required by (x11-misc/lightdm-gtk-greeter-2.0.1-r1:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.5.1:3 required by (x11-misc/xdg-user-dirs-gtk-0.10:0/0::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-3:3 required by (gnome-extra/zenity-3.18.1.1:0/0::gentoo, ebuild scheduled for merge)
    x11-libs/gtk+:3 required by (app-text/ghostscript-gpl-9.15-r1:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.12:3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=x11-libs/gtk+-3.12:3[abi_x86_32(-)]) required by (x11-themes/gnome-themes-standard-3.18.0:0/0::gentoo, installed)
    >=x11-libs/gtk+-3.0:3 required by (gnome-base/gvfs-1.26.3:0/0::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-3.12:3[X,introspection?] (>=x11-libs/gtk+-3.12:3[X,introspection]) required by (app-crypt/gcr-3.18.0:0/1::gentoo, ebuild scheduled for merge)
    x11-libs/gtk+:3 required by (gnome-extra/polkit-gnome-0.105-r1:0/0::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


Leio and I were talking it over, and we noticed (which I missed earlier) that you have "gtk2-only" set on mate-themes-meta. The user flag description for that is: "gtk2-only : Allow dependency-resolution for a system without GTK+3" In this case, I don't believe you want that, as that is for a system without GTK+3, not built without gtK+3 support (that is handled by gtk3 flags on MATE packages (and only becomes available starting with mate-1.12 anyway))

[Moderator edit: broke long whitespace-free lines in code tags to fix thread layout. -Hu]
Back to top
View user's profile Send private message
Leio
Developer
Developer


Joined: 27 Feb 2003
Posts: 480
Location: Estonia

PostPosted: Sat Sep 10, 2016 6:09 pm    Post subject: Reply with quote

NP-Hardass wrote:
Leio and I were talking it over, and we noticed (which I missed earlier) that you have "gtk2-only" set on mate-themes-meta. The user flag description for that is: "gtk2-only : Allow dependency-resolution for a system without GTK+3" In this case, I don't believe you want that, as that is for a system without GTK+3, not built without gtK+3 support (that is handled by gtk3 flags on MATE packages (and only becomes available starting with mate-1.12 anyway))


And it isn't a system without GTK+3, because x11-misc/lightdm-gtk-greeter is already installed, which uses GTK+3.
The blocker message wasn't so clear because there was a typo on the gtk3 blocker on mate-themes-meta[gtk2-only], so it didn't apply, and the message wasn't so clear. NP-Hardass is in the process of fixing that typo, hopefully it becomes more clear then.
But for Amaroq, because you already have gtk3 using lightdm-gtk-greeter, plus realized that gtk3 with python is fine via PyGObject on windows too and should use gtk3 for it, just remove gtk2-only.
_________________
GNOME team lead; GStreamer; MIPS/ARM64
Back to top
View user's profile Send private message
alexdu
n00b
n00b


Joined: 25 Oct 2005
Posts: 42
Location: Moscow, Russia

PostPosted: Mon Sep 19, 2016 8:24 pm    Post subject: Reply with quote

gnome, systemd and some others USE flags came from default/linux/amd64/13.0/desktop/gnome & default/linux/amd64/13.0/desktop/gnome/systemd profiles. Afaik, Mate works with "base" default/linux/amd64/13.0/desktop profile.
Code:
# eselect profile list
# eselect profile set 3
Back to top
View user's profile Send private message
cwr
Veteran
Veteran


Joined: 17 Dec 2005
Posts: 1968

PostPosted: Wed Jan 31, 2018 1:46 pm    Post subject: Reply with quote

Footnote to an old thread:

The current Mate 1.18 pulls in systemd unless emerged with -gnome, or -extra.
USE=-gnome seems the easiest approach.

Will
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum