Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] KDE plasma 5 - problem with migration - kwin?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Xywa
Veteran
Veteran


Joined: 23 Jul 2005
Posts: 1575
Location: /mnt/Gentoo/Europe

PostPosted: Fri Feb 12, 2016 5:41 pm    Post subject: [SOLVED] KDE plasma 5 - problem with migration - kwin? Reply with quote

Hi,

I am doing plasma 5 migration:
https://wiki.gentoo.org/wiki/KDE/Plasma_5_upgrade
I have done everything like in manual, but when I doing this nearly last step:
Code:
root #emerge --ask --changed-use --newrepo --deep world

I have such problem:
Code:
# emerge --changed-use --newrepo --deep world   
Calculating dependencies... done!
[ebuild  N     ] media-libs/libuninameslist-20091231
[ebuild  N     ] dev-db/lmdb-0.9.18  USE="-static-libs"
[ebuild  N     ] media-fonts/noto-2015.04  USE="X"
[ebuild  N     ] net-misc/socat-1.7.3.1  USE="ipv6 readline ssl tcpd"
[ebuild  N     ] net-libs/libndp-1.5  ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] dev-qt/qtpaths-5.5.1-r1  USE="-debug {-test}"
[ebuild  N     ] dev-libs/libinput-1.1.5  USE="{-test}"
[ebuild  N     ] dev-libs/libpwquality-1.3.0  USE="pam -python -static-libs" PYTHON_TARGETS="python2_7 python3_4 -python3_3"
[ebuild  N     ] dev-qt/qdbus-5.5.1-r1  USE="-debug {-test}"
[ebuild  N     ] net-misc/dhcp-4.3.3_p1  USE="client ipv6 ldap server ssl -libressl (-selinux) -vim-syntax"
[ebuild  N     ] gnome-base/gsettings-desktop-schemas-3.18.1  USE="introspection"
[ebuild  N     ] dev-libs/newt-0.52.18  USE="gpm nls -tcl" PYTHON_TARGETS="python2_7"
[ebuild   R    ] dev-util/cmake-3.4.3  USE="qt5* -qt4*"
[ebuild  N     ] kde-frameworks/kjs-5.18.0  USE="-debug -doc {-test}"
[ebuild  N     ] kde-plasma/kwayland-5.5.4  USE="-debug {-test}"
[ebuild  N     ] kde-frameworks/kidletime-5.18.0  USE="-debug -doc"
[ebuild  N     ] kde-plasma/libkscreen-5.5.4  USE="-debug {-test}"
[ebuild  N     ] kde-plasma/kdecoration-5.5.4  USE="-debug {-test}"
[ebuild  N     ] dev-qt/qtgraphicaleffects-5.5.1-r1  USE="-debug {-test}"
[ebuild   R    ] dev-qt/linguist-tools-5.5.1-r1  USE="qml*"
[ebuild   R    ] net-wireless/wpa_supplicant-2.5-r1  USE="qt5*"
[ebuild   R    ] dev-qt/qtwebkit-5.5.1-r1  USE="qml*"
[ebuild  N     ] kde-plasma/kwallet-pam-5.5.4  USE="-debug"
[ebuild  N     ] kde-plasma/plasma-workspace-wallpapers-5.5.4
[ebuild  N     ] kde-plasma/breeze-gtk-5.5.4  USE="-debug"
[ebuild  N     ] kde-frameworks/bluez-qt-5.18.0  USE="-debug -doc {-test}"
[ebuild  N     ] kde-frameworks/breeze-icons-5.18.0  USE="{-test}"
[ebuild  N     ] kde-frameworks/kplotting-5.18.0  USE="-debug -doc {-test}"
[ebuild   R    ] dev-qt/qtmultimedia-5.5.1-r2  USE="qml* widgets*"
[ebuild  N     ] kde-plasma/kwayland-integration-5.5.4  USE="-debug"
[ebuild  N     ] kde-frameworks/kjsembed-5.18.0  USE="-debug -doc"
[ebuild  N     ] kde-frameworks/kdnssd-5.18.0  USE="nls -debug -doc {-test} -zeroconf"
[ebuild  N     ] kde-frameworks/kpeople-5.18.0  USE="-debug -doc {-test}"
[ebuild   R    ] app-crypt/pinentry-0.9.7  USE="qt5* -qt4*"
[ebuild  N     ] media-gfx/fontforge-20150824  USE="X cairo gif gtk jpeg png python readline svg tiff unicode -truetype-debugger" PYTHON_SINGLE_TARGET="python2_7 -python3_3 -python3_4" PYTHON_TARGETS="python2_7 python3_4 -python3_3"
[ebuild  N     ] kde-plasma/oxygen-fonts-5.4.3  USE="X"
[ebuild  N     ] net-dialup/rp-pppoe-3.12  USE="-tk"
[ebuild  N     ] x11-misc/sddm-0.13.0-r1  USE="consolekit pam -systemd"
[ebuild  N     ] sys-auth/polkit-pkla-compat-0.1
[ebuild  N     ] kde-plasma/ksshaskpass-5.5.4  USE="-debug"
[ebuild  N     ] kde-frameworks/knotifyconfig-5.18.0  USE="phonon -debug -doc"
[ebuild  N     ] kde-frameworks/frameworkintegration-5.18.0  USE="X -debug -doc {-test}"
[ebuild  N     ] kde-frameworks/kxmlrpcclient-5.18.0  USE="-debug -doc {-test}"
[ebuild  N     ] kde-frameworks/khtml-5.18.0  USE="X -debug -doc {-test}"
[ebuild  N     ] kde-frameworks/kross-5.18.0  USE="-debug -doc {-test}"
[ebuild  N     ] kde-apps/kio-extras-15.08.3  USE="exif handbook phonon sftp -debug -mtp -samba -slp {-test}"
[ebuild  N     ] kde-plasma/user-manager-5.5.4  USE="-debug"
[ebuild  N     ] kde-plasma/kgamma-5.5.4  USE="handbook -debug"
[ebuild  N     ] kde-frameworks/krunner-5.18.0  USE="-debug -doc {-test}"
[ebuild  N     ] kde-plasma/sddm-kcm-5.5.4  USE="-debug"
[ebuild  N     ] kde-plasma/milou-5.5.4  USE="-debug"
[ebuild  N     ] kde-plasma/bluedevil-5.5.4  USE="-debug"
[uninstall     ] net-wireless/bluedevil-2.1.1
[blocks b      ] net-wireless/bluedevil ("net-wireless/bluedevil" is blocking kde-plasma/bluedevil-5.5.4)
[ebuild  N     ] kde-plasma/oxygen-5.5.4  USE="-debug"
[uninstall     ] kde-base/kdebase-cursors-4.11.22
[blocks b      ] kde-base/kdebase-cursors:4 ("kde-base/kdebase-cursors:4" is blocking kde-plasma/oxygen-5.5.4)
[ebuild  N     ] kde-plasma/kinfocenter-5.5.4  USE="X egl handbook opengl pci -debug -gles -ieee1394 -nfs -samba -wayland"
[uninstall     ] kde-base/kinfocenter-4.11.22
[blocks b      ] kde-base/kinfocenter:4 ("kde-base/kinfocenter:4" is blocking kde-plasma/kinfocenter-5.5.4)
[ebuild  N     ] kde-plasma/kscreen-5.5.4  USE="-debug"
[uninstall     ] kde-misc/kscreen-1.0.71_p20150824
[blocks b      ] kde-misc/kscreen ("kde-misc/kscreen" is blocking kde-plasma/kscreen-5.5.4)
[ebuild  N     ] kde-plasma/kde-gtk-config-5.5.4  USE="gtk3 -debug {-test}"
[uninstall     ] kde-misc/kde-gtk-config-2.2.1
[blocks b      ] kde-misc/kde-gtk-config ("kde-misc/kde-gtk-config" is blocking kde-plasma/kde-gtk-config-5.5.4)
[ebuild  N     ] kde-plasma/kscreenlocker-5.5.4-r1  USE="pam -debug {-test}"
[uninstall     ] kde-base/kdebase-pam-9
[blocks b      ] kde-base/kdebase-pam:0 ("kde-base/kdebase-pam:0" is blocking kde-plasma/kscreenlocker-5.5.4-r1)
[ebuild  N     ] kde-plasma/khelpcenter-5.5.4  USE="handbook -debug"
[uninstall     ] kde-base/khelpcenter-4.14.3
[blocks b      ] kde-base/khelpcenter:4 ("kde-base/khelpcenter:4" is blocking kde-plasma/khelpcenter-5.5.4)
[ebuild  N     ] kde-plasma/kwrited-5.5.4  USE="-debug"
[uninstall     ] kde-base/kwrited-4.11.22
[blocks b      ] kde-base/kwrited:4 ("kde-base/kwrited:4" is blocking kde-plasma/kwrited-5.5.4)
[ebuild  NS    ] kde-apps/kwrite-15.08.3 [4.14.3] USE="handbook -debug"
[uninstall     ] kde-apps/kwrite-4.14.3
[blocks b      ] kde-apps/kwrite:4 ("kde-apps/kwrite:4" is blocking kde-apps/kwrite-15.08.3)
[ebuild  NS    ] kde-apps/konsole-15.08.3-r1 [4.14.3-r2] USE="X handbook -debug {-test}"
[uninstall     ] kde-apps/konsole-4.14.3-r2
[blocks b      ] kde-apps/konsole:4 ("kde-apps/konsole:4" is blocking kde-apps/konsole-15.08.3-r1)
[ebuild  N     ] kde-plasma/libksysguard-5.5.4  USE="X detailedmemory -debug {-test}"
[ebuild  N     ] kde-plasma/ksysguard-5.5.4  USE="handbook lm_sensors -debug"
[uninstall     ] kde-base/ksysguard-4.11.22
[blocks b      ] kde-base/ksysguard:4 ("kde-base/ksysguard:4" is blocking kde-plasma/libksysguard-5.5.4, kde-plasma/ksysguard-5.5.4)
[ebuild  N     ] kde-plasma/kwin-5.5.4  USE="gles2 handbook -debug -multimedia {-test}"
[ebuild  N     ] kde-plasma/systemsettings-5.5.4  USE="gtk handbook -classic -debug"
[ebuild  N     ] kde-plasma/breeze-5.5.4  USE="qt4 -debug"
[ebuild   R    ] kde-apps/solid-runtime-15.08.3  USE="-bluetooth*"
[ebuild  N     ] net-libs/libproxy-0.4.11-r2  USE="kde -gnome -mono -networkmanager -perl -python -spidermonkey {-test} -webkit" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7"
[ebuild   R    ] kde-apps/libkipi-15.08.3  USE="minimal*"
[ebuild  N     ] kde-base/kwin-4.11.22  USE="opengl (-aqua) -debug -gles -wayland"
[ebuild  N     ] net-libs/glib-networking-2.46.1  USE="gnome libproxy ssl -smartcard {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] net-libs/libsoup-2.52.2  USE="introspection ssl -debug -samba {-test} -vala" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] kde-apps/kdeartwork-styles-15.08.3  USE="(-aqua) -debug"
[ebuild  N     ] net-misc/networkmanager-1.0.10-r1  USE="bluetooth consolekit dhclient introspection modemmanager ncurses nss ppp wext wifi -connection-sharing -dhcpcd -gnutls -resolvconf (-selinux) -systemd -teamd {-test} -vala -zeroconf" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] kde-frameworks/networkmanager-qt-5.18.0  USE="-debug -doc -teamd {-test}"
[ebuild  NS    ] kde-apps/kdebase-runtime-meta-15.08.3-r1 [4.14.3] USE="oldwallet"
[uninstall     ] kde-apps/kdebase-runtime-meta-4.14.3
[blocks b      ] kde-apps/kdebase-runtime-meta:4 ("kde-apps/kdebase-runtime-meta:4" is blocking kde-apps/kdebase-runtime-meta-15.08.3-r1)
[ebuild   R    ] media-video/vlc-2.2.2  USE="qt5* -qt4*"
[ebuild   R    ] media-libs/opencv-3.1.0-r1  USE="qt5* -qt4*"
[ebuild  N     ] kde-frameworks/kfilemetadata-5.18.0  USE="exif ffmpeg pdf -debug -doc -epub -libav -taglib {-test}"
[ebuild  N     ] kde-frameworks/baloo-5.18.0  USE="-debug -doc {-test}"
[ebuild   R    ] media-libs/mlt-0.9.8-r2  USE="qt5* -kde* -qt4*"
[ebuild  NS    ] kde-apps/baloo-widgets-15.08.3 [4.14.3] USE="-debug {-test}"
[uninstall     ] kde-apps/baloo-widgets-4.14.3
[blocks b      ] kde-apps/baloo-widgets:4 ("kde-apps/baloo-widgets:4" is blocking kde-apps/baloo-widgets-15.08.3)
[ebuild  NS    ] kde-apps/dolphin-15.08.3 [4.14.3-r1] USE="handbook semantic-desktop -debug {-test} (-thumbnail)"
[uninstall     ] kde-apps/dolphin-4.14.3-r1
[blocks b      ] kde-apps/dolphin:4 ("kde-apps/dolphin:4" is blocking kde-apps/dolphin-15.08.3)
[ebuild  N     ] kde-apps/kdecore-meta-15.08.3-r1  USE="wallpapers -minimal"
[ebuild  NS    ] kde-apps/kdenlive-15.12.1 [0.9.10] USE="gles2 handbook -debug -v4l"
[uninstall     ] kde-apps/kdenlive-0.9.10
[blocks b      ] kde-apps/kdenlive:4 ("kde-apps/kdenlive:4" is blocking kde-apps/kdenlive-15.12.1)
[ebuild  N     ] kde-plasma/plasma-workspace-5.5.4  USE="dbus geolocation handbook -debug -gps (-prison) -qalculate {-test}"
[uninstall     ] kde-base/kcminit-4.11.22
[blocks b      ] kde-base/kcminit:4 ("kde-base/kcminit:4" is blocking kde-plasma/plasma-workspace-5.5.4)
[uninstall     ] kde-base/ksplash-4.11.22
[blocks b      ] kde-base/ksplash:4 ("kde-base/ksplash:4" is blocking kde-plasma/plasma-workspace-5.5.4)
[uninstall     ] kde-base/libtaskmanager-4.11.22
[blocks b      ] kde-base/libtaskmanager:4 ("kde-base/libtaskmanager:4" is blocking kde-plasma/plasma-workspace-5.5.4)
[uninstall     ] kde-base/freespacenotifier-4.11.22
[blocks b      ] kde-base/freespacenotifier:4 ("kde-base/freespacenotifier:4" is blocking kde-plasma/plasma-workspace-5.5.4)
[uninstall     ] kde-base/ksmserver-4.11.22
[blocks b      ] kde-base/ksmserver:4 ("kde-base/ksmserver:4" is blocking kde-plasma/plasma-workspace-5.5.4)
[uninstall     ] kde-base/kdebase-startkde-4.11.22
[blocks b      ] kde-base/kdebase-startkde:4 ("kde-base/kdebase-startkde:4" is blocking kde-plasma/plasma-workspace-5.5.4)
[uninstall     ] kde-base/krunner-4.11.22
[blocks b      ] kde-base/krunner:4 ("kde-base/krunner:4" is blocking kde-plasma/plasma-workspace-5.5.4)
[uninstall     ] kde-base/klipper-4.11.22
[blocks b      ] kde-base/klipper:4 ("kde-base/klipper:4" is blocking kde-plasma/plasma-workspace-5.5.4)
[ebuild  N     ] kde-plasma/kdeplasma-addons-5.5.4  USE="-debug -ibus -scim"
[uninstall     ] kde-base/kdeplasma-addons-4.14.3
[blocks b      ] kde-base/kdeplasma-addons:4 ("kde-base/kdeplasma-addons:4" is blocking kde-plasma/kdeplasma-addons-5.5.4)
[ebuild  N     ] kde-plasma/powerdevil-5.5.4  USE="handbook -debug -systemd"
[uninstall     ] kde-base/powerdevil-4.11.22
[blocks b      ] kde-base/powerdevil:4 ("kde-base/powerdevil:4" is blocking kde-plasma/powerdevil-5.5.4)
[ebuild  N     ] kde-plasma/khotkeys-5.5.4  USE="handbook -debug"
[uninstall     ] kde-base/khotkeys-4.11.22
[blocks b      ] kde-base/khotkeys:4 ("kde-base/khotkeys:4" is blocking kde-plasma/khotkeys-5.5.4)
[ebuild  N     ] kde-plasma/kmenuedit-5.5.4  USE="handbook hotkeys -debug"
[uninstall     ] kde-base/kmenuedit-4.11.22
[blocks b      ] kde-base/kmenuedit:4 ("kde-base/kmenuedit:4" is blocking kde-plasma/kmenuedit-5.5.4)
[ebuild  N     ] kde-plasma/plasma-desktop-5.5.4  USE="evdev fontconfig handbook qt4 -debug -gtk2 -gtk3 -legacy-systray -pulseaudio {-test} -touchpad"
[uninstall     ] kde-base/systemsettings-4.11.22
[blocks b      ] kde-base/systemsettings:4[handbook] ("kde-base/systemsettings:4[handbook]" is blocking kde-plasma/powerdevil-5.5.4)
[blocks b      ] kde-base/systemsettings:4 ("kde-base/systemsettings:4" is blocking kde-plasma/systemsettings-5.5.4, kde-plasma/kwin-5.5.4, kde-plasma/plasma-desktop-5.5.4, kde-plasma/khotkeys-5.5.4)                                                                                                       
[uninstall     ] kde-base/plasma-workspace-4.11.22
[blocks b      ] kde-base/plasma-workspace:4 ("kde-base/plasma-workspace:4" is blocking kde-plasma/plasma-workspace-5.5.4, kde-plasma/plasma-desktop-5.5.4)                                                                                                                                                   
[uninstall     ] kde-base/solid-actions-kcm-4.11.22
[blocks b      ] kde-base/solid-actions-kcm:4 ("kde-base/solid-actions-kcm:4" is blocking kde-plasma/plasma-desktop-5.5.4)
[uninstall     ] kde-apps/kdepasswd-15.08.3
[blocks b      ] kde-apps/kdepasswd ("kde-apps/kdepasswd" is blocking kde-plasma/plasma-desktop-5.5.4)
[uninstall     ] kde-apps/knetattach-15.08.3
[blocks b      ] kde-apps/knetattach[handbook] ("kde-apps/knetattach[handbook]" is blocking kde-plasma/plasma-desktop-5.5.4)
[uninstall     ] kde-apps/kcontrol-15.08.3
[blocks b      ] kde-apps/kcontrol ("kde-apps/kcontrol" is blocking kde-plasma/plasma-desktop-5.5.4)
[ebuild  N     ] kde-plasma/plasma-meta-5.5.4  USE="bluetooth display-manager gtk sddm wallpapers -mediacenter -networkmanager -pulseaudio -sdk"
[ebuild  NS    ] kde-apps/kdebase-meta-15.08.3-r2 [4.14.3-r2]
[uninstall     ] kde-apps/kdebase-meta-4.14.3-r2
[blocks b      ] kde-apps/kdebase-meta:4 ("kde-apps/kdebase-meta:4" is blocking kde-apps/kdebase-meta-15.08.3-r2)
[blocks B      ] kde-base/kwin:4 ("kde-base/kwin:4" is blocking kde-plasma/kwin-5.5.4)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-plasma/kwin-5.5.4:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-plasma/kwin-5.5.4:5 required by (kde-plasma/plasma-desktop-5.5.4:5/5::gentoo, ebuild scheduled for merge)
    >=kde-plasma/kwin-5.5.4:5 required by (kde-plasma/plasma-workspace-5.5.4:5/5::gentoo, ebuild scheduled for merge)
    >=kde-plasma/kwin-5.5.4:5 required by (kde-plasma/plasma-meta-5.5.4:5/5::gentoo, ebuild scheduled for merge)

  (kde-base/kwin-4.11.22:4/4.11::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-base/kwin-4.11:4[aqua=] (>=kde-base/kwin-4.11:4[-aqua]) required by (kde-apps/kdeartwork-styles-15.08.3:4/15.08::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


Last edited by Xywa on Sat Feb 13, 2016 7:16 am; edited 1 time in total
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Fri Feb 12, 2016 6:19 pm    Post subject: Reply with quote

Look at this:

Code:
(kde-base/kwin-4.11.22:4/4.11::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-base/kwin-4.11:4[aqua=] (>=kde-base/kwin-4.11:4[-aqua]) required by (kde-apps/kdeartwork-styles-15.08.3:4/15.08::gentoo, ebuild scheduled for merge)


Why is kdeartwork-styles being pulled in? Can you please check if you still have it in your world file or any custom set of yours? You could also --exclude it from your emerge command and then just see what's going to complain.

Also check if kdeartwork-meta is installed:
Code:
$ equery l -iop kdeartwork-meta

If yes, it MUST be 15.08.3-r1.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Xywa
Veteran
Veteran


Joined: 23 Jul 2005
Posts: 1575
Location: /mnt/Gentoo/Europe

PostPosted: Fri Feb 12, 2016 7:37 pm    Post subject: Reply with quote

Code:
# equery l -iop kdeartwork-meta
 * Searching for kdeartwork-meta ...
[IP-] [  ] kde-apps/kdeartwork-meta-4.14.3:4
[-P-] [  ] kde-apps/kdeartwork-meta-15.08.3-r1:5


Code:
# emerge -s kdeartwork-meta
 
[ Results for search key : kdeartwork-meta ]
Searching...

*  kde-apps/kdeartwork-meta
      Latest version available: 15.08.3-r1
      Latest version installed: 4.14.3
      Size of files: 0 KiB
      Homepage:      https://www.kde.org/
      Description:   kdeartwork - merge this to pull in all kdeartwork-derived packages
      License:       metapackage

[ Applications found : 1 ]


Last edited by Xywa on Fri Feb 12, 2016 7:42 pm; edited 2 times in total
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Fri Feb 12, 2016 7:38 pm    Post subject: Reply with quote

So there you have the solution.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Xywa
Veteran
Veteran


Joined: 23 Jul 2005
Posts: 1575
Location: /mnt/Gentoo/Europe

PostPosted: Fri Feb 12, 2016 7:42 pm    Post subject: Reply with quote

genstorm wrote:
So there you have the solution.



UPDATE!
I just did emerge -1 kdeartwork-meta and have 15.08.3-r1, and compilation goes on now.

How did you know kdeartwork-meta was causing the problem? I was trying kde-apps/kdeartwork-styles without the success.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Fri Feb 12, 2016 7:51 pm    Post subject: Reply with quote

It's the only thing that can possibly depend on kdeartwork-styles, and I removed that dependency in kdeartwork-meta-15.08.3-r1 ;)

But since all kwin:4 dependencies were removed from world file from the preceeding command in the wiki guide, and because kdeartwork-meta is not strictly pulled in by 15.08 anymore - and it indeed isn't in your case -, unfortunately there is no upgrade in Portage's depgraph that automatically resolves the blocker.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Xywa
Veteran
Veteran


Joined: 23 Jul 2005
Posts: 1575
Location: /mnt/Gentoo/Europe

PostPosted: Fri Feb 12, 2016 8:23 pm    Post subject: Reply with quote

genstorm wrote:
It's the only thing that can possibly depend on kdeartwork-styles, and I removed that dependency in kdeartwork-meta-15.08.3-r1 ;)

But since all kwin:4 dependencies were removed from world file from the preceeding command in the wiki guide, and because kdeartwork-meta is not strictly pulled in by 15.08 anymore - and it indeed isn't in your case -, unfortunately there is no upgrade in Portage's depgraph that automatically resolves the blocker.


Fantastic help :)

Many thanks :) Hopefuly I will have plasma 5 tonight. I do not need this, but I need need newest kdenlive to my job, so... keeping fingers crossed.

[SOLVED]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum