Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kindaSolved] python blocking eselect-python
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
mayhew
n00b
n00b


Joined: 25 Feb 2013
Posts: 68

PostPosted: Fri Feb 05, 2016 4:52 pm    Post subject: [kindaSolved] python blocking eselect-python Reply with quote

ive been trying to install some software that needs python3.5 but attempting to fix slot conflicts has broken porthole and now i cant remerge python2.7 or fix porthole due to eselect-python being blocked by python itself

Code:
$ sudo emerge -qav1 =dev-lang/python-2.7.10-r1
--- Invalid atom in /etc/portage/package.unmask: apt-crypt/pinentry-0.9.5
--- Invalid atom in /etc/portage/package.unmask: ~games-roguelike/cataclysm-dda-9999 **

 * IMPORTANT: 12 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


 * IMPORTANT: 4 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.
[ebuild     U ] dev-lang/python-exec-2.1 [2.0.1-r1] PYTHON_TARGETS="(jython2_7) (pypy) (pypy3) (python2_7) (python3_3) (python3_4) (python3_5)"
[ebuild  N    ] app-eselect/eselect-python-20151117-r2
[ebuild  NS   ] dev-lang/python-2.7.10-r1 [3.4.3-r1] USE="gdbm ipv6 ncurses readline ssl threads (wide-unicode) xml (-berkdb) -build -doc -examples -hardened -sqlite -tk -wininst"
[blocks B     ] <dev-lang/python-3.4.3-r4:3.4 ("<dev-lang/python-3.4.3-r4:3.4" is blocking app-eselect/eselect-python-20151117-r2)
[blocks B     ] <dev-lang/python-2.7.10-r4:2.7 ("<dev-lang/python-2.7.10-r4:2.7" is blocking app-eselect/eselect-python-20151117-r2)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-lang/python-2.7.10-r1:2.7/2.7::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-lang/python-2.7.5-r2:2.7[threads(+),xml(+)] required by (app-portage/porthole-0.6.1-r4:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/pycairo-1.10.0-r4:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (x11-proto/xcb-proto-1.11:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pygame-1.9.2_pre20120101-r2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-vcs/git-2.4.10:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (gnome-base/gconf-3.2.6-r3:2/2::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/numpy-1.10.4:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (x11-misc/mozo-1.8.0:0/0::gentoo, installed)
    =dev-lang/python-2.7.10-r1
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pygobject-2.28.6-r55:2/2::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml(+),threads(+)] required by (app-portage/gentoolkit-0.3.0.9-r2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (mate-base/mate-applets-1.8.0-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/wxpython-2.8.12.1-r2:2.8/2.8::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (mate-base/mate-desktop-1.8.1-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[bzip2(+)] required by (sys-apps/portage-2.2.26:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (dev-libs/gobject-introspection-1.44.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/packaging-15.3-r2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (dev-libs/libxml2-2.9.2-r4:2/2::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (x11-libs/xpyb-1.3.1-r3:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-java/java-config-2.2.0:2/2::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pygobject-3.16.2:3/3::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pyxattr-0.5.5:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/certifi-2015.11.20:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[tk?] (>=dev-lang/python-2.7.5-r2:2.7) required by (dev-python/pyopengl-3.0.2-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/setuptools-18.4:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (games-strategy/lightyears-1.4-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (mate-base/mate-menus-1.8.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml(+)] required by (app-portage/layman-2.0.0-r3:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pygtksourceview-2.10.1-r1:2/2::gentoo, installed)

  (dev-lang/python-3.4.3-r1:3.4/3.4::gentoo, installed) pulled in by
    dev-lang/python:3.4[xml] required by (dev-libs/libxml2-2.9.2-r4:2/2::gentoo, installed)
    dev-lang/python:3.4 required by (x11-proto/xcb-proto-1.11:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/setuptools-18.4:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/pygobject-3.16.2:3/3::gentoo, installed)
    dev-lang/python:3.4[tk?] (dev-lang/python:3.4) required by (dev-python/pyopengl-3.0.2-r1:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/packaging-15.3-r2:0/0::gentoo, installed)
    dev-lang/python:3.4[threads(+)] required by (dev-python/pycairo-1.10.0-r4:0/0::gentoo, installed)
    dev-lang/python:3.4 required by @selected
    dev-lang/python:3.4[bzip2(+)] required by (sys-apps/portage-2.2.26:0/0::gentoo, installed)
    dev-lang/python:3.4[threads(+)] required by (dev-python/numpy-1.10.4:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/certifi-2015.11.20:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/pyxattr-0.5.5:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-java/java-config-2.2.0:2/2::gentoo, installed)
    dev-lang/python:3.4[xml(+),threads(+)] required by (app-portage/gentoolkit-0.3.0.9-r2:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/pygame-1.9.2_pre20120101-r2:0/0::gentoo, installed)



Im so confused and cant make heads or tails of this.
_________________
:)


Last edited by mayhew on Fri Feb 05, 2016 8:27 pm; edited 2 times in total
Back to top
View user's profile Send private message
mayhew
n00b
n00b


Joined: 25 Feb 2013
Posts: 68

PostPosted: Fri Feb 05, 2016 5:10 pm    Post subject: Reply with quote

ended up emerging eselect-python-20111108 which allowed python 2.7 to emerge
back to the package im trying to install.

eselect-python is still trying to update but is being blocked by both installed versions of python.

Code:
sudo emerge antimony
--- Invalid atom in /etc/portage/package.unmask: apt-crypt/pinentry-0.9.5
--- Invalid atom in /etc/portage/package.unmask: ~games-roguelike/cataclysm-dda-9999 **

 * IMPORTANT: 12 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


 * IMPORTANT: 4 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.
Calculating dependencies... done!
[ebuild  N    ~] dev-util/lemon-3.8.11.1
[ebuild   R    ] dev-libs/libpcre-8.38  USE="pcre16*"
[ebuild  NS    ] dev-qt/qtcore-5.4.2 [4.8.6-r2] USE="-debug -icu -systemd {-test}"
[ebuild  NS   ~] dev-lang/python-3.5.1-r2 [2.7.10-r1, 3.4.3-r1] USE="gdbm ipv6 ncurses readline ssl threads xml -build -examples -hardened -libressl -sqlite -tk -wininst"
[ebuild     U ~] dev-lang/python-exec-2.1 [2.0.1-r1]
[ebuild     U ~] app-eselect/eselect-python-20151117-r2 [20111108]
[blocks b      ] <app-eselect/eselect-python-20151117 ("<app-eselect/eselect-python-20151117" is blocking dev-lang/python-exec-2.1)
[ebuild   R    ] dev-libs/boost-1.56.0-r1  USE="python*"
[ebuild  N    ~] media-gfx/antimony-9999
[blocks B      ] <dev-lang/python-2.7.10-r4:2.7 ("<dev-lang/python-2.7.10-r4:2.7" is blocking app-eselect/eselect-python-20151117-r2)
[blocks B      ] <dev-lang/python-3.4.3-r4:3.4 ("<dev-lang/python-3.4.3-r4:3.4" is blocking app-eselect/eselect-python-20151117-r2)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-lang/python-2.7.10-r1:2.7/2.7::gentoo, installed) pulled in by
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pygobject-3.16.2:3/3::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (mate-base/mate-applets-1.8.0-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pyxattr-0.5.5:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/numpy-1.10.4:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-java/java-config-2.2.0:2/2::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (mate-base/mate-menus-1.8.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (dev-libs/gobject-introspection-1.44.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (games-strategy/lightyears-1.4-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pygtksourceview-2.10.1-r1:2/2::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+),xml(+)] required by (app-portage/porthole-0.6.1-r4:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[tk?] (>=dev-lang/python-2.7.5-r2:2.7) required by (dev-python/pyopengl-3.0.2-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (x11-proto/xcb-proto-1.11:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pygobject-2.28.6-r55:2/2::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (x11-libs/xpyb-1.3.1-r3:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/wxpython-2.8.12.1-r2:2.8/2.8::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/pygame-1.9.2_pre20120101-r2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml(+),threads(+)] required by (app-portage/gentoolkit-0.3.0.9-r2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (dev-libs/libxml2-2.9.2-r4:2/2::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (x11-misc/mozo-1.8.0:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/certifi-2015.11.20:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (mate-base/mate-desktop-1.8.1-r1:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[threads(+)] required by (dev-python/pycairo-1.10.0-r4:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/packaging-15.3-r2:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[bzip2(+)] required by (sys-apps/portage-2.2.26:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-python/setuptools-18.4:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-vcs/git-2.4.10:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml] required by (gnome-base/gconf-3.2.6-r3:2/2::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7[xml(+)] required by (app-portage/layman-2.0.0-r3:0/0::gentoo, installed)
    >=dev-lang/python-2.7.5-r2:2.7 required by (dev-libs/boost-1.56.0-r1:0/1.56.0::gentoo, ebuild scheduled for merge)

  (dev-lang/python-3.4.3-r1:3.4/3.4::gentoo, installed) pulled in by
    dev-lang/python:3.4 required by (dev-python/certifi-2015.11.20:0/0::gentoo, installed)
    dev-lang/python:3.4[threads(+)] required by (dev-python/pycairo-1.10.0-r4:0/0::gentoo, installed)
    dev-lang/python:3.4[xml(+),threads(+)] required by (app-portage/gentoolkit-0.3.0.9-r2:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (x11-proto/xcb-proto-1.11:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/pygobject-3.16.2:3/3::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/packaging-15.3-r2:0/0::gentoo, installed)
    dev-lang/python:3.4[threads(+)] required by (dev-python/numpy-1.10.4:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-java/java-config-2.2.0:2/2::gentoo, installed)
    dev-lang/python:3.4 required by (dev-libs/boost-1.56.0-r1:0/1.56.0::gentoo, ebuild scheduled for merge)
    dev-lang/python:3.4 required by (dev-python/pyxattr-0.5.5:0/0::gentoo, installed)
    dev-lang/python:3.4[bzip2(+)] required by (sys-apps/portage-2.2.26:0/0::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/pygame-1.9.2_pre20120101-r2:0/0::gentoo, installed)
    dev-lang/python:3.4[tk?] (dev-lang/python:3.4) required by (dev-python/pyopengl-3.0.2-r1:0/0::gentoo, installed)
    dev-lang/python:3.4 required by @selected
    dev-lang/python:3.4[xml] required by (dev-libs/libxml2-2.9.2-r4:2/2::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/setuptools-18.4:0/0::gentoo, installed)

  (app-eselect/eselect-python-20151117-r2:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=app-eselect/eselect-python-20151117-r1 required by (dev-lang/python-3.5.1-r2:3.5/3.5m::gentoo, ebuild scheduled for merge)
    app-eselect/eselect-python required by (dev-lang/python-2.7.10-r1:2.7/2.7::gentoo, installed)
    app-eselect/eselect-python required by (dev-lang/python-3.4.3-r1:3.4/3.4::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


_________________
:)
Back to top
View user's profile Send private message
mayhew
n00b
n00b


Joined: 25 Feb 2013
Posts: 68

PostPosted: Fri Feb 05, 2016 8:27 pm    Post subject: Reply with quote

I ended up unmasking the next versions of python in each slot than updated all of them
this allowed all blocks to resolve at once. i just hope i don't run into instabilities.
_________________
:)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum