Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
firefox-bin no german menu?[SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
dasPaul
Apprentice
Apprentice


Joined: 14 Feb 2012
Posts: 187
Location: Dresden

PostPosted: Tue Feb 02, 2016 2:32 pm    Post subject: firefox-bin no german menu?[SOLVED] Reply with quote

Hi

I just tried to set my firefox menu to german language but it seems not to work... Is this possible at all? Or do I have to emerge the non-bin-firefox?

What is set in firefox:
-Edit->Prefs->Content->Languages->german de-de (I know this is for websites only, but I want to change the GUI language)
-about:config->intl.locale.matchOS->LOCKED-True (cant change)

locale.gen:
Code:

en_US ISO-8859-1
en_US.UTF-8 UTF-8
de_DE ISO-8859-1
de_DE.UTF-8 UTF-8


make.conf:
Code:

LINGUAS="de en"


emerge -pv firefox-bin
Code:

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ~] www-client/firefox-bin-44.0::gentoo  USE="(-selinux) -startup-notification" LINGUAS="de -af -ar -as -ast -be -bg -bn_BD -bn_IN -br -bs -ca -cs -cy -da -el -en_GB -en_ZA -eo -es_AR -es_CL -es_ES -es_MX -et -eu -fa -fi -fr -fy_NL -ga_IE -gd -gl -gu_IN -he -hi_IN -hr -hu -hy_AM -id -is -it -ja -kk -kn -ko -lt -lv -mai -mk -ml -mr -nb_NO -nl -nn_NO -or -pa_IN -pl -pt_BR -pt_PT -rm -ro -ru -si -sk -sl -son -sq -sr -sv_SE -ta -te -tr -uk -vi -zh_CN -zh_TW" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB


Even when I start with "LC_MESSAGES="de_DE.UTF-8" /usr/bin/firefox-bin" the GUI is in english.


Last edited by dasPaul on Tue Feb 02, 2016 4:31 pm; edited 1 time in total
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2583

PostPosted: Tue Feb 02, 2016 2:38 pm    Post subject: Reply with quote

In https://wiki.gentoo.org/wiki/Firefox#External_resources there is a link about Change the interface language (LINGUAS). Does that solve your problem?
Setting LINGUAS for firefox only makes it download and install the xpi package but not switching the interface.
Back to top
View user's profile Send private message
dasPaul
Apprentice
Apprentice


Joined: 14 Feb 2012
Posts: 187
Location: Dresden

PostPosted: Tue Feb 02, 2016 4:30 pm    Post subject: Reply with quote

Thank you, downloading german language pack AND enabling it was sufficient, works now.
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2583

PostPosted: Tue Feb 02, 2016 5:23 pm    Post subject: Reply with quote

You should not have needed to download it since downloading and installation has already been done by portage.
With manually downloading and "installing" that xpi file directly in firefox you might have installed it in your personal ~/.mozilla/firefox/ directory.
Back to top
View user's profile Send private message
dasPaul
Apprentice
Apprentice


Joined: 14 Feb 2012
Posts: 187
Location: Dresden

PostPosted: Tue Feb 02, 2016 6:29 pm    Post subject: Reply with quote

I must confess about:addons -> Languages -> german lang. pack was disabled and I think simply enabling it did the trick. I think I disabled that in the past.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum