Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE Plasma 5 + Localization
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
hujuice
Apprentice
Apprentice


Joined: 16 Oct 2007
Posts: 278
Location: Rome, Italy

PostPosted: Fri Apr 29, 2016 11:35 am    Post subject: Reply with quote

Quote:
Those files are there, anyway, in the =kde-plasma/plasma-workspace-5.6.3 system too, but they belongs to kde-apps/kde4-l10n, pulled in by kdepim and others.
Trying to re- emerge -1 plasma-workspace gives no collisions.


I'm sorry, I'm wrong, delete that sentence.
Files pulled in by =kde-plasma/plasma-workspace-5.5.5-r2 in desktop A have not be pulled in by =kde-plasma/plasma-workspace-5.6.3 in desktop B.
e.g. /usr/share/locale/it/LC_MESSAGES/plasma_applet_org.kde.plasma.analogclock.mo is only in desktop A.

Regards,
HUjuice
_________________
Who hasn't a spine, should have a method.
Chi non ha carattere, deve pur avere un metodo.
Back to top
View user's profile Send private message
zoulou99
n00b
n00b


Joined: 15 Jan 2015
Posts: 16

PostPosted: Sat Apr 30, 2016 12:13 pm    Post subject: Reply with quote

genstorm wrote:
What package manager do you use, and what content does LINGUAS have on your system?


i use portage of course, & LINGUAS="fr".

Quote:
ki18n is not carrying translations for plasma, each plasma package ships its own. That means `equery f plasma-workspace` should give you plenty of content inside /usr/share/locale/<YOUR_LINGUAS>/LC_MESSAGES, can you check?


i know that ki10n dont carry translation files, i say nls or ki10n, refering to a gettext problem.

BUT finally folks applying locally this patch solve the probleme.

hujuice wrote:
Same problem here.
Something seems to go to my language (it) and something seems to go to American English.
Also, I cannot guess how italian is detected as my language, since American English is the unique available translation in the KDE settings and /etc/env.d/02locale is LANG="en_US.UTF-8". The one italian setting is the X keyboard layout.


just keep track when the updated "kde5.eclass" hit portage tree and recompile kf5/plasma/apps to get all of your translation files '*.mo' installed.
_________________
mydigitallife
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6998
Location: Austria

PostPosted: Sat Apr 30, 2016 12:32 pm    Post subject: Reply with quote

Ah, good that this is going to be settled soon.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
zoulou99
n00b
n00b


Joined: 15 Jan 2015
Posts: 16

PostPosted: Sat Apr 30, 2016 1:02 pm    Post subject: Reply with quote

genstorm wrote:
Ah, good that this is going to be settled soon.

thanks alot for your time & help genstorm.
_________________
mydigitallife
Back to top
View user's profile Send private message
hujuice
Apprentice
Apprentice


Joined: 16 Oct 2007
Posts: 278
Location: Rome, Italy

PostPosted: Sat Apr 30, 2016 1:05 pm    Post subject: Reply with quote

Nice to read :)
Thanks to zoulou99 too.
HUjuice
_________________
Who hasn't a spine, should have a method.
Chi non ha carattere, deve pur avere un metodo.
Back to top
View user's profile Send private message
zoulou99
n00b
n00b


Joined: 15 Jan 2015
Posts: 16

PostPosted: Sat Apr 30, 2016 10:48 pm    Post subject: Reply with quote

hujuice wrote:
Nice to read :)
Thanks to zoulou99 too.
HUjuice


thank you too, they commit the change in portage tree.
so rebuild your plasma packages.
_________________
mydigitallife
Back to top
View user's profile Send private message
dylanmc
Tux's lil' helper
Tux's lil' helper


Joined: 18 Apr 2014
Posts: 135
Location: Modena, Italy

PostPosted: Sun May 08, 2016 10:22 am    Post subject: Reply with quote

zoulou99 wrote:
genstorm wrote:
What package manager do you use, and what content does LINGUAS have on your system?


i use portage of course, & LINGUAS="fr".

Quote:
ki18n is not carrying translations for plasma, each plasma package ships its own. That means `equery f plasma-workspace` should give you plenty of content inside /usr/share/locale/<YOUR_LINGUAS>/LC_MESSAGES, can you check?


i know that ki10n dont carry translation files, i say nls or ki10n, refering to a gettext problem.

BUT finally folks applying locally this patch solve the probleme.

hujuice wrote:
Same problem here.
Something seems to go to my language (it) and something seems to go to American English.
Also, I cannot guess how italian is detected as my language, since American English is the unique available translation in the KDE settings and /etc/env.d/02locale is LANG="en_US.UTF-8". The one italian setting is the X keyboard layout.



just keep track when the updated "kde5.eclass" hit portage tree and recompile kf5/plasma/apps to get all of your translation files '*.mo' installed.




Can you explain the way to apply this patch? :)
Back to top
View user's profile Send private message
dylanmc
Tux's lil' helper
Tux's lil' helper


Joined: 18 Apr 2014
Posts: 135
Location: Modena, Italy

PostPosted: Sun May 08, 2016 10:39 am    Post subject: Reply with quote

I've found it, but already patched.
I've rebuild dolphin, but is still in english end not in italian as other programs :/
Same for konsole and others..
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6998
Location: Austria

PostPosted: Sun May 08, 2016 11:06 am    Post subject: Reply with quote

dylanmc wrote:
I've rebuild dolphin, but is still in english end not in italian as other programs :/
Same for konsole and others..

These are not part of Plasma. It's a different problem, translations needed to be removed from kde4-l10n to not collide with kde-l10n, Frameworks and Plasma. Will be solved when Applications 15.12.3 goes stable, soon.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
dylanmc
Tux's lil' helper
Tux's lil' helper


Joined: 18 Apr 2014
Posts: 135
Location: Modena, Italy

PostPosted: Sun May 08, 2016 2:34 pm    Post subject: Reply with quote

thanks for the info genstorm :)
I will have to wait :)
Back to top
View user's profile Send private message
hujuice
Apprentice
Apprentice


Joined: 16 Oct 2007
Posts: 278
Location: Rome, Italy

PostPosted: Fri May 13, 2016 10:26 am    Post subject: Reply with quote

dylanmc wrote:
Can you explain the way to apply this patch? :)

If you are in the unstable kde-plasma/plasma-workspace-5.6.3, you simply need to rebuild some packages, after a sync, obviously.
I cannot be sure, but I think that you must rebuild all the kde-plasma/* packages.

For example
Code:
emerge $(eix -I -# kde-plasma/* | xargs)


For me, that resolved the issue.

Regards,
HUjuice
_________________
Who hasn't a spine, should have a method.
Chi non ha carattere, deve pur avere un metodo.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6998
Location: Austria

PostPosted: Fri May 13, 2016 11:15 am    Post subject: Reply with quote

Or just do it with the upgrade to 5.6.4 automatically.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
mani001
Guru
Guru


Joined: 04 Dec 2004
Posts: 358
Location: Oleiros

PostPosted: Tue May 24, 2016 8:03 pm    Post subject: Reply with quote

Same problem here after the latest update (most applications now at 15.12.3) Any workaround?
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6998
Location: Austria

PostPosted: Tue May 24, 2016 8:13 pm    Post subject: Reply with quote

What versions of kde4-l10n and kde-l10n are installed and which use flags are set each?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
mani001
Guru
Guru


Joined: 04 Dec 2004
Posts: 358
Location: Oleiros

PostPosted: Tue May 24, 2016 8:19 pm    Post subject: Reply with quote

kde4-l10n--15.12.3-r1, and I don't have kde-l10n installed because
Code:

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild  N     ] kde-apps/kde-l10n-15.12.3-r2:5::gentoo  USE="handbook -debug" LINGUAS="es -ar -bg -bs -ca -ca@valencia -cs -da -de -el -en_GB -eo -et -eu -fa -fi -fr -ga -gl -he -hi -hr -hu -ia -id -is -it -ja -kk -km -ko -lt -lv -mr -nb -nds -nl -nn -pa -pl -pt -pt_BR -ro -ru -sk -sl -sr -sv -tr -ug -uk -wa -zh_CN -zh_TW" 1.683 KiB
[blocks B      ] <kde-apps/khelpcenter-5.5.5-r1 ("<kde-apps/khelpcenter-5.5.5-r1" is blocking kde-apps/kde-l10n-15.12.3-r2)

Total: 1 package (1 new), Size of downloads: 1.683 KiB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-apps/kde-l10n-15.12.3-r2:5/5::gentoo, ebuild scheduled for merge) pulled in by
    kde-apps/kde-l10n

  (kde-apps/khelpcenter-5.5.5:5/5::gentoo, installed) pulled in by
    kde-apps/khelpcenter:* required by (kde-base/kdelibs-4.14.16:4/4.14::gentoo, installed)
    >=kde-apps/khelpcenter-5.5.5:5 required by (kde-plasma/plasma-meta-5.5.5:5/5::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6998
Location: Austria

PostPosted: Tue May 24, 2016 8:30 pm    Post subject: Reply with quote

This might be a stabilisation bug, khelpcenter-5.5.5-r1 would fix this. If you don't want to wait, keyword that version, then you can proceed with kde-l10n-15.12.3-r2.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
mani001
Guru
Guru


Joined: 04 Dec 2004
Posts: 358
Location: Oleiros

PostPosted: Tue May 24, 2016 8:39 pm    Post subject: Reply with quote

That did the trick :D Thank you very much!!
Back to top
View user's profile Send private message
deranonyme
Guru
Guru


Joined: 09 Jul 2005
Posts: 364

PostPosted: Wed May 25, 2016 8:14 am    Post subject: Reply with quote

Is there any support for kde-apps/kdepim-l10n:5 at the moment? The last available version is 15.12.3
Code:
frank # emerge kdepim-l10n
Calculating dependencies... done!
[ebuild  N     ] kde-apps/kdepim-l10n-15.12.3  USE="handbook -debug" LINGUAS="de -ar -bg -bs -ca -ca@valencia -cs -da -el -en_GB -eo -es -et -eu -fa -fi -fr -ga -gl -he -hi -hr -hu -ia -id -is -it -ja -kk -km -ko -lt -lv -mr -nb -nds -nl -nn -pa -pl -pt -pt_BR -ro -ru -sk -sl -sr -sv -tr -ug -uk -wa -zh_CN -zh_TW"
[blocks B      ] <kde-apps/kdepim-l10n-16.04.1:5 ("<kde-apps/kdepim-l10n-16.04.1:5" is blocking kde-apps/kde-l10n-16.04.1)


Version kde-apps/kdepim-l10n-16.04.1:5 is not available for some days.

Frank
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6998
Location: Austria

PostPosted: Wed May 25, 2016 8:21 am    Post subject: Reply with quote

Thanks for the notice, could you give a heads-up in #gentoo-kde about that?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
deranonyme
Guru
Guru


Joined: 09 Jul 2005
Posts: 364

PostPosted: Wed May 25, 2016 9:16 am    Post subject: Reply with quote

I've never done this before but I tried it. I have no experiences with IRC chats and I was there very lonesome. :oops:

Now I got it. They will fix it. 8)
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6998
Location: Austria

PostPosted: Wed May 25, 2016 12:50 pm    Post subject: Reply with quote

Thanks for taking the plunge ;)

Although I must say, having kdepim-l10n:5 installed doesn't make any sense when you only use in-tree kdepim. For proper kdepim-meta:4 translations, you will need kdepim-l10n:4 and that is still at 4.14.3-r1.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
deranonyme
Guru
Guru


Joined: 09 Jul 2005
Posts: 364

PostPosted: Wed May 25, 2016 1:57 pm    Post subject: Reply with quote

genstorm wrote:
Thanks for taking the plunge ;)

Although I must say, having kdepim-l10n:5 installed doesn't make any sense when you only use in-tree kdepim. For proper kdepim-meta:4 translations, you will need kdepim-l10n:4 and that is still at 4.14.3-r1.


I have installed kdepim-l10n:4 now, and it works. :D
I thougt kdepim-l10n:5 should be installed if I work with the Kde 5 Framework because only l10n is available for kdepim:5. What else is the sense of this package?

Frank
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6998
Location: Austria

PostPosted: Wed May 25, 2016 2:00 pm    Post subject: Reply with quote

There is no kdepim:5 in the tree yet. ;) You can install kde-apps-meta-15.12.3 but with pim flag enabled it will still pull in kdepim-meta:4 which is using kdelibs4, not frameworks.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
deranonyme
Guru
Guru


Joined: 09 Jul 2005
Posts: 364

PostPosted: Wed May 25, 2016 2:48 pm    Post subject: Reply with quote

genstorm wrote:
There is no kdepim:5 in the tree yet. ;) You can install kde-apps-meta-15.12.3 but with pim flag enabled it will still pull in kdepim-meta:4 which is using kdelibs4, not frameworks.

Okay, I understand now. Kdepim-l10n:5 is the language pack for the meta ebuild. :idea: That's not really simple to find out (for me).
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6998
Location: Austria

PostPosted: Wed May 25, 2016 3:19 pm    Post subject: Reply with quote

For most people, this is just a dependency that comes in via USE=nls on kdepim-meta, nothing that they consciously emerge. ;)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2, 3  Next
Page 2 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum