Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Weird UI with Mono applications
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
andig
n00b
n00b


Joined: 27 Feb 2015
Posts: 33
Location: Germany

PostPosted: Thu Jan 28, 2016 7:51 am    Post subject: [Solved] Weird UI with Mono applications Reply with quote

Hello,

after an update, the UI of mono applications is kind of screwed. The problem is, I can't really tell which update, because I only use two applications (keepass and gitextensions) and I don't use them really often. So this could have happened anywhere during the last weeks...
Here are the screenshots: http://imgur.com/a/wMENI
I could not detect such glitches in KDE/Qt or GTK applications.

Here is the output of `emerge --info =app-admin/keepass-2.31`. Maybe this is helpful by any means.
Code:
Portage 2.2.27 (python 3.4.3-final-0, default/linux/amd64/13.0/desktop/plasma/systemd, gcc-5.3.0, glibc-2.22-r1, 4.4.0-gentoo-r1 x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.4.0-gentoo-r1-x86_64-Intel-R-_Xeon-R-_CPU_E5-1630_v3_@_3.70GHz-with-gentoo-2.2
KiB Mem:    32939672 total,  28613312 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Thu, 28 Jan 2016 07:30:01 +0000
sh bash 4.3_p42-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
distcc 3.2rc1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.3_p42-r1::gentoo
dev-java/java-config:     2.2.0::gentoo
dev-lang/perl:            5.22.1::gentoo
dev-lang/python:          2.7.11-r2::gentoo, 3.4.3-r7::gentoo
dev-util/cmake:           3.4.3::gentoo
dev-util/pkgconfig:       0.29::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.20.4::gentoo
sys-apps/sandbox:         2.10-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r1::gentoo
sys-devel/automake:       1.11.6-r2::gentoo, 1.12.6::gentoo, 1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r1::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            5.3.0::gentoo
sys-devel/gcc-config:     1.8::gentoo
sys-devel/libtool:        2.4.6-r1::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.22-r1::gentoo
Repositories:

<<Repositories stripped>>
 
Installed sets: @fonts, @qt5-addons, @qt5-essentials, @qt5-tools
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms split-elog strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="de_DE.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac aacplus aalib acl acpi aes airplay alsa amd64 amr amrenc autoipd avahi avx avx2 bazaar berkdb bluetooth bluray branding bzip2 cairo cdda cddb cdparanoia cdr clang cleartype cli context corefonts cracklib crypt cryptsetup css cups cxx dbus declarative detex dga dri dts dv dvb dvd dvdr dvi2tty dvipdfm emboss encode epspdf exif extra faac faad fam ffmpeg firefox flac fma3 fortran games gcj gdbm gif git glamor gphoto2 gpm graphics gsm gstreamer gtk humanities iconv icu imagemagick ipv6 jadetex java jpeg jpeg2k kde kipi ladspa lcms ldap libass libcaca libmpeg2 libnotify libsamplerate libsecret libv4l lm_sensors luatex lzma mad mdnsresponder-compat mercurial metapost mmx mmxext mng modplug modules mp3 mp4 mpeg multilib music musicbrainz nas ncurses networkmanager nfs nfsv4 nfsv41 nls nptl nsplugin ogg omega opencl opencv openexr opengl openmp pam pango pcre pdf pdfannotextractor phonon pim plasma png policykit popcnt postproc postscript ppds pstricks publishers pulseaudio qml qt3support qt4 qt5 rar readline rtmp samba science sdl seccomp semantic-desktop session sftp spell sse sse2 sse3 sse4_1 sse4_2 ssl ssse3 startup-notification subversion svg systemd taglib tcpd telepathy tex4ht texi2html tga theora threads tiff truetype twolame type1 udev udisks unicode upnp upower usb v4l vdpau vlc vnc vorbis vpx webp webserver widgets wxwidgets x264 x265 xattr xcb xcomposite xetex xindy xinerama xml xrandr xscreensaver xv xvid zeroconf zlib" ABI_X86="64 32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby23" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

app-admin/keepass-2.31::gentoo was built with the following:
USE="-aot" ABI_X86="64"


Are here any Keepass users with a similar issue? Any idea what exactly is wrong here? Deleting the .mono files did not help and I have no clue on what to do...


Last edited by andig on Thu Jan 28, 2016 6:49 pm; edited 1 time in total
Back to top
View user's profile Send private message
kensington
Developer
Developer


Joined: 02 Jan 2013
Posts: 175
Location: Australia

PostPosted: Thu Jan 28, 2016 6:47 pm    Post subject: Reply with quote

Which dev-dotnet/libgdiplus is installed? If it's 4.2, try with 4.2-r1 instead (and make sure it's built with USE="cairo").
Back to top
View user's profile Send private message
andig
n00b
n00b


Joined: 27 Feb 2015
Posts: 33
Location: Germany

PostPosted: Thu Jan 28, 2016 6:50 pm    Post subject: Reply with quote

Thanks, updating to dev-dotnet/libgdiplus-4.2-r1 did the trick...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum