Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Plasma 5.5: Hibernate, Shutdown and Restart missing
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
AnOriginalNick
n00b
n00b


Joined: 02 Apr 2015
Posts: 14

PostPosted: Wed Jan 27, 2016 12:38 pm    Post subject: Plasma 5.5: Hibernate, Shutdown and Restart missing Reply with quote

Buttons are simply missing in the menu, though Suspend is there still. I think this is connected with changing upower-pm-tools to simply upower (kde-libs were adamant that it can do that now and upower-pm-tools were no longer supported). Looks like a permissions problem, because suspend and hibernate (if I close the lid, per powerdevil's settings) works, but pkaction doesn't list any actions which correlate with it, should I add some rules myself?
Back to top
View user's profile Send private message
taikuus
n00b
n00b


Joined: 24 Jan 2016
Posts: 18

PostPosted: Thu Jan 28, 2016 2:13 pm    Post subject: Reply with quote

Hi!

I was having the same problem. To solve it you need to:

1.-Emerge upower-pm-utils. If you have upower, Umerge first
2.-Add yourself to the users group:
Code:

sudo gpasswd -a AnOriginalNick users
Back to top
View user's profile Send private message
Ocatrapseee
n00b
n00b


Joined: 28 Dec 2015
Posts: 6

PostPosted: Fri Jan 29, 2016 1:57 am    Post subject: Reply with quote

Might it be some problem with Consolekit? Are you sure it's running? I had a similar problems in the past -Hibernate, Sleep, and New Session buttons mising- and dealing with Consolekit solved it, although I now have another problem: I have all the buttons but Hibernate. I'm suspecting of Upower as well.

taikuus wrote:

I was having the same problem. To solve it you need to:

1.-Emerge upower-pm-utils. If you have upower, Umerge first


But see this message after installing powerdevil:
Code:

* Messages for package kde-plasma/powerdevil-5.5.4:

* You have sys-power/upower-pm-utils installed, which was recommended in the past to
* enable suspend and hibernate support. This workaround is no longer required, and it
* is now recommended to use a recent version of upower and consolekit instead:

* emerge --ask --update ">=sys-auth/consolekit-1.0.0" sys-power/upower

I have installed Upower and removed upower-pm-utils, but nothing. Besides, it seems that these packages depend on upower-pm-utils, included the just installed kde-plasma/powerdevil, which recommends to uninstall that upower-pm-utils on which it depends. Crazy:
Code:
# equery d  sys-power/upower-pm-utils
 * These packages depend on sys-power/upower-pm-utils:
kde-plasma/powerdevil-5.5.4 (sys-power/upower-pm-utils)
net-misc/networkmanager-1.0.6-r1 (!systemd ? sys-power/upower-pm-utils)
x11-misc/sddm-0.13.0-r1 (!systemd ? sys-power/upower-pm-utils)

So, I don't really know what to think about your recommendation. It works for you, lucky you, but I had upower-pm-utils before and I'm exactly the same now without it, lacking the Hibernate button; besides, Portage recommends to uninstall it and replace with Upower. Perhaps this madness is due to the «upower» flag in my make.conf, but said flag is only for «Enable power management support», be it vía upower-pm-utils or Upower, no? What a mess... :-/

Any kind and savy gentooer out there could throw some light, please?
Back to top
View user's profile Send private message
kensington
Developer
Developer


Joined: 02 Jan 2013
Posts: 175
Location: Australia

PostPosted: Fri Jan 29, 2016 11:06 am    Post subject: Reply with quote

There is currently bug #573138 filed about this.

Some information that might help diagnose the issue:


* OpenRC or systemd?
* Which version of consolekit is installed?
* How do you launch Plasma?
* Which groups is your user in?
Back to top
View user's profile Send private message
AnOriginalNick
n00b
n00b


Joined: 02 Apr 2015
Posts: 14

PostPosted: Fri Jan 29, 2016 11:44 am    Post subject: Reply with quote

kensington wrote:
There is currently bug #573138 filed about this.

Some information that might help diagnose the issue:


* OpenRC or systemd?
* Which version of consolekit is installed?
* How do you launch Plasma?
* Which groups is your user in?


Let's start:
1) sys-apps/openrc-0.20.4
2) sys-auth/consolekit-1.0.1
3) x11-misc/lightdm-1.16.6
4) wheel audio cdrom users portage plugdev vboxusers crontab wireshark power

About system behaviour:
1) Only Suspend option is present in the menu.
2) Hibernation on closed lid seems to work alright (set though power management menu). Also
qdbus org.kde.kded5 /org/freedesktop/PowerManagement CanHibernate returns False
3) Shutdown and reboot work alright through console.


Also it might be relevant that I use paludis and not portage for package management. If you need any other info just ask.
Back to top
View user's profile Send private message
kensington
Developer
Developer


Joined: 02 Jan 2013
Posts: 175
Location: Australia

PostPosted: Fri Jan 29, 2016 12:17 pm    Post subject: Reply with quote

Can you try with consolekit-1.0.0-r1?
Back to top
View user's profile Send private message
AnOriginalNick
n00b
n00b


Joined: 02 Apr 2015
Posts: 14

PostPosted: Fri Jan 29, 2016 12:41 pm    Post subject: Reply with quote

kensington wrote:
Can you try with consolekit-1.0.0-r1?


Should I ignore powerdevil RDEPEND and use consolekit-1.0.0-r1 with the latest version of powerdevil or downgrade both consolekit and powerdevil and more or less ignore further RDEPEND issues?


Last edited by AnOriginalNick on Fri Jan 29, 2016 12:49 pm; edited 1 time in total
Back to top
View user's profile Send private message
kensington
Developer
Developer


Joined: 02 Jan 2013
Posts: 175
Location: Australia

PostPosted: Fri Jan 29, 2016 12:43 pm    Post subject: Reply with quote

AnOriginalNick wrote:
kensington wrote:
Can you try with consolekit-1.0.0-r1?


Should I ignore powerdevil RDEPEND and use it with the latest version or downgrade both consolekit and powerdevil and more or less ignore further RDEPEND issues?


Whichever you're happier with - it shouldn't affect the test at all.
Back to top
View user's profile Send private message
AnOriginalNick
n00b
n00b


Joined: 02 Apr 2015
Posts: 14

PostPosted: Fri Jan 29, 2016 1:28 pm    Post subject: Reply with quote

kensington wrote:
AnOriginalNick wrote:
kensington wrote:
Can you try with consolekit-1.0.0-r1?


Should I ignore powerdevil RDEPEND and use it with the latest version or downgrade both consolekit and powerdevil and more or less ignore further RDEPEND issues?


Whichever you're happier with - it shouldn't affect the test at all.


So I tried consolekit-1.0.0-r1, it brought back Restart and Shutdown options in menu (functional), but removed Hibernate from possible actions for on closed lid (now that I think about it, I am not sure that hibernate was trully functional, looked more like suspend to ram). So no Hibernate.
Back to top
View user's profile Send private message
kensington
Developer
Developer


Joined: 02 Jan 2013
Posts: 175
Location: Australia

PostPosted: Fri Jan 29, 2016 1:41 pm    Post subject: Reply with quote

I wonder if it could also be related to some pam changes in lightdm. I am using consolekit-1.0.1 successfully, but with lightdm-1.12.3 instead.
Back to top
View user's profile Send private message
taikuus
n00b
n00b


Joined: 24 Jan 2016
Posts: 18

PostPosted: Sat Jan 30, 2016 5:27 pm    Post subject: Reply with quote

I don't think it has anything to do with lightdm. I think it is a bug in ConsoleKit: I am using sddm and I was having the same problem, no suspend would appear in the menu. After some research I found out that the Suspend and CanSuspend have disappeared from the D-Bus UPower interface. Trying to go to sleep from the command line would report:

Code:

gentoo # dbus-send --system --print-reply --dest="org.freedesktop.UPower" /org/freedesktop/UPower org.freedesktop.UPower.Suspend
Error org.freedesktop.DBus.Error.UnknownMethod: Method "Suspend" with signature "" on interface "org.freedesktop.UPower" doesn't exist


I was using consolekit-1.0.1. After downgrading to consolekit-1.0.0-r1 as suggested in this thread, everything went back to normal. Do you also think that it is a bug in consolekit?
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Sat Jan 30, 2016 5:30 pm    Post subject: Reply with quote

Please make sure you have a valid system-login pam.d file:

https://wiki.gentoo.org/wiki/KDE/Plasma_5_upgrade#Missing_shutdown.2C_reboot.2C_suspend_and_hibernate_buttons_when_using_OpenRC
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
taikuus
n00b
n00b


Joined: 24 Jan 2016
Posts: 18

PostPosted: Sat Jan 30, 2016 5:38 pm    Post subject: Reply with quote

I have checked was genstorm suggested and, in my case I had a valid system-login pam.d and sddm-0.13.0-r1.
My system was fulfilling all the requirements stated in the page that genstorm pointed at to.

I have checked and switching between consolekit-1.0.0 and consolekit-1.0.1 make the problem appear and disappaer, so I think that the problem is in consolekit-1.0.1.

NOTE: After emerge consolekit it is necessary to restart dbus.
Back to top
View user's profile Send private message
tnt
Veteran
Veteran


Joined: 27 Feb 2004
Posts: 1171

PostPosted: Sun Jan 31, 2016 7:17 pm    Post subject: Reply with quote

for last couple of weeks not just my plasma is missing reboot/shutdown buttons, but my regular user cannot execute reboot/halt from BASH (which was possible earlier).
I have to sudo/su root to reboot my box. :(
_________________
gentoo user
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Mon Feb 01, 2016 12:09 am    Post subject: Reply with quote

So, same for you:
kensington wrote:
* OpenRC or systemd?
* Which version of consolekit is installed?
* How do you launch Plasma?
* Which groups is your user in?


Also, do you use the plasma profile or not?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
tnt
Veteran
Veteran


Joined: 27 Feb 2004
Posts: 1171

PostPosted: Mon Feb 01, 2016 12:22 pm    Post subject: Reply with quote

thx for response. info:

Code:
[ebuild   R    ] sys-apps/openrc-0.20.4::gentoo
[ebuild   R    ] sys-auth/consolekit-1.0.1::gentoo
[ebuild   R    ] x11-misc/sddm-0.13.0-r1::gentoo


I have followed this guide:
https://wiki.gentoo.org/wiki/KDE/Plasma_5_upgrade#Display_manager
so I'm using sddm.

My user is a member of following groups:
Code:
lp wheel uucp audio cdrom dialout video usb users tnt plugdev lpadmin vboxusers games sddm


I did switch to plasma profile:
Code:
Available profile symlink targets:
  [1]   default/linux/amd64/13.0
  [2]   default/linux/amd64/13.0/selinux
  [3]   default/linux/amd64/13.0/desktop
  [4]   default/linux/amd64/13.0/desktop/gnome
  [5]   default/linux/amd64/13.0/desktop/gnome/systemd
  [6]   default/linux/amd64/13.0/desktop/kde
  [7]   default/linux/amd64/13.0/desktop/kde/systemd
  [8]   default/linux/amd64/13.0/desktop/plasma *
  [9]   default/linux/amd64/13.0/desktop/plasma/systemd
  [10]  default/linux/amd64/13.0/developer
  [11]  default/linux/amd64/13.0/no-multilib
  [12]  default/linux/amd64/13.0/systemd
  [13]  default/linux/amd64/13.0/x32
  [14]  hardened/linux/amd64
  [15]  hardened/linux/amd64/selinux
  [16]  hardened/linux/amd64/no-multilib
  [17]  hardened/linux/amd64/no-multilib/selinux
  [18]  hardened/linux/amd64/x32
  [19]  hardened/linux/musl/amd64
  [20]  hardened/linux/musl/amd64/x32
  [21]  default/linux/uclibc/amd64
  [22]  hardened/linux/uclibc/amd64

_________________
gentoo user
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Mon Feb 01, 2016 12:30 pm    Post subject: Reply with quote

Did you check your system-login file inside /etc/pam.d/ as the user above you? It needs to contain nox11.

Code:
$ ck-list-sessions


Do you use upower or upower-pm-utils?

Maybe it is also a problem with consolekit-1.0.1 for you, please try if the following fixes your problem:

Code:
# emerge -1 =consolekit-1.0.0*


What are your use flags here:

Code:
$ equery u sddm
$ equery u consolekit

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
AnOriginalNick
n00b
n00b


Joined: 02 Apr 2015
Posts: 14

PostPosted: Wed Feb 03, 2016 7:16 am    Post subject: Reply with quote

For me problem seemed to be in LightDM, because it worked with consolekit-1.0.0 alright and stopped working with conolekit-1.0.1, but SDDM works with consolekit-1.0.1 alright as it did with 1.0.0.

My pam.d was alright in both instances.
Back to top
View user's profile Send private message
tnt
Veteran
Veteran


Joined: 27 Feb 2004
Posts: 1171

PostPosted: Wed Feb 03, 2016 9:23 am    Post subject: Reply with quote

@genstorm

going back to =consolekit-1.0.0* solved my problem.

than again, installing consolekit-1.0.1 and setting nox11 correctly in pam.d also solved the problem, so I have stayed with this solution.

thx!
_________________
gentoo user
Back to top
View user's profile Send private message
Yamakuzure
Advocate
Advocate


Joined: 21 Jun 2006
Posts: 2273
Location: Bardowick, Germany

PostPosted: Wed Feb 03, 2016 10:55 am    Post subject: Reply with quote

Just don't forget that you still need pm-utils to be installed.
_________________
Important German:
  1. "Aha" - German reaction to pretend that you are really interested while giving no f*ck.
  2. "Tja" - German reaction to the apocalypse, nuclear war, an alien invasion or no bread in the house.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Wed Feb 03, 2016 1:45 pm    Post subject: Reply with quote

taikuus wrote:
I have checked was genstorm suggested and, in my case I had a valid system-login pam.d and sddm-0.13.0-r1.
My system was fulfilling all the requirements stated in the page that genstorm pointed at to.

Coming back to your problem - that means you indeed have nox11 present in your system-login file?

What version of powerdevil is installed? What USE flags are set on sddm?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
kistian
n00b
n00b


Joined: 09 Nov 2015
Posts: 13

PostPosted: Sat Mar 12, 2016 9:14 am    Post subject: Reply with quote

I've found the same error on consolekit-1.0.1

for me is solved by adding the nox11 to the policy like here:

https://wiki.gentoo.org/wiki/KDE/Plasma_5_upgrade#Missing_shutdown.2C_reboot.2C_suspend_and_hibernate_buttons_when_using_OpenRC

Code:
user $grep pam_ck_connector /etc/pam.d/system-login
session         optional        pam_ck_connector.so nox11


and I've found a new use flag for this version (>=1.0.1) package it needs to enable, is PM-UTILS

Code:
 * Found these USE flags for sys-auth/consolekit-1.0.1:
 U I
 + + acl      : Add support for Access Control Lists
 - - cgroups  : Use the kernel to track processes instead of the session cookie.
 - - debug    : Enable extra debug codepaths, like asserts and extra output. If you want to get meaningful backtraces see
                https://wiki.gentoo.org/wiki/Project:Quality_Assurance/Backtraces
 - - doc      : Add extra documentation (API, Javadoc, etc). It is recommended to enable per package instead of globally
 + + pam      : Add support for PAM (Pluggable Authentication Modules) - DANGEROUS to arbitrarily flip
 - - pm-utils : Adds support for suspend/resume using sys-power/pm-utils
 - - test     : Workaround to pull in packages needed to run with FEATURES=test. Portage-2.1.2 handles this internally, so don't set it in
                make.conf/package.use anymore


enable it adding this use to the package.use

for single file in package.use:
Code:
echo "sys-auth/consolekit pm-utils" >> /etc/portage/package.use


for tree file system on package.use:
Code:
echo "sys-auth/consolekit pm-utils" >> /etc/portage/package.use/consolekit
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum