Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
evince using wrong font
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
etagenklo
n00b
n00b


Joined: 23 May 2014
Posts: 6

PostPosted: Tue Jan 26, 2016 1:33 pm    Post subject: evince using wrong font Reply with quote

Hi,

I'm currently pulling my hair out trying to get evince to display the correct font for Arial. I've got Windows fonts installed and they seem to be working fine. But when I open a PDF document in evince with a non-embedded Arial font, evince is using Nimbus Sans L instead of Arial, which looks awful.

http://www2.pic-upload.de/thumb/29550144/screen_evince.png

Evince should be using fontconfig to select the correct font, and fontconfig says:

Code:
dirk@etkbox /usr/share/fonts/vista $ fc-match -v Arial|grep file
   file: "/usr/share/fonts/vista/arial.ttf"(w)


Code:
dirk@etkbox /usr/share/fonts/vista $ fc-match Arial --sort
arial.ttf: "Arial" "Normal"
arial.ttf: "Arial" "Normal"
n019003l.pfb: "Nimbus Sans L" "Regular"
DejaVuSans.ttf: "DejaVu Sans" "Book"
DejaVuSans-Bold.ttf: "DejaVu Sans" "Bold"
DejaVuSans-Oblique.ttf: "DejaVu Sans" "Oblique"
DejaVuSans-BoldOblique.ttf: "DejaVu Sans" "Bold Oblique"
DroidSansThai.ttf: "Droid Sans" "Regular"
DroidSansJapanese.ttf: "Droid Sans" "Regular"
DroidSansFallback.ttf: "Droid Sans" "Regular"
verdana.ttf: "Verdana" "Normal"
...


What am I missing here? Why does fc-match select the correct font, but evince ignores it and selects the 3rd on the list?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum