Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
wpa_supplicant stopped working after update [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Efo
Guru
Guru


Joined: 23 Jun 2005
Posts: 420

PostPosted: Sat Jan 23, 2016 4:21 pm    Post subject: wpa_supplicant stopped working after update [SOLVED] Reply with quote

Hi all,

During my last update, dhcpcd-6.10.0 was installed among other packages, and I also compiled kernel 4.1.15-r1 (went smooth, not sure this is relevant). Now wpa_supplicant doesnt work anymore. Here is what I have:

/etc/conf.d/net:
Code:
modules="wpa_supplicant"
wpa_supplicant_wlp2s0="-Dwext"
config_wlp2s0=("dhcp")


/etc/wpa_supplicant/wpa_supplicant.conf
Code:
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
#update_config=1

network={
        ssid="MyRouter"
        scan_ssid=1
        psk="#password"
        proto=RSN
        key_mgmt=WPA-PSK
        pairwise=TKIP
        auth_alg=OPEN
        eap=PSK
        wep_key0=#password
}


dhcpcd -k
Code:
sending signal ARLM to pid 4695
waiting for pid 4695 to exit
pid 4695 failed to exit


dhcpcd -dB (I removed info regarding ethernet card)
Code:
dhcpcd-6.10.0 starting
dev: loaded udev
wlp2s0: executing `/lib/dhcpcd/dhcpcd-run-hooks' PREINIT
wlp2s0: executing `/lib/dhcpcd/dhcpcd-run-hooks' NOCARRIER
DUID 00:01:00:00:1a:85:ba:cb
wlp2s0: waiting for carrier


wpa_cli
Code:
wpa_cli v2.4
Copyright (c) 2004-2015, Jouni Malinen <j@w1.fi> and contributors

This software may be distributed under the terms of the BSD license.
See README for more details.


Selected interface 'wlp2s0'

Interactive mode

<3>CTRL-EVENT-SCAN-RESULTS
<3>CTRL-EVENT-SSID-REENABLED id=0 ssid="MyRouter"
<3>SME: Trying to authenticate with **:**:**:**:**:** (SSID='MyRouter' freq=2427 MHz)
<3>Trying to associate with **:**:**:**:**:** (SSID='MyRouter' freq=2427 MHz)
<3>Associated with **:**:**:**:**:**
<3>CTRL-EVENT-DISCONNECTED bssid=**:**:**:**:**:** reason=3 locally_generated=1
<3>WPA: 4-Way Handshake failed - pre-shared key may be incorrect
<3>CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="MyRouter" auth_failures=36 duration=120 reason=WRONG_KEY
<3>CTRL-EVENT-REGDOM-CHANGE init=CORE type=WORLD
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
<3>CTRL-EVENT-SCAN-STARTED
<3>CTRL-EVENT-SCAN-RESULTS
...


It seems it is not accepting the key, but I have not changed any configuretion files; I just updated the system (I doubled checked the settings though). Everything else connected to the router has been working as usual.

Any help is highly appreciated.

Thanks,

Efo


Last edited by Efo on Wed Jan 27, 2016 6:10 am; edited 1 time in total
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1371

PostPosted: Sun Jan 24, 2016 12:39 am    Post subject: Reply with quote

Perhaps you - like me - used dhcpcd to start wpa_supplicant. Read the news:
2016-01-08-some-dhcpcd-hooks-are-now-examples
_________________
fun2gen2
Back to top
View user's profile Send private message
UberLord
Retired Dev
Retired Dev


Joined: 18 Sep 2003
Posts: 6737
Location: Blighty

PostPosted: Sun Jan 24, 2016 3:55 pm    Post subject: Reply with quote

Quote:
wpa_supplicant_wlp2s0="-Dwext"


Any reason you're forcing the wext driver? Try removing that line.
_________________
Use dhcpcd for all your automated network configuration needs
Use dhcpcd-ui (GTK+/Qt) as your System Tray Network tool
Back to top
View user's profile Send private message
Efo
Guru
Guru


Joined: 23 Jun 2005
Posts: 420

PostPosted: Sun Jan 24, 2016 6:26 pm    Post subject: Reply with quote

Hi ulenrich and UberLord,

Thank you for helping me out.

ulenrich: I did copy the hooks in /lib/dhcpcd/dhcpcd-hooks/

UberLord: I dont remember why I am forcing that driver (it was long ago). Anyway, I tried removing it, but I am experiencing the same problem.

Cant figure out why an update would compromise this....
Back to top
View user's profile Send private message
Efo
Guru
Guru


Joined: 23 Jun 2005
Posts: 420

PostPosted: Sun Jan 24, 2016 11:29 pm    Post subject: Reply with quote

This may be related to the wext driver:

wpa_supplicant -iwlp2s0 -Dwext -c/etc/wpa_supplicant/wpa_supplicant.conf
Code:
Successfully initialized wpa_supplicant
ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWSCAN]: Device or resource busy
wlp2s0: CTRL-EVENT-SCAN-FAILED ret=-1 retry=1
ioctl[SIOCSIWSCAN]: Device or resource busy
wlp2s0: CTRL-EVENT-SCAN-FAILED ret=-1 retry=1
ioctl[SIOCSIWSCAN]: Device or resource busy
wlp2s0: CTRL-EVENT-SCAN-FAILED ret=-1 retry=1
ioctl[SIOCSIWSCAN]: Device or resource busy
wlp2s0: CTRL-EVENT-SCAN-FAILED ret=-1 retry=1
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2583

PostPosted: Mon Jan 25, 2016 9:04 am    Post subject: Reply with quote

Efo wrote:

UberLord: I dont remember why I am forcing that driver (it was long ago). Anyway, I tried removing it, but I am experiencing the same problem.

Cant figure out why an update would compromise this....

You did it just recently:
Efo wrote:
This may be related to the wext driver:

wpa_supplicant -iwlp2s0 -Dwext -c/etc/wpa_supplicant/wpa_supplicant.conf

Did you mean -dnl80211 instead?
Back to top
View user's profile Send private message
Efo
Guru
Guru


Joined: 23 Jun 2005
Posts: 420

PostPosted: Mon Jan 25, 2016 3:07 pm    Post subject: Reply with quote

Hi charles17 and thank you for joining us,

The -Dwext has been there for a while; I havent changed net or wpa_supplicant.conf configurations, I just updated the system.

Now, with "wpa_supplicant -iwlp2s0 -Dnl80211 -c/etc/wpa_supplicant/wpa_supplicant.conf":

Daemon not started I get:
Code:
Successfully initialized wpa_supplicant

no more messages (i.e. stuck) and no connection.

With the Daemon started I get:
Code:
Successfully initialized wpa_supplicant
ctrl_iface exists and seems to be in use - cannot override it
Delete '/var/run/wpa_supplicant/wlp2s0' manually if it is not used anymore
Failed to initialize control interface '/var/run/wpa_supplicant'.
You may have another wpa_supplicant process already running or the file was
left by an unclean termination of wpa_supplicant in which case you will need
to manually remove this file before starting wpa_supplicant again.

nl80211: deinit ifname=wlp2s0 disabled_11b_rates=0


If I remove /var/run/wpa_supplicant with daemon started, I get the same response as if the daemon were stopped (i.e. first case).
Any suggestion?

thanks,

Efo
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2583

PostPosted: Mon Jan 25, 2016 3:35 pm    Post subject: Reply with quote

Efo wrote:
With the Daemon started I get:
Code:
Successfully initialized wpa_supplicant
ctrl_iface exists and seems to be in use - cannot override it
Delete '/var/run/wpa_supplicant/wlp2s0' manually if it is not used anymore
Failed to initialize control interface '/var/run/wpa_supplicant'.
You may have another wpa_supplicant process already running or the file was
left by an unclean termination of wpa_supplicant in which case you will need
to manually remove this file before starting wpa_supplicant again.

nl80211: deinit ifname=wlp2s0 disabled_11b_rates=0

Try with, as root "killall wpa_supplicant" before, See https://wiki.gentoo.org/wiki/Wpa_supplicant#Run_wpa_supplicant_in_debug_mode
Back to top
View user's profile Send private message
Efo
Guru
Guru


Joined: 23 Jun 2005
Posts: 420

PostPosted: Tue Jan 26, 2016 1:40 am    Post subject: Reply with quote

I tried that, but it didnt work. But maybe the debug info are useful:
Code:
wpa_supplicant v2.4
random: Trying to read entropy from /dev/random
Successfully initialized wpa_supplicant
Initializing interface 'wlp2s0' conf '/etc/wpa_supplicant/wpa_supplicant.conf' driver 'nl80211' ctrl_interface '/var/run/wpa_supplicant/' bridge 'N/A'
Configuration file '/etc/wpa_supplicant/wpa_supplicant.conf' -> '/etc/wpa_supplicant/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant/wpa_supplicant.conf'
ctrl_interface='/var/run/wpa_supplicant'
ctrl_interface_group='0'
Line: 5 - start of a new network block
ssid - hexdump_ascii(len=9):
     xx xx xx xx xx                       MyRouter
scan_ssid=1 (0x1)
PSK (ASCII passphrase) - hexdump_ascii(len=10): [REMOVED]
proto: 0x2
key_mgmt: 0x2
pairwise: 0x8
auth_alg: 0x1
eap methods - hexdump(len=16): 00 00 00 00 2f 00 00 00 00 00 00 00 00 00 00 00
PSK (from passphrase) - hexdump(len=32): [REMOVED]
Line 15: removed CCMP from group cipher list since it was not allowed for pairwise cipher
Line: 17 - start of a new network block
ssid - hexdump_ascii(len=4):
     43 72 61 70                                       Crap           
scan_ssid=1 (0x1)
PSK (ASCII passphrase) - hexdump_ascii(len=10): [REMOVED]
proto: 0x2
key_mgmt: 0x2
pairwise: 0x8
auth_alg: 0x1
eap methods - hexdump(len=16): 00 00 00 00 2f 00 00 00 00 00 00 00 00 00 00 00
PSK (from passphrase) - hexdump(len=32): [REMOVED]
Line 27: removed CCMP from group cipher list since it was not allowed for pairwise cipher
Priority group 0
   id=0 ssid='MyRouter'
   id=1 ssid='Crap'
rfkill: initial event: idx=0 type=1 op=0 soft=0 hard=0
nl80211: Supported cipher 00-0f-ac:1
nl80211: Supported cipher 00-0f-ac:5
nl80211: Supported cipher 00-0f-ac:2
nl80211: Supported cipher 00-0f-ac:4
nl80211: Supported cipher 00-0f-ac:10
nl80211: Supported cipher 00-0f-ac:8
nl80211: Supported cipher 00-0f-ac:9
nl80211: Using driver-based off-channel TX
nl80211: interface wlp2s0 in phy phy0
nl80211: Set mode ifindex 3 iftype 2 (STATION)
nl80211: Subscribe to mgmt frames with non-AP handle 0x6e0490
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0x6e0490 match=0104
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0x6e0490 match=040a
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0x6e0490 match=040b
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0x6e0490 match=040c
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0x6e0490 match=040d
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0x6e0490 match=090a
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0x6e0490 match=090b
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0x6e0490 match=090c
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0x6e0490 match=090d
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0x6e0490 match=0801
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0x6e0490 match=06
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0x6e0490 match=0a07
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0x6e0490 match=0a11
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0x6e0490 match=0a1a
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0x6e0490 match=1101
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0x6e0490 match=1102
nl80211: Register frame type=0xd0 (WLAN_FC_STYPE_ACTION) nl_handle=0x6e0490 match=0505
netlink: Operstate: ifindex=3 linkmode=1 (userspace-control), operstate=5 (IF_OPER_DORMANT)
nl80211: driver param='(null)'
Add interface wlp2s0 to a new radio phy0
nl80211: Regulatory information - country=00
nl80211: 2402-2472 @ 40 MHz 20 mBm
nl80211: 2457-2482 @ 40 MHz 20 mBm (no IR)
nl80211: 2474-2494 @ 20 MHz 20 mBm (no OFDM) (no IR)
nl80211: 5170-5250 @ 80 MHz 20 mBm (no IR)
nl80211: 5250-5330 @ 80 MHz 20 mBm (DFS) (no IR)
nl80211: 5490-5730 @ 160 MHz 20 mBm (DFS) (no IR)
nl80211: 5735-5835 @ 80 MHz 20 mBm (no IR)
nl80211: 57240-63720 @ 2160 MHz 0 mBm
nl80211: Added 802.11b mode based on 802.11g information
wlp2s0: Own MAC address: xx:xx:xx:xx:xx:xx
wpa_driver_nl80211_set_key: ifindex=3 (wlp2s0) alg=0 addr=(nil) key_idx=0 set_tx=0 seq_len=0 key_len=0
wpa_driver_nl80211_set_key: ifindex=3 (wlp2s0) alg=0 addr=(nil) key_idx=1 set_tx=0 seq_len=0 key_len=0
wpa_driver_nl80211_set_key: ifindex=3 (wlp2s0) alg=0 addr=(nil) key_idx=2 set_tx=0 seq_len=0 key_len=0
wpa_driver_nl80211_set_key: ifindex=3 (wlp2s0) alg=0 addr=(nil) key_idx=3 set_tx=0 seq_len=0 key_len=0
wpa_driver_nl80211_set_key: ifindex=3 (wlp2s0) alg=0 addr=(nil) key_idx=4 set_tx=0 seq_len=0 key_len=0
wpa_driver_nl80211_set_key: ifindex=3 (wlp2s0) alg=0 addr=(nil) key_idx=5 set_tx=0 seq_len=0 key_len=0
wlp2s0: RSN: flushing PMKID list in the driver
nl80211: Flush PMKIDs
wlp2s0: Setting scan request: 0.100000 sec
ENGINE: Loading dynamic engine
ENGINE: Loading dynamic engine
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: Supplicant port status: Unauthorized
nl80211: Skip set_supp_port(unauthorized) while not associated
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
ctrl_interface_group=0
wlp2s0: Added interface wlp2s0
wlp2s0: State: DISCONNECTED -> DISCONNECTED
nl80211: Set wlp2s0 operstate 0->0 (DORMANT)
netlink: Operstate: ifindex=3 linkmode=-1 (no change), operstate=5 (IF_OPER_DORMANT)
random: Got 20/20 bytes from /dev/random
RTM_NEWLINK: ifi_index=3 ifname=wlp2s0 operstate=2 linkmode=0 ifi_family=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK: ifi_index=3 ifname=wlp2s0 operstate=2 linkmode=1 ifi_family=0 ifi_flags=0x1003 ([UP])
wlp2s0: State: DISCONNECTED -> SCANNING
Scan SSID - hexdump_ascii(len=9):
     xx xx xx xx xx                       MyRouter
Scan SSID - hexdump_ascii(len=4):
     43 72 61 70                                       Crap           
wlp2s0: Starting AP scan for wildcard SSID
wlp2s0: Add radio work 'scan'@0x702a70
wlp2s0: First radio work item in the queue - schedule start immediately
....


Not sure about those unauthorized messages...
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2583

PostPosted: Tue Jan 26, 2016 9:39 am    Post subject: Reply with quote

Efo wrote:
I tried that, but it didnt work. But maybe the debug info are useful:
Code:
wpa_supplicant v2.4
random: Trying to read entropy from /dev/random
....
If it didn't work, how did you collect the debug info?
Anyway, reading through it, there might be something wrong but I didn't find.

So will you please post your output of "ifconfig -a"

And btw, which solution for network managment are you using? If netifrc, have you removed the cruft from your above mentioned "/etc/conf.d/net"?
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Tue Jan 26, 2016 11:32 am    Post subject: Re: wpa_supplicant stopped working after update Reply with quote

Efo wrote:
During my last update, dhcpcd-6.10.0 was installed among other packages, and I also compiled kernel 4.1.15-r1 (went smooth, not sure this is relevant). Now wpa_supplicant doesnt work anymore. Here is what I have:

Efo ... wpa_supplicant fails to assoc as the key is incorrect:

Efo wrote:
Code:
<3>WPA: 4-Way Handshake failed - pre-shared key may be incorrect
<3>CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="MyRouter" auth_failures=36 duration=120 reason=WRONG_KEY

I don't think your update, or dhcpcd, have anything to do with it, you can see 36 authentication failures.

Please try with a sane wpa_supplicant.conf ...

/etc/wpa_supplicant/wpa_supplicant.conf:
ctrl_interface=DIR=/run/wpa_supplicant GROUP=wheel

network={
        ssid="MyRouter"
        psk=pre_shared_key
}

psk needs to be a pre-shared-key, and I'm fairly sure '#' is not an accepted char (if that is in fact what you have). You can generate a psk with the following:

Code:
# wpa_passphrase MyRouter passphrase

Efo wrote:
It seems it is not accepting the key, but I have not changed any configuretion files; I just updated the system (I doubled checked the settings though).

I'm trying to think of a possible reason why this might happen and I can't, perhaps you'd updated wpa_supplicant and it's config parser has changed ... and the fact you request 'proto=RSN' (which is wpa2) but then pairwise=TKIP (which should be CCMP for wpa2), and the other conflicting parameters (like wep_key and eap) causes wpa_supplicant to baulk.

best ... khay
Back to top
View user's profile Send private message
Efo
Guru
Guru


Joined: 23 Jun 2005
Posts: 420

PostPosted: Wed Jan 27, 2016 2:21 am    Post subject: Reply with quote

Hi khay and thanks for the input,

The connection should be WPA; thank you for pointing out the inconsistencies.

here is what I tried:

/etc/wpa_supplicant/wpa_supplicant.conf
Code:
ctrl_interface=/var/run/wpa_supplicant GROUP=wheel

network={
   ssid="MyRouter"
   psk=#password created by wpa_passphrase
}


wpa_supplicant -Dwext -iwlp2s0 -C/var/run/wpa_supplicant/ -c/etc/wpa_pplicant/wpa_supplicant.conf -dd
Code:
wpa_supplicant v2.4
random: Trying to read entropy from /dev/random
Successfully initialized wpa_supplicant
Initializing interface 'wlp2s0' conf '/etc/wpa_supplicant/wpa_supplicant.conf' driver 'wext' ctrl_interface '/var/run/wpa_supplicant/' bridge 'N/A'
Configuration file '/etc/wpa_supplicant/wpa_supplicant.conf' -> '/etc/wpa_supplicant/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant/wpa_supplicant.conf'
ctrl_interface='/var/run/wpa_supplicant GROUP=wheel'
Line: 5 - start of a new network block
ssid - hexdump_ascii(len=9):
     xx xx xx xx xx xx xx                        MyRouter       
PSK - hexdump(len=32): [REMOVED]
Priority group 0
   id=0 ssid='MyRouter'
WEXT: cfg80211-based driver detected
wext: interface wlp2s0 phy: phy0
rfkill: initial event: idx=0 type=1 op=0 soft=0 hard=0
SIOCGIWRANGE: WE(compiled)=22 WE(source)=21 enc_capa=0xf
  capabilities: key_mgmt 0xf enc 0x1f flags 0x0
netlink: Operstate: ifindex=3 linkmode=1 (userspace-control), operstate=5 (IF_OPER_DORMANT)
Add interface wlp2s0 to a new radio phy0
wlp2s0: Own MAC address: xx:xx:xx:xx:xx:xx
wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=1 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=2 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=3 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=4 set_tx=0 seq_len=0 key_len=0
ioctl[SIOCSIWENCODEEXT]: Invalid argument
Driver did not support SIOCSIWENCODEEXT
wpa_driver_wext_set_key: alg=0 key_idx=5 set_tx=0 seq_len=0 key_len=0
ioctl[SIOCSIWENCODEEXT]: Invalid argument
Driver did not support SIOCSIWENCODEEXT
wpa_driver_wext_set_countermeasures
wlp2s0: RSN: flushing PMKID list in the driver
wlp2s0: Setting scan request: 0.100000 sec
ENGINE: Loading dynamic engine
ENGINE: Loading dynamic engine
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: Supplicant port status: Unauthorized
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
wlp2s0: Added interface wlp2s0
wlp2s0: State: DISCONNECTED -> DISCONNECTED
wpa_driver_wext_set_operstate: operstate 0->0 (DORMANT)
netlink: Operstate: ifindex=3 linkmode=-1 (no change), operstate=5 (IF_OPER_DORMANT)
random: Got 19/20 bytes from /dev/random
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlp2s0' added
WEXT: if_removed already cleared - ignore event
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlp2s0' added
WEXT: if_removed already cleared - ignore event
Wireless event: cmd=0x8b06 len=12
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlp2s0' added
WEXT: if_removed already cleared - ignore event
Wireless event: cmd=0x8b1a len=16
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlp2s0' added
WEXT: if_removed already cleared - ignore event
random: Got 1/1 bytes from /dev/random
wlp2s0: State: DISCONNECTED -> SCANNING
wlp2s0: Starting AP scan for wildcard SSID
wlp2s0: Add radio work 'scan'@0x6fe590
wlp2s0: First radio work item in the queue - schedule start immediately
wlp2s0: Starting radio work 'scan'@0x6fe590 after 0.000010 second wait
Scan requested (ret=0) - scan timeout 10 seconds
EAPOL: disable timer tick
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlp2s0' added
WEXT: if_removed already cleared - ignore event
Wireless event: cmd=0x8b19 len=16
wlp2s0: Event SCAN_RESULTS (3) received
Scan results did not fit - trying larger buffer (8192 bytes)
Scan results did not fit - trying larger buffer (16384 bytes)
Received 10008 bytes of scan results (19 BSSes)
wlp2s0: BSS: Start scan result update 1
wlp2s0: BSS: Add new id 0 BSSID 78:54:2e:a3:1b:54 SSID '\x00\x00\x00\x00\x00\x00\x00\x00\x00'
wlp2s0: BSS: Add new id 1 BSSID c4:27:95:3a:34:8e SSID 'HOME-348E'
wlp2s0: BSS: Add new id 2 BSSID c6:27:95:3a:34:8f SSID '\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00'
wlp2s0: BSS: Add new id 3 BSSID 58:6d:8f:17:59:56 SSID 'mmiranda_net'
wlp2s0: BSS: Add new id 4 BSSID d8:97:ba:c4:3a:08 SSID 'HOME-2A25-2.4'
wlp2s0: BSS: Add new id 5 BSSID d8:97:ba:c4:3a:09 SSID ''
wlp2s0: BSS: Add new id 6 BSSID c4:39:3a:b5:e9:eb SSID ''
wlp2s0: BSS: Add new id 7 BSSID c4:39:3a:b5:e9:e8 SSID 'HOME-E9E8'
wlp2s0: BSS: Add new id 8 BSSID c4:39:3a:b5:e9:ea SSID ''
wlp2s0: BSS: Add new id 9 BSSID 00:1c:b3:af:1c:80 SSID ''
wlp2s0: BSS: Add new id 10 BSSID c4:39:3a:b5:e9:e9 SSID ''
wlp2s0: BSS: Add new id 11 BSSID 74:9d:dc:d0:02:89 SSID '2WIRE998'
wlp2s0: BSS: Add new id 12 BSSID 02:1d:d6:f0:bd:d0 SSID ''
wlp2s0: BSS: Add new id 13 BSSID 58:23:8c:6b:40:da SSID 'HOME-40DA'
wlp2s0: BSS: Add new id 14 BSSID 5a:23:8c:6b:40:db SSID '\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00'
wlp2s0: BSS: Add new id 15 BSSID c6:27:95:3a:34:80 SSID 'xfinitywifi'
wlp2s0: BSS: Add new id 16 BSSID 58:6d:8f:17:59:58 SSID 'mmiranda_net-guest'
wlp2s0: BSS: Add new id 17 BSSID d8:97:ba:c4:3a:0a SSID 'xfinitywifi'
wlp2s0: BSS: Add new id 18 BSSID 06:1d:d6:f0:bd:d0 SSID 'xfinitywifi'
BSS: last_scan_res_used=19/32
wlp2s0: New scan results available (own=0 ext=0)
wlp2s0: Radio work 'scan'@0x6fe590 done in 3.112296 seconds
wlp2s0: Selecting BSS from priority group 0
wlp2s0: 0: 78:54:2e:a3:1b:54 ssid='\x00\x00\x00\x00\x00\x00\x00\x00\x00' wpa_ie_len=26 rsn_ie_len=0 caps=0x11 level=-32
wlp2s0:    skip - SSID mismatch
wlp2s0: 1: c4:27:95:3a:34:8e ssid='HOME-348E' wpa_ie_len=28 rsn_ie_len=24 caps=0x11 level=-69 wps
wlp2s0:    skip - SSID mismatch
wlp2s0: 2: c6:27:95:3a:34:8f ssid='\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00' wpa_ie_len=0 rsn_ie_len=20 caps=0x11 level=-71
wlp2s0:    skip - SSID mismatch
wlp2s0: 3: 58:6d:8f:17:59:56 ssid='mmiranda_net' wpa_ie_len=28 rsn_ie_len=24 caps=0x11 level=-73 wps
wlp2s0:    skip - SSID mismatch
wlp2s0: 4: d8:97:ba:c4:3a:08 ssid='HOME-2A25-2.4' wpa_ie_len=26 rsn_ie_len=24 caps=0x11 level=-77 wps
wlp2s0:    skip - SSID mismatch
wlp2s0: 5: d8:97:ba:c4:3a:09 ssid='' wpa_ie_len=26 rsn_ie_len=24 caps=0x11 level=-77
wlp2s0:    skip - SSID not known
wlp2s0: 6: c4:39:3a:b5:e9:eb ssid='' wpa_ie_len=26 rsn_ie_len=24 caps=0x11 level=-78
wlp2s0:    skip - SSID not known
wlp2s0: 7: c4:39:3a:b5:e9:e8 ssid='HOME-E9E8' wpa_ie_len=26 rsn_ie_len=24 caps=0x11 level=-80 wps
wlp2s0:    skip - SSID mismatch
wlp2s0: 8: c4:39:3a:b5:e9:ea ssid='' wpa_ie_len=26 rsn_ie_len=24 caps=0x11 level=-80
wlp2s0:    skip - SSID not known
wlp2s0: 9: 00:1c:b3:af:1c:80 ssid='' wpa_ie_len=0 rsn_ie_len=20 caps=0x11 level=-81
wlp2s0:    skip - SSID not known
wlp2s0: 10: c4:39:3a:b5:e9:e9 ssid='' wpa_ie_len=0 rsn_ie_len=20 caps=0x11 level=-82
wlp2s0:    skip - SSID not known
wlp2s0: 11: 74:9d:dc:d0:02:89 ssid='2WIRE998' wpa_ie_len=26 rsn_ie_len=24 caps=0x11 level=-86
wlp2s0:    skip - SSID mismatch
wlp2s0: 12: 02:1d:d6:f0:bd:d0 ssid='' wpa_ie_len=0 rsn_ie_len=20 caps=0x11 level=-89
wlp2s0:    skip - SSID not known
wlp2s0: 13: 58:23:8c:6b:40:da ssid='HOME-40DA' wpa_ie_len=28 rsn_ie_len=24 caps=0x11 level=-89 wps
wlp2s0:    skip - SSID mismatch
wlp2s0: 14: 5a:23:8c:6b:40:db ssid='\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00' wpa_ie_len=0 rsn_ie_len=20 caps=0x11 level=-89
wlp2s0:    skip - SSID mismatch
wlp2s0: 15: c6:27:95:3a:34:80 ssid='xfinitywifi' wpa_ie_len=0 rsn_ie_len=0 caps=0x1 level=-68
wlp2s0:    skip - SSID mismatch
wlp2s0: 16: 58:6d:8f:17:59:58 ssid='mmiranda_net-guest' wpa_ie_len=0 rsn_ie_len=0 caps=0x1 level=-75
wlp2s0:    skip - SSID mismatch
wlp2s0: 17: d8:97:ba:c4:3a:0a ssid='xfinitywifi' wpa_ie_len=0 rsn_ie_len=0 caps=0x1 level=-76
wlp2s0:    skip - SSID mismatch
wlp2s0: 18: 06:1d:d6:f0:bd:d0 ssid='xfinitywifi' wpa_ie_len=0 rsn_ie_len=0 caps=0x1 level=-84
wlp2s0:    skip - SSID mismatch
wlp2s0: No suitable network found
wlp2s0: Setting scan request: 5.000000 sec
wlp2s0: Starting AP scan for wildcard SSID
wlp2s0: Add radio work 'scan'@0x6fe590
wlp2s0: First radio work item in the queue - schedule start immediately
wlp2s0: Starting radio work 'scan'@0x6fe590 after 0.000013 second wait
Scan requested (ret=0) - scan timeout 30 seconds


I also have the same result with "-Dnl8021", but it seems it detects the driver with -Dwext.

If you are referring to the # before password, I ntended it as a comment since I didnt put the correct password :)

Not sure wht else to try...
Back to top
View user's profile Send private message
Efo
Guru
Guru


Joined: 23 Jun 2005
Posts: 420

PostPosted: Wed Jan 27, 2016 2:33 am    Post subject: Reply with quote

Ok, this is crazy. I turned on the "SSID Broadcast" on the router and it works.

Any idea why this is happening and if there is a way of connecting with a hidden SSID?

Thanks,

Efo
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Wed Jan 27, 2016 6:30 am    Post subject: Reply with quote

Efo wrote:
Ok, this is crazy. I turned on the "SSID Broadcast" on the router and it works. Any idea why this is happening and if there is a way of connecting with a hidden SSID?

Efo ... I've never seen the point in hidding the ssid, it's trivial to find such AP's and so it makes absolutely no sense to hide them. Anyhow ...

Code:
ctrl_interface=DIR=/run/wpa_supplicant GROUP=wheel
ap_scan=1

network={
   ssid="MyNetwork"
   essid=xx:xx:xx:xx:xx:xx
   scan_ssid=1
   psk=#password created by wpa_passphrase
}

/usr/share/doc/wpa_supplicant-2.5-r1/wpa_supplicant.conf.bz2 wrote:
# For finding networks using hidden SSID, scan_ssid=1 in the network block can be used with nl80211.

Also note that your use of '-Dwext' is incorrect, that is why you are seeing the above ioctl errors ... you should be using -Dnl80211.

HTH & best ... khay
Back to top
View user's profile Send private message
Efo
Guru
Guru


Joined: 23 Jun 2005
Posts: 420

PostPosted: Wed Jan 27, 2016 2:54 pm    Post subject: Reply with quote

Thanks Khay,

Hiding ssid may not depend on me, so I figured I may want to know how to connect :)

Anyway, thanks again for all your help and explanations; all fixed and well now (hidden ssid included).

Efo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum